Jump to content
Калькуляторы

Глупый вопрос по терминации абонентов SuperVlan / IP Unnumbered

Добрый день.

Есть желание сменить Dlink DGS-3610 на другое железо

но где мне найти аналог SuperVlan?

 

На цисках например есть IP unnumbered, но насколько я понял, годится он только в схеме влан на абонента.

У нас идет схема влан на свитч.

Share this post


Link to post
Share on other sites

но насколько я понял, годится он только в схеме влан на абонента.

Неа. Вполне нормально живет и в схемах влан на свитч/дом/преисподня.

Если прям очень хочется аналог supervlan - он реализован на экстримах.

Share this post


Link to post
Share on other sites

Сейчас постараюсь описать поподробнее что меня интересует:

 

вот например сейчас SuperVlan

 

!
vlan 4082
name NET_176.100.148.128/25
supervlan
subvlan 100,200,300
!
interface VLAN 4082
no ip proxy-arp
ip helper-address 10.254.254.254
ip address 176.100.148.129 255.255.255.128
!

 

я изучил примерно конфигурацию ip unnumbered, и предположил что это будет выглядеть так:

 

!
interface Loopback1
ip address 176.100.148.129 255.255.255.128
no ip redirects
!
interface Vlan100
ip unnumbered Loopback1
ip helper-address 10.254.254.254
!
interface Vlan200
ip unnumbered Loopback1
ip helper-address 10.254.254.254
!
interface Vlan300
ip unnumbered Loopback1
ip helper-address 10.254.254.254
!

 

Так вот, в SuperVlan длинка я могу в этих сабвланах 100,200,300 назначать адреса из назначенной мною подсети "в случайно порядке"

 

Например:

Vlan100: 2 абонента 176.100.148.130 и 176.100.148.150

Vlan200: 2 абонента 176.100.148.131 и 176.100.148.151

Vlan300: 2 абонента 176.100.148.152 и 176.100.148.254

 

то-есть мне не нужно придерживаться определенного диапазона ip адресов в каждом влане, что мне очень удобно т.к. я немогу резервировать под каждый дом адреса, а вдруг они кончатся и придется переделывать... да и вообще неудобно это былобы.

(хотя это тожно можно сделать, командой subvlan ip range, что-бы арп запросы на эти айпишники сыпались в конкретный сабвлан, а не во все сабвланы этого интерфейса супервлана)

 

В IP unnumbered поведение точно такоеже?

Я просто слышал что в старых iOS нужно статические маршруты делать...

 

но насколько я понял, годится он только в схеме влан на абонента.

Неа. Вполне нормально живет и в схемах влан на свитч/дом/преисподня.

Если прям очень хочется аналог supervlan - он реализован на экстримах.

ткни носом пожалуйсто в конкретную железку

и есле можешь, то поподробнее где почитать про ихний супервлан

 

например я изучил вопрос с супервланом на juniper, и там нужно ставить дополнительный коммутатор который будет принимать двойной тег (qinq) (supervlan tag + subvlan tag)

и уже будет дальше отправлять на коммутаторы доступа нужный влан

такой вариант мне не нравится

3610 получается сразу отправляет нужный тэг в обычно виде без qinq на коммутаторы доступа, то-есть внутри себя уже без доп. коммутатора растэгировывает

Edited by mcdemon

Share this post


Link to post
Share on other sites

Если в сети не шибко используется dhcp, то надо смотреть на ip unnumbered poll (connected host polling) - есть в 3550/3560/3750/4500/4900, но отсутствует в 6500/7600.

 

Что про supervlan на экстримах - очень подробно описано про него в xos concept guide (первая же ссылка в гугле, или можно взять на сайте экстрима)

Ну к примеру, summit x460 (24x,48x), коих у меня целый зверинец:

configure vlan vlan201 ipaddress a.b.c.d 255.255.255.0
enable ipforwarding vlan vlan201
configure vlan vlan201 add secondary-ipaddress a.b.e.d 255.255.255.0
configure vlan "vlan201" add subvlan "vlan44"
configure vlan "vlan201" add subvlan "vlan43"
configure vlan "vlan201" add subvlan "vlan42"
configure vlan "vlan201" add subvlan "vlan41"
configure vlan "vlan201" add subvlan "vlan40"
configure vlan "vlan201" add subvlan "vlan39"
configure vlan "vlan201" add subvlan "vlan35"
configure vlan "vlan201" add subvlan "vlan34"
configure vlan "vlan201" add subvlan "vlan33"
configure vlan "vlan201" add subvlan "vlan32"
configure vlan "vlan201" add subvlan "vlan31"
configure vlan "vlan201" add subvlan "vlan29"
configure vlan "vlan201" add subvlan "vlan28"
configure vlan "vlan201" add subvlan "vlan27"
configure vlan "vlan201" add subvlan "vlan26"
configure vlan "vlan201" add subvlan "vlan25"
configure vlan "vlan201" add subvlan "vlan24"
configure vlan "vlan201" add subvlan "vlan23"
configure vlan "vlan201" add subvlan "vlan22"
configure vlan "vlan201" add subvlan "vlan21"
configure vlan "vlan201" add subvlan "vlan20"
configure vlan "vlan201" add subvlan "vlan19"
configure vlan "vlan201" add subvlan "vlan18"
configure vlan "vlan201" add subvlan "vlan17"
configure vlan "vlan201" add subvlan "vlan16"
configure vlan "vlan201" add subvlan "vlan15"
configure vlan "vlan201" add subvlan "vlan14"
configure vlan "vlan201" add subvlan "vlan13"
configure vlan "vlan201" add subvlan "vlan12"
configure vlan "vlan201" add subvlan "vlan11"
configure vlan "vlan201" add subvlan "vlan10"
configure vlan "vlan201" add subvlan "vlan9"
configure vlan "vlan201" add subvlan "vlan8"
configure vlan "vlan201" add subvlan "vlan7"
configure vlan "vlan201" add subvlan "vlan6"
configure vlan "vlan201" add subvlan "vlan5"
configure vlan "vlan201" add subvlan "vlan4"
configure vlan "vlan201" add subvlan "vlan3"
configure vlan "vlan201" add subvlan "vlan2"
configure vlan "vlan201" add subvlan "vlan30"

и дальше у меня на каждый порт свой влан смотрит, а 201й остался только в центре (а ранее гулял по всем портам одной большой сеткой).

Share this post


Link to post
Share on other sites

спасибо

но 460 железка стоит 250 тыщ...

вообщем настроение испрочено, осталось смотреть на модель 3750 от SNR

только это получается шило на мыло

или БУ искать...

Share this post


Link to post
Share on other sites

одна x450a - сгодится под замену обоих 3610?

на ebay можно за 50-60 тыщ найти

 

и чем отличается от 460/480 ?

Edited by mcdemon

Share this post


Link to post
Share on other sites

Так вот, в SuperVlan длинка я могу в этих сабвланах 100,200,300 назначать адреса из назначенной мною подсети "в случайно порядке"

 

Например:

Vlan100: 2 абонента 176.100.148.130 и 176.100.148.150

Vlan200: 2 абонента 176.100.148.131 и 176.100.148.151

Vlan300: 2 абонента 176.100.148.152 и 176.100.148.254

 

то-есть мне не нужно придерживаться определенного диапазона ip адресов в каждом влане, что мне очень удобно т.к. я немогу резервировать под каждый дом адреса, а вдруг они кончатся и придется переделывать... да и вообще неудобно это былобы.

(хотя это тожно можно сделать, командой subvlan ip range, что-бы арп запросы на эти айпишники сыпались в конкретный сабвлан, а не во все сабвланы этого интерфейса супервлана)

 

Ну и правильно вы написали про конфиг IP Unnumbered, нужные вам IP адреса в нужных вланах в нужном количестве рулятся через DHCP сервер и/или статические маршруты через ваши vlan интерфейсы. А ARP пакеты будут в любом случае распространяться внутри влана, ибо езернет

Share this post


Link to post
Share on other sites

а сколько по времени держится маршрут после dhcp запроса от пользователя?

Share this post


Link to post
Share on other sites

Маршрут живёт столько, сколько живёт лис DHCP

 

Работаем со схемой vlan на дом с ip unnumbered и dhcp host polling на 6500, работает стабильно. И надо сказать вполне всё устраивает в этой схеме.

Share this post


Link to post
Share on other sites

А вот интерестно такое: если компьютер абонента выключен, dhcp лиз закончился. Маршрут соответственно пропал.

И пошел запрос на его айпишник, железка начнет генерировать arp запрос на него, он пойдет по всем вланам которые в этом loopback находятся?

ведь железка без маршрута не знает где этот айпишник.

 

на длинках с супервланами - поведение именно такое (если не указать subvlan ip range)

Share this post


Link to post
Share on other sites

И вот еще смоделируем ситуацию, допустим лиз тайм на dhcp выставлен в 48 часов

и вот абонент получил айпишник по dhcp, на узле что-то произошло (отсутствие электричества например)

вообщем циска перезагрузилась

соответственно маршрутов на ней нет

а у абонента на компьютере айпишник есть, и следующий dhcp запрос планируется еще не скоро

 

получается абонент не будет работать пока не проинициализирует dhcp (вытащит/вставит кабель, перезагрузить пк/сетевую) ?

Share this post


Link to post
Share on other sites

на узле что-то произошло (отсутствие электричества например)

Так у абонента интерфейс погаснет.

А когда оборудование включиться, абонент получит IP повторно.

Share this post


Link to post
Share on other sites

на узле что-то произошло (отсутствие электричества например)

Так у абонента интерфейс погаснет.

А когда оборудование включиться, абонент получит IP повторно.

как он у него погаснет? мы же не будет l3 циски на доступ ставить)))

линк то на коммутатор в его доме у него не пропадет

Share this post


Link to post
Share on other sites

А зачем ставить лиз тайм на 48 часов?

У нас стоит на 15 минут и нормально.

Если циска перезагрузилась - народ либо перезагружает компы, либо ждет 15 минут и обновляет лизу.

Share this post


Link to post
Share on other sites

а каждые 15 минут у абонентов не происходит мини обрыва? там ведь за милисекунды получается, удаляется и снова появляется маршрут на циске?

или на циске маршрут на несколько секунд долше сидит что-бы он мог просто продлиться?

Share this post


Link to post
Share on other sites

недостаток один и он не имеет отношения к Ip unnumbered - после ребута циски на ней динамические списки доступа синхронизируются 2 часа и соответственно у абонента будет как минимум 2 часа что бы подёргать свой роутер или комп. Это если вы конечно используете динамические списки доступа....

 

а каждые 15 минут у абонентов не происходит мини обрыва? там ведь за милисекунды получается, удаляется и снова появляется маршрут на циске?

или на циске маршрут на несколько секунд долше сидит что-бы он мог просто продлиться?

Это происходит абсолютно незаметно для абонента.

 

 

 

Edited by biox

Share this post


Link to post
Share on other sites

недостаток один и он не имеет отношения к Ip unnumbered - после ребута циски на ней динамические списки доступа синхронизируются 2 часа и соответственно у абонента будет как минимум 2 часа что бы подёргать свой роутер или комп. Это если вы конечно используете динамические списки доступа....

 

На микротике после перезагрузки все синхронизируется за несколько секунд и абоненты могут полноценно работать. При этом если поставить несколько серверов в центре, можно указать им разные IP шлюзов и они будут параллельно работать и вылавливать абонентов без всяких там LACP.

Share this post


Link to post
Share on other sites

недостаток один и он не имеет отношения к Ip unnumbered - после ребута циски на ней динамические списки доступа синхронизируются 2 часа и соответственно у абонента будет как минимум 2 часа что бы подёргать свой роутер или комп. Это если вы конечно используете динамические списки доступа....

 

На микротике после перезагрузки все синхронизируется за несколько секунд и абоненты могут полноценно работать. При этом если поставить несколько серверов в центре, можно указать им разные IP шлюзов и они будут параллельно работать и вылавливать абонентов без всяких там LACP.

 

только вот не надо. У нас бордер на микротике и мне прекрасно известно как "это" готовить, соответственно всё на своих местах находиться.

Share this post


Link to post
Share on other sites

а каждые 15 минут у абонентов не происходит мини обрыва? там ведь за милисекунды получается, удаляется и снова появляется маршрут на циске?

или на циске маршрут на несколько секунд долше сидит что-бы он мог просто продлиться?

DHCP lease time - время аренды, через половину этого времени клиент запросит подтверждение лизы и если этому ничего не мешает сервер подтвердит и продлит аренду.

Насколько помню вроде так.

Share this post


Link to post
Share on other sites

а чем не устраивает 3610 ?

насчет времени аренды 15 минут в принципе нормальный параметр, никаких обрывов во время продления аренды не происходит.

с точки зрения безболезненной смены железки 5-7 минут ждать в принципе недолго, в ТП по этому поводу только самые нетерпеливые звонят.

Share this post


Link to post
Share on other sites

Добрый день.

Есть желание сменить Dlink DGS-3610 на другое железо

но где мне найти аналог SuperVlan?

 

На цисках например есть IP unnumbered, но насколько я понял, годится он только в схеме влан на абонента.

У нас идет схема влан на свитч.

 

Cisco 3750G.

 

int lo1
ip addr 10.10.10.1/24
!
int vlan2
ip unnumbered lo1 poll
!
int vlan3
ip unnumbered lo1 poll
!

 

Будет по ARP узнавать какой IP в каком влане. Работает нормально. У меня был супервлан на 3610 - любое изменение конфига интерфейса приводило к длительному ожиданию. Плюс он расходывал tcam на N саб-вланов, чем дальше в лес, тем хуже.

 

С циской только одна проблема. У абонента сменился vlan, но не сменился ip-адрес, после чего cef видит его и в старом и в новом влане. Лечится шатдауном обоих интерфейсов. Возможно я просто не знаю как это подтюнить. Но у меня лично вланы если и меняются, то очень редко и проблем это не доставляет. Просто особенность.

Share this post


Link to post
Share on other sites

Если адреса выдаются по DHCP, можно забыть о костылях типа poll, и по снупингу инсталировать маршруты. Но я бы все же взял 4948-10G (банально пишу в каждой теме об этом), потому что ткам больше, цпу лучше, а это далеко не минус. SVI на циске точно так же расходуют ткам,но: а) он большой и "жырный"; б) там нелинейная зависимость, все помещается на ок.

Share this post


Link to post
Share on other sites

А вот интерестно такое: если компьютер абонента выключен, dhcp лиз закончился. Маршрут соответственно пропал.

И пошел запрос на его айпишник, железка начнет генерировать arp запрос на него, он пойдет по всем вланам которые в этом loopback находятся?

ведь железка без маршрута не знает где этот айпишник.

 

Тоже очень интересно. Пока кастомер не получит адрес, будет ли железка бесконечно poll'ить в loopback или просто дропать трафик?

С qtech и supervlan огромные проблемы именно с этим как раз потому, что в текущей схеме невозможно использовать address range для subvlan, т.к. это сильно ограничивает использование подсетей и, как результат, на коммутаторы доступа льется куча arp request'ов.

Edited by tehmeh

Share this post


Link to post
Share on other sites

Тоже очень интересно. Пока кастомер не получит адрес, будет ли железка бесконечно poll'ить в loopback или просто дропать трафик?

 

Если poll не включен, просто дропает. Я могу ошибаться по прошествии лет, конечно, но проблемы на 65ой с 2к вланов и без poll не наблюдается.

 

С qtech и supervlan огромные проблемы именно с этим как раз потому

 

Проблемы qtech лежат в другой плоскости. Впрочем, чтобы не поливать конкретно их, скажу только что нормально аннамберед организован только у циско (не у всех, правда), и juniper.

Все остальное эти супервланы у всех костылем приделаны. Даже у кем-то-там-любимых экстримов.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this