Jump to content
Калькуляторы

Наведение антены

Добрый вечер!Подскажите а есть ли у микротика звуковая индикация для наведения антенны как у ubnt?

Если есть,то как включить ее и где настроить?

Share this post


Link to post
Share on other sites

А то как же, есть, запустите вот такой скрипт и наслаждайтесь мелодией:

 

BEEP SCRIPT
:local beep "10ms";
:local no "2400ms";
:local s90 "1290ms";
:local s85 "790ms";
:local s80 "590ms";
:local s77 "390ms";
:local s74 "290ms";
:local s71 "240ms";
:local s68 "190ms";
:local s65 "140ms";
:local s62 "90ms";
:local s59 "60ms";
:local s56 "40ms";
:local s53 "20ms";
:local s50 "10ms";
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
:if ($"signal-strength" <= -90) do={
:delay $no;
}
:if ($"signal-strength" <= -85 && $"signal-strength" > -90) do={
:for i from=1 to=2 do={ :beep length=$beep; :delay $s90; }
} 
:if ($"signal-strength" <= -80 && $"signal-strength" > -85) do={
:for i from=1 to=3 do={ :beep length=$beep; :delay $s85; }
}
:if ($"signal-strength" <= -77 && $"signal-strength" > -80) do={
:for i from=1 to=4 do={ :beep length=$beep; :delay $s80; }
} 
:if ($"signal-strength" <= -74 && $"signal-strength" > -77) do={
:for i from=1 to=6 do={ :beep length=$beep; :delay $s77; }
} 
:if ($"signal-strength" <= -71 && $"signal-strength" > -74) do={
:for i from=1 to=8 do={ :beep length=$beep; :delay $s74; }
} 
:if ($"signal-strength" <= -68 && $"signal-strength" > -71) do={
:for i from=1 to=10 do={ :beep length=$beep; :delay $s71; }
} 
:if ($"signal-strength" <= -65 && $"signal-strength" > -68) do={
:for i from=1 to=12 do={ :beep length=$beep; :delay $s68; }
} 
:if ($"signal-strength" <= -62 && $"signal-strength" > -65) do={
:for i from=1 to=16 do={ :beep length=$beep; :delay $s65; }
} 
:if ($"signal-strength" <= -59 && $"signal-strength" > -62) do={
:for i from=1 to=24 do={ :beep length=$beep; :delay $s62; }
} 
:if ($"signal-strength" <= -56 && $"signal-strength" > -59) do={
:for i from=1 to=34 do={ :beep length=$beep; :delay $s59; }
} 
:if ($"signal-strength" <= -53 && $"signal-strength" > -56) do={
:for i from=1 to=48 do={ :beep length=$beep; :delay $s56; }
}
:if ($"signal-strength" <= -50 && $"signal-strength" > -53) do={
:for i from=1 to=80 do={ :beep length=$beep; :delay $s53; }
} 
:if ($"signal-strength" <= -20 && $"signal-strength" > -50) do={
:for i from=1 to=120 do={ :beep length=$beep; :delay $s50; }
} 
}
}

Share this post


Link to post
Share on other sites

Похоже, никто им не пользовался, т.к. неудобно. Сегодня мне удалось доработать скрипт, по аналогии с прибором для настройки спутниковых антенн. Пробуйте:

 

:local beep "50ms";
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=0.025 do={
:if ($"signal-strength" <= -90) do={
}
:if ($"signal-strength" <= -87 && $"signal-strength" > -90) do={
:beep length=$beep frequency=2000; :delay 90ms
}
:if ($"signal-strength" <= -84 && $"signal-strength" > -87) do={
:beep length=$beep frequency=2150; :delay 87ms
}
:if ($"signal-strength" <= -81 && $"signal-strength" > -84) do={
:beep length=$beep frequency=2300; :delay 84ms
}
:if ($"signal-strength" <= -78 && $"signal-strength" > -81) do={
:beep length=$beep frequency=2450; :delay 81ms
}
:if ($"signal-strength" <= -75 && $"signal-strength" > -78) do={
:beep length=$beep frequency=2600; :delay 78ms
}
:if ($"signal-strength" <= -72 && $"signal-strength" > -75) do={
:beep length=$beep frequency=2750; :delay 75ms
}
:if ($"signal-strength" <= -69 && $"signal-strength" > -72) do={
:beep length=$beep frequency=2900; :delay 72ms
}
:if ($"signal-strength" <= -66 && $"signal-strength" > -69) do={
:beep length=$beep frequency=3050; :delay 69ms
}
:if ($"signal-strength" <= -63 && $"signal-strength" > -66) do={
:beep length=$beep frequency=3200; :delay 66ms
}
:if ($"signal-strength" <= -60 && $"signal-strength" > -63) do={
:beep length=$beep frequency=3350; :delay 63ms
}
:if ($"signal-strength" <= -57 && $"signal-strength" > -60) do={
:beep length=$beep frequency=3500; :delay 60ms
}
:if ($"signal-strength" <= -54 && $"signal-strength" > -57) do={
:beep length=$beep frequency=3650; :delay 57ms
}
:if ($"signal-strength" <= -51 && $"signal-strength" > -54) do={
:beep length=$beep frequency=3800; :delay 54ms
}
:if ($"signal-strength" <= -48 && $"signal-strength" > -51) do={
:beep length=$beep frequency=3950; :delay 51ms
}
:if ($"signal-strength" <= -45 && $"signal-strength" > -48) do={
:beep length=$beep frequency=4100; :delay 48ms
}
:if ($"signal-strength" <= -42 && $"signal-strength" > -45) do={
:beep length=$beep frequency=4250; :delay 45ms
}
:if ($"signal-strength" <= -39 && $"signal-strength" > -42) do={
:beep length=$beep frequency=4400; :delay 42ms
}
:if ($"signal-strength" <= -36 && $"signal-strength" > -39) do={
:beep length=$beep frequency=4550; :delay 39ms
}
:if ($"signal-strength" <= -33 && $"signal-strength" > -36) do={
:beep length=$beep frequency=4700; :delay 36ms
}
:if ($"signal-strength" <= -20 && $"signal-strength" > -33) do={
:beep length=$beep frequency=4850; :delay 33ms
}
}
}

Share this post


Link to post
Share on other sites

Похоже, никто им не пользовался, т.к. неудобно. Сегодня мне удалось доработать скрипт, по аналогии с прибором для настройки спутниковых антенн. Пробуйте:

 

:local beep "50ms";
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=0.025 do={
:if ($"signal-strength" <= -90) do={
}
:if ($"signal-strength" <= -87 && $"signal-strength" > -90) do={
:beep length=$beep frequency=2000; :delay 90ms
}
:if ($"signal-strength" <= -84 && $"signal-strength" > -87) do={
:beep length=$beep frequency=2150; :delay 87ms
}
:if ($"signal-strength" <= -81 && $"signal-strength" > -84) do={
:beep length=$beep frequency=2300; :delay 84ms
}
:if ($"signal-strength" <= -78 && $"signal-strength" > -81) do={
:beep length=$beep frequency=2450; :delay 81ms
}
:if ($"signal-strength" <= -75 && $"signal-strength" > -78) do={
:beep length=$beep frequency=2600; :delay 78ms
}
:if ($"signal-strength" <= -72 && $"signal-strength" > -75) do={
:beep length=$beep frequency=2750; :delay 75ms
}
:if ($"signal-strength" <= -69 && $"signal-strength" > -72) do={
:beep length=$beep frequency=2900; :delay 72ms
}
:if ($"signal-strength" <= -66 && $"signal-strength" > -69) do={
:beep length=$beep frequency=3050; :delay 69ms
}
:if ($"signal-strength" <= -63 && $"signal-strength" > -66) do={
:beep length=$beep frequency=3200; :delay 66ms
}
:if ($"signal-strength" <= -60 && $"signal-strength" > -63) do={
:beep length=$beep frequency=3350; :delay 63ms
}
:if ($"signal-strength" <= -57 && $"signal-strength" > -60) do={
:beep length=$beep frequency=3500; :delay 60ms
}
:if ($"signal-strength" <= -54 && $"signal-strength" > -57) do={
:beep length=$beep frequency=3650; :delay 57ms
}
:if ($"signal-strength" <= -51 && $"signal-strength" > -54) do={
:beep length=$beep frequency=3800; :delay 54ms
}
:if ($"signal-strength" <= -48 && $"signal-strength" > -51) do={
:beep length=$beep frequency=3950; :delay 51ms
}
:if ($"signal-strength" <= -45 && $"signal-strength" > -48) do={
:beep length=$beep frequency=4100; :delay 48ms
}
:if ($"signal-strength" <= -42 && $"signal-strength" > -45) do={
:beep length=$beep frequency=4250; :delay 45ms
}
:if ($"signal-strength" <= -39 && $"signal-strength" > -42) do={
:beep length=$beep frequency=4400; :delay 42ms
}
:if ($"signal-strength" <= -36 && $"signal-strength" > -39) do={
:beep length=$beep frequency=4550; :delay 39ms
}
:if ($"signal-strength" <= -33 && $"signal-strength" > -36) do={
:beep length=$beep frequency=4700; :delay 36ms
}
:if ($"signal-strength" <= -20 && $"signal-strength" > -33) do={
:beep length=$beep frequency=4850; :delay 33ms
}
}
}

Зачёт тебе бро !!! Отлично работает !!!

Share this post


Link to post
Share on other sites

Огромное спасибо, работает круто, сохранил в свой backup

Share this post


Link to post
Share on other sites

Да,и мне скрипт понравился. Жаль что запускается он только на точке включенной клиентом . Настраивал мост и на базовой точке он не запустился. Пришлось удаленную точку переводить в "bridge" а на настраиваемой ставить "station bridge"....

Share this post


Link to post
Share on other sites

Похоже, никто им не пользовался, т.к. неудобно. Сегодня мне удалось доработать скрипт, по аналогии с прибором для настройки спутниковых антенн. Пробуйте:

 

:local beep "50ms";
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=0.025 do={
:if ($"signal-strength" <= -90) do={
}
:if ($"signal-strength" <= -87 && $"signal-strength" > -90) do={
:beep length=$beep frequency=2000; :delay 90ms
}
:if ($"signal-strength" <= -84 && $"signal-strength" > -87) do={
:beep length=$beep frequency=2150; :delay 87ms
}
:if ($"signal-strength" <= -81 && $"signal-strength" > -84) do={
:beep length=$beep frequency=2300; :delay 84ms
}
:if ($"signal-strength" <= -78 && $"signal-strength" > -81) do={
:beep length=$beep frequency=2450; :delay 81ms
}
:if ($"signal-strength" <= -75 && $"signal-strength" > -78) do={
:beep length=$beep frequency=2600; :delay 78ms
}
:if ($"signal-strength" <= -72 && $"signal-strength" > -75) do={
:beep length=$beep frequency=2750; :delay 75ms
}
:if ($"signal-strength" <= -69 && $"signal-strength" > -72) do={
:beep length=$beep frequency=2900; :delay 72ms
}
:if ($"signal-strength" <= -66 && $"signal-strength" > -69) do={
:beep length=$beep frequency=3050; :delay 69ms
}
:if ($"signal-strength" <= -63 && $"signal-strength" > -66) do={
:beep length=$beep frequency=3200; :delay 66ms
}
:if ($"signal-strength" <= -60 && $"signal-strength" > -63) do={
:beep length=$beep frequency=3350; :delay 63ms
}
:if ($"signal-strength" <= -57 && $"signal-strength" > -60) do={
:beep length=$beep frequency=3500; :delay 60ms
}
:if ($"signal-strength" <= -54 && $"signal-strength" > -57) do={
:beep length=$beep frequency=3650; :delay 57ms
}
:if ($"signal-strength" <= -51 && $"signal-strength" > -54) do={
:beep length=$beep frequency=3800; :delay 54ms
}
:if ($"signal-strength" <= -48 && $"signal-strength" > -51) do={
:beep length=$beep frequency=3950; :delay 51ms
}
:if ($"signal-strength" <= -45 && $"signal-strength" > -48) do={
:beep length=$beep frequency=4100; :delay 48ms
}
:if ($"signal-strength" <= -42 && $"signal-strength" > -45) do={
:beep length=$beep frequency=4250; :delay 45ms
}
:if ($"signal-strength" <= -39 && $"signal-strength" > -42) do={
:beep length=$beep frequency=4400; :delay 42ms
}
:if ($"signal-strength" <= -36 && $"signal-strength" > -39) do={
:beep length=$beep frequency=4550; :delay 39ms
}
:if ($"signal-strength" <= -33 && $"signal-strength" > -36) do={
:beep length=$beep frequency=4700; :delay 36ms
}
:if ($"signal-strength" <= -20 && $"signal-strength" > -33) do={
:beep length=$beep frequency=4850; :delay 33ms
}
}
}

Для Huges (спутниковый модем) можно скрипт применить .

Share this post


Link to post
Share on other sites

Похоже, никто им не пользовался, т.к. неудобно. Сегодня мне удалось доработать скрипт, по аналогии с прибором для настройки спутниковых антенн. Пробуйте:

 

 

Добрый день подскажите пожалуйста как сделать так чтобы данный скрипт работал в течении 5 минут после включения оборудования а потом завершался?

Share this post


Link to post
Share on other sites

сори за офтоп.

а на UBNT где включается эта индикация?

Share this post


Link to post
Share on other sites

SpawnMG, на UBNT нет звуковой индикации.

 

RVGSlava, проще передёрнуть питание по окончании работы.

Edited by TTvs

Share this post


Link to post
Share on other sites

Но вот же человек пишет в первом посту "Добрый вечер!Подскажите а есть ли у микротика звуковая индикация для наведения антенны как у ubnt?"

поиск в гугл выдал http://download.wmd.ru/manual/AirOS_v5_5_4.pdf

Share this post


Link to post
Share on other sites

У UBNT нет звуковой индикации. Есть у вашего ноутбука, так наверное?

И не видел я динамиков внутри этих устройств.

post-122707-039357500 1480006461_thumb.jpg

Edited by TTvs

Share this post


Link to post
Share on other sites

SpawnMG, на UBNT нет звуковой индикации.

 

RVGSlava, проще передёрнуть питание по окончании работы.

У меня немного другая задача мне нужно чтобы антенна пищать начинала сама после загрузки и это я решил а вот как ее заставить саму замолчать - не пойму

Share this post


Link to post
Share on other sites

Всем привет! Ребята а можно этот скрипт допилить под sxt lite5 ac ??? в нём то бипера нет((( а вот по частоте моргания led 1 было бы в помощь многим.

Share this post


Link to post
Share on other sites

У Lite5 АС есть антенна на 2,4 ГГц которая может работать в бридже с радио на 5ГГц. Подключайтесь смартфоном к антенне и программой Mikro Winbox наблюдайте уровень сигнала.

Share this post


Link to post
Share on other sites

Сегодня мне удалось доработать скрипт, по аналогии с прибором для настройки спутниковых антенн. Пробуйте:

Благодарю вас за проделанную работу!

Share this post


Link to post
Share on other sites

а куда скрипт то вставлять???

Share this post


Link to post
Share on other sites

Помогите советом. Пробую управлять светодиодами. Вот такой код работает при запуске в Terminal.

/system leds

set leds="led1" type=on

Но вылезает запрос

numbers:

Что он значит, не знаю. Но если ввести число 0 и нажать Enter, то всё работает, указанный светодиод переключается в нужное состояние. Можно как-то сделать, чтобы этот запрос не вылезал, или чтоб число numbers вводилось автоматом? Хочу сделать скрипт, чтобы он работал самостоятельно, без участия человека.

 

 

 

Share this post


Link to post
Share on other sites
2 часа назад, lomal сказал:

или чтоб число numbers вводилось автоматом?

set leds=led1 type=on number=0

 

не благодари,

2 часа назад, lomal сказал:

Что он значит, не знаю.

это порядковый номер устройства в списке.......

 

Share this post


Link to post
Share on other sites

Потренировавшись, понял, что команда

/interface wireless monitor wlan1 interval=1 do={
:if ($"signal-strength" ........

работает только на клиентском устройстве. Но иногда бывает нужно навести антенну базы. И она не знает что такое $"signal-strength". Как бы клиентов может быть много, и у каждого уровень сигнала свой.

Однако, скриптом можно считать уровень сигнала конкретного устройства из registration-table:

:local "ss"
:set ss [/interface wireless registration-table get number=0 value="signal-strength"]

где number=0 - порядковый номер клиентского устройства. В моём случае число number равно нулю, поскольку у меня всего один клиент держит связь с базовой станцией.

Сопоставляя значение переменной ss с определённым уровнем сигнала, можно управлять пьезодинамиком или светодиодами.

Кстати, значение "signal-strength"можно извлекать и на клиентском устройстве - просто чтобы не писать отдельно скрипт для базы, отдельно для клиента, получается универсальная вещь.

 

Только есть проблема. Если выполнить

:local ss
:set ss [/interface wireless registration-table get number=0 "signal-strength"]

то получим на выходе строку с припиской "dBm", хотя по документации должно быть целое число (integer). Вот как бы преобразовать в число? Что-то с регулярными выражениями не выходит.

А хотя командой pick можно.

 

Edited by lomal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now