Jump to content
Калькуляторы

Несколько Vlan`ов в один порт

Доброго дня всем! Я думаю, многие сталкивались с ситуацией, когда клиенту нужно с 2-х и более точек сделать цифровой канал в одну точку. Т.е. на конечный коммутатор приходит, к примеру 10 вланов, а у клиента нет активного оборудования чтобы разобрать эти вланы у себя в сети, т.е. транком ему каналы не подать и кучу витых пар его тоже не устраивает. Несколько лет эта проблема решалась довольно просто, но дорого, а именно, на свитче делались перемычки витухой между портами (кому надо - расскажу подробнее) и таким образом, на выходе к клиенту мы имели один access порт. Но, всё-таки время идет и жалко занимать такое количество портов, хочется найти какое то решение, чтобы замес вланов происходил на самом коммутаторе (вся сеть на Cisco ME3400). Слышал, что есть свитчи Длинка, которые позволяют реализовать этот беспредел, но недавно наткнулся на одну доку, ниже выжимка из неё. Прошу тех, кто в теме, рассказать механизм реализации, возможно ли это, или же нет.

post-73856-087896200 1315204956_thumb.jpg

Edited by ilili

Share this post


Link to post
Share on other sites

Это что-то из серии "влан в влане". Когда есть один приватный VLAN, и его пользователи или частично видят друг друга, или не видят вообще (или комбинация). Зато видят сервер.

 

Кстати, почему нельзя по сети для одного клиента использовать VLAN с одним ID?

Share this post


Link to post
Share on other sites

Кстати, почему нельзя по сети для одного клиента использовать VLAN с одним ID?

Если несколько каналов в пределах одного ядра сети - то можно. Если с другой части города - будьте добры xconnect отдельным вланом. "влан в влане" - это Вы q-in-q имеете в виду? такой вариант не подойдет, опять же, нужно активное оборудование на стороне клиента.

Share this post


Link to post
Share on other sites

Кстати, почему нельзя по сети для одного клиента использовать VLAN с одним ID?

Если несколько каналов в пределах одного ядра сети - то можно. Если с другой части города - будьте добры xconnect отдельным вланом. "влан в влане" - это Вы q-in-q имеете в виду? такой вариант не подойдет, опять же, нужно активное оборудование на стороне клиента.

 

Не понятна причина, по которой требуется гнать два VLAN и потом их смешивать... Ну если уж так хотите, поставьте где-нибудь рядом с ядром Mikrotik или Linux, сбриджуйте VLAN и если требуется, разделите их через ebtables для частичной видимости.

Share this post


Link to post
Share on other sites

Клиент хочет страшного - пусть покупает железку, они нынче подешевели.

 

Если же куча вланов инициатива прова - пусть у себя бриджует.

Share this post


Link to post
Share on other sites

Если же куча вланов инициатива прова - пусть у себя бриджует.

Конечно инициатива прова. И само собой ставить какой-то тазик и там их роутить - вообще не вариант. Я к чему и задал вопрос, схему приложил, может кто реализовал - подскажет именно по этой схеме.

 

Не понятна причина, по которой требуется гнать два VLAN и потом их смешивать... Ну если уж так хотите, поставьте где-нибудь рядом с ядром Mikrotik или Linux, сбриджуйте VLAN и если требуется, разделите их через ebtables для частичной видимости.

Причина простая - ядро сети представляет из себя 4 Cisco 7606, по кольцам - МЕ3400. Как сделать через EoMPLS везде кучу каналов в одном влане - я не знаю :) Так что тут Микротики не катят

Edited by ilili

Share this post


Link to post
Share on other sites

"влан в влане" - это Вы q-in-q имеете в виду? такой вариант не подойдет, опять же, нужно активное оборудование на стороне клиента.

Нет. Это не Q-in-Q. Это для того, чтобы пользователей одного влана в какой-то мере изолировать друг от друга.

Ну вот пример. Вы домовой провайдер и используете один влан надом. И надо вам чтобы абоненты друг к другу не ходили. Что делать? Включить на коммутаторе функцию приватных/изолированных/ещё-разные-названия-есть вланов и Proxy ARP на L3 устройстве, терминирующим подсеть. И влан на пользователя не надо, и сети на /30 нарезать не надо. Так вот. Это как раз по той схеме.

Share this post


Link to post
Share on other sites

А что мешает их бриджевать на 76й?

Вы это имеете в виду? Если нет - подскажите как.

Ниже, кусок конфига с гигабитного порта

   switchport vlan mapping 1362 1264
  switchport vlan mapping 1363 1265

Только всё бы хорошо, но эта опция действует не на один порт, а сразу на восемь

 

Asymmetric VLAN не прокатит?

 

http://www.cisco.com...09478e.shtml#xl

Не оно?

Оно, но только это для каталистов, для ME3400 не подходит.

 

 

(config-if)#switchport mode ?
 access        Set trunking mode to ACCESS unconditionally
 dot1q-tunnel  set trunking mode to TUNNEL unconditionally
 private-vlan  Set private-vlan mode
 trunk         Set trunking mode to TRUNK unconditionally

Edited by ilili

Share this post


Link to post
Share on other sites

Оно, но только это для каталистов, для ME3400 не подходит.

чукча не читатель, чукча писатель.

The multi-VLAN port feature is supported only on Catalyst 2900XL/3500XL Series Switches. This feature is not supported on Catalyst 4500/4000, 5500/5000, or 6500/6000 Series Switches or any other Catalyst switches.

 

 

лучше читать доку к конкретно вашему устройству.

http://www.cisco.com/en/US/docs/switches/metro/me3400/software/release/12.2_37_se/configuration/guide/swpvlan.html

Share this post


Link to post
Share on other sites

лучше читать доку к конкретно вашему устройству.

http://www.cisco.com...de/swpvlan.html

Да не прокатит это. Уже пробовал. Комьюнити влан нельзя сделать на транковом порту, только на порту хоста.

 

Т.е. согласно картинке, влан 100 между коммутаторами, но (!) влан 202 м/д свитчами передать уже не получается.

 

116084.jpg

 

Может кто как по-другому реализовывает?

Edited by ilili

Share this post


Link to post
Share on other sites

чукча не читатель, чукча писатель.

Вот уж точно! )

Нужно из десяти приходящих VLAN-ов, сделать 1 порт, untagged, во все VLAN-ы сразу.

Т.е. asymmetric VLAN и НИКАК иначе.

Предлагается в тех местах, где это необходимо, заменить ME3400 на 3500XL, ну или добавить оный.

Share this post


Link to post
Share on other sites

Предлагается в тех местах, где это необходимо, заменить ME3400 на 3500XL.

Это слишком просто )))

Share this post


Link to post
Share on other sites

Т.е. на конечный коммутатор приходит, к примеру 10 вланов, а у клиента нет активного оборудования чтобы разобрать эти вланы у себя в сети, т.е. транком ему каналы не подать и кучу витых пар его тоже не устраивает.

Дешево и сердито - 2 конечных коммутатора: один с кучей вланов по медным портам, другой - в режиме port-based vlan, + N патч-кордов. Ну либо линукс тазик таки поставить.

Edited by NiTr0

Share this post


Link to post
Share on other sites

Ну, как вариант, все x-connect'ы стянуть в vpls, если набивка 7600 позволяет.

Share this post


Link to post
Share on other sites

Если бы набивка позволяла, ТС сделал бы xconnect с svi интерфейсов между ядрами и не парился :)

Share this post


Link to post
Share on other sites

Если бы набивка позволяла, ТС сделал бы xconnect с svi интерфейсов между ядрами и не парился :)

набивка позволяет это делать только с одного узла :) плата ES-20 уж больно волосато стоит. На остальных - по старинке, с интерфейсов giX/XX.XXXX :)

Share this post


Link to post
Share on other sites

Вы это имеете в виду? Если нет - подскажите как.

Ниже, кусок конфига с гигабитного порта

   switchport vlan mapping 1362 1264
  switchport vlan mapping 1363 1265

Только всё бы хорошо, но эта опция действует не на один порт, а сразу на восемь

 

 

набивка позволяет это делать только с одного узла :) плата ES-20 уж больно волосато стоит. На остальных - по старинке, с интерфейсов giX/XX.XXXX :)

 

Ну вы схему не показываете, как что у вас работает мы не знаем. В случае отсутствия VPLS и прочих радостей, обычно предлагают делать "петлю" на одной из 76й, ближней к клиенту. С одной стороны на порту терминируются xconnect'ы:

 

interface GigabitEthernet2/11
desc /* XConnect Loop to 2/12 */

interface GigabitEthernet2/11.123
desc /* Office 1 */
encapsulation dot1Q 123
xconnect a.b.c.188 123 pw-class client_a

interface GigabitEthernet2/11.124
desc /* Office 2 */
encapsulation dot1Q 124
xconnect a.b.c.187 124 pw-class client_a

interface GigabitEthernet2/11.125
desc /* Office 3 */
encapsulation dot1Q 125
xconnect a.b.c.189 125 pw-class client_a

 

А в другой порт будут выходить чистые вланы:

 

interface GigabitEthernet2/12
description /* Trnuk Interface - Loop to g2/11   */
switchport trunk allowed vlan 123-125
switchport mode trunk

 

Cоответственно, на каждый такой влан можно поднять пустой svi, назначить ему тупо бридж группу и получится звезда. В центральный офис уйдет один влан, например 126, как в нашем случае. На одной петле у нас обычно много клиентов болтается.

Edited by Danuuk

Share this post


Link to post
Share on other sites

набивка позволяет это делать только с одного узла :) плата ES-20 уж больно волосато стоит. На остальных - по старинке, с интерфейсов giX/XX.XXXX :)

 

Если есть одна карта - делайте vpls hub, как вам уже писали выше.

Share this post


Link to post
Share on other sites

Danuuk, так если vlan в туннеле EoMPLS, мы его уже заюзать не сможем? Его же "как бы" нет уже. Какой тогда смысл от схемы. Где-то я что-то упустил, если что - поправьте

Share this post


Link to post
Share on other sites

Danuuk, так если vlan в туннеле EoMPLS, мы его уже заюзать не сможем? Его же "как бы" нет уже. Какой тогда смысл от схемы. Где-то я что-то упустил, если что - поправьте

 

Смысл в том, что можно вытащить из xconnect'а, объединить и при желании засунуть или чистым вланом, или xconnect'ом куда надо, своеобразный VPLS на коленках. Если есть ES20 карта, то можно на ней сделать объединение по-человечески, это уже посоветовали.

Share this post


Link to post
Share on other sites

Если есть ES20 карта, то можно на ней сделать объединение по-человечески, это уже посоветовали.

Окей, буду разбираться!

Share this post


Link to post
Share on other sites

Извиняюсь за ап старой темы, но возникла такая же задача.

Идея в этом сообщении понравилась.

http://forum.nag.ru/forum/index.php?showtopic=69077&view=findpost&p=638312

Но я тоже не понял как забрать вланы с того же роутера? Ведь если они заведены в xconnect, то создать svi и влан уже не получится?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this