Jump to content
Калькуляторы

Cisco 890 режет скорость

Добрый день ..

 

Cisco IOS Software, C890 Software (C890-UNIVERSALK9_NPE-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)

 c890-universalk9_npe-mz.152-4.M5.bin

 

Напрямую проверяю закачку с yandex.disk ~100 мбит/с , после циски ~20 мбит/с

 

========

r1#sh run
Building configuration...

Current configuration : 7529 bytes
!
! Last configuration change at 11:35:13 UTC Fri Jul 3 2020 by admin
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 4 F
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization network default local
!
!
!
!
!
aaa session-id common
no ip source-route
!
!
!
ip dhcp excluded-address 192.168.99.1
ip dhcp excluded-address 192.168.99.11 192.168.99.100
!
ip dhcp pool test
 import all
 network 192.168.99.0 255.255.255.0
 default-router 192.168.1.1
!
!
!
no ip bootp server
no ip domain lookup
ip domain name xxxx.ru
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3951281973
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3951281973
 revocation-check none
 rsakeypair TP-self-signed-3951281973
!
!
crypto pki certificate chain TP-self-signed-3951281973
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
        quit
license udi pid CISCO892-K9 sn FCZ17539076
license accept end user agreement
!
!
!
redundancy
!
!
!
!
!
!
interface Tunnel1
 ip address 10.10.149.2 255.255.255.252
 ip mtu 1500
 tunnel source GigabitEthernet0
 tunnel mode ipip
 tunnel destination XXXXXXXXX
!
interface Tunnel3
 ip address 192.168.198.1 255.255.255.252
 tunnel source GigabitEthernet0
 tunnel mode ipip
 tunnel destination XXXXXXXXXXX
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn termination multidrop
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 no ip address
!
interface FastEthernet5
 no ip address
!
interface FastEthernet6
 no ip address
!
interface FastEthernet7
 no ip address
!
interface FastEthernet8
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip unnumbered GigabitEthernet0
 peer default ip address pool vpn
 no keepalive
 ppp authentication ms-chap ms-chap-v2 chap
!
interface GigabitEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Vlan1
 description LAN_IN
 ip address 192.168.99.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip local pool vpn 192.168.99.230 192.168.99.235
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip forward-protocol nd
!
!
ip nat source list 1 interface Vlan1 overload
ip nat inside source list 1 interface GigabitEthernet0 overload
ip nat inside source static tcp 192.168.99.15 80 XXXXXXXXX 80 extendable
ip route 10.10.13.0 255.255.255.0 Tunnel1
ip route 192.168.16.4 255.255.255.255 Tunnel3
!
access-list 1 permit 192.168.99.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.7
no cdp run
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 transport input telnet ssh
!
!
end
 

Share this post


Link to post
Share on other sites

а заявленную производительность смотрели? Может она просто не тянет 100мб/с?

Share this post


Link to post
Share on other sites

скачать честно моей модели я не нашел конкретики, кроме каких то абстрактных графиков .. 

но при этом sh processes cpu sorted ... CPU utilization for five seconds: 23%/20%; one minute: 4%; five minutes: 3% 

по памяти вроде тоже порядок .. я бы не сказал, что она сильно устала .. 

Share this post


Link to post
Share on other sites

Во время теста посмотрите на show proc cpu sort.

ip nat source list 1 interface Vlan1 overload лишнее 

Share this post


Link to post
Share on other sites
4 minutes ago, zhenya` said:

ip nat source list 1 interface Vlan1 overload лишнее 

Согласен, это я разные варианты пробовал .. 

 

=============

r1#show proc cpu sort 5sec
CPU utilization for five seconds: 23%/19%; one minute: 9%; five minutes: 4%
 PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
 106       69272       28902       2396  1.51%  1.25%  1.24%   0 COLLECT STAT COU
   6        7300         879       8304  0.87%  0.15%  0.12%   0 Check heaps
 116           4      741233          0  0.31%  0.23%  0.18%   0 Ethernet Msec Ti
  31         976         223       4376  0.15%  0.28%  0.21%   0 Exec
 143           0      180244          0  0.07%  0.03%  0.02%   0 IPAM Manager
 290           0      180390          0  0.07%  0.01%  0.00%   0 MMON MENG
 371           4       11281          0  0.07%  0.00%  0.00%   0 IP NAT Ager
 366           0      180327          0  0.07%  0.04%  0.05%   0 PPP Events
  77           4        1157          3  0.07%  0.00%  0.00%   0 Compute load avg
 365           8      180327          0  0.07%  0.08%  0.07%   0 PPP manager
  11           0           1          0  0.00%  0.00%  0.00%   0 License Client N

 

Посмотрел таблицу производительности и  расстроился ..  WAN 15 очков :((
 

Share this post


Link to post
Share on other sites

Туннели отключал, скорость не поменялась :(

А стоит иос менять .. мне еще NPE смущает ?

Share this post


Link to post
Share on other sites

По итогу вообще все интересно стало .. 

 

1. Замер Яндекс.Интернетометр (через Cisco), скорость ~24 мбит/с 

2. Закачка с Disk.Yandex (через Cisco), скорость ~2.9 МБ/с

3. Замер через Speedtest (через Cisco) ~95 мбит/с

4. Загрузка с Google Disk (через Cisco) ~10 МБ/с

 

А теперь самое интересно:

5. Замер Яндекс.Интернетометр (напрямую в ПК), скорость ~95 мбит/с 

6. Закачка с Disk.Yandex (напрямую в ПК) скорость ~10 МБ/с

7. Замер через Speedtest (напрямую в ПК) ~95 мбит/с

8. Загрузка с Google Disk (напрямую в ПК) ~10 МБ/с

 

И еще, пробовал "no ip cef"  .. нагрузка на ЦПУ 80% .. и сразу падает скорость до ~20 мбит/с на всех тестилках и загрузках .. 

 

Не могу понять в чем может быть проблема ?

 

 

 

 

Edited by serg999

Share this post


Link to post
Share on other sites
10 часов назад, serg999 сказал:

По итогу вообще все интересно стало .. 

 

1. Замер Яндекс.Интернетометр (через Cisco), скорость ~24 мбит/с 

2. Закачка с Disk.Yandex (через Cisco), скорость ~2.9 МБ/с

3. Замер через Speedtest (через Cisco) ~95 мбит/с

4. Загрузка с Google Disk (через Cisco) ~10 МБ/с

 

А теперь самое интересно:

5. Замер Яндекс.Интернетометр (напрямую в ПК), скорость ~95 мбит/с 

6. Закачка с Disk.Yandex (напрямую в ПК) скорость ~10 МБ/с

7. Замер через Speedtest (напрямую в ПК) ~95 мбит/с

8. Загрузка с Google Disk (напрямую в ПК) ~10 МБ/с

 

И еще, пробовал "no ip cef"  .. нагрузка на ЦПУ 80% .. и сразу падает скорость до ~20 мбит/с на всех тестилках и загрузках .. 

 

Не могу понять в чем может быть проблема ?

 

 

 

 

Npe это non payload encryption, Вы строите туннели какие то?  

No ip cef не надо делать. 

Пробовали торрент файлик качнуть? Или взять iperf и протестировать до публичных серверов, 75 мбит она точно должна качать

 

Ps, часто облачные сервисы использую для обмена, они прям плохо в последнее время работают

Share this post


Link to post
Share on other sites

Туннели есть, но во первых они чистыq GRE без шифрования ... во вторых я их отключил ... результата это не дало .. 

ip cef отключал для проверки что пойдет нагрузка на проц .. 

торрент попробовал выше 3 МБ/с не поднимается :(

 

Насчет облачного сервиса ... подключаю ПК напрямую ... и пров выдает заявленную скорость, а через циску нет ...

Share this post


Link to post
Share on other sites
17 hours ago, serg999 said:

Добрый день ..

 

Cisco IOS Software, C890 Software (C890-UNIVERSALK9_NPE-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)

 c890-universalk9_npe-mz.152-4.M5.bin
 

Настоятельно рекомендую обновить IOS: https://mfd.sk/fneQSs-7u3beQaA2MHz_xCeX

Не знаю как в 15.2.4M5, а в предыдущем M4a есть баг с таблицей маков.

Share this post


Link to post
Share on other sites

обновил на c890-universalk9-mz.159-3.M1.bin .. чуда не произошло

Share this post


Link to post
Share on other sites

Я не кошковод, но:

1. убедитесь что киска выше IP не лезет и просто перекладывает пакеты, без всяких проверок валидности их содержимого

2. что нет ошибок на портах со всех сторон: и на киске, и на коммутаторе и на сетевухе компа

3. убедитесь что у кошки не переполняются никакие буффера

4. посмотрите на flow control на кошке и поиграйте с ним, на обоих линках

 

PS: кошку на помойку, какойнить тплинк + опенврт зарулят лучше.

Share this post


Link to post
Share on other sites

Делал когда-то мелкий тест. Некоторые данные остались.

 

Cisco IOS Software, C890 Software (C890-UNIVERSALK9-M), Version 15.2(4)M8, RELEASE SOFTWARE (fc1)

 

iperf3 -c iperf.volia.net
Connecting to host iperf.volia.net, port 5201
[  4] local 192.168.100.27 port 49176 connected to 77.120.3.236 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.01   sec  4.25 MBytes  35.2 Mbits/sec
[  4]   1.01-2.01   sec  4.88 MBytes  41.0 Mbits/sec
[  4]   2.01-3.01   sec  5.50 MBytes  46.2 Mbits/sec
[  4]   3.01-4.01   sec  5.75 MBytes  48.3 Mbits/sec
[  4]   4.01-5.01   sec  5.75 MBytes  48.3 Mbits/sec
[  4]   5.01-6.01   sec  5.75 MBytes  48.3 Mbits/sec
[  4]   6.01-7.00   sec  5.75 MBytes  48.3 Mbits/sec
[  4]   7.00-8.00   sec  5.75 MBytes  48.3 Mbits/sec
[  4]   8.00-9.00   sec  5.50 MBytes  46.2 Mbits/sec
[  4]   9.00-10.02  sec  5.75 MBytes  47.6 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.02  sec  54.6 MBytes  45.8 Mbits/sec                  sender
[  4]   0.00-10.02  sec  54.6 MBytes  45.8 Mbits/sec                  receiver

iperf Done.

                     4444444444                                   
      222222222288888999991111111111222222222222222222221111122222
  100                                                             
   90                                                             
   80                                                             
   70                                                             
   60                                                             
   50                *****                                        
   40                **********                                   
   30                **********                                   
   20                **********                                   
   10           ***************                                   
     0....5....1....1....2....2....3....3....4....4....5....5....6
               0    5    0    5    0    5    0    5    0    5    0
               CPU% per second (last 60 seconds)

Скорость по тарифу была 50 Мбит. Интерфейс использовался Fa8. А подключение pppoe.

Спидтест, насколько помню, показывал несколько выше результаты, чем тарифная скорость.

 

Share this post


Link to post
Share on other sites

Такие косяки с любым оборудованием могут быть, а то что пока не могу понять где "горлышко бутылки" это не повод для замены .. 

да и 890 железяка с учетом того что она БУ на наге  ~14 тыр как то косвенно подталкивает разобраться :)

 

Может еще можно, что то выключить ?

 

===

GigabitEthernet0 is up, line protocol is up
  Internet address is XX.XX.XX.XX/23
  Broadcast address is 255.255.255.255
  Address determined by DHCP
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is enabled, interface in domain outside
  BGP Policy Mapping is disabled
  Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, NAT Outside, MCI Check
  Output features: Post-routing NAT Outside, Common Flow Table, Stateful Inspection, NAT ALG proxy
  IPv4 WCCP Redirect outbound is disabled
  IPv4 WCCP Redirect inbound is disabled
  IPv4 WCCP Redirect exclude is disabled
 

Vlan1 is up, line protocol is up
  Internet address is 192.168.99.1/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF switching turbo vector
  IP Null turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is enabled, interface in domain inside
  BGP Policy Mapping is disabled
  Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, MCI Check
  Output features: NAT Inside, Common Flow Table, Stateful Inspection, NAT ALG proxy
  IPv4 WCCP Redirect outbound is disabled
  IPv4 WCCP Redirect inbound is disabled
  IPv4 WCCP Redirect exclude is disabled
 

 

Share this post


Link to post
Share on other sites

Как минимум ещё no ip proxy-arp на всех L3, ну и до кучи  no ip redirects,  no ip unreachables

Share this post


Link to post
Share on other sites

Протестил на:

 

Cisco 892 (MPC8300) processor (revision 1.0) with 498688K/25600K bytes of memory.
Cisco IOS Software, C890 Software (C890-UNIVERSALK9-M), Version 15.9(3)M1, RELEASE SOFTWARE (fc1)

 

1. https://www.speedtest.net/ru/result/9714310428

 

1.thumb.png.8ce25c3fe728d92f2a745ae30601a152.png

 

2. 

 

.\iperf3.exe -c ping.online.net -P 4
Connecting to host ping.online.net, port 5201
[  4] local 10.10.0.115 port 64873 connected to 62.210.18.40 port 5201
[  6] local 10.10.0.115 port 64874 connected to 62.210.18.40 port 5201
[  8] local 10.10.0.115 port 64875 connected to 62.210.18.40 port 5201
[ 10] local 10.10.0.115 port 64876 connected to 62.210.18.40 port 5201
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-60.01  sec   104 MBytes  14.5 Mbits/sec                  sender
[  4]   0.00-60.01  sec   104 MBytes  14.5 Mbits/sec                  receiver
[  6]   0.00-60.01  sec   190 MBytes  26.6 Mbits/sec                  sender
[  6]   0.00-60.01  sec   190 MBytes  26.6 Mbits/sec                  receiver
[  8]   0.00-60.01  sec   190 MBytes  26.5 Mbits/sec                  sender
[  8]   0.00-60.01  sec   190 MBytes  26.5 Mbits/sec                  receiver
[ 10]   0.00-60.01  sec   191 MBytes  26.7 Mbits/sec                  sender
[ 10]   0.00-60.01  sec   191 MBytes  26.7 Mbits/sec                  receiver
[SUM]   0.00-60.01  sec   675 MBytes  94.4 Mbits/sec                  sender
[SUM]   0.00-60.01  sec   675 MBytes  94.4 Mbits/sec                  receiver

2.thumb.png.13a19d36a72c2e5fa7c7d539b9677fbf.png

 

Что-то у вас с железкой совсем не так. Надо обнулять. Но совет @SOFTOLAB - одобряю, железкам оным на пенсию пора было еще лет пять назад.

Share this post


Link to post
Share on other sites

Мда ... время будет вечерком попробую сброс сделать ..

 

image.thumb.png.b29c17117a064b1fe597aef82c3f70d3.png

 

#sh processes cpu
CPU utilization for five seconds: 10%/8%; one minute: 3%; five minutes: 2%
 PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
   1          16          83        192  0.00%  0.00%  0.00%   0 Chunk Manager
   2          44       33625          1  0.00%  0.01%  0.00%   0 Load Meter
   3           0           1          0  0.00%  0.00%  0.00%   0 LICENSE AGENT
   4           0           1          0  0.00%  0.00%  0.00%   0 EDDRI_MAIN
   5           0           1          0  0.00%  0.00%  0.00%   0 RO Notify Timers
   6      219244       25608       8561  0.00%  0.09%  0.10%   0 Check heaps
   7          56        2820         19  0.00%  0.00%  0.00%   0 Pool Manager
   8           0           2          0  0.00%  0.00%  0.00%   0 DiscardQ Backgro
   9           0           2          0  0.00%  0.00%  0.00%   0 Timers
  10           0         122          0  0.00%  0.00%  0.00%   0 WATCH_AFS
  11           0           1          0  0.00%  0.00%  0.00%   0 License Client N
 --More--
 

Share this post


Link to post
Share on other sites

Сброс, девственный конфиг, только NAT, результат 2,5 МБ/с ... какая то чертовщина :((

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now