Jump to content
Калькуляторы

Как получить маршруты из Global в VRF и обратно на одном и том же маршрутизаторе? обмен маршрутами между Global RT и VRT

Всем привет!

Как получить маршруты из Global в VRF и обратно на одном и том же маршрутизаторе?

Есть один 6509 IOS 12.2(33) SXI6

 

Настроена vrf-lite и интерфейсы

 

ip vrf MN

rd 65000:1

 

interface Loopback10

ip vrf forwarding MN

ip address 172.26.0.1 255.255.0.0

 

interface Vlan9

ip vrf forwarding MN

ip unnumbered Loopback10

ip helper-address 10.0.100.9

 

interface Vlan5

ip address 192.168.1.200 255.255.255.0

ip pim sparse-mode

 

ip route 172.26.0.0 255.255.0.0 loopback10

 

Необходимо получить маршрут к 192.168.1.200 и к сети 192.168.1.0/24 из Global в VRF

В сети есть масса примеров о том как настроить route leaking для двух роутеров и сетей за ними но в рамках одного маршрутизатора всё непонятно.

 

такой вариант не прокатывает

ip route vrf MN 192.168.1.200 255.255.255.255 vlan 5

 

выдаётся ошибка

% For VPN routes, must specify a next hop IP address if not a point-to-point interface

 

по идее надо указать next-hop но ведь нам нужен этот адрес

Edited by mnemonic

Share this post


Link to post
Share on other sites

в рамках одного маршрутизатора все решается или через физическую петлю, или через bgp с route-leaking. и первый и второй варианты имеют тонны подводных камней.

Share this post


Link to post
Share on other sites

BGP Route-leaking в вашем случае не нужен, вы просто не правильно статик-роуты написали.

Укажите ip адрес, вместо интерфейса, и там еще должна быть такая команда в конце роута global, указывающая на GRT.

Share this post


Link to post
Share on other sites

ip route vrf MN 192.168.1.0 255.255.255.0 192.168.1.200 global

Пробовал. Вот что выдает -

(config)#ip route vrf MN 192.168.1.0 255.255.255.0 192.168.1.200 global

%Invalid next hop address (it's this router)

 

в рамках одного маршрутизатора все решается или через физическую петлю, или через bgp с route-leaking. и первый и второй варианты имеют тонны подводных камней.

назовите пару камней. Чтоб не тешил себя надеждой и начал копать в другую сторону

Share this post


Link to post
Share on other sites

смотря каким способом решаете задачу. если через порт-петлю, то в какой-то момент рискуете упереться в емкость порта, а ежели через костыли, то и софтовые глюки всплывать будут (как например когда трафик в одну сторону ходит, а в обратную не ходит), и приколы с cef (вплоть до полного отвала, и восстановление через ребут).

Share this post


Link to post
Share on other sites

Есть старинный смешной способ с 2-мя лупбэками и 2-мя туннелями с VRF и GRT. Между ними поднимается сессия BGP и сливаются маршруты. Костыль конечно тот еще, но зато line-rate вроде как.

http://www.4salesbyself.com/dynamic-route-leaking-.aspx

 

ПС. Вообще ликинг GRT-VRF в циске костыль само по себе. И костыльно работает. Я еще не уверен что ваша коробка может...

Edited by DVM-Avgoor

Share this post


Link to post
Share on other sites

Решил смаршрутизировать vrf с нужными сетями через соседний маршрутизатор. Всё работает. Правда только статические маршруты сделал. Надо попробовать через OSPF обменяться маршрутами.

Сразу возник вопрос с мультикастом.

Есть коммутатор доступа, Cat 2950 и на нем абоненты сидят каждый в своем влане. Все вланы маршрутизирутся через Global RT. Поднят MVR на 2950. MVR влан приходит на 6500 где в него интерфейс L3 отдает мультикаст. Всё работает. Теперь берем влан одного абонента и маршрутизируем через vrf на этой 6500.

 

Отдаст ли MVR мультикаст поток в тот влан который роутиться через vrf?

Или придётся городить отдельную мультикаст маршрутизацию для vrf. Хотя я не уверен что можно делать 2 MVR влана на одном коммутаторе. Надо проверить.

Edited by mnemonic

Share this post


Link to post
Share on other sites

MVR заработал без проблем!

Спасибо всем за помощь и советы!

Share this post


Link to post
Share on other sites

в рамках одного маршрутизатора все решается или через физическую петлю, или через bgp с route-leaking. и первый и второй варианты имеют тонны подводных камней.

Физическая петля это не комильфо для маршрутизаторов.

 

Можно просто сделать туннель где один коннец в врф а второй в глобале.

 

Что же касаемо протокола маршрутизации то сильно пофиг какой в туннеле гонять.

Edited by myst

Share this post


Link to post
Share on other sites
Как получить маршруты из Global в VRF и обратно на одном и том же маршрутизаторе?

Есть один 6509 IOS 12.2(33) SXI6

у циски ущербный рут ликинг: как только дело доходит до global'а, начинается геморрой. ну вон, туннелями с лупбака обложиться и заработает.

 

а вообще возможно стоит подумать над дизайном где ненужны vrf'ы.

Share this post


Link to post
Share on other sites

Обновится до 15.3 там есть экспорт маршрутов из vrf в global. Импорт из global в vrf есть с 12.2S

Share this post


Link to post
Share on other sites

Обновится до 15.3 там есть экспорт маршрутов из vrf в global. Импорт из global в vrf есть с 12.2S

 

 

На 65ой коробке разве 15-ая ветка IOS есть?

 

UPD: FN говорит что есть 15.1 на 720 и S2T. Но это не 15.3

Edited by DVM-Avgoor

Share this post


Link to post
Share on other sites

По FN не смотрел. Есть в 7600, начиная с 15.2S какой-то. В 15.3S есть во всех.

Вот еще один ответ на вопрос, чем отличается 7600 от 6500 :)

Share this post


Link to post
Share on other sites

Одно непонятно, зачем обновляться когда туннелей более чем достаточно. Плюс туннелей в том, что там может функционировать любой протокол маршрутизации, не только BGP, да и поднять такой туннель можно почти на любом каталисте который имеет уникальные BIA на интерфесах, а не только на роутерах.

Share this post


Link to post
Share on other sites
Одно непонятно, зачем обновляться когда туннелей более чем достаточно.
мастер анальный проктолог делится бесценным опытом ? :D

А обосновать?

Мне кажется роут-ликинг темболее статический, темболее на циске и есть самая настоящая анальная стоматология.

Share this post


Link to post
Share on other sites
Мне кажется роут-ликинг темболее статический, темболее на циске и есть самая настоящая анальная стоматология.
рут ликинг бывает не только статическим, но и при этом без странных туннелей, лишних бгп сессий и чего-то там еще. в циске с этим, рут ликингом, всегда было плохо. но если в новом софте стало лучше, то почему бы этим не пользоваться ?

Share this post


Link to post
Share on other sites
Мне кажется роут-ликинг темболее статический, темболее на циске и есть самая настоящая анальная стоматология.
рут ликинг бывает не только статическим, но и при этом без странных туннелей, лишних бгп сессий и чего-то там еще. в циске с этим, рут ликингом, всегда было плохо. но если в новом софте стало лучше, то почему бы этим не пользоваться ?

1) странные туннели совершенно обычные gre которые уже стопицот лет работают без всяких проблем, на всех l3 коммутаторах(и роутерах) выше 3550.

2) купить новый софт, поменять проверенно рабочий и огребать новые глюки только потому что цисках до сих пор ниасилила человеческий роутликинг? Хехе, ну и кто из нас после этого анальных дел мастер?

 

С новым годом коллега .)

Edited by myst

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this