Jump to content
Калькуляторы

Доступ из внешней и локальной сети на веб сервер

Здравствуйте, столкнулся с такой проблемой.

 

На сервере стоит moodle.

 

Как сейчас работает:

пользователи могут заходить на moodle через внешний ip адрес из интернета.

пользовалели не могут зайти на moodle из локальной сети.

 

Как нужно:

Чтобы пользовали могли заходить из локальной сети по внешнему ip адресу.

 

Схема сети:

Сервер

Cisco

Локальная сеть

 

Подробуню схему и настройки выложу чуть попозже.

 

Буду рад советам, пожеланием. Спасибо.

Share this post


Link to post
Share on other sites

Как я понимаю, речь идет о доступе к www серверу? Apache 2.???

Share this post


Link to post
Share on other sites

Схема сети

202ebf68eb52.png

 

Настройки на cisco

/* В этот порт подключен сервер*/ 
interface FastEthernet2
switchport access vlan 7
no ip address
!
/* Локальная подсеть сервер-циско, со стороны сервера ip 192.168.100.253 */
interface Vlan7 
ip address 192.168.100.10 255.255.255.0
ip nat inside
ip virtual-reassembly in
!


/* Этот порт к провайдеру*/

interface FastEthernet4 
ip address 78.58.111.162 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!


/* Локальная подсеть пользователей */
interface Vlan3
ip address 192.168.101.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!


Настройки маршрутизации и нат

ip nat inside source list 3 interface FastEthernet4 overload
ip nat inside source static 192.168.0.253 78.58.111.163
ip route 0.0.0.0 0.0.0.0 78.58.111.161

access-list 3 permit 192.168.101.0 0.0.0.255

 

В итоге, если пользователь, например из подсети 192.168.101.* хочет попасть на сервер 78.57.111.163, то нат не срабатывает. То есть этот ip виден, пингуется, но на внутренний ип сервера (192.168.100.253) не проходят пакеты. Замечу, что из внешней (из интернета) nat работает.

Очень жду ответов, спасибо!

Share this post


Link to post
Share on other sites

Как я понимаю, речь идет о доступе к www серверу? Apache 2.???

Да, все верно.

Share this post


Link to post
Share on other sites

У вас локальный DNS-сервер имеется? Можете заставить его все запросы с 192.168.101.0/24 к youremoodle.ru на 192.168.100.253 будет вам доступ к сайту из локалки и интернета одновременно. Ибо не умеет ваша шайтан арба из коробки работать и с ip, и с доменным именем одновременно.

Share this post


Link to post
Share on other sites

У вас локальный DNS-сервер имеется? Можете заставить его все запросы с 192.168.101.0/24 к youremoodle.ru на 192.168.100.253 будет вам доступ к сайту из локалки и интернета одновременно. Ибо не умеет ваша шайтан арба из коробки работать и с ip, и с доменным именем одновременно.

 

+1

 

google: split dns

Share this post


Link to post
Share on other sites
У вас локальный DNS-сервер имеется?
google: split dns

Из пушки по воробьям.

Знаю единственный сценарий когда это оправданно ибо другого выхода практически нет: локальный домен с актив директори и при этом почта и сайт где то там в инете.

Во всех остальных случаях это решается на L3, и может быть подстройкой веб сервера.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this