Jump to content
Калькуляторы

Mikrotik RB2011LS возможность объединения чипов коммутации

Доброго времени суток всем) У меня имеется такая штуковина как Mikrotik RB2011LS. Те кто встречался с ней ну либо слышал знает что в ней два чипа коммутации. Так вот вопрос, как объединить эти два чипа с помощью процессора. У меня на первый switch1 приходит 2 vlan-а в 1 и 2 порт. Нужно во второй switch2 на все порты отправить трафик приходящий из 2 порта switch1. Сделал так

# NAME SWITCH VLAN-MODE VLAN-HEADER DEFAULT-VLAN-ID

0 sfp1-gateway switch1 secure leave-as-is auto

1 ether1 switch1 secure leave-as-is auto

2 ether2 switch1 secure leave-as-is auto

3 ether3 switch1 secure add-if-missing 22

4 ether4 switch1 secure always-strip 50

5 ether5 switch1 secure always-strip 50

6 ether6 switch2 disabled leave-as-is 20

7 ether7 switch2 disabled leave-as-is 20

8 ether8 switch2 disabled leave-as-is 20

9 ether9 switch2 disabled leave-as-is 20

10 System switch2 disabled always-strip 20

11 switch1-cpu switch1 secure leave-as-is auto

12 switch2-cpu switch2 secure leave-as-is 0

 

# NAME MTU MAC-ADDRESS ARP MASTER-PORT SWITCH

0 RS System 1500 D4:CA:6D:86:7C:9D enabled ether6 switch2

1 R ether1 1500 D4:CA:6D:86:7C:94 enabled none switch1

2 RS ether2 1500 D4:CA:6D:86:7C:95 enabled none switch1

3 R ether3 1500 D4:CA:6D:86:7C:96 enabled none switch1

4 RS ether4 1500 D4:CA:6D:86:7C:97 enabled ether1 switch1

5 RS ether5 1500 D4:CA:6D:86:7C:98 enabled ether1 switch1

6 RS ether6 1500 D4:CA:6D:86:7C:99 enabled none switch2

7 S ether7 1500 D4:CA:6D:86:7C:9A enabled ether6 switch2

8 S ether8 1500 D4:CA:6D:86:7C:9B enabled ether6 switch2

9 S ether9 1500 D4:CA:6D:86:7C:9C enabled ether6 switch2

10 X sfp1-ga... 1500 D4:CA:6D:86:7C:93 enabled none switch1

 

# INTERFACE BRIDGE PRIORITY PATH-COST HORIZON

0 ether6 bridge 0x80 10 none

1 ether2 bridge 0x80 10 none

 

# ADDRESS NETWORK INTERFACE

1 192.168.3.2/24 192.168.3.0 bridge

 

Ping-уется 192.168.3.2 с порта 10,9,8,7. Сетка на стороне 2 порта не Ping-уется с этих же портов. Как правильно настроить?

Share this post


Link to post
Share on other sites

Сбросьте начальную конфигурацию и объединяйте порты с помощью бриджей, а не средствами свич чипа.

 

Вам нужно из 2 порта отправить данные во все порты 6-10? Создаете бридж, в него добавляете 2 порт и 6-10, соответственно все заработает как не управляемый коммутатор. Далее фильтрами или путем создания нужных вланов управляете трафиком.

Share this post


Link to post
Share on other sites

Сбросьте начальную конфигурацию и объединяйте порты с помощью бриджей, а не средствами свич чипа.

 

Вам нужно из 2 порта отправить данные во все порты 6-10? Создаете бридж, в него добавляете 2 порт и 6-10, соответственно все заработает как не управляемый коммутатор. Далее фильтрами или путем создания нужных вланов управляете трафиком.

Мда уж, вы тут меня чуть ли не рукожопым с микротиком назвали в своё время, а сами показываете незнание матчасти.

Действительно, чипы можно объединить программным бриджем два мастер порта, аппаратный acl тоже имеется в меню switch.

Edited by SyJet

Share this post


Link to post
Share on other sites

Конфиг ниже поможет понять как в свитче работать с vlan, в том числе с management vlan (в данном случае vlan100). ACL для свитча - это закладка RULE в меню Switch.

/interface ethernet
set [ find default-name=ether2 ] comment=Trunk
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] comment=Alfa master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
/ip neighbor discovery
set ether1 discover=no
set ether2 comment=Trunk discover=no
set ether3 discover=no
set ether4 comment=AlfaNeva discover=no
set ether5 discover=no
/interface vlan
add comment=vlan100 interface=ether2 l2mtu=1594 name=vlan100 vlan-id=100
/ip neighbor discovery
set vlan100 comment=vlan100
/interface ethernet switch port
set 0 default-vlan-id=100 vlan-header=add-if-missing vlan-mode=secure
set 1 default-vlan-id=100 vlan-header=add-if-missing vlan-mode=secure
set 2 default-vlan-id=77 vlan-header=always-strip vlan-mode=secure
set 3 default-vlan-id=22 vlan-header=always-strip vlan-mode=secure
set 4 vlan-mode=secure
/interface ethernet switch vlan
add ports=ether2,ether3,switch1-cpu switch=switch1 vlan-id=100
add ports=ether2,ether3,ether5 switch=switch1 vlan-id=22
add ports=ether2,ether3 switch=switch1 vlan-id=60
add ports=ether2,ether4 switch=switch1 vlan-id=77
/ip address
add address=192.168.200.24/24 interface=vlan100 network=192.168.200.0
/ip route
add distance=1 gateway=192.168.200.1

Edited by SyJet

Share this post


Link to post
Share on other sites

Я настраивал всё по данному мануалу http://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features. На данный момент у меня всё настроено как нужно. На первый порт приходит 3 vlan-а их я разруливаю на одном switch-е. То есть там получается так: на 3 порт идёт нетегированным 22 vlan, 10, 50 и 20 тегированный. На 4 и 5 идёт нетегированным 50 vlan. Теперь мне не хватает портов 5 и мне нужно ещё 5 портов в switch2. И ещё кстати про предложенное решение про Bridge мне не подходит так как это замедляет систему и так же ещё у Mikrotik хреновый процессор для multicast-а и картинка тормозит. Так вот вернемся к вопросу как связать два switch-а (switch1 и switch2)?

Share this post


Link to post
Share on other sites

Никак, без бриджа... Хотя конечно может физическое кольцо делать патчкордом между свитчей, но как это будет работать я хз, пробуйте

Share this post


Link to post
Share on other sites

Хотя конечно может физическое кольцо делать патчкордом между свитчей

 

патчкорд работает всегда :) я бы выбрал именно патч, а не софтовый бридж между свитчами, если конечно по порту лишнему есть с каждой стороны

Share this post


Link to post
Share on other sites

Думал я про патчкорд)Но вот как раз лишнего нет порта на гигабит которые идут 5 штук. Так а если через бридж, как объединить два свитча им. Нужно что бы один порт как бы принимал трафик с первого switch1 и передавал его через процессор во второй switch2. Необходимо что бы 4 порта на switch2 работали между собой именно как свитч а не через проц, как мне выше предлагали объединить все порты со второго switch2 в мост, понятно дело работать будет, я так делал, но нагрузка на проц большая идёт в этом случае, он от этого зависает даже раз в сутки. Покажите как можно мостом объединить эти два сегмента через проц, но при этом что бы 4 порта из 5 работали в свитче. Ниже показано что вообще должно получится, по крайней мере как себе это представляю я.

post-123322-001617200 1421172952_thumb.png

Edited by mazahakq

Share this post


Link to post
Share on other sites

Или я не понял вопроса, или вам уже сказали: мастерпорты в бридж, все лишнее поотключать, чтобы работал bridge fast path handlier.

Share this post


Link to post
Share on other sites

А не проще взять обычный коммутатор людской и на нем уже вланы, порты и проч рулить?

Share this post


Link to post
Share on other sites

А не проще взять обычный коммутатор людской и на нем уже вланы, порты и проч рулить?

Проще. И надежнее.

 

Я тоже пытался свитч-чип настроить на 2011.

По итогам понял, что реализовано все криво и коммутировать (особенно если еще и VLAN используются) нужно через бридж.

Share this post


Link to post
Share on other sites

alibek, я вообще с тоски соединил свитч и 2011 оптикой (наговские сфп модули и их же патчкорд). А вся медь, включая аплинк от провайдера, приходят в коммутатор.

post-82929-013004000 1421229986_thumb.jpg

Share this post


Link to post
Share on other sites

Ну да в целом, проще поставить ещё одну железку управляемую и всё. Но пока что так охота) Кстати пару дней мучений, всё таки получилось данную схему сделать. Все принты что я выше указывал но плюс ещё нужно было просто проц от первого свитча в 20 влан кинуть и всё заработало) Спасибо за поддержку ребята. Дали мне понять что не бредовые идеи мне в голову лезли.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this