Jump to content
Калькуляторы

Автоматическое обновление прошивок Микротика

Здравствуйте!

Если такая фича на микротике как автоматическое обновление прошивок?Например с tftp сервера.

Share this post


Link to post
Share on other sites

Здравствуйте!

Если такая фича на микротике как автоматическое обновление прошивок?Например с tftp сервера.

 

Можно обновлять через The DUDE, она даже сама определяет в какой последовательности перепрошивать, начинает от дальних устройств к ближним. Но есть одна интересная особенность - если в сеть какое-то оборудование подключено от RB750UP, то во время такой массовой прошивки оно перестанет работать, т.к. запустив процесс прошивки на подключенных устройствах, система перезагрузит и RB750UP, что и приведет к необходимости снимать оборудование и восстанавливать прошивку.

 

Поэтому самое верное обновлять ПО вручную, и все новое оборудование прошивать перед установкой.

Share this post


Link to post
Share on other sites

Меня в приципе чисто автоматическое обновление не интересует. А вот функциеей Check For Updates иногда пользуюсь. Но работает она только на основном микротике где распределяется трафик. А микротики находящиеся в локальной сети закачать прошивку не могут хотя выход в интернет имеют: пингуется гугл и сам сайт микротика.

Внизу пишет could not resolve address upgrade.mikrotik.com

 

 > ping upgrade.mikrotik.com        
HOST                                     SIZE TTL TIME  STATUS                   
54.230.93.225                              56  57 70ms 
54.230.93.225                              56  57 79ms 
54.230.93.225                              56  57 97ms 
54.230.93.225                              56  57 78ms 

ping mikrotik.com   
HOST                                     SIZE TTL TIME  STATUS                                                                                       
159.148.147.196                            56  53 75ms 
159.148.147.196                            56  53 76ms 
159.148.147.196                            56  53 77ms 

 

Что нужно, на базовом микротике сакой то порт открыть и маршрут прописать?

Edited by uraso

Share this post


Link to post
Share on other sites

could not resolve address upgrade.mikrotik.com -

Они же тебе черным по белому говорят, не могут резолвить, то есть не могут сопоставить адрес с айпишником, тоесть DNS на них включи.

У них както хитро работает этот апдейт, у меня стал резолвить только после включения dns сервера на микроте после главного. Но мне не жалко :)

Edited by Ermak_

Share this post


Link to post
Share on other sites
Они же тебе черным по белому говорят, не могут резолвить, то есть не могут сопоставить адрес с айпишником, тоесть DNS на них включи.

У них както хитро работает этот апдейт, у меня стал резолвить только после включения dns сервера на микроте после главного.

 

На обновляемом микротике в локалке ДНС включен.... 8.8.8.8. И добавлен динамический 213.179.249.133 с DHCP клиента. Обновлятся не хочет...

Edited by uraso

Share this post


Link to post
Share on other sites

Вот только что попробовал, резолвиться, обновляется нормально. за главным стоит локальный.

Может на нем у Вас какие правила мешают?

Share this post


Link to post
Share on other sites

Похоже что ты прав.... На другой сети в примерно той же ситуации и такие же самые девайсы в локальной сети за натом резолвились сразу после введения DNS.... А в етой сети на главном роутере сделал forvard-> accept и поднял вверх.... Не помогло....

Edited by uraso

Share this post


Link to post
Share on other sites

Как не крути можешь придумать еще пару велосипедов но все равно после обновления прошивки фирмваре обновлять прийдется заходить вручную , так что винбокс + мышка + айда кликать и жди ребута точки , не жги себе мозг ( ведь тебе этим мозгом придется с микротиком еще и работать а не только обновлять- побереги извилины!)

Edited by zaza11

Share this post


Link to post
Share on other sites

Как не крути можешь придумать еще пару велосипедов но все равно после обновления прошивки фирмваре обновлять прийдется заходить вручную , так что винбокс + мышка + айда кликать и жди ребута точки , не жги себе мозг ( ведь тебе этим мозгом придется с микротиком еще и работать а не только обновлять- побереги извилины!)

 

Конечно мышкой удобнее - открыть штук 5-10 окошек и залить в них прошивку, после все перезагрузить. И так далее. Заодно можно еще какие-то действия произвести.

Share this post


Link to post
Share on other sites

Здравствуйте!

Если такая фича на микротике как автоматическое обновление прошивок?Например с tftp сервера.

System -> Scripts

 

добавляем скрипт:

/system package update

check-for-updates

:delay 2s;

:if ( [get current-version] != [get latest-version]) do={ upgrade }

 

закидываем в шедулер таск на выполнение раз в месяц, в таске:

/system script run <название_вашего_скрипта_для_апдейта>

Share this post


Link to post
Share on other sites

Название темы прочитал как "автоматическое создание себе проблем".

Вот так обновится, и окажется, что пакеты уже иначе идут внутри. Или, например, global переименовали.

 

Или тут предлагается обновлять минорные версии?

Edited by nukunuku

Share this post


Link to post
Share on other sites
Guest IL-48
В 11.12.2013 в 17:49, uraso сказал:

Обновлятся не хочет...

Пропишите (ip\routes) маршрут по умолчанию (0.0.0.0/0)  до гейтвея - центрального роутера. Точки не знают, через что им выходить в инет.

А вообще в инет каждой точке можно и не лазить, прошивку можно забрать и с локалки (в планировщике нужно сделать ребут в указанное время).

Auto upgrade - укажите адрес того микрота, куда будет заливаться прошивка с сайта (должна быть та же архитектура).

Желательно на центральный поставить NTP сервер - доп пакет, для централизации времени, инатравить все микроты на него - клиентами.

 

Share this post


Link to post
Share on other sites
В 09.12.2013 в 16:43, montino сказал:

Здравствуйте!

Если такая фича на микротике как автоматическое обновление прошивок?Например с tftp сервера.

В  провайдерском  деле  секс  видимо  на  первом  месте.  Более  тыщи  этих  побрякушек  и  ни  когда  голову  не  грел,  чтобы  при  выходе  новой  прошивки

 стремиться  все  обновить.  Надо  деньги  зарабатывать,  а  не  херней  заниматься.  От  прошивки  к  прошивке  ни  дальность  связи ни  кол-во  абонентов  не  прибавиться.

  Не  шевелишь гавно,  так    оно и  не  пахнет.....

Share this post


Link to post
Share on other sites

Если оставить активной службу FTP на микротиках, можно удаленно заливать туда файл прошивки, и удаленно по телнету или ssh выполнять перезапуск. При этом можно все автоматизировать, выставив последовательность обновлений, что бы перезагрузки роутеров не прервали процесс обновления, если они подают питание на базовые станции и т.п.

Share this post


Link to post
Share on other sites

не было печали, апдейтов накачали (с)

 

выпустят не дай бог прошивку с багом и пол/вся сеть ляжет, прикольно =))

Edited by yKpon

Share this post


Link to post
Share on other sites
11 часов назад, npokypop сказал:

Ух ты! Ответ спустя 3 года) 

Ну  да  резкая  критика.  Тут  скорей  100  грамм  повлияли :)

 просто  правое  полушарие  не  сообразило  что  сделало левое

Share this post


Link to post
Share on other sites

Я пока не встречал людей кто юзает автоматическое обновление RouterOS у себя на сети. Или есть такие экстрималы ? Поделитесь опытом работы в этой сфере. 

Share this post


Link to post
Share on other sites
В 28.10.2017 в 12:52, npokypop сказал:

Я пока не встречал людей кто юзает автоматическое обновление RouterOS у себя на сети. Или есть такие экстрималы ? Поделитесь опытом работы в этой сфере. 

А чем плохо иметь актуальную версию ПО на клиентских устройствах?

Share this post


Link to post
Share on other sites

test90 тем плохо, что на выходе можно получить кирпичи вместо клиентских устройств.
У них после каждого релиза на форуме вой стоит что все сломалось и километры багфиксов чейнджлогах.

Share this post


Link to post
Share on other sites
Guest khodeich

Коллеги,

а какое правило надо добавить  в firewall, чтобы работал check for update,

Связанный/установленный трафик пропускаю:

add action=accept chain=forward connection-state=established,related connection-type=""
add action=accept chain=input connection-state=established,related connection-type=""

 

у меня дропается почти  весь трафик в цепочке INPUT

add action=drop chain=input in-interface=tap1-wan log=yes log-prefix=DropToTap1

в логе после нажатия на check for update:

DropToTap1 input: in:tap1-wan out:(none), proto TCP (SYN,ACK), 13.33.76.46:80->мой ip:52460, len 60

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this