Перейти к содержимому
Калькуляторы

Ericsson / Redback Smartedge. Отзывы, реальная производительность. Особенности, плюсы, минусы

Здравствуйте, подскажите пожалуйста такую вещь - трафик ходит по следующей схеме: абонентский трафик аггрегируется на Cisco 6500 далее абонентские РРРоЕ сессии попадают на один из 2х БРАСов, где, собственно, терминируются, после них — на погрничный маршрутизатор, а оттуда либо в пиринг либо в default gateway. Среди РРРоЕ абонентов есть некоторое количество со статическими IP-адресами. Для маршрутизации трафика этих абонентов хотим сделать следующее - на порту пограничного маршрутизатора добавить IP из той же подсетки, что и абонентская статика, а далее — маршрутизация по arp-запросу: пограничный роутер посылает who has, получает ответ от одного из брасов, отправляет трафик куда нужно. Собственно вопрос: нужно ли в такой схеме вешать IP-шник из той же подсети и на интерфейс SE, смотрящий на погрничный коммутатор?

И еще один вопрос: неужели нельзя линки между Cisco и SE, по которым ходят РРРоЕ сессии объединить в link-group? Это ж балансить дико неудобно...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И еще один вопрос: неужели нельзя линки между Cisco и SE, по которым ходят РРРоЕ сессии объединить в link-group? Это ж балансить дико неудобно...

Если не используете NAT и мультисервисный аккаутинг через Радиус, то можно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день!

 

При покупке SE100 в комплекте с самой железкой на CF идет SEOS-se100-6.2.1.6.tar.gz

Вот тут вот: http://shop.nag.ru/article/smartedge-install-guide настоятельно рекомендуется обновить как саму SEOS так и бутлоадер, но обновления бутлоадера на флешке нету.

Подскажите пожалуйста, где можно взять обновление бутлоадера?

И вопрос второй: в статье предлагают апдейтиться с ftp, но образ SEOS с флешки вытянуть не удалось, т.к. какая там файловая система не понятно, по scp копироваться он не хочет (крашится после выгрузки 90 с копейками процентов) по фтп и тфтп тоже его вылить на внеший узел не удалось. Что делать? Не париться и апдейтиться с флешки (документация такое допускает) или биться с выгрузкой прошивки на фтп?

 

Заранее благодарен.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день!

 

При покупке SE100 в комплекте с самой железкой на CF идет SEOS-se100-6.2.1.6.tar.gz

Вот тут вот: http://shop.nag.ru/article/smartedge-install-guide настоятельно рекомендуется обновить как саму SEOS так и бутлоадер, но обновления бутлоадера на флешке нету.

Подскажите пожалуйста, где можно взять обновление бутлоадера?

И вопрос второй: в статье предлагают апдейтиться с ftp, но образ SEOS с флешки вытянуть не удалось, т.к. какая там файловая система не понятно, по scp копироваться он не хочет (крашится после выгрузки 90 с копейками процентов) по фтп и тфтп тоже его вылить на внеший узел не удалось. Что делать? Не париться и апдейтиться с флешки (документация такое допускает) или биться с выгрузкой прошивки на фтп?

 

Заранее благодарен.

 

Здравствуйте,

 

Обычно, свежую версию ПО вам могут предоставить там, где вы приобрели маршрутизатор. Если у вас установлена более ранняя версия SEOS и в /md (к этой директории монтируется внешняя CF) у вас есть более поздняя, то вы можете установить её напрямую с внешней CF:

 

[local]Redback#release download /md ?
 WORD  URL for source file in format /filename

 

Несколько уточняющих вопросов:

С какой на какую версию вы хотите обновится?

А что у вас показывает "show version"?

Вы включили сервис ftp server в настройках контекста (если у вас уже включен ssh server, то можете попробовать скопировать файл с помощью sftp)?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

shefys, спасибо за подсказку!

Несколько уточняющих вопросов:

С какой на какую версию вы хотите обновится?

А что у вас показывает "show version"?

Вы включили сервис ftp server в настройках контекста (если у вас уже включен ssh server, то можете попробовать скопировать файл с помощью sftp)?

 

1. Обновиться хочу с SEOS-5.0.7.2-Release на SEOS-6.2.1.6-Release

2. sh ver показывает:

Redback Networks SmartEdge OS Version SEOS-5.0.7.2-Release
Built by sysbuild@lx-lsf235 Wed Aug 23 10:01:32 PDT 2006
Copyright (C) 1998-2006, Redback Networks Inc. All rights reserved.
System Bootstrap version is PowerPC,rev2.0.1.2
Installed minikernel version is 2.6
Router Up Time -   19 hours 48 minutes 10 secs

3. ftp server не нашел. нашел только клиент. Но удалось слить все, что хотел, через sftp.

 

Версию успешно обновил через release download /md

 

Остался вопрос по бутлоадеру -- трогать не трогать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Обновить в обязательном порядке BootROM и Minikernel.

 

Понял. Спасибо!

Буду просить у НАГовцев последнюю версию всего софта (т.к. покупали железку тут)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, подскажите пожалуйста такую вещь - трафик ходит по следующей схеме: абонентский трафик аггрегируется на Cisco 6500 далее абонентские РРРоЕ сессии попадают на один из 2х БРАСов, где, собственно, терминируются, после них — на погрничный маршрутизатор, а оттуда либо в пиринг либо в default gateway. Среди РРРоЕ абонентов есть некоторое количество со статическими IP-адресами. Для маршрутизации трафика этих абонентов хотим сделать следующее - на порту пограничного маршрутизатора добавить IP из той же подсетки, что и абонентская статика, а далее — маршрутизация по arp-запросу: пограничный роутер посылает who has, получает ответ от одного из брасов, отправляет трафик куда нужно. Собственно вопрос: нужно ли в такой схеме вешать IP-шник из той же подсети и на интерфейс SE, смотрящий на погрничный коммутатор?

Зачем такие сложности, настроить динамическую маршрутизацию не проще?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Появилась SEOS 6.5.1.3. Что нового? Стоит ли обновлятся с 6.2.1.8?

 

много если:

если есть непреодолимая тяга мигрировать на ipv6, то можно и обновиться,

если используете FAC, то оставайтесь на 6.2.1.8,

если используете NAT, то лучше откажитесь от него вообще независимо от релиза,

если ...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Зачем такие сложности, настроить динамическую маршрутизацию не проще?

Как ее правильно настроить на SE100?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сформулирую конкретнее: схема подключения как описано вот тут http://forum.nag.ru/forum/index.php?showtopic=65559&view=findpost&p=642084 то есть 6 портов, по трём портам через Cisco 6509 подключаются PPPoE сабскрайберы (downstream), три других порта объединены в link-group и смотрят на пограничный маршрутизатор (upstream).

 

Конфигурация сейчас в целом такая:

 

context users
! 
ip name-servers x.x.8.4
no ip domain-lookup
!
interface loop1 loopback
 ip address y.y.32.2/22
!
interface subs multibind lastresort
 ip unnumbered loop1
 ip pool y.y.32.10 to y.y.34.255
!
interface server
 description Server Ring
 ip address 192.168.101.5/24
  ip source-address radius 
!
interface toX450a
 description Uplink
 ip address x.x.8.92/29
logging console
!
......................................
!
ip route 0.0.0.0/0 x.x.8.89
ip route 10.0.0.0/8 192.168.101.1
ip route 192.168.0.0/16 192.168.101.1
ip route 194.79.8.0/22 192.168.101.1
service tftp
!
!
!
! ** End Context **
......................................
!
link-group uplink dot1q
dot1q pvc 12
 bind interface toX450a users
dot1q pvc 101
 bind interface server users
dot1q pvc 200
 bind interface sce local
maximum-links 6
lacp passive
!

 

Каким образом в такой схеме сделать так, чтобы пограничный маршрутизатор "видел" адреса РРРоЕ сабскрайберов?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Каким образом в такой схеме сделать так, чтобы пограничный маршрутизатор "видел" адреса РРРоЕ сабскрайберов?

 

например настроить OSPF на "пограничный маршрутизатор" и SE. Вопрос вида: "Как настраивать OSPF с нуля" не задавать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

например настроить OSPF на "пограничный маршрутизатор" и SE. Вопрос вида: "Как настраивать OSPF с нуля" не задавать.

 

А еще можно BGP анонсами /32 адреса отдавать ага, громоздко сильно получается, интересует можно-ли в такой ситуации использовать proxy-arp и как его правильно сконфигурить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ок. пробуем по-малу настроить у вас динамическую маршрутизацию.

первое:

используете мультибинд ластресорт, т.е. ip unnumbered loop1 - маска на интерфейсе loop1 должна быть /32

второе:

пул адресов у вас примерно /23, в OSPF есть команда summary-address, которая позволяет анонсить хоть весь /23-блок, хоть меньшими блоками.

шаблон будет примерно такой:

!
router ospf 1
 fast-convergence
 router-id x.x.8.92
 log-neighbor-up-down
 area 0.0.0.0
  interface toX450a
   authentication md5 ospf-key
  interface loop1
 redistribute connected
 summary-address y.y.32.0/23
!
key-chain ospf-key key-id 1
 key-string encrypted bla-bla-bla
!

 

перенесите ваш вопрос в этот раздел

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

За советы спасибо, в каком направлении копать понял, будет что-то не понятно еще спрошу.

 

перенесите ваш вопрос в этот раздел

 

[#10333] Система не смогла найти форум, который вы пытаетесь посмотреть - то-ли лыжи не едут, то-ли ссылка нерабочая...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Появился закрытый раздел на форуме для обладателей Ericsson Smartedge. Заявки на добавление в группу можете отправлять на адрес smartedge@nag.ru

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В логах SE100 постоянно появляются сообщения вида:

Nov 14 12:55:23: %PPAINFRA-3-QUEUE_ERROR: cc6696df/0013026354/769700000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

Nov 14 12:57:14: %PPAINFRA-3-QUEUE_ERROR: 5a2dfdd7/0013026465/670600000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

Nov 14 13:00:36: %PPAINFRA-3-QUEUE_ERROR: bd5d96ba/0013026667/504400000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

Nov 14 13:17:44: %PPAINFRA-3-QUEUE_ERROR: 461060cd/0013027695/208600000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

Nov 14 13:29:25: %PPAINFRA-3-QUEUE_ERROR: b3b482f0/0013028396/661400000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

Nov 14 13:34:29: %PPAINFRA-3-QUEUE_ERROR: e4ba6202/0013028700/692800000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

Nov 14 13:35:29: %PPAINFRA-3-QUEUE_ERROR: 07156f73/0013028760/290700000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

Nov 14 13:38:56: %PPAINFRA-3-QUEUE_ERROR: db321db3/0013028967/244900000:02/IPPA/EU00:Singly linked empty queue 0xe010a190 space 65535 limit 65536 is inconsistent - 0005a08c 000aa27c

00059bf4 000b69b8 000b6a4e 000b77c8 000b781a 000737ca 000a6380 000a6358 00000000

 

Что бы это значило?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

либо откажитесь от rflow/fac, либо перейдите на seos 6.2.1.8

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

подскажите пожалуйста про SE100:

к management порту привязан интерфейс из контекста local - я могу смаршрутизировать пакет, пришедший на этот интерфейс, в другой контекст?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

подскажите пожалуйста про SE100:

к management порту привязан интерфейс из контекста local - я могу смаршрутизировать пакет, пришедший на этот интерфейс, в другой контекст?

нет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Для "включения/выключения" доступа абонентов в Интернет используем на cisco dynamic ACL. При включении доступа биллинг отправляет правило вида access-template XXX RULE-OUT host xxx.xxx.xxx.xxx any на NAS по rsh, при выключении правило удаляется из ACL - clear access-template XXX...

Вопрос по реализации rsh в SE понимался в середине данной темы, но ответ был довольно расплывчатым.

 

1.Возможна ли реализация описанной "технологии" управления доступом на SE100? Если да, то через какие "механизмы".

2.Если не возможна по представленной схеме, то возможно ли это реализовать другим способом?

 

Клиенты на данном SE100 не терминируются (бордер) - занимается пропуском трафика, BGP, OSPF.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Chrst, попробую ответить на ваш вопрос, хотя я не так уж и опытен в SE100.

Ранее, так же использовал access-template + extended access-list + snmp в кошках, либо linux/freebsd шейперы как для ограничение доступа + ограничения скорости per-ip.

В SE100 идеология чуть другая:

здесь есть две сущности:

1. пользователь (subscriber)

2. сессия ( circuit)

 

Это сделано для абстракции от реализации конкретной технологии доступа в сеть.

Применительно в plain ip access/IpoE под пользователем понимается его IP-адрес.

Сессия - некий интервал времени когда пользователь получает услугу с заявленными/купленными параметрами.

 

Вот эта идеология - она честно говоря коверкает всё восприятие по крайней мере. Потом - всё встаёт на свои места.

Так вот - SE100 может пропускать\запрещать доступ для пользователя без ACL. Т.е. он просто не авторизует сессию пользователя и всё.

Пока что я это увидел и раскурил с привязкой к РАДИУС-серверу. Т.е. когда от абонента приходит IP-трафик на SE100 то SE100 спрашивает у RADIUS-a - "пустить его или нет". Как ответит радиус - так и будет.

 

ACL - тоже есть, на вид - те же extended access-list. Так же используются и для security и для qos и для pbr.

Можно почитать де неплохих статейки про SE100 вот тут:

http://shop.nag.ru/article/baza-znanij

POLICY how to — статья про управление трафиком с помощью QoS, Forward, NAT policies

CLIPS how to — статья про принципы работы IPoE (static и DHCP)

Но переходить с кошки на SE100 - очень тяжело...

Зато по мере того как раскуриваешь "тему" - становится всё интереснее и интереснее (чем дальше в лес тем толще партизаны).

Документация вполне себе приличная, описано всё, с примерами. Естественно всё на английском.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Мы у себя немного по другому сделали:

Сделали две ACL, одна разрешает доступ, другая запрещает.

Субскрайберам с отключенным инетом вещается ACL с запретом, при необходимости сменить статус доступа делаем Radius CoA.

Просто я так понимаю у Chst используется utm5, а там радиус дурацкий и rfw не умеет отдавать Id сессии в радиусе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сижу ковыряю SE400 (достался в наследство).

Задача заменить им линукс-сервак. Юзеры - 802.1x через жуткие костыли.

Схема включения: ИНЕТ - БОРДЕР - SE400 - CISCO(ip unnumbered) - пачка L2 коммутаторов.

Не могу толком разобраться как создать кучу статических субскрайберов. Между SE400 и CISCO подсеть /30.

Настраиваю так:

 

context local

interface USERS multibind
 ip address 31.*.*.33/30
 ip access-group cisco-L3-allow-only in

ip access-list cisco-L3-allow-only
 seq 10 permit ip host 31.*.*.34

subscriber name S1
 ip address 31.*.*.1

! ** End Context **

link-group USERS access
bind interface USERS local
service clips
  clips pvc 1
   bind subscriber S1@local
lacp active

 

Но по show subscribers никаких изменений.

Все примеры в мануале подразумевают терминирование пользовательских виланов на самом SE400 (т.е. L2 вариант) и IP-адрес multibind-интерфейса находится в диапазоне юзерских IP, а у нас-же L3 с ip unnumbered на Cisco и хз как тут сделать правильно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас