Jump to content
Калькуляторы

Mikrotik-приоритеты трафика

Здравствуйте, в качестве роутеров и сервера доступа использую компы с Микротиками.

 

Интересует такой вопрос, бывают моменты когда весь внешний канал загружен качальщиками, пробовал методом метки пакетов и выставлением приоритетов это дело разграничивать, чтобы народ серфил нормально, но что-то как-то улучшений не замечено(((

 

Подскажите кто как делает на микротиках? в таких случаях? если не жалко то скиньте правила для этих целей.

 

 

За ранее спасибо.

 

 

Share this post


Link to post
Share on other sites
Здравствуйте, в качестве роутеров и сервера доступа использую компы с Микротиками.

 

Интересует такой вопрос, бывают моменты когда весь внешний канал загружен качальщиками, пробовал методом метки пакетов и выставлением приоритетов это дело разграничивать, чтобы народ серфил нормально, но что-то как-то улучшений не замечено(((

 

Подскажите кто как делает на микротиках? в таких случаях? если не жалко то скиньте правила для этих целей.

 

 

За ранее спасибо.

Читали? http://www.x-drivers.ru/articles/manuals/12/3.html

Share this post


Link to post
Share on other sites

Кроме simple queue еще иерархические очереди есть.

Share this post


Link to post
Share on other sites
Здравствуйте, в качестве роутеров и сервера доступа использую компы с Микротиками.

 

Интересует такой вопрос, бывают моменты когда весь внешний канал загружен качальщиками, пробовал методом метки пакетов и выставлением приоритетов это дело разграничивать, чтобы народ серфил нормально, но что-то как-то улучшений не замечено(((

 

Подскажите кто как делает на микротиках? в таких случаях? если не жалко то скиньте правила для этих целей.

 

 

За ранее спасибо.

Читали? http://www.x-drivers.ru/articles/manuals/12/3.html

 

аха, вдоль и поперек)))

 

Но такое ощущение что не хочет срабатывать приоритет...данные идут, все вроде нормально, но засада в том что возможно я что-то упускаю...просто нигде отзывов о том что у кого то это работает нету, поэтому ориентироваться сложно вслепую. Вот и решил поднять этот вопрос и уяснить для себя до конца.

Share this post


Link to post
Share on other sites

приоритет без шейпинга нормально работать не будет

Share this post


Link to post
Share on other sites

приоритет без шейпинга нормально работать не будет

а конкретнее можно?

Share this post


Link to post
Share on other sites
приоритет без шейпинга нормально работать не будет
а конкретнее можно?

Ограничивайте максимально возможную скорость для качальщиков.

Share this post


Link to post
Share on other sites
приоритет без шейпинга нормально работать не будет
а конкретнее можно?

Ограничивайте максимально возможную скорость для качальщиков.

Каким образом? выявлять качальщиков метить их трафик и ограничивать по скорости?

Share this post


Link to post
Share on other sites

Если у вас скорость порта <= скорости канала, то достаточно приоритетов. Если скорость порта > скорости канала, то трафик который вы отдаете на скорости большей чем пропустит канала все равно попадет в затор, только немного дальше. Поэтому мало выпустить нужные пакеты первыми, нужно еще и зажать исходящий трафик так чтобы не было превышения пропускной способности канала.

Share this post


Link to post
Share on other sites
Если у вас скорость порта <= скорости канала, то достаточно приоритетов. Если скорость порта > скорости канала, то трафик который вы отдаете на скорости большей чем пропустит канала все равно попадет в затор, только немного дальше. Поэтому мало выпустить нужные пакеты первыми, нужно еще и зажать исходящий трафик так чтобы не было превышения пропускной способности канала.

зажать исходящий трафик в сторону локалки? Возможны потери пакетов? при достижении пиковых скоростей.

Share this post


Link to post
Share on other sites

ну Вы и вопросы задаете. Вы сами сперва тогда определитесь чего хотите.

У вас загружен внешний канал в каком направлении? к Вам? Тогда на своей стороне вы ничего приоритетами уже не сделаете - трафик вами уже получен и отдаете вы его в заведомом более быстрый порт чем канал. Вам нужно искуственно зажимать скорость отдачи абонентам/клиентам. Тем самым вы все равно не сможете повлиять на уже полученный трафик, но статистически чем медленнее вы будете отдавать, тем медленнее будете получать, тем самым освободив полосу под трафик который не шейпится на отдаче. Естественно любой шейпинг может приводить к отбрасываюнию части пакетов, но других способов все равно нет. Красиво шейпится только исходящий трафик, соответственно его вам шейпить должен ваш провайдер.

Share this post


Link to post
Share on other sites

делать провайдеру больше нечего, кроме того, чтобы шейпить трафик на клиентов клиента.

на самом деле шейпингом исходящего трафика можно добиться практически того же результата, просто его продумать надо хорошо, т.к. разные протоколы имеют разные соотношения запрос/ответ.

качальщики преимущественно что используют? http? ftp? torrent? dc++? другой p2p протокол?

Т.е. первый шаг - анализ трафика, который бегает на предмет его классификации по протоколам, только после этого можно вырабатывать политику предоставления QoS.

А уже только потом ее имлементировать.

 

Share this post


Link to post
Share on other sites
приоритет без шейпинга нормально работать не будет
если вы имеетве ввиду шейпер это ограничение скорости на клиента то вы ошибаетесь - очень даже нормально работает.

 

У вас загружен внешний канал в каком направлении? к Вам? Тогда на своей стороне вы ничего приоритетами уже не сделаете - трафик вами уже получен и отдаете вы его в заведомом более быстрый порт чем канал. Вам нужно искуственно зажимать скорость отдачи абонентам/клиентам.
бред

 

если по теме

вот читайте http://mum.mikrotik.com/presentations/US09/megis_qos.pdf конкретно на примерах расписано как пошейпить чесно скорость на клиентов. и в конце начало как выставить приоритеты трафика при гарантированом канале. ну а правила по аналогии я думаю автор подсказал куда копать - вы уже догадаетесь как. куда копать все в этом талмуде есть. я по нему делал и все работает - серфинг отдельно, закачки отдельно. торентщики в легкой жопе в часы пик (жопка для торента, серфинг/игры/аська все в порядке).

Edited by Fog

Share this post


Link to post
Share on other sites
приоритет без шейпинга нормально работать не будет
если вы имеетве ввиду шейпер это ограничение скорости на клиента то вы ошибаетесь - очень даже нормально работает.

 

У вас загружен внешний канал в каком направлении? к Вам? Тогда на своей стороне вы ничего приоритетами уже не сделаете - трафик вами уже получен и отдаете вы его в заведомом более быстрый порт чем канал. Вам нужно искуственно зажимать скорость отдачи абонентам/клиентам.
бред

 

если по теме

вот читайте http://mum.mikrotik.com/presentations/US09/megis_qos.pdf конкретно на примерах расписано как пошейпить чесно скорость на клиентов. и в конце начало как выставить приоритеты трафика при гарантированом канале. ну а правила по аналогии я думаю автор подсказал куда копать - вы уже догадаетесь как. куда копать все в этом талмуде есть. я по нему делал и все работает - серфинг отдельно, закачки отдельно. торентщики в легкой жопе в часы пик (жопка для торента, серфинг/игры/аська все в порядке).

спасибо, щас почитаем что там да как...У Вас работает?

 

Скорость для абонентов у меня выставляет биллинг в Simple queues!

Edited by parazit74

Share this post


Link to post
Share on other sites
спасибо, щас почитаем что там да как...У Вас работает?
у меня работает, 4 внешних канала, на каждом настроен шейпер (ограничение скорости) PCQ и QoS (приоритет трафика),

причем все на одном RB450G...

только не принимайте ссылку которую вам дали за идеал, там статья не дописана :)

Share this post


Link to post
Share on other sites

ну да. недописана. для приоритетов ненаписано для того чтобы головой думать иногда а не тупо копировать и кричать шо никуя неработает.

а так все по аналогии настраивается и работает.

Edited by Fog

Share this post


Link to post
Share on other sites
ну да. недописана. для приоритетов ненаписано для того чтобы головой думать иногда а не тупо копировать и кричать шо никуя неработает.
меня тот мануал вообще сбивал столку, настроил без него...

в том мануале идет настройка приоритета трафика над группами а не над типом трафика, поэтому он и не дописан,

по тому как если его дописывать то структуру построения нужно менять вот его автор и не дописывает :)

самое главное понимать как идет пакет от пользователя через тик и обратно и тогда станет все ясно....

и как только это стало понятно за 20 минут настроил то что есть на данный момент, далее еще прокси на каждый канал

буду прикручивать, с шейпером.... и это все на одном тике :)

Share this post


Link to post
Share on other sites
приоритет без шейпинга нормально работать не будет
если вы имеетве ввиду шейпер это ограничение скорости на клиента то вы ошибаетесь - очень даже нормально работает.

 

У вас загружен внешний канал в каком направлении? к Вам? Тогда на своей стороне вы ничего приоритетами уже не сделаете - трафик вами уже получен и отдаете вы его в заведомом более быстрый порт чем канал. Вам нужно искуственно зажимать скорость отдачи абонентам/клиентам.
бред

 

если по теме

вот читайте http://mum.mikrotik.com/presentations/US09/megis_qos.pdf конкретно на примерах расписано как пошейпить чесно скорость на клиентов. и в конце начало как выставить приоритеты трафика при гарантированом канале. ну а правила по аналогии я думаю автор подсказал куда копать - вы уже догадаетесь как. куда копать все в этом талмуде есть. я по нему делал и все работает - серфинг отдельно, закачки отдельно. торентщики в легкой жопе в часы пик (жопка для торента, серфинг/игры/аська все в порядке).

Можно поподробнее - как именно торренщики в жопе?

Я это вкурил (даже перевел и запостил в вики микротика)

Получилось настроить шейперы.

Но по приоретизации статья не дописана. Как вы именно торрент-трафик метите?

Даже если тупо попробывать правило P2P зарезать (временно - чисто для теста)- очень мало пакетов туда попадает. Ибо uTP....

 

Или как-то по другому режите?

Share this post


Link to post
Share on other sites

Имеется RB 750 как выставить ограничение сессий на конкретного пользователя или создать общее правило?

Share this post


Link to post
Share on other sites

Интересно, если заместо drop использовать что-то другое, ведь потери пакетов быть не должно?

Share this post


Link to post
Share on other sites
Имеется RB 750 как выставить ограничение сессий на конкретного пользователя или создать общее правило?
/ip firewall filter
add action=drop chain=forward comment="tcp session limit" connection-limit=40,32
disabled=no protocol=tcp src-address=тут ваш IP

Share this post


Link to post
Share on other sites

Добавляю правило через WinBox-->New Terminal /ip firewall filter

add action=drop chain=forward comment="tcp session limit" connection-limit=40,32

а это disabled=no protocol=tcp src-address=тут ваш IP ставлю свой 192.168.88.100 вылезает ошибка.

И во вкладке IP-->Firewall--> NAT-->Extra-->connection-limit ограничение не отображается.

Share this post


Link to post
Share on other sites
Добавляю правило через WinBox-->New Terminal /ip firewall filter

add action=drop chain=forward comment="tcp session limit" connection-limit=40,32

а это disabled=no protocol=tcp src-address=тут ваш IP ставлю свой 192.168.88.100 вылезает ошибка.

это одно правило, а не два....
И во вкладке IP-->Firewall--> NAT-->Extra-->connection-limit ограничение не отображается.
а с чего оно должно там отобразится?

Share this post


Link to post
Share on other sites
.....серфинг отдельно, закачки отдельно. торентщики в легкой жопе в часы пик (жопка для торента, серфинг/игры/аська все в порядке).

Так поделитесь, плиз, как вы торрент-трафик "выделяете" ?

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this