Jump to content
Калькуляторы

FreeBSD Прерывания трафика

Добрый день.

Есть маршрутизатор на FreeBSD 7.2 - Stable: Core 2 Duo 2.2, 2G RAM, 2-x Intel PRO1000 MT - Deskstop Adapter. Трафик ~ 120 мбит.

До этого трафик был и больше (150 мбит) Но сейчас появились странные прерывания.. Работает приблизительно 20 минут потом трафик полностью

прерывается, буквально на секунд 20 и снова восстанавливается. "Физика" при этом - все ок. Подозреваю что может переполнятся буфер на самой карточке.

Пробовал другие карты, тоже самое.

 

Спасибо за помощь.

Share this post


Link to post
Share on other sites

Диагностика?

Share this post


Link to post
Share on other sites

Диагностика?

Хотелось бы услышать какие-то идеи. Спасибо

Share this post


Link to post
Share on other sites

подземный стук не лечится.

гугль в помощь.

Share this post


Link to post
Share on other sites

А кто выступает аплинком? Можно в ПМ.

У меня похожая ситуация была, но на фре.

Share this post


Link to post
Share on other sites

дайте угадаю - intel pro 1000 MT Desktop Adapter на PCI (32) шине? дык она сдохнет от пакетной нагрузки. она даже 200k pps не выдержит - шина сдохнет. да и на 100к pps сомнения дикие уже.

поприличней карточки воткните, и обязательно на pci-express. да хотя бы те же intel pro 1000 mt server adapter на pci-express. она уже спокойно протащит за 200k pps. если конечно и систему хорошо оттюните.

производительность гиговых pci карт, особенно под freebsd, да еще и на базе интела - очень распространенный материал в поисках гоголя.

Edited by darkagent

Share this post


Link to post
Share on other sites
дайте угадаю - intel pro 1000 MT Desktop Adapter на PCI (32) шине? дык она сдохнет от пакетной нагрузки. она даже 200k pps не выдержит - шина сдохнет. да и на 100к pps сомнения дикие уже.

поприличней карточки воткните, и обязательно на pci-express. да хотя бы те же intel pro 1000 mt server adapter на pci-express. она уже спокойно протащит за 200k pps. если конечно и систему хорошо оттюните.

производительность гиговых pci карт, особенно под freebsd, да еще и на базе интела - очень распространенный материал в поисках гоголя.

Возможно, Вы правы. Но нужно учитывать:

 

1.

Трафик ~ 120 мбит. До этого трафик был и больше (150 мбит) Но сейчас появились странные прерывания..

2.

Подозреваю что может переполнятся буфер на самой карточке. Пробовал другие карты, тоже самое.

Share this post


Link to post
Share on other sites

пакетная нагрузка != потоковая нагрузка.

если раньше вам давали полноразмерные пакеты (1500байт) и вы кушали 150мбит/с - то это примерно нагрузка в 13-15k pps;

если сейчас вам дают мелкими пакетами 100мбит (допустим по 100байт, ддосят) - это уже 130k pps;

ход мысли надеюсь понятен..

 

вы пробовали другие карты на pci или pci-express? пробуйте исключительно второй вариант.

сейчас все серверные системы (которые не стыдно использовать), имеют интегрированные гигабитные сетевухи на pci-express. держут они нагрузку такую, какая вам не снилась. у меня би-нат на базе proliant'а 380го с NetXtreme II BCM5708 - держит гигабит спокойно (на линухе правда), как мелкими пакетами так и большими. а вы говорите..

Edited by darkagent

Share this post


Link to post
Share on other sites

 

новогодняя история - линузятники лечат подземный стук

Share this post


Link to post
Share on other sites
пакетная нагрузка != потоковая нагрузка.

если раньше вам давали полноразмерные пакеты (1500байт) и вы кушали 150мбит/с - то это примерно нагрузка в 13-15k pps;

если сейчас вам дают мелкими пакетами 100мбит (допустим по 100байт, ддосят) - это уже 130k pps;

ход мысли надеюсь понятен..

1.

Зачем говорить очевидные вещи? Почему не допустить мысль, что собеседник не дурак?

 

2.

Это не моя тема, но не думаю, что у автора темы внезапно изменился характер трафика.

(на вашем языке: Меню не изменилось)

 

вы пробовали другие карты на pci или pci-express? пробуйте исключительно второй вариант.

сейчас все серверные системы (которые не стыдно использовать), имеют интегрированные гигабитные сетевухи на pci-express. держут они нагрузку такую, какая вам не снилась. у меня би-нат на базе proliant'а 380го с NetXtreme II BCM5708 - держит гигабит спокойно (на линухе правда), как мелкими пакетами так и большими. а вы говорите..

Эта совешенно определенная тема, а Вы рассказываете, что нужно менять все в корне.

Думаю, автор об этом может догадаться и без подсказок,

но его волнует немного другое.

 

 

Share this post


Link to post
Share on other sites
Зачем говорить очевидные вещи? Почему не допустить мысль, что собеседник не дурак?
прошу прощения, если мои соображения кого то задели.
Это не моя тема, но не думаю, что у автора темы внезапно изменился характер трафика.
привык просчитывать всевозможные варианты, потому как на практике доводилось сталкиваться с многим.
Эта совешенно определенная тема, а Вы рассказываете, что нужно менять все в корне.
я не говорю что нужно менять все в корне, я просто предложил вариант. с подобной проблемой самому доводилось сталкиваться, правда уже очень давно (годов эдак 2-3 назад).

 

Share this post


Link to post
Share on other sites
Это не моя тема, но не думаю, что у автора темы внезапно изменился характер трафика.
Если все работало и вдруг перестало - надо искать что поменялось.

 

Share this post


Link to post
Share on other sites

У меня были похожие симптомы на одном сервере, когда был конфликт IP-адресов, в те моменты, когда трафик не ходил, на другой стороне в arp-таблице был не тот мак.

Share this post


Link to post
Share on other sites
новогодняя история - линузятники лечат подземный стук
все сразу в экстрасенсы и телепаты ударились :)

удаленно диагностируют и лечат подземный стук )))

Share this post


Link to post
Share on other sites

Всем спасибо за помощь!

Проблема оказалась в аплинке. Приходил кривой влан судя по всему.

Сменили влан - все заработало.

 

 

Share this post


Link to post
Share on other sites
Проблема оказалась в аплинке. Приходил кривой влан судя по всему.

Сменили влан - все заработало.

Это как так? И как вообще такое могло работать? А у аплинка что за железо стоит?

Share this post


Link to post
Share on other sites
Проблема оказалась в аплинке. Приходил кривой влан судя по всему.

Сменили влан - все заработало.

Это как так? И как вообще такое могло работать? А у аплинка что за железо стоит?

Пока непонятно как. С нашей стороны стоит С3560 с ихней - какой-то Zyxel..

Share this post


Link to post
Share on other sites

видел непонятные глюки в свое время, когда два vlan между парой железок шли. Один с тегом, другой без. работало через задницу. Когда оба vlan пустили с тегом - все волшебным образом стало хорошо.

Share this post


Link to post
Share on other sites
новогодняя история - линузятники лечат подземный стук
новогодняя история-2: мэтры не читают ни тем ни содержания топиков (это там, где про 7.2)

 

вы бы хоть уровень логов посоветовали сменить, все бы польза была

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this