Jump to content
Калькуляторы

Подскажите решение по MPLS

Приветствую.

 

Прошу помощи в решении.

 

Есть два ЦОДа, в каждом ядро, маршрутизаторы и свой канал в интернет, в который публикуется одинаковая AS с разными подсетями. Между ЦОД два канала L2VPN с EIGRP.

Из локальной сети выход в интернет через файерволы.

 

simple.thumb.jpg.42f9a3e571fd3cc12153e3bb7f5b1e70.jpg

 

Для отказоустойчивости хочу публиковать через каждого провайдера обе подсети (вторую с понижающей community), и межу маршрутизаторами отдавать маршрут по умолчанию.

Как лучше "прокинуть" PI адреса через ядро, чтобы они не появились в маршрутах локальной сети ?

 

Сначала организовал от 4451 прямые линки на 9300, в обход FW.

А вот далее...

Первое, что в голову пришло это поднять туннели между маршрутизаторами . Но не красиво как-то.

Второе VRF, но тогда получается надо на 9300 между ЦОД поднимать сабинтерфейсы. Не возникнет ли проблем с тем что каналы между ЦОД  L2VPN, а не темная оптика?

Третье MPLS. С этим не работал. Не получится какой-то MPLS поверх MPLS ?

 

Как бы вы сделали ?

 

 

Edited by alger

Share this post


Link to post
Share on other sites

MPLS поверх MPLS  великолепно работает, главное, что бы на текущих 2xL2VPN у вас MTU был с "запасом"

Share this post


Link to post
Share on other sites
1 час назад, fork сказал:

MPLS поверх MPLS  великолепно работает, главное, что бы на текущих 2xL2VPN у вас MTU был с "запасом"

Можно подробнее. Минимальное и идеальное значение сколько ?

С MPLS вообще опыта работы нет. Как проверить, на существующих каналах будет работать ?

Edited by alger

Share this post


Link to post
Share on other sites

MTU в MPLS зависит от количества меток, одна метка = 4 байта, количество меток зависит от того как вы будете использовать свой MPLS.

Стык с оператором предоставляющим 2xL2VPN как организован? в этом месте тоже могут накапливаться overhead.

Просите у своего поставщика 1550, этого хватит с небольшим запасом.

Проверить можно: Router#ping AA.AA.AA.AA df-bit size 1508

 

Share this post


Link to post
Share on other sites

В реальности сеть выглядит так как нарисовано ? По одному 9300 одному бордеру в дц и тп ? Если да то отказоустойчивость тут эфемерна.  В вашем случае проще всего сделать тунель на лупбэках  и планировать редизайн сети для поддержки малтитенанси нативно . Вариант добавить по провайдеру в каждый дц не рассматривали ? 

 

9 hours ago, fork said:

MTU в MPLS зависит от количества меток, одна метка = 4 байта, количество меток зависит от того как вы будете использовать свой MPLS.

Стык с оператором предоставляющим 2xL2VPN как организован? в этом месте тоже могут накапливаться overhead.

Просите у своего поставщика 1550, этого хватит с небольшим запасом.

Проверить можно: Router#ping AA.AA.AA.AA df-bit size 1508

 

Если просить то уже 9200 байта 

Share this post


Link to post
Share on other sites
8 часов назад, EvgeniySerb сказал:

В реальности сеть выглядит так как нарисовано ? По одному 9300 одному бордеру в дц и тп ? Если да то отказоустойчивость тут эфемерна.

9300 конечно же по два, в стэке.

 

17 часов назад, fork сказал:

MTU в MPLS зависит от количества меток, одна метка = 4 байта, количество меток зависит от того как вы будете использовать свой MPLS.

Стык с оператором предоставляющим 2xL2VPN как организован? в этом месте тоже могут накапливаться overhead.

Просите у своего поставщика 1550, этого хватит с небольшим запасом.

Проверить можно: Router#ping AA.AA.AA.AA df-bit size 1508

 

спасибо за подсказку.

 

L2VPN это два отдельных канала от разных провайдеров. пока еще не реализованы, поэтому можно попробовать что-то изменить.

как будут провайдеры делать не знаю.

MPLS мне нужен только чтобы изолировать мои подсети внешних адресов от локальной сети.

 

Может, в моем случае, MPLS похоже как "из пушки по воробьям". И проще сделать сабинтерфесы на каналах L2VPN и использовать VRF. С сабинтерфейсами, как я понимаю, также должен MTU подходящим ?

Share this post


Link to post
Share on other sites
4 hours ago, alger said:

9300 конечно же по два, в стэке.

 

спасибо за подсказку.

 

L2VPN это два отдельных канала от разных провайдеров. пока еще не реализованы, поэтому можно попробовать что-то изменить.

как будут провайдеры делать не знаю.

MPLS мне нужен только чтобы изолировать мои подсети внешних адресов от локальной сети.

 

Может, в моем случае, MPLS похоже как "из пушки по воробьям". И проще сделать сабинтерфесы на каналах L2VPN и использовать VRF. С сабинтерфейсами, как я понимаю, также должен MTU подходящим ?

Тут не в мту проблема (хотя фреймы будут больше ) . Подтвердить с провайдером надо что они пропускают тэгированные фреймы . Имейте ввиду что mpls не работает на сабинтерфейсах 

 

 

ну и стэк это не про ридаденси.

Share this post


Link to post
Share on other sites
4 часа назад, EvgeniySerb сказал:

Имейте ввиду что mpls не работает на сабинтерфейсах

Почему не работает? Вроде нормально работает

 

4 часа назад, EvgeniySerb сказал:

Подтвердить с провайдером надо что они пропускают тэгированные фреймы

Если ТС не хочет связыватья с MPLS, можно ведь запросить QinQ и гонять VRF-lite поверх

Share this post


Link to post
Share on other sites
29 minutes ago, VolanD666 said:

Почему не работает? Вроде нормально работает

 

Мой косяк , работает но есть нюансы 

Share this post


Link to post
Share on other sites
10 часов назад, EvgeniySerb сказал:
10 часов назад, VolanD666 сказал:

Почему не работает? Вроде нормально работает

 

Мой косяк , работает но есть нюансы 

Ну вы же знаете правила? :)

Share this post


Link to post
Share on other sites

Собрал небольшую тестовую площадку.

laba.thumb.jpg.1fd837b3e22cc3530111b722c9aefa5a.jpg

c 203.0.113.2 203.0.113.18 и обратно пинги проходят.

но  10.10.10.1 и 30.30.30.1 не пингуются, хотя маршруты есть.

 

Что не так ?

 

BGP1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     203.0.113.0/28 is subnetted, 2 subnets
S       203.0.113.16 [1/0] via 203.0.113.1
C       203.0.113.0 is directly connected, FastEthernet0/0.5
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.1 is directly connected, Loopback0
     30.0.0.0/32 is subnetted, 1 subnets
B       30.30.30.1 [200/0] via 203.0.113.18, 00:18:53
BGP1#ping 30.30.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.30.30.1, timeout is 2 seconds:
UU.U.
Success rate is 0 percent (0/5)
BGP1#ping 203.0.113.18

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 203.0.113.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/37/44 ms
BGP1#

 

 

Current configuration : 1191 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BGP1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 203.0.113.2 255.255.255.240
!
interface FastEthernet0/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router bgp 496
 no synchronization
 bgp router-id 203.0.113.2
 bgp log-neighbor-changes
 network 10.10.10.1 mask 255.255.255.255
 neighbor 203.0.113.18 remote-as 496
 neighbor 203.0.113.18 update-source FastEthernet0/0.5
 no auto-summary
!
ip forward-protocol nd
ip route 203.0.113.16 255.255.255.240 203.0.113.1
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login    
!
!
end

BGP1#

 

MSK#sh run
Building configuration...

Current configuration : 2347 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MSK
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf one
 rd 496:0
 route-target export 496:0
 route-target import 496:0
!
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
archive
 log config
  hidekeys
! 
!
!
vlan internal allocation policy ascending
!
!
!
!
!
interface Loopback0
 ip address 10.192.0.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no switchport
 ip address 10.192.4.1 255.255.255.252
 mpls ip
 mpls mtu 1512
!
interface FastEthernet2/1
!
interface FastEthernet2/2
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
 no switchport
 ip address 10.192.32.1 255.255.255.0
!
interface Vlan1
 no ip address
!
interface Vlan5
 ip vrf forwarding one
 ip address 203.0.113.1 255.255.255.240
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet2/0
 network 10.192.0.1 0.0.0.0 area 0
 network 10.192.4.0 0.0.0.3 area 0
 network 10.192.32.0 0.0.0.255 area 1
!
router bgp 65000
 no synchronization
 bgp router-id 10.192.0.1
 bgp log-neighbor-changes
 neighbor 10.193.0.1 remote-as 65000
 neighbor 10.193.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 10.193.0.1 activate
  neighbor 10.193.0.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  redistribute connected
  redistribute static
  no synchronization
  network 203.0.113.0 mask 255.255.255.240
 exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!         
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
          
MSK#

 

EKB#sh run
Building configuration...

Current configuration : 2289 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EKB
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf one
 rd 496:0
 route-target export 496:0
 route-target import 496:0
!
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
archive
 log config
  hidekeys
! 
!
!
vlan internal allocation policy ascending
!
!
!
!
!
interface Loopback0
 ip address 10.193.0.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no switchport
 ip address 10.192.4.2 255.255.255.252
 mpls ip
 mpls mtu 1512
!
interface FastEthernet2/1
!
interface FastEthernet2/2
 switchport mode trunk
 speed 100
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!         
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
 no switchport
 ip address 10.193.32.1 255.255.255.0
!
interface Vlan1
 no ip address
!
interface Vlan5
 ip vrf forwarding one
 ip address 203.0.113.17 255.255.255.240
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet2/0
 network 10.192.4.0 0.0.0.3 area 0
 network 10.193.0.1 0.0.0.0 area 0
 network 10.193.32.0 0.0.0.255 area 2
!
router bgp 65000
 no synchronization
 bgp router-id 10.193.0.1
 bgp log-neighbor-changes
 neighbor 10.192.0.1 remote-as 65000
 neighbor 10.192.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 10.192.0.1 activate
  neighbor 10.192.0.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  network 203.0.113.16 mask 255.255.255.240
 exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!         
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

EKB#

 

Building configuration...

Current configuration : 1191 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BGP3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
!
!
!
interface Loopback0
 ip address 30.30.30.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 203.0.113.18 255.255.255.240
!
interface FastEthernet0/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router bgp 496
 no synchronization
 bgp router-id 203.0.113.18
 bgp log-neighbor-changes
 network 30.30.30.1 mask 255.255.255.255
 neighbor 203.0.113.2 remote-as 496
 neighbor 203.0.113.2 update-source FastEthernet0/0.5
 no auto-summary
!
ip forward-protocol nd
ip route 203.0.113.0 255.255.255.240 203.0.113.17
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login    
!
!
end

BGP3#

 

Share this post


Link to post
Share on other sites

зачем вам такая РЕ - СЕ  схема, да еще и со статиками на 4451?

настраивайте уже тогда 4451 как РЕ!

 

и покажите таблицу маршрутизации со всех устройств, на PE можно только таблицу для vrf ONE

 

Share this post


Link to post
Share on other sites
4 часа назад, alger сказал:

но  10.10.10.1 и 30.30.30.1 не пингуются, хотя маршруты есть.

 

Что не так ?

В данной конфигурации у вас просто нет маршрутов внутри vrf one на PE (MSK, EKB) до этих сетей. Посмотрите сами на PE командой show ip route vrf one

 

 

Share this post


Link to post
Share on other sites
5 часов назад, crank сказал:

В данной конфигурации у вас просто нет маршрутов внутри vrf one на PE (MSK, EKB) до этих сетей. Посмотрите сами на PE командой show ip route vrf one

 

 

Да я видел что нет маршрута, просто не пойму что сделать.

 

MSK#sh ip route vrf one

Routing Table: one
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     203.0.113.0/28 is subnetted, 2 subnets
B       203.0.113.16 [200/0] via 10.193.0.1, 13:45:52
C       203.0.113.0 is directly connected, Vlan5
MSK#

 

EKB#sh ip route vrf one

Routing Table: one
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     203.0.113.0/28 is subnetted, 2 subnets
C       203.0.113.16 is directly connected, Vlan5
B       203.0.113.0 [200/0] via 10.192.0.1, 13:49:02
EKB#

 

 

10 часов назад, reef сказал:

зачем вам такая РЕ - СЕ  схема, да еще и со статиками на 4451?

настраивайте уже тогда 4451 как РЕ!

вы предлагает убрать vrf с 9300, и переместить его на 4451 ?

это решение было сделано на основе текущей конфигурации с минимальными изменениями на 4451.

надо подумать, если 4451 сделать PE , не усложнит ли это отдачу 3 vlan с 4451 на 9300.

Edited by alger

Share this post


Link to post
Share on other sites
2 часа назад, alger сказал:

Да я видел что нет маршрута, просто не пойму что сделать.

Добавил на PE статические маршруты типа :

MSK#sh run | in ip route
ip route vrf one 10.10.10.1 255.255.255.255 203.0.113.2
MSK#

пинги между 10.10.10.1 и 30.30.30.1 пошли. но это статика :(

получается еще и внутри vrf надо ospf поднимать ?
что-то я уже совсем запутался

 

В 24.02.2020 в 23:04, EvgeniySerb сказал:
В 24.02.2020 в 22:34, VolanD666 сказал:

Почему не работает? Вроде нормально работает

 

Мой косяк , работает но есть нюансы 

Подскажите какие нюансы ?

Share this post


Link to post
Share on other sites
4 часа назад, alger сказал:

получается еще и внутри vrf надо ospf поднимать ?

Нет, если у вас MPLS то оспф внутри поднимать не нужно. У вас BGP должен роутить трафик для каждого сервиса.

 

Еще раз спрошу, QinQ и VRF-lite не проше будет сделать?

Share this post


Link to post
Share on other sites
Только что, VolanD666 сказал:

Нет, если у вас MPLS то оспф внутри поднимать не нужно. У вас BGP должен роутить трафик для каждого сервиса.

У меня получилось только с OSPF. Буду признателен если скажете как без OSPF обойтись.

 

BGP1

hostname BGP1
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 203.0.113.2 255.255.255.240
!
router ospf 2
 router-id 203.0.113.2
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet0/0.5
 network 10.10.10.1 0.0.0.0 area 0
 network 203.0.113.0 0.0.0.15 area 0
!
router bgp 496
 no synchronization
 bgp router-id 203.0.113.2
 bgp log-neighbor-changes
 network 10.10.10.1 mask 255.255.255.255
 neighbor 203.0.113.18 remote-as 496
 neighbor 203.0.113.18 update-source FastEthernet0/0.5
 no auto-summary
!
end

MSK

hostname MSK
ip cef
!
ip vrf one
 rd 496:0
 route-target export 496:0
 route-target import 496:0
!
mpls label protocol ldp
multilink bundle-name authenticated
!
interface Loopback0
 ip address 10.192.0.1 255.255.255.255
!
interface FastEthernet2/0
 no switchport
 ip address 10.192.4.1 255.255.255.252
 mpls ip
 mpls mtu 1512
!
interface FastEthernet2/2
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet2/15
 no switchport
 ip address 10.192.32.1 255.255.255.0
!
interface Vlan5
 ip vrf forwarding one
 ip address 203.0.113.1 255.255.255.240
!
router ospf 2 vrf one
 router-id 203.0.113.1
 log-adjacency-changes
 redistribute bgp 65000 metric 20 subnets
 network 203.0.113.0 0.0.0.15 area 0
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet2/0
 network 10.192.0.1 0.0.0.0 area 0
 network 10.192.4.0 0.0.0.3 area 0
 network 10.192.32.0 0.0.0.255 area 1
!
router bgp 65000
 no synchronization
 bgp router-id 10.192.0.1
 bgp log-neighbor-changes
 neighbor 10.193.0.1 remote-as 65000
 neighbor 10.193.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 10.193.0.1 activate
  neighbor 10.193.0.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  redistribute ospf 2 vrf one
  no synchronization
  network 203.0.113.0 mask 255.255.255.240
 exit-address-family
!
!
mpls ldp router-id Loopback0
!
end

EKB & BGP3 похожие настройки.

 

 

10 минут назад, VolanD666 сказал:

Еще раз спрошу, QinQ и VRF-lite не проше будет сделать?

QinQ не хотелось бы L2 трафик гонять.

VRF-lite да, проще. Этот вариант тоже рассматриваю, и возможно выберу его.

Просто решил попробовать MPLS для общего понимания.

Share this post


Link to post
Share on other sites
7 часов назад, alger сказал:

вы предлагает убрать vrf с 9300, и переместить его на 4451 ?

это решение было сделано на основе текущей конфигурации с минимальными изменениями на 4451.

надо подумать, если 4451 сделать PE , не усложнит ли это отдачу 3 vlan с 4451 на 9300.

 

да, с 9300 убрать vrf который по большому счету не нужен на этом свитче, можете оставить 9300 если хочется как Р устройство.

на отдачу 3 vlan с 4451 на 9300 не повлияет точно, а вот то что вы выкосите избыточность с 9300, это как раз таки Вам сильно упросит схему.

 

Share this post


Link to post
Share on other sites
36 минут назад, alger сказал:

EKB & BGP3 похожие настройки.

Кажется разобрался в вашей схеме.

Первое, вам нужно решить кто будет ПЕ (Лично я бы на коммутаторах ПЕ не делал):

1) Если вы делаете 9300 ПЕ. То в таком случае BGP у вас заканчивается на нем и дальше идет OSPF. Я бы сделал так в этом случае

2) Если вы делаете ПЕ на роутерах. Тогда на 9300 у вас нет никакого bgp и весь MP-BGP переносится на ПЕ. Задача 9300 просто роутить трафик.

 

Ну либо вы можете просто сделать роутеры слева и справа DC прокинув влан через 9300

Share this post


Link to post
Share on other sites
42 минуты назад, reef сказал:

 

да, с 9300 убрать vrf который по большому счету не нужен на этом свитче, можете оставить 9300 если хочется как Р устройство.

на отдачу 3 vlan с 4451 на 9300 не повлияет точно, а вот то что вы выкосите избыточность с 9300, это как раз таки Вам сильно упросит схему.

 

тогда с 4451 mpls  пойдет на 9300 с сабинтерфейса. Проблем из-за сабинтерфейса не будет ?

Share this post


Link to post
Share on other sites
30 минут назад, alger сказал:

тогда с 4451 mpls  пойдет на 9300 с сабинтерфейса. Проблем из-за сабинтерфейса не будет ?

Не должно быть там никаких проблем, если у вас с MTU все хорошо.

Share this post


Link to post
Share on other sites
31 минуту назад, VolanD666 сказал:

Не должно быть там никаких проблем, если у вас с MTU все хорошо.

между 4451 и 9300 прямой кабель, что может быть с MTU ?

Share this post


Link to post
Share on other sites

Ещё раз перечитал тему. Если я правильно понял, то вы хотите, чтобы PI адреса были только на 4451. В таком случае просто разверните MPLS + OSPF/IS-IS от одного 4451 до другого и поднимите iBGP поверх на лупбэках. Эти лупбэки проанонсируйте в IGP - OSPF/IS-IS, чтобы появилась транспортная MPLS метка до них. При этом маршруты передаваемые по BGP на 9300 будут отсутствовать, а трафик через них (9300) будет бегать с транспортной меткой MPLS. И не надо будет городить никаких vrf'ов.

Share this post


Link to post
Share on other sites
18 часов назад, crank сказал:

Ещё раз перечитал тему. Если я правильно понял, то вы хотите, чтобы PI адреса были только на 4451. В таком случае просто разверните MPLS + OSPF/IS-IS от одного 4451 до другого и поднимите iBGP поверх на лупбэках. Эти лупбэки проанонсируйте в IGP - OSPF/IS-IS, чтобы появилась транспортная MPLS метка до них. При этом маршруты передаваемые по BGP на 9300 будут отсутствовать, а трафик через них (9300) будет бегать с транспортной меткой MPLS. И не надо будет городить никаких vrf'ов.

Попробую так сделать.

Правда, пока не совсем понял как отказаться от vrf.

 

Изменил схему и убрал все лишние настройки. на 9300 ядре остались только vlan и mpls.

mpls2.thumb.jpg.8eefb6da7e15761ba750445d35f74f78.jpg

 

На BGP1 AS496 192.0.2.2/24, на BGP3 та же AS496 только подсеть другая 198.51.100.2/24. Вся задумка чтобы сделать возможным публиковать обе подсети в разных места.

 

Конфиг BGP1, BGP3 аналогичный.

hostname BGP1
!
mpls label protocol ldp
!
interface FastEthernet0/0
 description 9300-1_fa2/2
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 mpls ip
!
interface FastEthernet0/0.333
 description our_PI
 encapsulation dot1Q 333
 ip address 192.0.2.2 255.255.255.0
!
interface FastEthernet1/0
 description ISP1
 ip address 1.1.1.2 255.255.255.252
 duplex auto
 speed auto
!
router bgp 496
 no synchronization
 bgp router-id 1.1.1.2
 bgp log-neighbor-changes
 network 192.0.2.0
 neighbor 1.1.1.1 remote-as 100
 neighbor 198.51.100.2 remote-as 496
 neighbor 198.51.100.2 update-source FastEthernet0/0.5
 no auto-summary
!         
mpls ldp router-id FastEthernet0/0.5

Правильно я понимаю, на FastEthernet0/0.5 надо поднять OSPF ? 

Кстати, а EIGPR можно ?

 

И по mpls, правильно настраивать на сабинтерфейсе FastEthernet0/0.5 или на FastEthernet0/0, а на ядре на транковом порту или vlan ?

Edited by alger

Share this post


Link to post
Share on other sites
16 минут назад, alger сказал:

Правильно я понимаю, на FastEthernet0/0.5 надо поднять OSPF ? 

какой саб  использовать, это вам решать, у вас задача настроить IP связность таким образом, чтобы BGP1 и BGP3  увидели друг друга в OSPF.

 

17 минут назад, alger сказал:

Кстати, а EIGPR можно ?

можно все что угодно, хоть статики прописать, best practices это link-state  протокол

 

20 минут назад, alger сказал:

И по mpls, правильно настраивать на сабинтерфейсе FastEthernet0/0.5 или на FastEthernet0/0, а на ядре на транковом порту или vlan ?

если вы через 9300 свитчи собираетесь по L2 пропустить трафик с портов interface FastEthernet0/0.5  роутеров BGP1 и BGP3  то вообще никаких настроек на 9300 свитчах не требуется для пропуска меток MPLS ну кроме MTU

если вы через 9300 свитчи собираетесь по L3 пропустить трафик с портов interface FastEthernet0/0.5 роутеров BGP1 и BGP3  то на всех интерфейсах svi (interface vlan xxx) участвующих в транзите трафика между BGP1 и BGP3 требуется включить "mpls ip"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now