Jump to content
Калькуляторы

Мониторинг PPPoE на MikroTIk

Доброго времени суток коллеги.

Используем MikroTik CCR1036-8G-2S+ в качестве сервера доступа. Требуется мониторить кол-во активных PPPoE сессий, соответственно если сессий будет меньше определённого значения должно приходить оповещение.

В интернете ни чего не нашёл, скриптами тоже пока не знаю как сделать. Подскажите, может есть у кого какие идеи.

Share this post


Link to post
Share on other sites

По мне так лишняя заморочка, если что то где то не так тебя сами начнут искать))) Мониторить своё оборудование надо! Абоны парой поражают выключением роутера из розетки на ночь дабы сэкономить на электричестве:)))

 

В качестве мониторинга дудку ставь и смотри

Share this post


Link to post
Share on other sites

У нас CCR сам отправляет эту статистику(количество PPPoE- сессий) на сервер, а дальше уж как надо делайте оповещения:

/system scheduler
add interval=1m name=pppoe_count_send on-event=":local pppcount [/ppp active print count-only]\r\
    \n\r\
    \n/tool fetch url=\"http://[IP_address_server]/zr/pppoe-count.php\\\?ip=[IP_address_PPPoE_SERVER]&pppcount=\$pppcount\" keep-result=no mode=http\r\
    \n\r\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup

,где:

  • [IP_address_server] - адрес сервера куда отрпавляете
  • [IP_address_PPPoE_server] - адрес PPPoE сервера

pppoe-count.php - наипростейший  скрипт по разбору GET-запроса и складывания в базу.

Share this post


Link to post
Share on other sites

У меня работает на дудке. Показывает текущее количество сессий, и рисует график. Очень полезно и информативно.

Ночные отключения роутеров в пределах погрешности, не мешают. Показывает сбои в сети, даже те, о которых никто не подозревает, и не беспокоит соответственно. 

В частности, у нас полностью радио сеть на оспф, реально полезная статистика. 

 

PPPOE.PNG

 

Видно три дропа за последние пару дней, по логам можно найти, где и дальше разбираться, почему

 

Видно три дропа за последние пару дней, по логам можно найти, где и дальше разбираться, почему

ActivePPPoE.PNG

 

CountPPPoE.PNG

 

@swat11 дайте знать если нужна помощь, ну и хотелось бы узнать, помог или нет ))

Share this post


Link to post
Share on other sites
В 01.11.2018 в 11:09, saaremaa сказал:

У нас CCR сам отправляет эту статистику(количество PPPoE- сессий) на сервер, а дальше уж как надо делайте оповещения:


/system scheduler
add interval=1m name=pppoe_count_send on-event=":local pppcount [/ppp active print count-only]\r\
    \n\r\
    \n/tool fetch url=\"http://[IP_address_server]/zr/pppoe-count.php\\\?ip=[IP_address_PPPoE_SERVER]&pppcount=\$pppcount\" keep-result=no mode=http\r\
    \n\r\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup

,где:

  • [IP_address_server] - адрес сервера куда отрпавляете
  • [IP_address_PPPoE_server] - адрес PPPoE сервера

pppoe-count.php - наипростейший  скрипт по разбору GET-запроса и складывания в базу.

 

а snmp oid .1.3.6.1.2.1.2.1.0 минус количество Ethernet и подобное - чем не угождает? :)

Share this post


Link to post
Share on other sites
56 минут назад, SyJet сказал:

а snmp oid .1.3.6.1.2.1.2.1.0 минус количество Ethernet и подобное - чем не угождает? :)

Как вариант, но нам не удобно. :)

Share this post


Link to post
Share on other sites
В 30.10.2018 в 18:24, swat11 сказал:

MikroTik CCR1036-8G-2S

А сколько эта штука может PPPoE сессий с шейпингом держать? есть у кого такие данные?

Share this post


Link to post
Share on other sites

@Sacrament 5к-10к будет перебор, обычно ещё нужно сдать флоу + нат + фильтра. Я больше 800-1000 не вешал пппое сервер + флоу + нат(маскарад)+ 3-4 правила фаервола+шейпер. Клиенты начинают жаловаться(возможно у меня не те микротик как у Саба).

Два порта нагрузка 700-800 мигабит с 100-150к пакетов.

 

З.Ы. сейчас оспф + флоу + шейпер думаю вытянит 1000-2000

З.з.ы. все лишние пакеты выключены.

 

Share this post


Link to post
Share on other sites

вот как всегда. куча оффтопа и нет ответа. у mikrotik есть вполне конкертный oid для мониторинга кол-ва pppoe-сессий

               <item>
                    <name>PPPoE Sessions actvie</name>
                    <type>4</type>
                    <snmp_community>{$SNMPCOMMUNITY}</snmp_community>
                    <multiplier>0</multiplier>
                    <snmp_oid>1.3.6.1.4.1.9.9.150.1.1.1.0</snmp_oid>
                    <key>.1.3.6.1.4.1.9.9.150.1.1.1.0</key>

 

Share this post


Link to post
Share on other sites
4 минуты назад, s.lobanov сказал:

вот как всегда. куча оффтопа и нет ответа. у mikrotik есть вполне конкертный oid для мониторинга кол-ва pppoe-сессий


               <item>
                    <name>PPPoE Sessions actvie</name>
                    <type>4</type>
                    <snmp_community>{$SNMPCOMMUNITY}</snmp_community>
                    <multiplier>0</multiplier>
                    <snmp_oid>1.3.6.1.4.1.9.9.150.1.1.1.0</snmp_oid>
                    <key>.1.3.6.1.4.1.9.9.150.1.1.1.0</key>

 

Походу не так давно он появился. Лет так 8 назад его не находил

Share this post


Link to post
Share on other sites
46 минут назад, pingz сказал:

З.Ы. сейчас оспф + флоу + шейпер думаю вытянит 1000-2000

Если поставить 2 микротика - первый для терминации и шейпинга, второй для НАТ, тогда такая работа будет эффективнее, чем поставить 2 таких же микротика параллельно. Если, конечно, не брать в расчет вопросы резервирования, что на PPPoE очень удобно делается. На количество сессий очень влияет само количество мак адресов в пределах одного PPPoE интерфейса (PPPoE Servera на неком порту микротика), а так же приход мусора от абонентов. То есть если свести все вланы со всех абонентов и подать на микротике в один порт, он обслужит сессий меньше, чем если бы данные с каждого домового коммутатора пришли на него в EoIP или MPLS туннеле, и каждый PPPoE сервер на этом туннеле обслуживал порядка 24 абонентов.

Share this post


Link to post
Share on other sites

@Saab95 т.е. ещё нужно + 6-8 микротиков под мплс или EoIP? Или я не правильно понял?

Share this post


Link to post
Share on other sites

Понятно, жаль, думал будет получше тазиков на BSD или Linux.

Share this post


Link to post
Share on other sites

Вообще если у вас сеть на микротике, то в центре выгодно иметь микротик, что бы гибко управлять всей сетью и использовать все возможности микротика.

Если есть сделана на коммутаторах и ином оборудовании, тогда следует рассматривать все варианты, которые можете использовать. Однако не будет такой гибкости в настройках, какие позволяет микротик. Опять же для работы с линуксом и иными системами нужно иметь больше знаний и опыта.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this