Jump to content
Калькуляторы

Валится OSPF При анонсах BGP

Приветствую всех.

 

Коллеги, помогите пожалуйста разобраться в чем дело? Голову уже сломал, потому как казалось бы от не связанных вещей начинает валиться OSPF.

 

О сети:

 

1. Имеется сетка с двумя бордерами на базе Mikrotik. На обоих подняты BGP с получением только дефолта.

2. Имеется две белые сетки, которые анонсируются обоими бордерами (с разными препендами, для выделения одного из них в качестве бэкапа)

3. В сети бегает OSPF с несколькими регионами.

4. Включена редистрибуция дефолтов из BGP в OSPF

 

post-57229-036910500 1410263374_thumb.jpg

 

В общих чертах суть проблемы.

 

1. При анонсах BGP одной из сетей (той, на которой построены L3 линки между железками) начинают отваливаться OSPF соседи.

2. В тоже время, при анонсах второй сети - все в порядке и такого эффекта не происходит

 

Куда копать ума не приложу. Единственная зацепка - это то, что начинаются проблемы только после анонса сети на которой держится OSPF.

 

Есть идеи куда и как копать?

Share this post


Link to post
Share on other sites

Сделайте связь по OSPF на адресах, отличной от анонсируемой сети.

Share this post


Link to post
Share on other sites

... в сторону редистрибьюции копать

... в сторону логов копать

... и экстрасенсов не забыть позвать

:)

Share this post


Link to post
Share on other sites

зафига вообше что либо редистибютить из БГП? дефолt можно заанонсить через ОСПФ по типу циски "default-information originate". какие сети анонсите? транзитные вланы (они не /30 или /31)?

 

Сделайте связь по OSPF на адресах, отличной от анонсируемой сети.

это фича микротика? дохнуть от анонса сети по БГП?

Share this post


Link to post
Share on other sites

Можно конечно переделать OSPF на серую сетку, но возни много. Хотя можно поступить так и надеяться, что оно не всплывет.

 

Дефолт на микротике в OSPF попадает вот таким образом.

 

post-57229-024975600 1410273871_thumb.png

 

Транзитные вланы /30

Share this post


Link to post
Share on other sites

а что за фильтры настроены? (ospf-in / out)

Share this post


Link to post
Share on other sites

Пустые, по умолчанию были.

 

какие сети анонсите? транзитные вланы (они не /30 или /31)?

 

Сети - одна (из нее стыковочные сетки попилены) /23, вторая /21

Стыковочные сетки для OSPF /30

Share this post


Link to post
Share on other sites

Настройки чего? В микротике не знаю как вывести весь конфиг или хотя бы все, что касается OSPF :(

Share this post


Link to post
Share on other sites

А что значит "Валится"?

По-научному объясните пожалуйста, а лучше логи покажите.

Share this post


Link to post
Share on other sites

Валится - отваливаются соседи. Выглядит ровно так, как и звучит :) В логах ничего внятного не нашел :(

 

/interface bridge
add disabled=yes name=loopback
/interface ethernet
set 0 mac-address=00:15:17:F2:5C:08 name=10GE-KIR speed=1Gbps
set 1 speed=1Gbps
set 2 speed=1Gbps
set 3 mac-address=00:15:17:F2:5C:09 speed=1Gbps
/ip neighbor discovery
set AMS discover=no
set CORE discover=no
set OTR discover=no
set WST discover=no
/interface vlan
add interface=10GE-KIR name=AMS vlan-id=4094
add interface=10GE-KIR name=CORE vlan-id=4
add interface=10GE-KIR name=Manage vlan-id=3
add interface=10GE-KIR name=OTR vlan-id=6
add interface=10GE-KIR name=SHL vlan-id=9
/interface bonding
add disabled=yes mode=802.3ad name=KIR-TR slaves=ether1,ether2 transmit-hash-policy=layer-2-and-3
/interface vlan
add disabled=yes interface=KIR-TR name=WST vlan-id=255
/routing bgp instance
set default as=49439 client-to-client-reflection=no router-id=193.169.62.13
/routing ospf instance
set [ find default=yes ] distribute-default=if-installed-as-type-2 metric-bgp=10 router-id=10.3.0.2
/ip address
add address=178.236.128.253/30 disabled=yes interface=AMS network=178.236.128.252
add address=193.169.62.18/29 disabled=yes interface=CORE network=193.169.62.16
add address=193.169.62.20/32 disabled=yes interface=vrrp1 network=193.169.62.20
add address=178.236.128.1/29 interface=AMS network=178.236.128.0
add address=91.199.153.206/30 disabled=yes interface=WST network=91.199.153.204
add address=193.169.62.26/29 disabled=yes interface=OTR network=193.169.62.24
add address=193.169.62.193/30 interface=OTR network=193.169.62.192
add address=10.3.0.2/16 interface=Manage network=10.3.0.0
add address=193.169.62.130/30 interface=CORE network=193.169.62.128
add address=193.169.62.161/30 interface=SHL network=193.169.62.160
/ip route
add disabled=yes distance=140 gateway=193.169.62.129 routing-mark=ttk
add distance=200 dst-address=10.60.0.0/16 gateway=193.169.62.17
add disabled=yes distance=1 dst-address=93.100.195.0/24 gateway=193.169.62.17
add distance=200 dst-address=193.169.62.0/28 gateway=193.169.62.17
add distance=200 dst-address=193.169.62.252/30 gateway=193.169.62.17
add distance=200 dst-address=193.169.63.0/24 gateway=193.169.62.17
/ip route rule
add routing-mark=ttk table=ttk
/routing bgp network
add network=193.169.62.0/23 synchronize=no
add network=176.114.48.0/21 synchronize=no
add disabled=yes network=176.114.55.0/24 synchronize=no
add disabled=yes network=176.114.48.0/24 synchronize=no
/routing bgp peer
add in-filter=ams-in name=ams out-filter=ams-out remote-address=178.236.128.6 remote-as=44843 ttl=default
add disabled=yes in-filter=wst-in name=wst out-filter=wst-out remote-address=91.199.153.205 remote-as=31189 \
   ttl=default
/routing filter
add action=accept chain=ams-in prefix=0.0.0.0/0 set-distance=50
add action=accept chain=wst-in prefix=0.0.0.0/0 set-distance=50
add action=discard chain=ams-in
add action=discard chain=wst-in
add action=accept chain=ams-out prefix=193.169.62.0/23 set-bgp-prepend=1
add action=accept chain=wst-out prefix=193.169.62.0/23 set-bgp-prepend=7
add action=accept chain=ams-out prefix=176.114.48.0/21 set-bgp-prepend=1
add action=accept chain=wst-out prefix=176.114.48.0/21 set-bgp-prepend=7
add action=discard chain=wst-out
add action=accept chain=ams-out disabled=yes prefix=176.114.55.0/24
add action=discard chain=ams-out
/routing ospf network
add area=backbone network=193.169.62.16/29
add area=backbone disabled=yes network=193.169.62.24/29
add area=backbone network=193.169.62.192/30
add area=backbone network=193.169.62.128/30
add area=backbone network=193.169.62.160/30
/routing pim interface
add interface=CORE
add interface=OTR
add interface=SHL
/system identity
set name=M1-KIR

Share this post


Link to post
Share on other sites

UP

 

Есть идеи у кого нибудь? Не знаю даже с какой стороны подойти :(

 

Напомню - в логах ничего вразумительного, за что можно было бы зацепиться. Разве что вот такие записи встречаются:

 

11:27:34 route,ospf,info OSPFv2 neighbor 10.3.0.2: state change from Full to Down
11:28:45 route,ospf,info Database Description packet has different master status flag
11:28:45 route,ospf,info     new master flag=false
11:28:45 route,ospf,info OSPFv2 neighbor 10.3.0.2: state change from Full to 2-Way

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this