Перейти к содержимому
Калькуляторы

kostas

Активный участник
  • Публикации

    304
  • Зарегистрирован

  • Посещение

О kostas

  • Звание
    Студент

Информация

  • Пол
    Мужчина

Город

  • Город
    St.Petersburg
  1. Валится OSPF

    UP Есть идеи у кого нибудь? Не знаю даже с какой стороны подойти :( Напомню - в логах ничего вразумительного, за что можно было бы зацепиться. Разве что вот такие записи встречаются: 11:27:34 route,ospf,info OSPFv2 neighbor 10.3.0.2: state change from Full to Down 11:28:45 route,ospf,info Database Description packet has different master status flag 11:28:45 route,ospf,info new master flag=false 11:28:45 route,ospf,info OSPFv2 neighbor 10.3.0.2: state change from Full to 2-Way
  2. Валится OSPF

    Валится - отваливаются соседи. Выглядит ровно так, как и звучит :) В логах ничего внятного не нашел :( /interface bridge add disabled=yes name=loopback /interface ethernet set 0 mac-address=00:15:17:F2:5C:08 name=10GE-KIR speed=1Gbps set 1 speed=1Gbps set 2 speed=1Gbps set 3 mac-address=00:15:17:F2:5C:09 speed=1Gbps /ip neighbor discovery set AMS discover=no set CORE discover=no set OTR discover=no set WST discover=no /interface vlan add interface=10GE-KIR name=AMS vlan-id=4094 add interface=10GE-KIR name=CORE vlan-id=4 add interface=10GE-KIR name=Manage vlan-id=3 add interface=10GE-KIR name=OTR vlan-id=6 add interface=10GE-KIR name=SHL vlan-id=9 /interface bonding add disabled=yes mode=802.3ad name=KIR-TR slaves=ether1,ether2 transmit-hash-policy=layer-2-and-3 /interface vlan add disabled=yes interface=KIR-TR name=WST vlan-id=255 /routing bgp instance set default as=49439 client-to-client-reflection=no router-id=193.169.62.13 /routing ospf instance set [ find default=yes ] distribute-default=if-installed-as-type-2 metric-bgp=10 router-id=10.3.0.2 /ip address add address=178.236.128.253/30 disabled=yes interface=AMS network=178.236.128.252 add address=193.169.62.18/29 disabled=yes interface=CORE network=193.169.62.16 add address=193.169.62.20/32 disabled=yes interface=vrrp1 network=193.169.62.20 add address=178.236.128.1/29 interface=AMS network=178.236.128.0 add address=91.199.153.206/30 disabled=yes interface=WST network=91.199.153.204 add address=193.169.62.26/29 disabled=yes interface=OTR network=193.169.62.24 add address=193.169.62.193/30 interface=OTR network=193.169.62.192 add address=10.3.0.2/16 interface=Manage network=10.3.0.0 add address=193.169.62.130/30 interface=CORE network=193.169.62.128 add address=193.169.62.161/30 interface=SHL network=193.169.62.160 /ip route add disabled=yes distance=140 gateway=193.169.62.129 routing-mark=ttk add distance=200 dst-address=10.60.0.0/16 gateway=193.169.62.17 add disabled=yes distance=1 dst-address=93.100.195.0/24 gateway=193.169.62.17 add distance=200 dst-address=193.169.62.0/28 gateway=193.169.62.17 add distance=200 dst-address=193.169.62.252/30 gateway=193.169.62.17 add distance=200 dst-address=193.169.63.0/24 gateway=193.169.62.17 /ip route rule add routing-mark=ttk table=ttk /routing bgp network add network=193.169.62.0/23 synchronize=no add network=176.114.48.0/21 synchronize=no add disabled=yes network=176.114.55.0/24 synchronize=no add disabled=yes network=176.114.48.0/24 synchronize=no /routing bgp peer add in-filter=ams-in name=ams out-filter=ams-out remote-address=178.236.128.6 remote-as=44843 ttl=default add disabled=yes in-filter=wst-in name=wst out-filter=wst-out remote-address=91.199.153.205 remote-as=31189 \ ttl=default /routing filter add action=accept chain=ams-in prefix=0.0.0.0/0 set-distance=50 add action=accept chain=wst-in prefix=0.0.0.0/0 set-distance=50 add action=discard chain=ams-in add action=discard chain=wst-in add action=accept chain=ams-out prefix=193.169.62.0/23 set-bgp-prepend=1 add action=accept chain=wst-out prefix=193.169.62.0/23 set-bgp-prepend=7 add action=accept chain=ams-out prefix=176.114.48.0/21 set-bgp-prepend=1 add action=accept chain=wst-out prefix=176.114.48.0/21 set-bgp-prepend=7 add action=discard chain=wst-out add action=accept chain=ams-out disabled=yes prefix=176.114.55.0/24 add action=discard chain=ams-out /routing ospf network add area=backbone network=193.169.62.16/29 add area=backbone disabled=yes network=193.169.62.24/29 add area=backbone network=193.169.62.192/30 add area=backbone network=193.169.62.128/30 add area=backbone network=193.169.62.160/30 /routing pim interface add interface=CORE add interface=OTR add interface=SHL /system identity set name=M1-KIR
  3. Валится OSPF

    Настройки чего? В микротике не знаю как вывести весь конфиг или хотя бы все, что касается OSPF :(
  4. Валится OSPF

    Пустые, по умолчанию были. Сети - одна (из нее стыковочные сетки попилены) /23, вторая /21 Стыковочные сетки для OSPF /30
  5. Валится OSPF

    Можно конечно переделать OSPF на серую сетку, но возни много. Хотя можно поступить так и надеяться, что оно не всплывет. Дефолт на микротике в OSPF попадает вот таким образом. Транзитные вланы /30
  6. Приветствую всех. Коллеги, помогите пожалуйста разобраться в чем дело? Голову уже сломал, потому как казалось бы от не связанных вещей начинает валиться OSPF. О сети: 1. Имеется сетка с двумя бордерами на базе Mikrotik. На обоих подняты BGP с получением только дефолта. 2. Имеется две белые сетки, которые анонсируются обоими бордерами (с разными препендами, для выделения одного из них в качестве бэкапа) 3. В сети бегает OSPF с несколькими регионами. 4. Включена редистрибуция дефолтов из BGP в OSPF В общих чертах суть проблемы. 1. При анонсах BGP одной из сетей (той, на которой построены L3 линки между железками) начинают отваливаться OSPF соседи. 2. В тоже время, при анонсах второй сети - все в порядке и такого эффекта не происходит Куда копать ума не приложу. Единственная зацепка - это то, что начинаются проблемы только после анонса сети на которой держится OSPF. Есть идеи куда и как копать?
  7. Hardware TCAM exceeded

    Тогда понятно. Просто думал, что ресурсы TCAM могут быть размазаны по супервизору и линейкам. А если копируются, то смысл понятен. Сколько всяких интересных вещей бывает на этом каталисте ))
  8. Hardware TCAM exceeded

    То есть, получаеся, на карточках WS-F6700-DFC3B могут использоваться локальные ресурсы этой карты и тем самым переполнения TCAM супервизора не происходит? s.lobanov скорее всего прав - напихали то, что было. Покупалось действительно б/у. Но мы явно такого не желали и если бы знали, то конечно же подняли бы бучу. С другой стороны, разношерстность была замечена ранее, на что наг сказал ничего страшного.
  9. Hardware TCAM exceeded

    На обоих одинаково. Обе железки комплектовали в NAG )) ds1#show platform hardware pfc mode PFC operating mode : PFC3B ds2#show platform hardware pfc mode PFC operating mode : PFC3B
  10. Hardware TCAM exceeded

    Вот чего еще пока понять не могу, так это то, почему на второй точно такой же железке ни TCAM ни переполняются, ни процессор не подпрыгивает от каждого чиха с ними. Стоит как вкопаный. Хотя и ACL точно такие же развесистые на IN и WCCP включен. Как думаете, что может быть? Потроха практически идентичны. Это на котором всплыли проблемы ds1#sh mod Mod Ports Card Type Model Serial No. --- ----- -------------------------------------- ------------------ ----------- 1 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1101CTTW 2 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1021P4JY 3 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1023QBRV 4 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1021NW0X 5 5 Supervisor Engine 720 10GE (Active) VS-S720-10G SAL12372PJX 6 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1021P2PY 7 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1218P77T 8 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1217NT0X 9 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1052BYZA Mod MAC addresses Hw Fw Sw Status --- ---------------------------------- ------ ------------ ------------ ------- 1 001a.6cbe.a460 to 001a.6cbe.a48f 2.5 12.2(14r)S5 12.2(33)SXI6 Ok 2 0017.e041.1d9c to 0017.e041.1dcb 2.3 12.2(14r)S5 12.2(33)SXI6 Ok 3 0018.1833.8644 to 0018.1833.8673 2.3 12.2(14r)S5 12.2(33)SXI6 Ok 4 0017.0ed4.82e4 to 0017.0ed4.8313 2.3 12.2(14r)S5 12.2(33)SXI6 Ok 5 001d.45e2.6030 to 001d.45e2.6037 2.0 8.5(2) 12.2(33)SXI6 Ok 6 0017.e041.2474 to 0017.e041.24a3 2.3 12.2(14r)S5 12.2(33)SXI6 Ok 7 001f.9e0f.7088 to 001f.9e0f.70b7 2.7 12.2(14r)S5 12.2(33)SXI6 Ok 8 001f.9e5c.3b88 to 001f.9e5c.3bb7 2.7 12.2(14r)S5 12.2(33)SXI6 Ok 9 001a.2f80.f5c0 to 001a.2f80.f5ef 2.5 12.2(14r)S5 12.2(33)SXI6 Ok Mod Sub-Module Model Serial Hw Status ---- --------------------------- ------------------ ----------- ------- ------- 1 Centralized Forwarding Card WS-F6700-CFC SAD103102LM 3.0 Ok 2 Centralized Forwarding Card WS-F6700-CFC SAL1019MBDB 2.0 Ok 3 Centralized Forwarding Card WS-F6700-CFC SAL1029W0ZC 2.0 Ok 4 Centralized Forwarding Card WS-F6700-CFC SAL1017LFEZ 2.0 Ok 5 Policy Feature Card 3 VS-F6K-PFC3C SAL12372VEC 1.0 Ok 5 MSFC3 Daughterboard VS-F6K-MSFC3 SAL12351G4C 1.0 Ok 6 Centralized Forwarding Card WS-F6700-CFC SAL1022PXU8 2.0 Ok 7 Distributed Forwarding Card WS-F6700-DFC3B SAL1219Q10J 4.6 Ok 8 Distributed Forwarding Card WS-F6700-DFC3B SAL1219Q12S 4.6 Ok 9 Centralized Forwarding Card WS-F6700-CFC SAL10360MGJ 3.0 Ok А этот, который как ни в чем не бывало трудится ds2#sh module Mod Ports Card Type Model Serial No. --- ----- -------------------------------------- ------------------ ----------- 1 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1128U8UD 2 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1023QFHW 3 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1225UNPZ 4 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1219Q3HG 5 5 Supervisor Engine 720 10GE (Active) VS-S720-10G SAD1205064T 6 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL09370BH6 7 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1225UKDK 8 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL1225UKC1 9 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL09211X60 Mod MAC addresses Hw Fw Sw Status --- ---------------------------------- ------ ------------ ------------ ------- 1 001b.d5fb.87b8 to 001b.d5fb.87e7 2.6 12.2(18r)S1 12.2(33)SXI6 Ok 2 0018.1854.4174 to 0018.1854.41a3 2.3 12.2(14r)S5 12.2(33)SXI6 Ok 3 0021.553a.2de0 to 0021.553a.2e0f 3.0 12.2(18r)S1 12.2(33)SXI6 Ok 4 0021.552a.baf0 to 0021.552a.bb1f 2.7 12.2(14r)S5 12.2(33)SXI6 Ok 5 0017.944a.b2c4 to 0017.944a.b2cb 2.0 8.5(2) 12.2(33)SXI6 Ok 6 0015.6245.f740 to 0015.6245.f76f 2.3 12.2(14r)S5 12.2(33)SXI6 Ok 7 001d.703c.d2f0 to 001d.703c.d31f 3.0 12.2(18r)S1 12.2(33)SXI6 Ok 8 0021.d85a.5a38 to 0021.d85a.5a67 3.0 12.2(18r)S1 12.2(33)SXI6 Ok 9 0014.1c34.1980 to 0014.1c34.19af 2.2 12.2(14r)S5 12.2(33)SXI6 Ok Mod Sub-Module Model Serial Hw Status ---- --------------------------- ------------------ ----------- ------- ------- 1 Centralized Forwarding Card WS-F6700-CFC SAL09465GH5 2.1 Ok 2 Centralized Forwarding Card WS-F6700-CFC SAL1022Q043 2.0 Ok 3 Centralized Forwarding Card WS-F6700-CFC SAL1225UFH0 4.1 Ok 4 Distributed Forwarding Card WS-F6700-DFC3B SAL1219Q13B 4.6 Ok 5 Policy Feature Card 3 VS-F6K-PFC3C SAD1203056E 1.0 Ok 5 MSFC3 Daughterboard VS-F6K-MSFC3 SAL1205F09R 1.0 Ok 6 Centralized Forwarding Card WS-F6700-CFC SAL093813ST 2.0 Ok 7 Centralized Forwarding Card WS-F6700-CFC SAL1225UE1J 4.1 Ok 8 Centralized Forwarding Card WS-F6700-CFC SAL1225UM6K 4.1 Ok 9 Centralized Forwarding Card WS-F6700-CFC SAL09264CLM 2.0 Ok Может есть у кого нибудь версии?
  11. Hardware TCAM exceeded

    Ага, не углядел эту цифру. Спасибо! Теперь понятно на что хоть смотреть в случае чего. Ну что же - теперь хоть будем знать с чем столкнулись... Спасибо еще раз всем за помощь и советы.
  12. Hardware TCAM exceeded

    Спасибо большое за дельные советы. Попробую переделать ACL на исходящий трафик. PS: Я до сих пор так и не нашел, где посмотреть на какой процент забиты TCAM. s.lobanov давал парочку команд, но там вроде нет такой информации.
  13. Hardware TCAM exceeded

    Интересно, а что это значит? Interface: Vlan3 is up TCAM screening for features: ACTIVE inbound TCAM screening for features: ACTIVE outbound Interface: Vlan6 is up TCAM screening for features: ACTIVE inbound TCAM screening for features: ACTIVE outbound Если ACL только на входящий трафик навешаны? interface Vlan3 ip address 10.3.0.1 255.255.0.0 ip access-group ACL1 in ip helper-address 10.0.0.252 ! interface Vlan6 ip address 10.6.0.1 255.255.0.0 ip access-group ACL2 in ip helper-address 10.0.0.252 А что выдает команда "sh tcam detail acl"? На что там смотреть? То, что log в ACL нагружает control plane - это понятно. Стоит для настройки ACL, временно. Но как быть с established? Всегда думал, что оно как раз сокращает ACL. Как без него обойтись? Обратный трафик он ведь разный бывает. Все правилами не охватишь. Да и листы от этого только распухнут. Кстати, ACL на исходящий трафик интерфейса ведь не использует TCAM? Где-то в мануалах cisco проскакивало. Они как раз рекомендуют вешать толкьо на входящий трафик.
  14. Hardware TCAM exceeded

    То есть, если я уберу WCCP куда нибудь в сторонку с этой железяки, я могу нормальные ACL делать? Или все таки фига с два? Как посмотреть где я упираюсь? Без этой информации развлекаться не удобно ))
  15. Hardware TCAM exceeded

    Спасибо. Попробую оптимизировать. А железка как наз бралась на локалку, где большой трафик между сетками ходит. Много портов надо. Но в тоже время нужна безопасность между сетками. Поэтому в общем-то и рассматривался каталист. Но никак не думал, что обычная пакетная фильтрация убьет его нафиг. Скажите, а что лучше - один большой универсальный ACL на все интерфейсы или чуть проще, но на каждый интерфейс один? Во втором случае в каждом листе будет дублироваться правила, тк есть стандартные для всех сетей правила. PS: И еще, не совсем понял, где видно, что есть переполнение TCAM. Что в данном случае показывает sh tcam counts detail? #sh tcam counts detail Used Free Percent Used Reserved ---- ---- ------------ -------- Labels:(in) 35 4037 1 24 Labels:(eg) 0 4072 0 24 ACL_TCAM -------- HI BANK Masks: 118 1930 5 72 Entries: 289 16095 1 576 LOW BANK Masks: 1978 70 96 0 Entries: 11132 5252 67 0 QOS_TCAM -------- HI BANK Masks: 25 2023 1 25 Entries: 0 16384 0 200 LOW BANK Masks: 7 2041 0 0 Entries: 32 16352 0 0 LOU: 9 119 7 ANDOR: 1 15 6 ORAND: 0 16 0 ADJ: 3 2045 0 Или чем-то другим смотреть надо?