Jump to content
Калькуляторы

Management vlan dlink + cisco

Имеется:

1) D-link 3200-24, конфиг:

create vlan vlan2 tag 2
config vlan vlan2 add tagged 25-28
config vlan vlan2 add untagged 1
config vlan default delete 1-28
config ipif System ipaddress 172.16.10.14/24 vlan vlan2 state enable

 

2) Cisco 2950t-48-sl

int vlan 2
description mgmt
ip address 172.16.10.16 255.255.255.0
no shutdown
exit
int vlan 1
shutdown
exit
int range gi0/1 - 2
no cdp enable
switchport mode trunk
switchport trunk allowed vlan 2,20,101,102,103,104,105
no shutdown
exit
int fa 0/1
no cdp enable
switchport mode access
switchport access vlan 2
no shutdown
exit

 

3) d-link соединен c cisco на гигабитном порту (d-link 25 порт - cisco gi0/1)

 

В такой ситуации с одного коммутатора не пингуется второй, ну по сути транк не работает

если вставить комп в первый порт коммутатора длинк то пингуется только длинк, циска не пингуется

если вставить комп в первый порт коммутатора циска то пингуется только циска, длинк не пингуется

подскажите пожалуйста, в чем ошибка

Edited by Kizim

Share this post


Link to post
Share on other sites

И линк точно установился ?

 

sh int gi0/1 покажите еще

 

 

 

 

 

Share this post


Link to post
Share on other sites

#sh int gi0/1
GigabitEthernet0/1 is up, line protocol is up (connected)
 Hardware is Gigabit Ethernet, address is 000f.90c4.13f1 (bia 000f.90c4.13f1)
 MTU 1500 bytes, BW 1000000 Kbit, DLY 1000 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 1000Mb/s, link type is auto, media type is T
 output flow-control is off, input flow-control is off
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 25000 bits/sec, 37 packets/sec
    1 packets input, 64 bytes, 0 no buffer
    Received 0 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    549828 packets output, 50675767 bytes, 0 underruns
    0 output errors, 0 collisions, 3 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out

 

Понять не могу, может из-за jumbo frames? на dlink они включены, на циске их нет.

 

На 2950

conf t

vlan 2

exit

wr

Делал, не помогает

Share this post


Link to post
Share on other sites

а

sh vlan port 25

на Длинке что покажет ?

Share this post


Link to post
Share on other sites

А на d-link

 

sh packet port 25

 

sh erro po 25

 

 

Share this post


Link to post
Share on other sites

И еще попробуйте напрямую с циски пингануть длинк и наоборот.

Share this post


Link to post
Share on other sites

Если вы пингуете не с машины находящейся в сети 172.16.10.0/24, то на длинке надо еще дефолт-роут прописать.

 

1 packets input, 64 bytes, 0 no buffer

 

Ну и еще как бы ничего с длинка не приходит, будто не согласовалась скорость.

Share this post


Link to post
Share on other sites

а

sh vlan port 25

на Длинке что покажет ?

 

admin#sh vlan port 25 
Command: show vlan ports 25

Port   VID   Untagged  Tagged  Dynamic  Forbidden
-----   ----  --------  ------  -------  ---------
25     2       -         X       -        -      
25     20      -         X       -        -      
25     101     -         X       -        -      
25     102     -         X       -        -      
25     103     -         X       -        -      
25     104     -         X       -        -      
25     105     -         X       -        -     

 

А на d-link

 

sh packet port 25

 

sh erro po 25

 

#sh packet port 25
Command: show packet ports 25

Port Number : 25     
==================================================================
Frame Size/Type       Frame Counts                  Frames/sec 
---------------       ----------------------        -----------
64                    3063                          0            
65-127                4076                          0            
128-255               673                           0            
256-511               331                           0            
512-1023              144                           0           
1024-1518             82                            0           
Unicast RX            114                           0           
Multicast RX          536                           0           
Broadcast RX          4001                          0          

Frame Type            Total                         Total/sec 
---------------       ----------------------        -----------
RX Bytes              446279                        0           
RX Frames             4651                          0           
TX Bytes              516656                        0           
TX Frames             3718                          0           

 

#sh erro po 25
Command: show error ports 25


Port Number : 25     
                RX Frames                                   TX Frames
                ---------                                   ---------
CRC Error       0                     Excessive Deferral    0         
Undersize       0                     CRC Error             0         
Oversize        0                     Late Collision        0         
Fragment        1                     Excessive Collision   0         
Jabber          0                     Single Collision      0         
Drop Pkts       4651                  Collision             0         
Symbol Error    0         

 

И еще попробуйте напрямую с циски пингануть длинк и наоборот.

я вначале писал. пинга нет

 

Если вы пингуете не с машины находящейся в сети 172.16.10.0/24, то на длинке надо еще дефолт-роут прописать.

 

1 packets input, 64 bytes, 0 no buffer

 

Ну и еще как бы ничего с длинка не приходит, будто не согласовалась скорость.

 

d-link 172.16.10.14

cisco 172.16.10.16

pk 172.16.10.2

Я в начале этот конфиг писал

Share this post


Link to post
Share on other sites

Еще на D-Link

 

sh ports 25 deta

 

или sh ports 25

 

 

Share this post


Link to post
Share on other sites

А на других вланах трафик идет?

Share this post


Link to post
Share on other sites

На Dlink и Cisco ручками укажите скорость и дуплекс.

Share this post


Link to post
Share on other sites

d-link тупо дропает пакеты этож видно. а jumbo frames я бы попробывал выключить(если это не критично) проблема может быть в MTU.

ну а если хотите точно решить проблему, то настраивайте зеркалированние портов и смотрите дамп с компа.

Edited by Neonchik

Share this post


Link to post
Share on other sites

Имеется:

1) D-link 3200-24, конфиг:

create vlan vlan2 tag 2
config vlan vlan2 add tagged 25-28
config vlan vlan2 add untagged 1
config vlan default delete 1-28
config ipif System ipaddress 172.16.10.14/24 vlan vlan2 state enable

 

2) Cisco 2950t-48-sl

int vlan 2
description mgmt
ip address 172.16.10.16 255.255.255.0
no shutdown
exit
int vlan 1
shutdown
exit
int range gi0/1 - 2
no cdp enable
switchport mode trunk
switchport trunk allowed vlan 2,20,101,102,103,104,105
no shutdown
exit
int fa 0/1
no cdp enable
switchport mode access
switchport access vlan 2
no shutdown
exit

 

3) d-link соединен c cisco на гигабитном порту (d-link 25 порт - cisco gi0/1)

 

В такой ситуации с одного коммутатора не пингуется второй, ну по сути транк не работает

если вставить комп в первый порт коммутатора длинк то пингуется только длинк, циска не пингуется

если вставить комп в первый порт коммутатора циска то пингуется только циска, длинк не пингуется

подскажите пожалуйста, в чем ошибка

 

sh int trunk

 

switchport trunk encapsulation dot1q

Share this post


Link to post
Share on other sites

Надо бы показать конфиг обоих портов, наверняка trunk не UPнулся сам =).

 

switchport trunk encapsulation dot1q

29-тые железки кажись не умеют ISL, там dot1q по дефорлту.

Share this post


Link to post
Share on other sites

Надо бы показать конфиг обоих портов, наверняка trunk не UPнулся сам =).

 

switchport trunk encapsulation dot1q

29-тые железки кажись не умеют ISL, там dot1q по дефорлту.

Да, по дефолту, они не воспринимают

switchport trunk encapsulation dot1q

 

Еще на D-Link

 

sh ports 25 deta

 

или sh ports 25

 

DES-3200-28:admin#sh ports 25 deta
Command: show ports 25 details

Port : 25        
--------------------                                                            
Port Status                 : Link Up                                           
Description                 :                                                   
HardWare Type               : Gigabits Ethernet                                 
MAC Address                 : CC-B2-55-89-8F-99                                 
Bandwidth                   : 1000000Kbit                                      
Auto-Negotiation            : Enabled                                           
Duplex Mode                 : Full Duplex                                       
Flow Control                : Disabled                                          
MDI                         : Cross                                             
Address Learning            : Enabled                                           
Last Clear of Counter       : 20 hours 49 mins ago
BPDU Hardware Filtering Mode: Disabled                                          
Queuing Strategy            : FIFO                                              
TX Load                     :   0/100,          0 bits/sec,        0 packets/sec
RX Load                     :   0/100,          0 bits/sec,        0 packets/sec

 

DES-3200-28:admin#sh ports 25
Command: show ports 25

Port      State/          Settings             Connection          Address 
          MDIX      Speed/Duplex/FlowCtrl  Speed/Duplex/FlowCtrl   Learning
-------  --------  ---------------------  ----------------------  ---------
25   (C) Enabled   Auto/Disabled          1000M/Full/None         Enabled     
         Auto  
25   (F) Enabled   Auto/Disabled          Link Down               Enabled   

Share this post


Link to post
Share on other sites

А на других вланах трафик идет?

 

нет

 

jumbo_frames отключил

меня терзают смутные сомненья что железка длинк дохлая

Edited by Kizim

Share this post


Link to post
Share on other sites

на 29-той глянь мак делинка, есть он ваще на коммутаторе 29 и в каком вилане, мб прилетает но без тега.

Share this post


Link to post
Share on other sites

jumbo_frames отключил

меня терзают смутные сомненья что железка длинк дохлая

А включить комп в гигабитный порт и проверить?

Ещё посмотреть что с киски идёт.

Share this post


Link to post
Share on other sites

на 29-той глянь мак делинка, есть он ваще на коммутаторе 29 и в каком вилане, мб прилетает но без тега.

 

DES-3200-28:admin#show arpentry    
Command: show arpentry


ARP Aging Time : 20

Interface      IP Address       MAC Address        Type
-------------  ---------------  -----------------  ---------------
System         172.16.10.0      FF-FF-FF-FF-FF-FF  Local/Broadcast
System         172.16.10.14     CC-B2-55-89-8F-80  Local
System         172.16.10.255    FF-FF-FF-FF-FF-FF  Local/Broadcast

Total Entries: 3

 

#sh arp 
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.10.16            -   000f.90c4.13c0  ARPA   Vlan2

Edited by Kizim

Share this post


Link to post
Share on other sites

jumbo_frames отключил

меня терзают смутные сомненья что железка длинк дохлая

А включить комп в гигабитный порт и проверить?

Ещё посмотреть что с киски идёт.

ничего, пусто все))

Share this post


Link to post
Share on other sites
DES-3200-28:admin#show arpentry

не, sh fdb просили с длинка.

извиняюсь, не так понял

DES-3200-28:admin#sh fdb
Command: show fdb

Unicast MAC Address Aging Time  = 120

VID  VLAN Name                        MAC Address       Port  Type    Status
---- -------------------------------- ----------------- ----- ------- -------
2    vlan2                            CC-B2-55-89-8F-80 CPU   Self    Forward 

Total Entries: 1

Share this post


Link to post
Share on other sites

Я же говорил еще 10ок сообщений назад, что связь не установилась как надо. Кабель то между свитчами целый?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this