Jump to content
Калькуляторы

Mikrotik 750gl + PPPoE

Здраствуйте. Проблема такая, купил такой роутер для дома и теперь не могу настроить. Точнее просто в тупик уже вошел. Вобщем провайдер домолинк инет приходит через адсл модем (d-link 2500), в модеме создаю бридж в микротике подключение через pppoe, всё нормально работает примерно минут 5-10 дальше начинаются приколы. Постепенно начинают пропадать сайты чем дальше тем больше, то есть вот сейчас например открывался сайт а через минуту он уже не доступен. Соединение pppoe не рвется, помогает перезагрузка роутера и частично помогает на недолго очистка кеша днс на компе. Модем так же вне подозрений, когда роутер в нем включаю без микротика то инет нормально работает хоть месяц не выключаясь. Пробовал игратся с mtu pppoe не помогло. Что это может быть ?

Share this post


Link to post
Share on other sites

днс тиковский снаружи фаером закройте.

Если не поможет - снифер пакетов в руки и вперёд.

Share this post


Link to post
Share on other sites

Для начала гляньте System -> Resources. Загрузка CPU (ок, если 0..3%). Печаль, если 30%...100%.

В интерфейсе РРРоЕ находите кнопку Torch, в открывшемся меню ставите галки Protocol, Port , жмете кнопку старт и смотрите. Скорее всего есть большое количество подключений из сети на ваш внешний IP порт 53.

 

Фильтруете:

/ip firewall filter
add action=drop chain=input dst-port=53 in-interface=pppoe-out1 protocol=udp

 

или если IPoE

/ip firewall filter
add action=drop chain=input dst-address=171.25.xxx.xxx dst-port=53 in-interface=ether1 protocol=udp

Edited by pvl

Share this post


Link to post
Share on other sites

>Печаль, если 30%...100%.

У меня регулярно 65-70 и все OK. Торренты по 80 Мб/с + HD IPTV.+ Web серфинг.

100 конечно это ппц. Но вот до 100 - микротик вполне работает. В этом его преимущество.

Share this post


Link to post
Share on other sites

У меня регулярно 65-70 и все OK

Может надо смотреть в простое?))

Share this post


Link to post
Share on other sites

Всё попробовал не помогло(( Попытался опять понять что происходит и вроде как понял. Пров выдает сови локальные адреса на ether1-gateway и видимо выходило путаница после поднятия pppoe, как понятней обьяснить не знаю лучше скажу что сделал)) Зашел в IP->DHCP client и там в default configuration снял галки Use Peer DNS, Use Peer NTP, Add Default Route. И уже больше часа работает без сбоев, пробовал вообще отключить эту запись но перестает работать iptv на приставке домолинка. Заметил что инет работает шустрей через микротик чем через роутер модема... Спасибо за помощь.

Share this post


Link to post
Share on other sites

Чтобы не создавать новую тему спрошу тут, какое правило сделать чтобы можно было подключатся к микротику винбоксом через интернет ? Соединение к инету статика.

Share this post


Link to post
Share on other sites

Вкладка IP -> Services

 

Можно оставить только WinBox и там в свойствах указать доступ только из нужных подсетей или IP.

Share this post


Link to post
Share on other sites

Там только вкл или выкл и смена порта, а мне надо разрешить доступ через wan по умолчанию пускает только с локальных...

Share this post


Link to post
Share on other sites

Там только вкл или выкл и смена порта, а мне надо разрешить доступ через wan по умолчанию пускает только с локальных...

 

Сбросьте настройки и отмените начальную конфигурацию, после чего большинство проблем исчезнут.

Share this post


Link to post
Share on other sites

В свое время помогло это:

 

Если не открываются Некоторые страницы в Мтике

 

/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1360 disabled=no

 

Share this post


Link to post
Share on other sites

Сбросьте настройки и отмените начальную конфигурацию, после чего большинство проблем исчезнут.

Зачем мне сбрасывать настройки ? Он настроен и работает в сети, после сброса опять придется настраивать. Мне просто нужно настроить доступ к нему из вне (из центрального офиса к тц) так как бывают ситуации когда нужно открыть либо закрыть доступ к инету определенным компам и ради этого ездить на другой конец города бывает просто лень))).

 

В свое время помогло это:

 

Если не открываются Некоторые страницы в Мтике

 

/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1360 disabled=no

У меня все страницы открываются норм, но только из локалки а из внешки не пробится вообще. Подозреваю что фаер блокирует, но каким правилом открыть я еще не знаю.

Share this post


Link to post
Share on other sites

Там только вкл или выкл и смена порта, а мне надо разрешить доступ через wan по умолчанию пускает только с локальных...

 

Сбросьте настройки и отмените начальную конфигурацию, после чего большинство проблем исчезнут.

 

1391487594_1862652229.jpg

Share this post


Link to post
Share on other sites

Там только вкл или выкл и смена порта, а мне надо разрешить доступ через wan по умолчанию пускает только с локальных...

Вообще то там ещё поле Available from есть и если там что то прописано то будет пускать только с прописанных адресов. Если там пусто - добавьте правило в filter rules в chain input разрешающее необходимый вам протокол управления с порта WAN и разместите его до запрещающих правил.

А вообще - неплохо бы Mikrotik WiKi почитать для начала.

Edited by NikAlexAn

Share this post


Link to post
Share on other sites

Тему можно закрыть, решил проблему добавлением исключения для определенного ip в запрещающем правиле для wan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this