Jump to content
Калькуляторы

Страница напоминалка MikroTik

Хочу сделать так: 20 числа любой, кто пытается зайти на любую страницу появляется страница-напоминалка, где будет написано о том, что нужно заплатить до конца месяца, они прочли, и закрыли эту страницу, и дальше пользуются интернетом.

Чего я уже добился:

 

Создал правило, обращение к 80 порту будет записывать в Address List

add action=add-src-to-address-list address-list=page_ok chain=forward dst-port=80 protocol=tcp

 

Создал правило NAT, те которые не в Adress List перебрасываются на сервер с страницей, т.е. есть скрипт, который будет активировать это правило по 26 числам

add action=dst-nat chain=dstnat dst-port=80 protocol=tcp src-address-list=!black to-addresses=10.10.10.1

 

Скрипт

:global dateall [system clock get date]
:global dateday [:pick $dateall 4 6]
if ($dateday=26) do={/ip firewall nat enable [find comment="napominalka"] } else={/ip firewall nat disable [find comment="napominalka"]}

 

Работает все как-то через раз

Share this post


Link to post
Share on other sites

Другой вариант

 

Перенаправляем всех на прокси, кроме адрес листа opovestil

Порт прокси лучше использовать отличный от 8080.

 

chain=dstnat action=redirect to-ports=8081 protocol=tcp 
src-address=10.0.0.0/8 dst-address=!10.0.0.0/8 src-address-list=!opovestil 
dst-port=80

 

Всех перешедших добавляем в адрес лист на 1 день (сколько нужно)

 

chain=dstnat action=add-src-to-address-list protocol=tcp 
address-list=opovestil address-list-timeout=1d dst-port=8081

 

Вроде так, если не напутал.

Edited by AKim

Share this post


Link to post
Share on other sites

вот чисто интересно у какого процента операторов такое реализовано и на сколько это поправило финансовые показатели

Share this post


Link to post
Share on other sites

У нас проще админы организовали - sms информирование абонентов.

Share this post


Link to post
Share on other sites

add action=dst-nat chain=dstnat dst-port=80 protocol=tcp src-address-list=!black to-addresses=10.10.10.1

А можно сделать (без веб прокси) так, чтобы переадресовывал только при попытке открыть определенный сайт?

Share this post


Link to post
Share on other sites

А можно сделать (без веб прокси) так, чтобы переадресовывал только при попытке открыть определенный сайт?

chain=dstnat action=redirect to-ports=8081 protocol=tcp

src-address=10.0.0.0/8 dst-address=(ip ресурса) src-address-list=!opovestil

dst-port=80

Edited by AKim

Share this post


Link to post
Share on other sites

AKim на прокси не получится, т.к. там уже крутится страница, которая появляется если пропадает интернет.

 

Всех перешедших добавляем в адрес лист на 1 день (сколько нужно)

т.е. страница будет появляться каждый день?

 

chain=dstnat action=redirect to-ports=8081 protocol=tcp

src-address=10.0.0.0/8 dst-address=(ip ресурса) src-address-list=!opovestil

dst-port=80

правило не работает

Share this post


Link to post
Share on other sites

правило не работает

 

проверил. точно не работает.

 

 

Это работает, но с условием, если у человека не публиный DNS. В другом случае он не перейдёт на уведомление и будет постоянно смотреть на страницу "Сервер не найден"

 

 

 1   chain=dstnat action=redirect to-ports=8081 protocol=tcp 
    src-address=10.0.0.0/8 dst-address=!10.0.0.0/8 src-address-list=!opovestil 
    dst-port=80 

2   chain=dstnat action=add-src-to-address-list protocol=tcp 
    src-address=10.0.0.0/8 dst-address=(ip страницы с сообщением) address-list=opovestil 
    address-list-timeout=5m dst-port=80 

Share this post


Link to post
Share on other sites

AKim, все так же не работает :(

 

я его проверил. всё работает

Share this post


Link to post
Share on other sites

AKim можете провести платную консультацию? Можете я какой-то момент опустил? Мой скайп: baxim69. А то уже сил не хватает.

Edited by baxim69

Share this post


Link to post
Share on other sites

AKim можете провести платную консультацию? Можете я какой-то момент опустил? Мой скайп: baxim69. А то уже сил не хватает.

 

за что тут деньги брать? помогу просто так

Share this post


Link to post
Share on other sites

я вот только не пойму как перекинуть его обратно на страницу на которой клиент сидел? Например перекинули вы его на страницу , что "скоро платить дорогой", а дальше, как вернуть его на исходную? Чтобы его все вкладки не превратились в напоминалку?

Share this post


Link to post
Share on other sites

я вот только не пойму как перекинуть его обратно на страницу на которой клиент сидел? Например перекинули вы его на страницу , что "скоро платить дорогой", а дальше, как вернуть его на исходную? Чтобы его все вкладки не превратились в напоминалку?

 

В теории при загрузке первой вкладки, его ip добавится в адрес лист и остальные вкладки не переадресует.

 

Мы не используем напоминаний. От этого больше вреда чем пользы.

 

Человек прописал себе днс гугла и интернет 20 числа у него перестал работать.

 

У нас редиректы только для неизвестных ip (используем привязку IP+MAC). Человек воткнул новый роутер и ему сообщение о том, что устройсво не опознано и нужно позвонить по телефону или настроить роутер.

И для отключенных за неуплату.

post-101104-023893100 1390769747_thumb.jpg

Share this post


Link to post
Share on other sites

У нас редиректы только для неизвестных ip (используем привязку IP+MAC). Человек воткнул новый роутер и ему сообщение о том, что устройсво не опознано и нужно позвонить по телефону или настроить роутер.

И для отключенных за неуплату.

 

Не, это не правильно. Вот допустим купил человек новый компьютер, взял ящик пива и сидит файлы со старого на новый перекачивает, как все сделал, уже стемнело, а то и ночь наступила, так вот, втыкает он кабель от интернета в новый комп и бац - страница напоминалка и никакого интернета нет. Если еще и техподдержка не круглосуточная - то вообще труба, придется включать старый комп, смотреть мак, вводить его на новом компе.

 

Поэтому от привязки по маку нужно как можно скорее уходить.

Share this post


Link to post
Share on other sites

(используем привязку IP+MAC)

Вот от этого убожества откажитесь и совсем вам цены не будет))

Share this post


Link to post
Share on other sites

Не, это не правильно. Вот допустим купил человек новый компьютер, взял ящик пива и сидит файлы со старого на новый перекачивает, как все сделал, уже стемнело, а то и ночь наступила, так вот, втыкает он кабель от интернета в новый комп и бац - страница напоминалка и никакого интернета нет. Если еще и техподдержка не круглосуточная - то вообще труба, придется включать старый комп, смотреть мак, вводить его на новом компе.

 

Поэтому от привязки по маку нужно как можно скорее уходить.

 

уходить в сторону vlan per user или opt82

 

в первом случае не хочется от локалки отказываться, во втором не все свичи opt82 поддерживают.

Share this post


Link to post
Share on other sites

Все довольно просто, человек заходит в интернет, появляется страница обновлялка, он и прочел, и внизу это страницы кнопка "Закрыть сообщение" (вкладка обновляется или закрывается). На счет IP+MAC согласен, слишком геморойно.

Share this post


Link to post
Share on other sites

в первом случае не хочется от локалки отказываться

А какие у вас тарифы на интернет? Наверняка от 10М и выше.В таком случае локалка нафиг не сдалась.Мой провайдер постепенно отключает локалку в каждом районе.Оставляет чистый РРРоЕ.Тарифы от 20 до 100.

Share this post


Link to post
Share on other sites

уходить в сторону vlan per user или opt82

 

в первом случае не хочется от локалки отказываться, во втором не все свичи opt82 поддерживают.

 

Только в схему влан на клиента без всяких опций, локалка у них и так заработает, если прокси-арп включите.

Share this post


Link to post
Share on other sites

Только в схему влан на клиента без всяких опций, локалка у них и так заработает, если прокси-арп включите.

 

А если свитч на доме сгорел, все вланы на нос руками переколачиваете? Или как? Ну и еще вариант свитч агрегации больше 256-ти ВЛАНов не поддерживает - есть и такие например АТ-8624...

Share this post


Link to post
Share on other sites

А если свитч на доме сгорел, все вланы на нос руками переколачиваете? Или как? Ну и еще вариант свитч агрегации больше 256-ти ВЛАНов не поддерживает - есть и такие например АТ-8624...

 

Это уже обсудили. Vlan per User должен биллинг рулить. Так же можно использовать QinQ, тогда конфигурация на всём доступе идентичная.

Share this post


Link to post
Share on other sites

Извиняюсь, что немного не по теме, но или лыжи не катят или я и..от. Вот тут http://www.alliedtelesis.ru/media/fount/datasheet/8600_DS_RevW.pdf не увидел QinQ, Аллид как-то его по своему зашифровал или АТ8624 древнее .овно?

Edited by 47~GrAnd~74

Share this post


Link to post
Share on other sites

Аллид как-то его по своему зашифровал или АТ8624 древнее .овно?

 

не видно в нём QinQ

Share this post


Link to post
Share on other sites

Аллид как-то его по своему зашифровал или АТ8624 древнее .овно?

 

не видно в нём QinQ

Вот поэтому авторизацию MAC+IP не надо так уж огульно отметать. Есть сети со скромным бюджетом и с древним железом. Влан в нос хорошая штука, но не всем по карману...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this