Jump to content
Калькуляторы

DES-3526 портит мультикаст потоки

Доброго дня!

 

Может кто сталкивался с моей проблемой?

 

Прошивка коммутаторе стоит последняя 6.00.В48. При включении коммутатор в сеть, проходящие сквозь него мультикаст потоки бьются, соответственно картинка начинает сыпаться. Без коммутатор или через другой коммутатор, все работает хорошо.

 

Всех поздравляю с наступающим НГ!

Edited by minderm

Share this post


Link to post
Share on other sites

show traffic control

?

если увидите там циферке в столбце multicast - conf traffic control all multi dis вас спасет

Edited by darkagent

Share this post


Link to post
Share on other sites

Вот что выводит ком***:

Command: show traffic control
Traffic Storm Control Trap : None

Port Broadcast/          Multicast/          Unicast/           Time     Count
     Threshold/Action    Threshold/Action    Threshold/Action   Interval down
     (Action Indication  D:drop S:shutdown  *:port shutdown)
---- ------------------  ------------------  ------------------ -------- -----
1    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
2    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
3    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
4    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
5    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
6    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
7    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
8    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
9    Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
10   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
11   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
12   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
13   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
14   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
15   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
16   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
17   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
18   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
19   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
20   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
21   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
22   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
23   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
24   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
25   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0
26   Disabled/128000/D   Disabled/128000/D   Disabled/128000/D  5        0

 

Насколько я понимаю все что можно уже выключено.

Share this post


Link to post
Share on other sites

Command: show igmp_snooping

IGMP Snooping Global State : Enabled
Multicast router Only      : Disabled

VLAN  Name                 : default
Query Interval             : 125
Max Response Time          : 10
Robustness Value           : 2
Last Member Query Interval : 1
Host Timeout               : 260
Route Timeout              : 260
Leave Timer                : 2
Querier State              : Enabled
Querier Router Behavior    : Non-Querier
State                      : Enabled

Total Entries: 1

 

Share this post


Link to post
Share on other sites

попробуй conf igmp_s q a s d

хотя не факт что поможет

еще покажи show multicast port_filtering_mode

Share this post


Link to post
Share on other sites
попробуй conf igmp_s q a s d

Непомогло )

 

Command: show multicast port_filtering_mode
Port    Multicase Filter Mode
------  ---------------------------
1       filter_unregistered_groups
2       filter_unregistered_groups
3       filter_unregistered_groups
4       filter_unregistered_groups
5       filter_unregistered_groups
6       filter_unregistered_groups
7       filter_unregistered_groups
8       filter_unregistered_groups
9       filter_unregistered_groups
10      filter_unregistered_groups
11      filter_unregistered_groups
12      filter_unregistered_groups
13      filter_unregistered_groups
14      filter_unregistered_groups
15      filter_unregistered_groups
16      filter_unregistered_groups
17      filter_unregistered_groups
18      filter_unregistered_groups
19      filter_unregistered_groups
20      filter_unregistered_groups
21      filter_unregistered_groups
22      filter_unregistered_groups
23      filter_unregistered_groups
24      filter_unregistered_groups
25      filter_unregistered_groups
26      filter_unregistered_groups

 

Поскольку я уже неделю бьюсь с коммутатором, начинаю подумывать что это брак или проблема с прошивкой.

Share this post


Link to post
Share on other sites

config multicast port_filtering_mode all forward_all_groups

 

если уж и это не поможет - то менять софт.

могу порекомендовать только Build 6.00.B23 - может и немножко устарела прошивка, но лично у меня к ней никаких нареканий, особенно по части мультикаста нет.

Share this post


Link to post
Share on other sites
config multicast port_filtering_mode all forward_all_groups

 

если уж и это не поможет - то менять софт.

могу порекомендовать только Build 6.00.B23 - может и немножко устарела прошивка, но лично у меня к ней никаких нареканий, особенно по части мультикаста нет.

А можешь мне переслать эту прошивку?

Share this post


Link to post
Share on other sites
email в личку скинь, перешлю

отписал, попробую сделать downgrade.

Share this post


Link to post
Share on other sites
email в личку скинь, перешлю

отписал, попробую сделать downgrade.

что за коммутатор такой. теперь и шиться не хочет :)

Share this post


Link to post
Share on other sites
Прошивка коммутаторе стоит последняя 6.00.В48.
B48 - проблемная прошивка, как и B46.

 

 

Share this post


Link to post
Share on other sites

На форуме длика такая проблема обсуждалась, надо включить или выключить flow_control на портах

Share this post


Link to post
Share on other sites

Вообщем зря я валил на длинк, проблема оказывается в сетевой карте.

 

Устанавливаю режим в 100мегабит полный дуплекс, картинка перестает сыпаться. Как только автоопределние на 1000мегабит, все сыпится. Что интересно нигде ошибок нет.

 

Есть идеи что можно подкрутить на линуксе?

Share this post


Link to post
Share on other sites
Вообщем зря я валил на длинк, проблема оказывается в сетевой карте.

 

Устанавливаю режим в 100мегабит полный дуплекс, картинка перестает сыпаться. Как только автоопределние на 1000мегабит, все сыпится. Что интересно нигде ошибок нет.

 

Есть идеи что можно подкрутить на линуксе?

Жестко поставить на карте и на свиче 1 гиг на порту

Share this post


Link to post
Share on other sites
Вообщем зря я валил на длинк, проблема оказывается в сетевой карте.

 

Устанавливаю режим в 100мегабит полный дуплекс, картинка перестает сыпаться. Как только автоопределние на 1000мегабит, все сыпится. Что интересно нигде ошибок нет.

 

Есть идеи что можно подкрутить на линуксе?

Жестко поставить на карте и на свиче 1 гиг на порту

Все оказалось еще тривиальней. Линукс с ядром 2.6.35-22 неверно определяет мой сетевой контроллер realtek 8111C, устанавливая не правильные драйвера, проблема как выяснилось распространенная.

Share this post


Link to post
Share on other sites

Замена сетевой карты нужного эффекта не дала. Сеть на гигабите то завелась, пакеты забегали как надо. Но вот мультикаст не работает, картинка сыпится. Переключаю на 100мегабит и все сразу работает красиво.

 

От чего такое может быть?

 

Offload parameters for eth0:
rx-checksumming: off
tx-checksumming: off
scatter-gather: off
tcp-segmentation-offload: off
udp-fragmentation-offload: off
generic-segmentation-offload: off
generic-receive-offload: off
large-receive-offload: off
ntuple-filters: off
receive-hashing: off

 

Ring parameters for eth0:
Pre-set maximums:
RX:             4096
RX Mini:        0
RX Jumbo:       0
TX:             1024
Current hardware settings:
RX:             2048
RX Mini:        0
RX Jumbo:       0
TX:             1024

Share this post


Link to post
Share on other sites

А если совсем ни чего не помогает тогда смотрите подвздутые конденсаторы на материнке свича )))) у меня на таких свичах первым делом автоопределение некорректно работало.

Share this post


Link to post
Share on other sites

на кондеры еще не смотрел. вообщем ребус так и остается не разгаданным, коммутатор временно заменили на catalyst 2950t.

Share this post


Link to post
Share on other sites

С прошивками я протупил, у меня версия свича DC, т.е. D-Link DES 3526DC. Есть прошивки для этого коммутатора у кого-нибудь?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this