Jump to content
Калькуляторы

FREEBSD 7.1 input errs em0 которые нифига не инпут

Столкнулся тут с интересным поведением фряхи при тесте роутера:

Роутер, на ем0 4 влана и IP, iperf, UDP, 1 источник в влане 2 -> 2 приемника по очереди в вланах 0 и 3 (в влане 3 тормозной виндовый клиент)

Генератор трафа
iperf -u -c 10.188.0.2 -i 10 -l 500 -t 300 -b 450M
[  3] local 10.188.2.2 port 65395 connected with 10.188.0.2 port 5001
[  3]  0.0-10.0 sec    576 MBytes    483 Mbits/sec

На роутере 
    108819     0   58935177     108707     0   58927926     0
            input          (em0)           output
   packets  errs      bytes    packets  errs      bytes colls
    113774     0   61639210     113712     0   61633212     0
    117544     0   63674806     117474     0   63666074     0
    123170     0   66734632     123121     0   66730180     0
    124256     0   67302522     124161     0   67294944     0
    118490     0   64185545     118405     0   64178190     0
    123968     0   67164222     123916     0   67157818     0
    120498     0   65286677     120450     0   65282498     0
    113446     0   61447772     113362     0   61441344     0
    122729     0   66493631     122664     0   66488990     0
    118977     0   64459075     118929     0   64454142     0
    119740     0   64871273     119623     0   64865700     0
    101661     0   55050764     101591     0   55043034     0
    117619     0   63716010     117574     0   63709072     0
    121278     0   65704443     121215     0   65697670     0
    122416     0   66321644     122357     0   66316380     0
    115586     0   62597701     115470     0   62588758     0
    126360     0   68466173     126335     0   68462412     0
     65358     0   35400414      65316     0   35395962     0
        61     0       6778          2     0        224     0

Генератор трафа
iperf -u -c 10.188.3.2 -i 10 -l 500 -t 300 -b 450M
[  3] local 10.188.2.2 port 51940 connected with 10.188.3.2 port 5001
[  3]  0.0-10.0 sec    578 MBytes    485 Mbits/sec
[  3] 10.0-20.0 sec    564 MBytes    473 Mbits/sec

На роутере
     76887     0   41627325      76769     0   41617982     0
    122980    46   66579813     122829     0   66567580     0
            input          (em0)           output
   packets  errs      bytes    packets  errs      bytes colls
    118730  1962   64326532     118665     0   64321532     0
    121284   325   65718064     121250     0   65714690     0
    121322   237   65715537     121229     0   65708510     0
    114368  3286   61952482     114297     0   61946776     0
    122565   178   66403595     122524     0   66398476     0
    117199   340   63484299     117079     0   63476554     0
    121536   276   65832689     121468     0   65820162     0
    121622   113   65889332     121565     0   65884660     0
    113954   503   61736517     113892     0   61731134     0
    120674  2418   65385308     120631     0   65381142     0
    119128   270   64519164     119022     0   64509064     0
    118688   389   64306458     118643     0   64302020     0
    113888  2947   61706955     113812     0   61700420     0
    121584    20   65871356     121556     0   65866594     0
    122726   341   66475645     122629     0   66466768     0
    116544   996   63142360     116505     0   63137804     0
    105936   431   57395074     105886     0   57391520     0
    114118   419   61830175     114069     0   61825622     0
    106462  3545   57655138     106350     0   57646622     0
    117992   192   63923340     117940     0   63917200     0

Может кто подскажет почему ошибки на input интерфейсе???

И как тестить роутер без этих граблей?

Share this post


Link to post
Share on other sites

3 дня 70 просмотров, похоже спецы по фре вымерли..

Share this post


Link to post
Share on other sites

скорее похоже вопрос непонятен

- конкретно схема включения

-- конкретнее при какой позе начинаются появлятся ошибки.

Share this post


Link to post
Share on other sites

1 прот на тестируемом сервере, на нем 3 влана с IP и сетями которые роутятся, 1 свич гигабитный глупый , 3 клиента, тоже по 1 порту на клиента, на каждом поднят свой влан, IP и прописан роутинг в остальные 2 сети через сервер.

При отправке UDP потока с клиента 1 на клиента 2 ошибок нет, а при отправке потока с клиента 1 на клиента 3 до 5 % дропов, дропы на ИНПУТ порта сервера.

Share this post


Link to post
Share on other sites

ситуация аналогичная, на em0 висит несколько влан, терминируем по mpd5.2 , после 600 тунелей наблюдаю ошибки на input.

внятного предложения пока не получил :(

Share this post


Link to post
Share on other sites
flow-control ?

в принципе очень даже вариант.

 

хотя если проблема не возникает на прошлых релизах, то не вариант

 

Share this post


Link to post
Share on other sites

tOly, на em'ах статистика есть: sysctl dev.em.0.stats=1. Она что-нибудь показывает?

Share this post


Link to post
Share on other sites

:)

да, ещё там дебаг есть он тоже что то показвает.

Share this post


Link to post
Share on other sites

Это мояже тема, тока здесь еще 1 полтергейс описан :)

Share this post


Link to post
Share on other sites

точно. ступил я маленько :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this