Jump to content
Калькуляторы

Quagga + centos7

На Centos есть 4 физических интерфейса.

На каждом интерфейсе  висят влан интерфейсы, которые я планирую использовать в ospf. 

Запускаю vtysh и кроме как просто интерфейсов я не вижу ничего. Почему нет настроек ip? Или это норм состояние? Мне получается нужно продублировать ручками  настройки  ip в консоли quagga? Я предполагал что, все настройки должны подтянуться при запуске сервиса.

Мануал я читал, просто затестить неначем, а сервер в продакшене стоит.

Трафик ~3г в пике, связку делаю с микротом. 

Подскажите, кто имел дело с оспф и др. на линукс и какие косяки с этой quagga бывают или есть? 

Share this post


Link to post
Share on other sites

В 04.09.2021 в 07:47, Владимир320 сказал:

На Centos есть 4 физических интерфейса.

На каждом интерфейсе  висят влан интерфейсы, которые я планирую использовать в ospf. 

Запускаю vtysh и кроме как просто интерфейсов я не вижу ничего. Почему нет настроек ip? Или это норм состояние? Мне получается нужно продублировать ручками  настройки  ip в консоли quagga? Я предполагал что, все настройки должны подтянуться при запуске сервиса.

Мануал я читал, просто затестить неначем, а сервер в продакшене стоит.

Трафик ~3г в пике, связку делаю с микротом. 

Подскажите, кто имел дело с оспф и др. на линукс и какие косяки с этой quagga бывают или есть? 

Это нормально. На интерфейсах в квагге только достаточно включить оспф и аутентификацию для area, если она используется. Ну и в настройках роутера оспф не забудьте объявить сети с маской, которые на интерфейсах используются в той же area, чтобы установилось соседство. А дальше уже указываете, что анонсируете соседям, фильтры на прием анонсов и т.д.

Share this post


Link to post
Share on other sites

3 часа назад, murano сказал:

Это нормально. На интерфейсах в квагге только достаточно включить оспф и аутентификацию для area, если она используется. Ну и в настройках роутера оспф не забудьте объявить сети с маской, которые на интерфейсах используются в той же area, чтобы установилось соседство. А дальше уже указываете, что анонсируете соседям, фильтры на прием анонсов и т.д.

ну я же могу продублировать настройки ip в квагге? а то как-то смущает вид без ip, или так не делается в этой квагге?

Share this post


Link to post
Share on other sites

10 часов назад, Владимир320 сказал:

ну я же могу продублировать настройки ip в квагге? а то как-то смущает вид без ip, или так не делается в этой квагге?

Не стоит. Если хотите в квагге вешать айпишники, то тогда из центосных конфигов уберите адреса и держите их только в квагге, она сама будет конфигурить интерфейсы

Share this post


Link to post
Share on other sites

Пытаюсь сдать статичные маршруты, добавленные в линуксе:

 

 

router ospf
 ospf router-id 10.11.11.2
 redistribute static route-map Static-to-OSPF
 passive-interface default
 no passive-interface vlan3800
 no passive-interface vlan3801
 no passive-interface vlan3802
 network 10.11.11.2/32 area 0.0.0.0
 network 89.255.97.4/30 area 0.0.0.0
 network 89.255.97.8/30 area 0.0.0.0
 network 89.255.97.14/30 area 0.0.0.0
!
access-list 20 permit 10.135.121.0 0.0.0.255
access-list 20 permit 172.16.121.0 0.0.0.255
access-list 20 permit 172.17.121.0 0.0.0.255
access-list 20 permit 10.135.116.0 0.0.0.255
access-list 20 permit 172.16.116.0 0.0.0.255
access-list 20 permit 172.17.116.0 0.0.0.255
!
route-map Static-to-OSPF permit 100
 match ip address 20
 

Маршруты на микрот не прилетают, адрес лупбека прилетает, соседство есть.

Куагга видит статичные маршруты, но в оспф не сдает. Хелп.

Данную схему делал на обычных цисках и все работает, на куагге нет

Edited by Владимир320

Share this post


Link to post
Share on other sites

в общем добавил маршрут через куаггу и сразу все отработало. Есть какойнить вариант заставить куаггу сдавать статичные линуксовые маршруты)? Или это бред, если работает куагга, то логично все делать через нее

Edited by Владимир320

Share this post


Link to post
Share on other sites

12 часов назад, kayot сказал:

@Владимир320 

Они скорее всего для квагги kernel а не static.

да, сделал redistribute kernel route-map Static-to-OSPF

Edited by Владимир320

Share this post


Link to post
Share on other sites

на случай краха оспф оставил статичные маршруты с метрикой 150. У меня появился вопрос по поводу дефолтного шлюза в кваге. Один дефолт я получаю от микрота с distance 110, другой дефолт я прописываю руками route add default gw 10.10.10.10 150.

Проверяю маршруты в кваге:

 

K>* 0.0.0.0/0 via 10.10.10.10, vlan3800
O   0.0.0.0/0 [110/11] via 10.10.10.10, vlan3800, 1d00h50m

 

метрику оспф я вижу, а вот метрику в линуксе я не вижу и получается что сейчас активен статичный маршрут а не оспф.

 

Делаю route -n

0.0.0.0         10.10.10.10     0.0.0.0         UG    150    0        0 vlan3800

 

Помогите разобраться

Edited by Владимир320

Share this post


Link to post
Share on other sites

В 10.09.2021 в 14:46, Владимир320 сказал:

на случай краха оспф оставил статичные маршруты с метрикой 150. У меня появился вопрос по поводу дефолтного шлюза в кваге. Один дефолт я получаю от микрота с distance 110, другой дефолт я прописываю руками route add default gw 10.10.10.10 150.

Проверяю маршруты в кваге:

 

K>* 0.0.0.0/0 via 10.10.10.10, vlan3800
O   0.0.0.0/0 [110/11] via 10.10.10.10, vlan3800, 1d00h50m

 

метрику оспф я вижу, а вот метрику в линуксе я не вижу и получается что сейчас активен статичный маршрут а не оспф.

 

Делаю route -n

0.0.0.0         10.10.10.10     0.0.0.0         UG    150    0        0 vlan3800

 

Помогите разобраться

 

потому, что статические маршруты всегда при любой метрике будут иметь выше приоритет, чем динамические. Вторые в свою очередь просто будут игнорироваться.

Share this post


Link to post
Share on other sites

В 15.09.2021 в 00:13, murano сказал:

потому, что статические маршруты всегда при любой метрике будут иметь выше приоритет, чем динамические. Вторые в свою очередь просто будут игнорироваться.

Дам как так? Сто раз динамику делал преоритетней статики, тока делал это на спецовых маршрутизаторах, циски и тд. 

Share this post


Link to post
Share on other sites

10 часов назад, Владимир320 сказал:

Дам как так? Сто раз динамику делал преоритетней статики, тока делал это на спецовых маршрутизаторах, циски и тд. 

Никогда динамика не была приоритетней  статики.

Share this post


Link to post
Share on other sites

13 часов назад, Владимир320 сказал:

Дам как так? Сто раз динамику делал преоритетней статики, тока делал это на спецовых маршрутизаторах, циски и тд. 

 Научите ? :) При условии что маска сети одинаковая....

Share this post


Link to post
Share on other sites

1 час назад, YuryD сказал:

 Научите ? :) При условии что маска сети одинаковая....

 


show running-config

...

ip route 0.0.0.0/0 a.b.c.69 250

...

 

show ip route 0.0.0.0/0

 

Routing entry for 0.0.0.0/0
  Known via "bgp", distance 20, metric 0, tag 0, vrf 0, best, fib
  Last update 03w5d07h ago
  >* x.y.z.100, via vlan8

Routing entry for 0.0.0.0/0
  Known via "static", distance 250, metric 0, tag 0, vrf 0
  >  a.b.c.69, via em0

Share this post


Link to post
Share on other sites

не смог воспроизвести на брокаде сер. у меня при нескольких пирах только один маршрут 0/0, да и он прилетел по бгп

 

1       0.0.0.0/0          xx.xx.xx.109   eth 1/1       20/0          Be   116d

 

Хотя есть и pbr  в конфиге для pa

 

Share this post


Link to post
Share on other sites

 

у меня там квага, фря (но ОС в данном случае не важна, на линуксе оно так же будет) при этом в ОС будет один маршрут, тот что бест, в зебре все.

 

на циске, я так вспоминаю, что тоже проблем небыло сделать бакапный статичный маршрут аналогично кваге (ну в смысле наоборот, это зебра реализовала логику как было к циске, а потом форкнуласть в квагу).

Share this post


Link to post
Share on other sites

 Я, перепрыгивая с зебры/квагги на аппаратные решения, вообще не заметил разницы в логике и конфигах, ну и особо в маршрутизации проблем вообще не было, голый синтаксис. Давно было... Примеры тырил в инете, киска, квагга,брокада  - в бгп одинаково стандартны. Но использовал только бгп, крайняя связка - квагга freebsd+cisco+пингвин_какойто в звезде, это внутри. В снаружи - квагга/брокада, подходы одинаковы. и вообще, нах ospf, если e/i bgp одинаково рулит.

Share this post


Link to post
Share on other sites

в линукс есть проблемы... я сталкивался в FRR с передачей маршрутов из "квагги/зебры" в кернел таблицу. Там надо задействовать механизм ECMP, чтобы нормально мультипатч отрабатывал... но в реализации FRR проблема в том, что когда в кернел таблицу приходит маршрут аналогичный уже имеющемуся, то надо переписать weight и вот реализация "квагги/зебры" в этом FRR не могла это сделать.

Хотя руками отрабатывала команда: ip route replace default proto static scope global nexthop dev ens2f0 via 192.168.0.1 weight 1 nexthop dev ens2f1 via 192.168.10.1 weight 10

Edited by guеst

Share this post


Link to post
Share on other sites

4 часа назад, guеst сказал:

в линукс есть проблемы... я сталкивался в FRR с передачей маршрутов из "квагги/зебры" в кернел таблицу. Там надо задействовать механизм ECMP, чтобы нормально мультипатч отрабатывал... но в реализации FRR проблема в том, что когда в кернел таблицу приходит маршрут аналогичный уже имеющемуся, то надо переписать weight и вот реализация "квагги/зебры" в этом FRR не могла это сделать.

Хотя руками отрабатывала команда: ip route replace default proto static scope global nexthop dev ens2f0 via 192.168.0.1 weight 1 nexthop dev ens2f1 via 192.168.10.1 weight 10

 

А что за ядро?

У меня версия 7.5 frr вообще падала, когда делал:

sh ip ospf interface

Сейчас в 8.0 исправили, но есть проблема в том, что в debian 11 как раз попала версия 7.5.

 

Также есть проблема с залипанием ipv6 multipath маршрутов. Решается обновлением ядра >4.11.

Share this post


Link to post
Share on other sites

14 часов назад, guеst сказал:

4.19... на Debian 10

Проблем быть не должно. По поводу метрик - это возможно недоработка frr.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.