Jump to content
Калькуляторы

2 прова 2 разных ip как подключится к микротику с двух ip

Добрый день, подскажите пожалуста как настроить mikrotik, если прова 2, 2 ip и необходимо иметь возможность подключения к микротику по разным ip? заранее спасибо!

Share this post


Link to post
Share on other sites
1 час назад, iraklizh сказал:

Добрый день, подскажите пожалуста как настроить mikrotik, если прова 2, 2 ip и необходимо иметь возможность подключения к микротику по разным ip? заранее спасибо!

А как сейчас маршрутизация настроена? Вы же не сделали просто 2 дефолта, правильно? Как вариант можно строить два туннеля до него по схеме 1 туннель-1 провайдер. И уже внутри этих туннелей городить маршрутизацию, можно даже динамическую.

Share this post


Link to post
Share on other sites

НА ДАННЫЙ МОМЕНТ: 1WAN НАСТРОЕНО ВСЕ: 2-Й WAN ТОЛЬКО СЕЙЧАС ПОДКЛЮЧИЛИ ПОКА НИЧЕГО НЕ НАСТРАИВАЛ. ПРОВ ОДИН И ТОТ ЖЕ.НО ГЕЙТЫ РАЗНЫЕ...(Т.Е. IP ИЗ РАЗНЫХ ПОДСЕТЕЙ) ОБА WAN ПОЛУЧАЮТ IP ДИНАМИЧЕСКИ, НО ЭТО НЕ БЕДА, НАСТРОЕННО  НА ИМЕЮЩЕМСЯ IP (INT 1) ddns + САМ ПРОВ ДЕЛАЕТ ПРИВЯЗКУ ИНТЕРФЕЙСОВ ПО MAC АДРЕСАМ, В ОБЩЕМ ЕСЛИ ИЗМЕНИТСЯ IP НА INT1 ТО ПО ЛОГИКЕ НА INT1 ВСЕ РАВНО НА МИКРОТ ДОЛЖЕН ЗАЙТИ... ИЗМЕНИТСЯ ЛИ ВТОРОЙ СО ВРЕМЕНЕМ НА ДАННЫЙ МОМЕНТ НЕ ВАЖНО, ВАЖНО ЧТОБ Я ПОПАЛ СЕЙЧАС НА МИКРОТ ЕСЛИ ПЕРВЫЙ ЛИНК УЙДЕТ В ДАУН. ЕСЛИ Я В ip service list winbox  8293 (порт поменял) а в available from  пропишу 0.0.0.0 не сработает?

Share this post


Link to post
Share on other sites

Вам надо в firewall mangle делать маркировку prerouting входящих и исходящих пакетов для второго интерфейса, и соответственно отделять этот трафик в свою таблицу маршрутизации, создавая правила route по маркировке. См. Ping через разные таблицы маршрутизации - Mikrotik коммутаторы и маршрутизаторы - Форумы NAG.RU

Share this post


Link to post
Share on other sites
20 минут назад, jffulcrum сказал:

Вам надо в firewall mangle делать маркировку prerouting входящих и исходящих пакетов для второго интерфейса, и соответственно отделять этот трафик в свою таблицу маршрутизации, создавая правила route по маркировке. См. Ping через разные таблицы маршрутизации - Mikrotik коммутаторы и маршрутизаторы - Форумы NAG.RU

А разве можно управление микротиком запихать в отдельную таблицу? Он же только из глобала управляется или что-то изменилось?

Share this post


Link to post
Share on other sites

Я может не в курсе... но причем тут глобал.

Куда проц заглядывает - оттуда и управляется, нет?

 

И.. что-то мне подсказывает, что раз пров один.. оба линка уйдут в даун.. но может это не точно. =)

Edited by gard

Share this post


Link to post
Share on other sites
56 минут назад, gard сказал:

И.. что-то мне подсказывает, что раз пров один.. оба линка уйдут в даун.. но может это не точно. =)

 

MAC и IP разные - не должно.

А вот в чём смысл использовать одного провайдера непонятен

Edited by witch

Share this post


Link to post
Share on other sites

А вот провод может быть один, с разными волокнами. оО

Share this post


Link to post
Share on other sites
34 минуты назад, gard сказал:

А вот провод может быть один, с разными волокнами. оО

да хоть 1 волокно с разными длиннами волн....   для L3 это уже разное...

Share this post


Link to post
Share on other sites

Не буду спорить, будем считать что их два. )

Share this post


Link to post
Share on other sites
12 часов назад, gard сказал:

Я может не в курсе... но причем тут глобал.

Куда проц заглядывает - оттуда и управляется, нет?

 

И.. что-то мне подсказывает, что раз пров один.. оба линка уйдут в даун.. но может это не точно. =)

 

Не знаю как сейчас, но раньше было не так. Раньше микротик слушал сервисами только в глобале. Скорее всего и сейчас так же, т.к. у микротика vrf ненастоящие, настоящие обещались сделать в 7ой версии так что ждемс...

Share this post


Link to post
Share on other sites

 Пров один, подключения разные, логика в том что беру 100 мб.сек  (дальше технодогия не позволяет нарастить канал), а чувакам нужго больше скорости, вот беру еше один линк на 100 мб.сек ... конечно геморно будет всем разные роуты писать ну да ладно ... пока других вариантов ( завести оптику и т.д) нет. Но подсети разные от прова, деф гейт тоже... ( такая схема уже работает спасибо форуму за это!) но и там могу подключатся только к конкретному соединению, ко второму ужо не получается ( правда в сервисах winbox порт стандартный порт поменял а конект с 0.0.0.0 не прописывал явно...

Share this post


Link to post
Share on other sites

Как правильно сказали выше - маркировкой. Куда будут ходить юзеры и как будут настроены таблицы - уже другой вопрос

Share this post


Link to post
Share on other sites

используйте /ip route rules

можно управление сделать и при помощи /ip firewall mangle, но вариант через firewall жрёт ресурсы cpu сильно больше.

вот тут есть packet flow mikrotik:

https://www.mikrotik-trainings.com/trainings_files/docs/PacketFlowV6wIPSec.pdf

решение о том через какой интерфейс отправлять ответные пакеты принимается в routing decision, а по диаграмме это сразу после local process. В общем правило будет выглядить примерно так:

/ip route add gateway=<isp1_gw> routing-mark=<table_name>

/ip route rules add src-address=<ip_from_isp1> action=lookup table=<table_name>

 

если нужно чтоб публик ип отвечал с внутренних сетей, то добавляем как в фаерволе правило повыше:

/ip route rules add src-address=<ip_from_isp1> dst-address=<internal_network> action=lookup table=main

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this