Jump to content
Калькуляторы

OSPF Nexus 3K и Mikrotik

Коллеги, всем добра.

2 дня ломаю голову - ничего не выходит.

Дано:

Nexus 3064 c  NXOS: version 9.3(3)

Есть 2 сервера с bird

quagga

парочка Mikrotik

ospf broadcast

 

Суть такова, что после установки 3064 quagga начала сыпать:

OSPF: Link State Acknowledgment: Neighbor[172.20.0.2] state 2-Way is less than Exchange

Mikrotik сыпет:

 route,ospf,info Ignoring Link State Acknowledgment packete 
 route,ospf,info     state=2-Way 

bird при этом молчит.

 

При чем LSA бегают, мрашруты передаются как с nexus, так и на него. В соседях везде все есть. Циска в статусе 172.20.0.2        1 2-Way/DROther     39.423s 172.20.0.2

 

MTU 1500 везде(но но всякий на quagga и nexus есть ip ospf mtu-ignore). Таймауты совпадают.

Конфиг Nexus:

router ospf 1
  router-id 172.20.0.2
  default-information originate
  redistribute direct route-map ospf-out
  log-adjacency-changes

interface Vlan3
  ip ospf network broadcast
  no ip ospf passive-interface
  ip ospf mtu-ignore
  ip router ospf 1 area 10.10.10.0 secondaries none

 

Прошу помощи гуру.

Edited by devil_MC

Share this post


Link to post
Share on other sites
1 час назад, devil_MC сказал:

имеется ввиду active\passive?

Нет, p2p p2m bcast и т.п.

Share this post


Link to post
Share on other sites

Да, везде broadcast. Пробовал менять на p2m - безрезультатно.

Share this post


Link to post
Share on other sites

Не устанавливает соседство. Прыгает Init-Exchange-Full на циске.

 Total number of neighbors: 1
 Neighbor ID     Pri State            Up Time  Address         Interface
 172.20.0.5       10 EXCHANGE/ -      00:00:01 172.20.0.5      Vlan3

 

 

На микротике:

14:26:44 route,ospf,info Discarding packet: no neighbor with this source address
14:26:44 route,ospf,info     RouterId=172.20.0.2
14:26:44 route,ospf,info     source=172.20.0.2

 

Share this post


Link to post
Share on other sites

Может таки МТУ не сходится, попробуйте пакеты поснифать и посмотреть что у них при установке соседства

 

Он в DBD должен быть

Share this post


Link to post
Share on other sites

Попробовал откинуть одного из пиров, что c bird.

При этом DRом стал один из микротиков и на нем перестали сыпаться сообщения

Ignoring Link State Acknowledgment packete 

Прилагаю дамп. Судя из него все шлют LS Acknowledge на 224.0.0.6, а циска на 224.0.0.5. Это все что я увидел. Получается баг? Или может оно так и должно быть, пока соседство нормально не установится?

example.cap

Edited by devil_MC

Share this post


Link to post
Share on other sites

Нет, врядли.

Nexus

Цитата

IP address 172.20.0.2/24
    Process ID 1 VRF default, area 10.10.10.0
    Enabled by interface configuration
    State DROTHER, Network type BROADCAST, cost 40
    Index 1, Transmit delay 1 sec, Router Priority 1
    Designated Router ID: 172.20.0.6, address: 172.20.0.6
    Backup Designated Router ID: 172.20.0.3, address: 172.20.0.3
    6 Neighbors, flooding to 2, adjacent with 2
    Timer intervals: Hello 10, Dead 40, Wait 40, Retransmit 5

Mikrotik

Цитата

routing ospf interface print detail
Flags: X - disabled, I - inactive, D - dynamic, P - passive
 0    interface=vlan3 bridge cost=10 priority=10 authentication=none authentication-key=""
      authentication-key-id=1 network-type=broadcast instance-id=0 retransmit-interval=5s
      transmit-delay=1s hello-interval=10s dead-interval=40s use-bfd=no

 

Share this post


Link to post
Share on other sites

Интересно. А если прошивку на нексусе понизить?

Edited by TriKS

Share this post


Link to post
Share on other sites

Какая версия прошивки на микротике? 

Адреса на основном интерфейсе висят? 

Share this post


Link to post
Share on other sites
5 часов назад, TriKS сказал:

А если прошивку на нексусе понизить?

Страшно. Никогда этим не занимался. Если вариантов не будет больше, то попробую.

 

1 час назад, kapydan сказал:

Какая версия прошивки на микротике? 

три разных версии из трех последних. Но я не думаю, что проблема в микротиках. Выше писал что

 

В 07.04.2020 в 15:04, devil_MC сказал:

Судя из него все шлют LS Acknowledge на 224.0.0.6, а циска на 224.0.0.5. Это все что я увидел. Получается баг?

 

1 час назад, kapydan сказал:

Адреса на основном интерфейсе висят?

на vlan.

Share this post


Link to post
Share on other sites
13 минут назад, devil_MC сказал:
2 часа назад, kapydan сказал:

Адреса на основном интерфейсе висят?

на vlan.

имел ввиду немного иное, например на циске можно повесить secondary ip адрес на интерфейс или подинтерфейс.

 

а как area настроены на устройствах?

 

Share this post


Link to post
Share on other sites
59 минут назад, kapydan сказал:

имел ввиду немного иное, например на циске можно повесить secondary ip адрес на интерфейс или подинтерфейс.

Я считаю что vlan это и есть subinterface. На циске так

Цитата

interface Vlan3
  no shutdown
  no ip redirects
  ip address 172.20.0.2/24
  ip ospf network broadcast
  no ip ospf passive-interface
  ip ospf mtu-ignore
  ip router ospf 1 area 10.10.10.0 secondaries none

 

1 час назад, kapydan сказал:

а как area настроены на устройствах?

Одинаково. По циске выше есть, микротик так

Цитата

 0    name="area10" instance=default type=default area-id=10.10.10.0

 

Share this post


Link to post
Share on other sites

@devil_MC  У меня связка mx 80 микротик работает все норм. 

 

ИМХО выложите весь конфиг. 

 

/routing ospf instance
add name=ospf8 router-id=x.x.x.8
/routing ospf area
add area-id=0.0.0.8 default-cost=1 inject-summary-lsas=no instance=ospf8 name=\
    area8 translator-role=translate-never type=nssa
/routing ospf interface
add authentication=simple authentication-key=xxxxxxxxxxxx interface=sfp2.3012 \
    network-type=point-to-point
/routing ospf network
add area=area8 network=x.x.0.0/18
add area=area8 network=x.x.254.24/30
add area=area8 network=x.x.255.8/32
add area=area8 network=y.y.y.0/24
add area=area8 network=x.x.254.76/30

 

 

show protocols ospf area 0.0.0.8
nssa no-summaries;
interface xe-0/0/0.3012 {
    interface-type p2p;
    priority 50;
    authentication {
        simple-password "$9$u71x1SlKMX7ds8XqmTQCAeKMLds"; ## SECRET-DATA

 

 

 

Share this post


Link to post
Share on other sites

@pingz Спасибо что откликнулись, я уже начинаю отчаиватся. У меня сомнения по поводу работы ospf циски. bird,quagga,микротик - все работают. Проблема вылезла именно с nexus 3064

Вот микротик:

Цитата

0  * name="default" router-id=172.20.0.11 distribute-default=never redistribute-connected=as-type-1
      redistribute-static=no redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no metric-default=1
      metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in
      out-filter=ospf-out

Цитата

 0    name="area10" instance=default type=default area-id=10.10.10.0

Цитата

0    interface=vlan3 cost=10 priority=10 authentication=none authentication-key="" authentication-key-id=1
      network-type=broadcast instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=10s
      dead-interval=40s use-bfd=no

 

Nexus:

Цитата

 

router ospf 1
  router-id 172.20.0.2
  default-information originate
  redistribute direct route-map ospf-out
  log-adjacency-changes

interface Vlan3
  ip ospf network broadcast
  no ip ospf passive-interface
  ip ospf mtu-ignore
  ip router ospf 1 area 10.10.10.0 secondaries none

 

 

Share this post


Link to post
Share on other sites

Это у вас не бекбон? Почему использована area 10.10.10.0 ?

Share this post


Link to post
Share on other sites

@devil_MC  Между циской, микротиком, квагой, что стоит? 

 

 

Я как понял у вас большой L2 и в нем OSPF? Если так, то нужно проверять всех участников OSPF.

 

Может переделать все посадить на отдельные вланы и разбить по зонам? 

 

Присоединяюсь к vurd'у если у вас не бекбон 0.0.0.0 создайте отдельный инстанс. 

 

Когда я запускал на бекбон у меня в упор не запускался nssa т.к. в этой зоне нельзя этого делать. 

 

 

 

 

Share this post


Link to post
Share on other sites
8 часов назад, vurd сказал:

Это у вас не бекбон? Почему использована area 10.10.10.0 ?

несколько лет назад настраивал так. По инструкции какой-то. Там говорили, что нужно выбрать area уникальным, но не важно каким. Так и настроил.

7 часов назад, pingz сказал:

Между циской, микротиком, квагой, что стоит? 

Изначально стоит BDCOM. В него включены quagga,bird,mikrotik,nexus. В планах все перенести в nexus. Но вылезла вот такая засада.

7 часов назад, pingz сказал:

Я как понял у вас большой L2 и в нем OSPF?

Я бы не сказал что он большой. 2 bird, 3 mikrotik, 1 quagga. Раньше было чуть больше, но мы оптимизировали.

7 часов назад, pingz сказал:

Если так, то нужно проверять всех участников OSPF.

Зачем? Все остальные участники работают. Если DR\BDR отваливаются, все перестраивается и работает. За 4 года проблем не было.

И в случае с nexus, если сделать так, что DR становится один из mikrotik - то на этом DR mikrotik - перестают сыпаться ошибки.

7 часов назад, pingz сказал:

Присоединяюсь к vurd'у если у вас не бекбон 0.0.0.0 создайте отдельный инстанс. 

А можно, пожалуйста, подробней? Вот я считаю, что у меня бекбон. Других area нет и не предвидится. Почему нельзя взять любую area?

1 час назад, zhenya` сказал:

Переходите на p2p. Шаред вланы зло.

Почему? У нас не так много роутеров, абонентского трафика в этом вилане нет. с p2p морок много. Для каждой свой вилан и настройки.

Share this post


Link to post
Share on other sites

Начните с перевода на area 0, area 0.0.0.0. По идеи вы можете использовать другие зоны, конечно, но тут у нас сааб усирался за то, что в микроте только нормально с нулями и работает протокол.

В общем это пока очевидный момент, который можно легко поправить, если не поможет будем дальше думать.

 

Share this post


Link to post
Share on other sites

@vurd Спасибо, попробую вариант.

 

Кстати утром пробовал понизить версию NXOS с 9.3(3). Не все так просто. На nxos.7.0.3.I7.8 не захотел понижаться. Пришлось ставить 7.0(3)I4(5). Кстати на ней проблема все та же.

Share this post


Link to post
Share on other sites

имхо понижать версию, была самая бесполезная затея

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this