Jump to content
Калькуляторы

hAP lite и ip-tv Сыпется картинка про просмотре ip-tv

Друзья, поставил домой Mikrotik hAP lite и упёрся в настройку IPTV. IPTV смотрю в через wifi на ТВ Samsung ( через PeersTV), иногда, на ноуте (тоже через вайфай). Картинка появляется, но сыпется безбожно и подвисает. Через богомерзкий dlink dir 300 таких проблем не появлялось.

Включил wmm-support=enabled и multicast-helper=full.

Подскажите, плиз, куда копать.

 

# aug/24/2017 20:55:56 by RouterOS 6.40.1
# software id = 
#
# model = RouterBOARD 941-2nD
# serial number =
/interface bridge
add name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] comment=WAN name=ethet1
set [ find default-name=ether2 ] name=ethet2
set [ find default-name=ether3 ] master-port=ethet2
set [ find default-name=ether4 ] master-port=ethet2
/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods="" management-protection=\
   allowed mode=dynamic-keys name=profile1 supplicant-identity="" \
   wpa-pre-shared-key=****** wpa2-pre-shared-key=******
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
   default-forwarding=no disabled=no mode=ap-bridge multicast-helper=full \
   security-profile=profile1 wmm-support=enabled
/ip pool
add name=dhcp_pool0 ranges=192.168.88.2-192.168.88.20
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge-local name=dhcp1
/interface bridge port
add bridge=bridge-local interface=ethet2
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.88.1/24 interface=bridge-local network=192.168.88.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ethet1
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip firewall filter
add action=accept chain=input comment="Allow IGMP" in-interface=ethet1 protocol=igmp
add action=accept chain=input comment="IPTV UDP incoming" dst-port=1234 in-interface=ethet1 protocol=udp
add action=accept chain=forward comment="IPTV UDP forwarding" dst-port=1234 in-interface=ethet1 protocol=udp
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ethet1
/ip route
add distance=1 gateway=10.21.22.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/routing igmp-proxy
set query-interval=1s query-response-interval=1s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ethet1 upstream=yes
add interface=bridge-local
/system clock
set time-zone-name=Europe/Moscow
/system ntp client
set enabled=yes primary-ntp=195.151.98.66 secondary-ntp=80.240.216.155
#error exporting /system routerboard mode-button

Edited by vadiara50

Share this post


Link to post
Share on other sites

У некротика мультикаст через вафлю плоховато работает, как ни настраивал.

Смотрю иптв на дюне.

Share this post


Link to post
Share on other sites

vadiara50, я бы начал с /interface wireless set name=wlan1 band=2ghz-onlyn bridge-mode=disabled и показом /interface wireless registration-table print

Share this post


Link to post
Share on other sites

vadiara50, я бы начал с /interface wireless set name=wlan1 band=2ghz-onlyn bridge-mode=disabled и показом /interface wireless registration-table print

Извольте

 # INTERFACE            RADIO-NAME       MAC-ADDRESS       AP  SIGNAL-STRENGTH TX-RATE UPTIME       
0        wlan1                           AC:E0:10:26:42:F1      no  -57dBm@1Mbps     144.... 2m31s               
1        wlan1                           FC:3D:93:44:34:33      no  -55dBm@1Mbps    54Mbps  2m30s               
2        wlan1                           7C:FA:DF:C5:BC:1F      no  -61dBm@6Mbps    65Mb... 2m30s               
3        wlan1                           78:AB:BB:E9:71:DD      no  -40dBm@HT20-3   86.6... 59s

Share this post


Link to post
Share on other sites

vadiara50, я бы начал с /interface wireless set name=wlan1 band=2ghz-onlyn bridge-mode=disabled и показом /interface wireless registration-table print

/interface wireless set name=wlan1 band=2ghz-onlyn bridge-mode=disabled не спасло отца русской демократии

Share this post


Link to post
Share on other sites
В 24.08.2017 в 21:03, vadiara50 сказал:

add action=accept chain=input comment="Allow IGMP" in-interface=ethet1 protocol=igmp

add action=accept chain=input comment="IPTV UDP incoming" dst-port=1234 in-interface=ethet1 protocol=udp

add action=accept chain=forward comment="IPTV UDP forwarding" dst-port=1234 in-interface=ethet1 protocol=udp

Бессмысленно, у вас ни одного запрещающего правила нет.

В 24.08.2017 в 21:03, vadiara50 сказал:
/routing igmp-proxy set query-interval=1s query-response-interval=1s quick-leave=yes

Откуда такие дикие значения query-interval и query-response-interval? Зачем меняли? Верните дефолтные, первое 00:02:05, второе 00:00:10. Тест скорости через wifi-подключение делали?

Share this post


Link to post
Share on other sites

Микротик + мультикаст - это уже трагедия. А Вы еще по вайфаю хотите...

Share this post


Link to post
Share on other sites
31 минуту назад, vnkorol сказал:

Микротик + мультикаст - это уже трагедия.

Не надо драм, за исключением до недавнего времени отсутствовавшего igmp-snooping-а ничего трагичного в мультикасте у МТ не наблюдалось. И по wifi тоже. Другой вопрос, что у ТС с локальным состоянием глобально засранного в 2,4Ghz эфира.

Share this post


Link to post
Share on other sites

DRiVen 

Я что-то пропустил? Появился IGMP snooping? wifi стал нормально пропускать мультикаст?

Share this post


Link to post
Share on other sites
17 минут назад, vnkorol сказал:

Появился IGMP snooping?

В changelog пишут:

Other changes since 6.40.2:
...

*) bridge - added initial support for hardware "igmp-snooping" on CRS1xx/2xx (CLI only);
...

*) bridge - fixed multicast forwarding (introduced in v6.40rc36);
...

*) bridge - implemented software based "igmp-snooping" (CLI only);

А wifi вполне нормально пропускал изначально (с соответствующими настройками).

Share this post


Link to post
Share on other sites
3 часа назад, DRiVen сказал:

interface bridge set name=bridge_local igmp-snooping=yes

?

Не получается.

 

[admin@MikroTik-2-multicast] > interface bridge set name=bridge-vlan0122 igmp-snooping=yes  
expected end of command (line 1 column 56)

 

Подсвечивается символ знака "равно".

Share this post


Link to post
Share on other sites
16 часов назад, DRiVen сказал:

bridge - added initial support for hardware "igmp-snooping" on CRS1xx/2xx (CLI only);

В этом коротком предложении прекрасно все.

И initial support, и on CRS1xx/2xx, и CLI only.

Надо бы у Saab95 спросить, когда у мультикаста отменили статус "устаревшей технологии".

Share this post


Link to post
Share on other sites

alibek 

Так я не пойму, оно только на CRS работает? CLI - это у них типа консоль так зовется или еще чего выдумали прибалты?

Share this post


Link to post
Share on other sites

Понятия не имею, я в Микротиках разочаровался давно и с тех пор желания экспериментировать нет.

Но changelog с таким количеством оговорок заставляет сомневаться, что в RouterOS решили проблему с нормальной работой мультикаста.

Share this post


Link to post
Share on other sites

Я чем больше с микротом дело имею, теб больше убеждаюсь, что пусть он как роутер и неплох местами, но как коммутатор - ад. Т.е. подключить одним кабелем к свитчу и вланами развести - еще куда не шло, а пользоваться портами на борту - слишком много граблей уже собрал...

Share this post


Link to post
Share on other sites

Микротик это неплохая железка для дома и небольшого офиса (при условии, что не используется мультикаст). Ну или для радиомостов.

Для операторских или корпоративных задач он подходит плохо.

Share this post


Link to post
Share on other sites
1 час назад, vnkorol сказал:

Так я не пойму, оно только на CRS работает?

На CRS аппаратно, софтово - на остальных, все на последней бете (6.41rc20), и ессно через консоль (cli).  Лень открыть changelog?

 

1 час назад, vnkorol сказал:

как коммутатор - ад.

Угу. Правда перемены некоторые есть, но мелкие и редкие.

 

alibek , а зачем в корпоративном контексте мультикаст? МТ, как роутер, мультик обрабатывает нормально, вот как soho-гибрид да, кисло было без igmp-snooping.

Share this post


Link to post
Share on other sites
Только что, DRiVen сказал:

а зачем в корпоративном контексте мультикаст?

За корпоратив не скажу, но например видеонаблюдение или голосовые оповещения.

А у операторов — IPTV через мультикаст. У нас работает замечательно.

Share this post


Link to post
Share on other sites

DRiVen 

Обновился до RC, в винбоксе появилась галка. И, о чудо, у меня в мфу теперь не льются террабайты мультикаста. Спасибо большое.

 

 

Share this post


Link to post
Share on other sites
В 26.08.2017 в 20:51, DRiVen сказал:
В 24.08.2017 в 21:03, vadiara50 сказал:

add action=accept chain=input comment="Allow IGMP" in-interface=ethet1 protocol=igmp

add action=accept chain=input comment="IPTV UDP incoming" dst-port=1234 in-interface=ethet1 protocol=udp

add action=accept chain=forward comment="IPTV UDP forwarding" dst-port=1234 in-interface=ethet1 protocol=udp

Бессмысленно, у вас ни одного запрещающего правила нет.

В 24.08.2017 в 21:03, vadiara50 сказал:
/routing igmp-proxy set query-interval=1s query-response-interval=1s quick-leave=yes

Откуда такие дикие значения query-interval и query-response-interval? Зачем меняли? Верните дефолтные, первое 00:02:05, второе 00:00:10. Тест скорости через wifi-подключение делали?

Правила запрещающие были, я заново конфиг сбросил для чистоты эксперимента.

значения query-interval и query-response-interval вернул на место, теперь они по дефолту.

Картинка не изменилась.

Поставил 6.41rc20. Где тут волшебная галка в винбоксе, которая сделает зашибись?

 

 

Share this post


Link to post
Share on other sites
1 час назад, vadiara50 сказал:

 

Поставил 6.41rc20. Где тут волшебная галка в винбоксе, которая сделает зашибись?

 

 

 

2017-08-29.png

Share this post


Link to post
Share on other sites

 

vadiara50 , тест скорости доступа по wifi делали? Сколько АР вокруг? Каков средний битрэйт у мультикаста? /interface wireless export еще раз покажите.

 

Вот на этом конфиге вполне себе живет stb и пара смартов:

/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode band=2ghz-onlyn basic-rates-a/g=24Mbps \
    basic-rates-b="" bridge-mode=disabled channel-width=20mhz disabled=no frequency=auto hw-retries=5 \
    mode=ap-bridge multicast-helper=full name=wlan2.4 noise-floor-threshold=-90 preamble-mode=short rate-set=configured \
    ssid=******** supported-rates-a/g=24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b="" tx-power=12 tx-power-mode=\
    all-rates-fixed wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled

 

Share this post


Link to post
Share on other sites
49 минут назад, DRiVen сказал:

 

vadiara50 , тест скорости доступа по wifi делали? Сколько АР вокруг? Каков средний битрэйт у мультикаста? /interface wireless export еще раз покажите.

 

 

Скорость померил с ноута, точки оттуда же. или это надо с микротика сделать? Где глянуть битрейт у мультикаста? 

# software id = *******
#
# model = RouterBOARD 941-2nD
# serial number = 7C2C07B*****
/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed \
    mode=dynamic-keys name=profile1 supplicant-identity="" wpa-pre-shared-key=\
    ******** wpa2-pre-shared-key=********
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn bridge-mode=disabled \
    channel-width=20/40mhz-Ce default-forwarding=no disabled=no mode=ap-bridge \
    multicast-helper=full security-profile=profile1 wmm-support=enabled

 

wifi.JPG

ap.jpg

1 час назад, vnkorol сказал:

 

2017-08-29.png

Спасибо, уже нашёл. улучшилось положение немного, но всё равно подсыпается периодически картинка. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now