Jump to content
Калькуляторы

Transmit loop detected

кто-нибудь сталкивался? в логах голубенькое "transmit loop detected, downing interface for 60 seconds".

http://forum.mikrotik.com/viewtopic.php?t=91959

http://forummikrotik.ru/viewtopic.php?t=5995

прошивка 6.30.3. судя по отзывам по ссылкам - апгрейдом не лечится.

 

ну я не буду бить себя пяткой в грудь и говорить, что колец нет )) а их нет, чесслово.

вопрос в другом - как полечить, чтобы если уж оно отключало, то действительно на 60 секунд, а не насовсем?

 

пока лечу руками - захожу на микротик, прибиваю eoip-тоннель, на котором сработал детект, создаю новый - все прекрасно начинает работать.

Share this post


Link to post
Share on other sites

столкнулись с аналогичной проблемой.

14:09:08 interface,warning eoip1631 transmit loop detected, downing interface for 60 seconds

 

Туннель обратно сам не встал, disable/enable не помог, пришлось пересоздать туннель.

board-name: RB1200 version: 6.32.1

 

Есть идеи для фикса?

Share this post


Link to post
Share on other sites

откат до версии, меньшей 6.22 - пока это единственный фикс. ну или продолжать руками.

Share this post


Link to post
Share on other sites

v6.35.1

v6.35.2

Edited by mafijs

Share this post


Link to post
Share on other sites

v6.35.1

v6.35.2

полез читать чейнджлог - не нашел ничего, связанного с. откуда вы взяли информацию про 6.35.х?

 

но зато в версии 6.34 упомянуто:

*) tunnel - fix complaining about loop after ~248 days;

это, похоже, мой случай.

Share this post


Link to post
Share on other sites

Ну так если испевлено в 6.34 то в 6.35 тем более.

Share this post


Link to post
Share on other sites

Ну так если испевлено в 6.34 то в 6.35 тем более.

 

Займусь некропостингом, ибо... Наступил на эти грабли сейчас. Версия 6.38.1, может какое-то время проработать нормально, потом опять грести начинает. Лечения не нашли ещё?

Share this post


Link to post
Share on other sites

Zmeyko, в свойствах интерфейса появилась настройка "loop detect". Можно установить в "off" если есть ложные срабатывания.

Share this post


Link to post
Share on other sites

Zmeyko, в свойствах интерфейса появилась настройка "loop detect". Можно установить в "off" если есть ложные срабатывания.

 

Спасибо, да. Это меню я видел, но вот беда - плевать оно хотело на неё. Хоть включай (пробовал установить большой интервал между проверками), хоть выключай - loop detector работае... кхм, гребёт независимо, как из пушки.

Даунгрейд прошивки (сейчас 6.38.1) очень опасаюсь делать, железка важная и далеко.

Share this post


Link to post
Share on other sites

Zmeyko, уж сколько раз твердили миру - в рабочих системах используйте только bugfix-ветку.

Share this post


Link to post
Share on other sites

Zmeyko, уж сколько раз твердили миру - в рабочих системах используйте только bugfix-ветку.

 

Дык... Мопед не совсем мой, вот, нарвался. А какая сейчас последняя bugfix и насколько вероятно огрести проблем при даунгрейде? На домашних-то я делал, особо не задумываясь, но в данном случае...

Share this post


Link to post
Share on other sites

Zmeyko, последний bugfix 6.37.4

У меня вообще системы живут на 6.36.4, а некоторые на 6.34.6.

Share this post


Link to post
Share on other sites

Zmeyko, последний bugfix 6.37.4

У меня вообще системы живут на 6.36.4, а некоторые на 6.34.6.

 

А вдруг вам нетрудно - можете проверить, есть ли эта проблема там? Научный тык (даунгрейдить без гарантии) не хочется применять, это может денег стоить. Тогда уж лучше сразу пробовать 6.21, чтобы два раза не платить, если что.

Спасибо.

Share this post


Link to post
Share on other sites

Zmeyko, в смысле проверить? Закольцевать линк на рабочем роутере? Мсье шутник.

Share this post


Link to post
Share on other sites

Zmeyko, в смысле проверить? Закольцевать линк на рабочем роутере? Мсье шутник.

 

Конечно же нет. :) Сделать EoIP тоннель между двумя МТ, с обеих сторон тоннель добавить в бридж (иначе не проявляется, причём достаточно бриджа только с одним EoIP тоннелем) и посмотреть, будет ли FP срабатывание (я поясняю, что имел ввиду, вовсе не просил деструктивных действий).

Проблема нифига не решилась. Пока отложили до момента, когда около удалённого роутера сможет быть человек с набором на случай "что-то пошло не так".

Share this post


Link to post
Share on other sites

Zmeyko, в смысле проверить? Закольцевать линк на рабочем роутере? Мсье шутник.

Незнаком с мокротиком совершенно, но в более-менее солидных коммутаторах-маршрутизаторах есть команда reload at/in или reload/restart через 120 секунд например. Это сильно уменьшает вероятие поездок с консольным кобелем и ноутом в бебеня. До сохранения конфига естественно. Применилось, отработало - сохраняем конфиг в железе. Накосячили - дивайс сам перезагрузится с древним конфигом. Физические проключения - ну там боец есть, если что - подождёт.

Share this post


Link to post
Share on other sites

Zmeyko, в смысле проверить? Закольцевать линк на рабочем роутере? Мсье шутник.

Незнаком с мокротиком совершенно, но в более-менее солидных коммутаторах-маршрутизаторах есть команда reload at/in или reload/restart через 120 секунд например. Это сильно уменьшает вероятие поездок с консольным кобелем и ноутом в бебеня. До сохранения конфига естественно. Применилось, отработало - сохраняем конфиг в железе. Накосячили - дивайс сам перезагрузится с древним конфигом. Физические проключения - ну там боец есть, если что - подождёт.

 

Там есть "safe mode", но это только в случае изменения настроек работает. При слёте всего при даунгрейде (вероятность есть) это не поможет, увы. Да, dual firmware тоже нет. Увы.

Share this post


Link to post
Share on other sites

Конечно же нет. :) Сделать EoIP тоннель между двумя МТ, с обеих сторон тоннель добавить в бридж (иначе не проявляется, причём достаточно бриджа только с одним EoIP тоннелем) и посмотреть, будет ли FP срабатывание (я поясняю, что имел ввиду, вовсе не просил деструктивных действий).

Проблема нифига не решилась. Пока отложили до момента, когда около удалённого роутера сможет быть человек с набором на случай "что-то пошло не так".

 

Нет такой проблемы. Используется множество EoIP туннелей. Естественно, STP протоколы на бридже нужно отключать. При создании бриджа без указания этих параметров, часто STP становиться активированным.

Share this post


Link to post
Share on other sites

Конечно же нет. :) Сделать EoIP тоннель между двумя МТ, с обеих сторон тоннель добавить в бридж (иначе не проявляется, причём достаточно бриджа только с одним EoIP тоннелем) и посмотреть, будет ли FP срабатывание (я поясняю, что имел ввиду, вовсе не просил деструктивных действий).

Проблема нифига не решилась. Пока отложили до момента, когда около удалённого роутера сможет быть человек с набором на случай "что-то пошло не так".

 

Нет такой проблемы. Используется множество EoIP туннелей. Естественно, STP протоколы на бридже нужно отключать. При создании бриджа без указания этих параметров, часто STP становиться активированным.

 

Так и у меня на куче микротиков нет такой проблемы. А вот тут нашёлся один такой, клиентский - и всё. Хоть убейся, плевать он хотел на настройки, с регулярностью часов кладёт тоннели. Причём на тех, что нет проблем, прошивки и той же версии, и других версий. Вообще, конечно, косячище микротиков - ну сделайте вы *реальное* отключение этой фичи, раз бывают ситуации, когда она гребёт. Под ответственность юзера. Но нет.

 

П. С. ®stp, разумеется, отключено везде.

Share this post


Link to post
Share on other sites

та бага, из-за которой я создавал эту тему, была пофикшена - EoIP тоннель ложился через 250 суток работы по лупдетекту.

у вас - явно не то.

где-то на конце тоннеля, где он переходит в медь (если переходит) - проблем с кабелем быть не может?

ну и влейте багфикс таки, а не текущую версию. причем попробуйте что-то вроде 6.34.6, где лупдетекта в виде отдельной настройки еще не было ))

Share this post


Link to post
Share on other sites

Вдруг кому пригодится - вылечилось только даунгрейдом прошивки до 6.21.1. Никакие другие пляски не помогали. Сейчас работает стабильно. Даунгрейд сделал только "центральному" рутеру, на остальных этой проблемы нет. Модель пациента - CRS125-24G-1S.

Share this post


Link to post
Share on other sites

У меня EoIP писал про transmit loop detected, downing interface for 60 seconds если он выходит интернет (путь до соседнего микротика) через влан который добавлен в бридж вместе с ним.

Если добавить влан не в бридж, а в физический интерфейс, то ошибка пропадает

Edited by bytestore

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this