Jump to content
Калькуляторы

Mikrotik RD750 Firewall Нужен совет

Доброго времени суток, имеется Mikrotik RD750 Firewall

Подскажите возможно ли запретить просмотр пользователям онлайн видео?

Перебрал кучу сайтов в интернет, не нашел ничего хорошего((

И еще интересует такой зверь как Shareman, методом закрытия торрентов не получается(, все равно качает(.

Share this post


Link to post
Share on other sites

возможно! используете L7

/ip firewall layer7-protocol add name=http-video regexp="http/(0.9|1.0|1.1)[x09-x0d ][1-5][0-9][0-9][x09-x0d -~]*(content-type: video)"

Share this post


Link to post
Share on other sites

а где можно все регулярные выражения прочитать?

Share this post


Link to post
Share on other sites

Я вообще режектил весь контект /video

Помогло

Share this post


Link to post
Share on other sites

Доброго времени суток, имеется Mikrotik RD750 Firewall

Подскажите возможно ли запретить просмотр пользователям онлайн видео?

Перебрал кучу сайтов в интернет, не нашел ничего хорошего((

И еще интересует такой зверь как Shareman, методом закрытия торрентов не получается(, все равно качает(.

 

И так режете /film /films и.т.д

1.PNG

Снимок.PNG

Share this post


Link to post
Share on other sites

Доброго времени суток, имеется Mikrotik RD750 Firewall

Подскажите возможно ли запретить просмотр пользователям онлайн видео?

Перебрал кучу сайтов в интернет, не нашел ничего хорошего((

И еще интересует такой зверь как Shareman, методом закрытия торрентов не получается(, все равно качает(.

 

 

/ip firewall filter

add ac=drop ch=forward p2p=a

add ac=drop ch=forward in-int=e2 pr=udp cont=«d1:ad2:id20:» dst-port=1025-65535 packet-s=95-190

add ac=drop ch=forward in-int=e2 pr=tcp cont=«info_hash=» dst-port=2710,80

 

Опционально, т.е. не обязательно:

 

— Блокируем скачку .torrent файлов:

add ac=drop ch=forward cont="\r\nContent-Type: application/x-bittorrent" out-in=e2 pr=tcp src-p=80

 

— Блокируем локальный торрент:

add ac=drop ch=forward cont="\r\nInfohash: " in-in=e2 pr=udp dst-port=6771

 

e2 = ether2 — Внутренний LAN интерфейс.

Команды, там где "\r\n… "- вставлять только через консоль. Фильтрацию по IP дописать думаю сможете и сами.

Share this post


Link to post
Share on other sites

Громадное спасибо, все завелось на ура, в итоге оказалось все очень намного проще)

Как говорится - Век живи - Век учись)

Share this post


Link to post
Share on other sites

Позвольте спрошу здесь, что бы не создавать тему: запущен web-proxy - там правило редиркта на страницу заглушки . Перенаправляет на сторонний сайт в интернете. Когда это правило выполняется для всех адресов, то на страницу редиректа попадают все клиенты, которые стоят за микротиком и все которые ломятся из вне по паблику (типа поисковых ботов, спама и т.д.).

Для того, что бы исключить редикеркты из вне - назначаю в правиле web-proxy подсеть внутренних адресов, теперь из вне никто не переадресовывается, но дико возрастает нагрузка на cpu микротика. Как можно правильно заблокировать лишний трафик из вне, но при этом разрешить переадрессацию внутренних ip ?

post-115647-035171400 1419173752_thumb.png

Edited by kinord

Share this post


Link to post
Share on other sites

Позвольте спрошу здесь, что бы не создавать тему: запущен web-proxy - там правило редиркта на страницу заглушки . Перенаправляет на сторонний сайт в интернете. Когда это правило выполняется для всех адресов, то на страницу редиректа попадают все клиенты, которые стоят за микротиком и все которые ломятся из вне по паблику (типа поисковых ботов, спама и т.д.).

Для того, что бы исключить редикеркты из вне - назначаю в правиле web-proxy подсеть внутренних адресов, теперь из вне никто не переадресовывается, но дико возрастает нагрузка на cpu микротика. Как можно правильно заблокировать лишний трафик из вне, но при этом разрешить переадрессацию внутренних ip ?

 

Ничего не трогайте в вебпрокси, все настройки адресов и других данных для перенаправления нужно делать в файрволе, тогда и нагрузки на процессор не будет.

Share this post


Link to post
Share on other sites

— Блокируем скачку .torrent файлов:

add ac=drop ch=forward cont="\r\nContent-Type: application/x-bittorrent" out-in=e2 pr=tcp src-p=80

 

Вы сами пробовали использовать это правило? У меня оно не работает.

Edited by Magil81

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this