Jump to content
Калькуляторы

gpon bdcom P3310B multicast разрешить все мультикаст ip для клиента

Подскажите,

существует ли способ для bdcom P3310B

разрешить для клиента, все мультикаст ip.

При помощи "ip mcst mc-vlan range"

можно только максимум 256 задать.

Edited by Стич

Share this post


Link to post
Share on other sites

Нет, нельзя.

 

Я писал костыль, который берет адреса каналов с базы и заполняет конфигурацию на bdcom-е через snmp.

Share this post


Link to post
Share on other sites

Кто нибудь пытался у bdcom

запрашивать реализацию igmp radius?

Share this post


Link to post
Share on other sites

привет, помогите разобраться с multicast - что-то не ходит.

 

uplink g0/6

mcast vlan 23

inet vlan 20

 

конфиг:

 

!

interface GigaEthernet0/6

switchport trunk vlan-allowed 20,23

switchport mode trunk

!

interface EPON0/1

epon bind-onu mac ххххххххххх 1

switchport trunk vlan-allowed 20,23

switchport mode trunk

!

interface EPON0/1:1

onu-configuration

epon onu port 1 ctc vlan mode tag 20

epon onu port 1 loopback detect

epon onu port 1 ctc mcst tag-stripe enable

epon onu port 1 ctc mcst mc-vlan add 23

!!onu-configuration-end

 

!

vlan 20

name test

!

vlan 23

name iptv

!

vlan 1,20,23

!

ip mcst enable

ip mcst series-connection

ip mcst mrouter interface GigaEthernet0/6

ip mcst mc-vlan 23 range 239.59.0.1 - 239.59.0.254

!

 

 

test-pon#sh ip mcst gr

 

Total Group Counts: 1

 

Vlan Group Type Port(s)

---- --------------- -------- -------------------------------------

1 239.59.0.55 LEARNING EPON0/1

Share this post


Link to post
Share on other sites

Не хватает у вас команды одной.

 

interface GigaEthernet0/1
description Uplink Copper
switchport trunk vlan-allowed 1201,1251,1261,2201,3201
switchport trunk vlan-untagged none
switchport mode trunk
! ### Это очень важный момент, здесь обязательно нужно указать мальтикаст vlan!
switchport pvid 1251
dhcp snooping trust
no shutdown

 

Читайте вот мою статью - http://nag.ru/articles/article/26698/bdcom-p3310b-v-ipoe-seti-so-shemoy-s-vlan.html

Share this post


Link to post
Share on other sites

Оживлю старую тему дабы новую не плодить. Помогите разобраться. Второй день голову ломаю. Имеется конфиг (98 vlan выход в мир, 971 - multicast):

 

 

 

epon onu-config-template test

cmd-sequence 1 epon onu port 1 ctc vlan mode tag 98

cmd-sequence 2 epon onu all-port ctc mcst mc-vlan add 971

cmd-sequence 3 epon onu all-port ctc mcst tag-stripe enable

!

interface GigaEthernet0/2

switchport trunk vlan-allowed 1,20,98,666,971

switchport trunk vlan-untagged none

switchport mode trunk

switchport pvid 971

!

interface EPON0/1

epon pre-config-template test binded-onu-llid 1

epon bind-onu mac хххх.хххх.хххх 1

switchport trunk vlan-allowed 98,971

switchport mode trunk

!

interface EPON0/1:1

onu-configuration

epon onu port 1 ctc vlan mode tag 98

epon onu port 1 ctc mcst tag-stripe enable

epon onu port 1 ctc mcst mc-vlan add 971

epon onu port 2 ctc mcst tag-stripe enable

epon onu port 2 ctc mcst mc-vlan add 971

epon onu port 3 ctc mcst tag-stripe enable

epon onu port 3 ctc mcst mc-vlan add 971

epon onu port 4 ctc mcst tag-stripe enable

epon onu port 4 ctc mcst mc-vlan add 971

!!onu-configuration-end

!

!

!

!

vlan 1,20,98,666,971,1251

!

ip mcst enable

ip mcst timer response-time 10

ip mcst mrouter interface GigaEthernet0/2

ip mcst mc-vlan 971 range 238.1.1.1 - 238.1.1.255

 

 

 

Onu получает все параметры конфига прекрасно. через 98 vlan я могу выйти в мир по dhcp получаю адрес и в путь. А вот multicast не показывает. включал через обычную бытовую приставку не катит. Перечила много статей вроде все правильно прописано а все равно не идет. Подскажите куда смотреть где что менять. Ответь менять что-то в голове не принимается)))

Share this post


Link to post
Share on other sites

Попробуйте переключить в режим igmp proxy.

 

ip igmp-proxy enable

 

Ну и прошивку на 3314_en_21324.bin обновить, если иная стоит (судя по отсутствию строчки ip mcst series-connection так и есть)

Share this post


Link to post
Share on other sites

сейчас вот такие настройки:

 

 

ip mcst enable

ip igmp-proxy enable

ip igmp-proxy last-member-query interval 3

ip mcst timer response-time 10

ip mcst series-connection

ip mcst mrouter interface GigaEthernet0/2

ip mcst mc-vlan 971 range 238.1.1.1 - 238.1.1.255

 

 

И все равно не показывает. даже список каналов получить не может

 

и ещё запара вышла. никак не могу два разных по портам раскидать. ONU принимает коняиг все отлично, но ни один влан не работает. Конфиг был такой:

 

 

interface EPON0/1:2

onu-configuration

epon onu port 1 ctc vlan mode tag 98

epon onu port 1 ctc vlan mode tag 20

!!onu-configuration-end

 

 

Почему то ни dhcp из влан не прилетал ни по статике не работал. Настройки остальные выше приведены

Share this post


Link to post
Share on other sites

И ещё почему то не получается подать мультикаст просто в влане. С коммутатора просто выдаю влан цепляю бытовую приставку и все отлично. а когда тут делаю так что на порт влан. то тоже не показывает

Share this post


Link to post
Share on other sites

Вроде добил, что то показывает но только через однопортовую онушку. Но странно показывает, включаешь канал идет. когда 10 секунд когда минуты 3-4, когда полминуты. Игрался таймерами ip igmp-proxy last-member-query interval 3, ip mcst timer response-time 10 - результата ноль. все равно рандомно канал выключается

Share this post


Link to post
Share on other sites

столкнулся с новой проблемой. Вот конфиг тот что работает:

 

 

interface GigaEthernet0/1

switchport trunk vlan-allowed 666,971

switchport trunk vlan-untagged none

switchport mode trunk

switchport pvid 971

!

interface GigaEthernet0/2

switchport pvid 971

!

 

!

interface EPON0/1

epon bind-onu mac fcfa.f718.66ff 1

epon bind-onu mac fcfa.f7c6.039f 2

switchport trunk vlan-allowed 666,971,1971

switchport mode trunk

!

interface EPON0/1:1

onu-configuration

epon onu port 1 ctc vlan mode tag 666

epon onu port 1 ctc mcst tag-stripe enable

epon onu port 1 ctc mcst mc-vlan add 1971

epon onu port 2 ctc mcst tag-stripe enable

epon onu port 2 ctc mcst mc-vlan add 1971

!!onu-configuration-end

!

interface EPON0/1:2

onu-configuration

epon onu port 1 ctc mcst tag-stripe enable

epon onu port 1 ctc mcst mc-vlan add 1971

!!onu-configuration-end

!

!!slot end

!

interface VLAN666

ip address 10.1.251.102 255.255.255.0

!

!

!

vlan 1,666,971,1971

!

ip mcst enable

ip mcst timer router-age 600

ip mcst timer response-time 120

ip mcst mc-vlan 1971 range 238.1.1.1 - 238.1.1.250

!

 

 

 

Проблема в следующем что подключившись компьютером в первую онушку я смотрю любой канал без проблем. А если ко второй онушке я подключаю STB то на ней я могу смотреть только тот канал который в данный момент показывает на компьютере с первой онушки. На компьютере переключаю канал и на STB канал отваливается. Но стоит мне подключить к одной онушке компьтютер и STB они работают отлично. каждое устройство может смотреть свой канал спокойно, не завися от другого. где в настройках косяк?! поддержка нага начала советовать да замолчала, целый день от них тишина

Share this post


Link to post
Share on other sites

ip igmp-proxy enable

ip igmp-proxy last-member-query interval 3

Share this post


Link to post
Share on other sites

уже думал об этом вечером. но вот сейчас прописал и не помогло((( все равно могу смотреть только одинаковые каналы((

Share this post


Link to post
Share on other sites

OLT работает в режиме proxy - проблем не знаем с multicast.

 

Есть опыт подключения к OLT "паровозом" еще один OLT или коммутатор, чтобы на подключеном устройстве тоже мультикаст работал?

Share this post


Link to post
Share on other sites

OLT работает в режиме proxy - проблем не знаем с multicast.

 

Есть опыт подключения к OLT "паровозом" еще один OLT или коммутатор, чтобы на подключеном устройстве тоже мультикаст работал?

Нет, такого не было, и слава богу.

 

уже думал об этом вечером. но вот сейчас прописал и не помогло((( все равно могу смотреть только одинаковые каналы((

После применения настроек необходимо перезагрузить OLT.

Share this post


Link to post
Share on other sites

уже думал об этом вечером. но вот сейчас прописал и не помогло((( все равно могу смотреть только одинаковые каналы((

 

После применения настроек необходимо перезагрузить OLT.

 

Это касается только мультикаста?! потому что все остальные настройки у меня применялись сразу без перезагрузки

Share this post


Link to post
Share on other sites

и перезагрузка тоже не помогла. все по старому. так же с разных онушек могу смотреть только один канал

Share this post


Link to post
Share on other sites

и перезагрузка тоже не помогла. все по старому. так же с разных онушек могу смотреть только один канал

Тогда остаётся снифить трафик на предмет join / leave после ONU и перед OLT.

Edited by uk2558

Share this post


Link to post
Share on other sites

Идея хорошая но как подключиться в разрыв onu-olt? через другую onu дак опять у нее свои там настройки будут?! больше ничего в голову придти не может. Наговцы уже у производителя запросили ответ на эту ситуацию

Share this post


Link to post
Share on other sites

Миррор пон-порта на olt можно сделать?

Share this post


Link to post
Share on other sites

а я сегодня собирал схемы по разному. в наличии 2 однопортовых и одна 4 портовая онушка. Дак вот в 4 портовой все прекрасно работает. любой порт любой влан и мультикаст. А вот тот же конфиг прописываю на однопортовую онушку

 

epon onu port 1 ctc mcst tag-stripe enable

epon onu port 1 ctc mcst mc-vlan add 1971

 

и на ней не работает мультикаст пока на 4 портовой не включиш канал. А если никто не смотрит канал ни один то соответственно не показывает ни один канал. Вот только 4 портовой второй нет проверить. Может конфиг не правильный на однопортовую онушку?!

Share this post


Link to post
Share on other sites

OLT работает в режиме proxy - проблем не знаем с multicast.

 

Есть опыт подключения к OLT "паровозом" еще один OLT или коммутатор, чтобы на подключеном устройстве тоже мультикаст работал?

Добрый день.

По заявлению от BDCOM, для того чтобы OLT работали паровозам необходимо использовать опцию ip mcst series-connection. Но данная опция не работает на OLT 3310B серии. Она полноценно работает только на 36ХХ серии.

Share this post


Link to post
Share on other sites

Каким образом реализовать MVR на оборудовании? Есть задача доставить и интернет и мультикаст по одной UTP. Либо запустить мультикаст в vlan с pppoe.

 

 

рабочий конфиг с DHCP, stalker, multicast:

 

!

interface GigaEthernet0/5

description --uplink--

switchport trunk vlan-untagged none

switchport mode trunk

switchport pvid 333

!

!

interface EPON0/1:1

onu-configuration

description Orehovaya_136

epon onu port 1 ctc vlan mode tag 1501

epon onu port 2 ctc vlan mode tag 720

epon onu port 3 ctc vlan mode tag 333

epon onu port 1 loopback detect

epon onu port 2 loopback detect

epon onu port 3 loopback detect

epon onu port 4 loopback detect

epon onu port 3 ctc mcst tag-stripe enable

epon onu port 3 ctc mcst mc-vlan add 666

!!onu-configuration-end

!

!

ip mcst enable

ip igmp-proxy enable

ip igmp-proxy last-member-query interval 3

ip mcst timer response-time 10

ip mcst series-connection

ip mcst mrouter interface GigaEthernet0/5

ip mcst mc-vlan 666 range 239.0.10.1 - 239.0.10.255

!

Edited by loschikatilos

Share this post


Link to post
Share on other sites

Каким образом реализовать MVR на оборудовании? Есть задача доставить и интернет и мультикаст по одной UTP. Либо запустить мультикаст в vlan с pppoe.

 

 

рабочий конфиг с DHCP, stalker, multicast:

 

!

interface GigaEthernet0/5

description --uplink--

switchport trunk vlan-untagged none

switchport mode trunk

switchport pvid 333

!

....

 

Добрый день.

Пример конфигурации, который вы привели, соответствует озвученной задаче, подать интернет и мультикаст по одному UTP. Подать все в одном vlan настоятельно не рекомендуется BDCOM.

Можете конкретизировать что именно у вас не получается?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this