Jump to content
Калькуляторы

BGP: настройка quagga как узнать на чьей стороне косяк

Поднимаю BGP на quagga, uplink KTTK

bgpd.conf

hostname AS58217

password ***

enable password ***

log file /var/log/quagga/bgpd.log

log stdout

 

debug bgp events

debug bgp updates

 

!

bgp multiple-instance

!

router bgp 58217

bgp router-id 195.206.122.254

network 193.41.93.0/24

network 195.206.122.0/23

 

bgp log-neighbor-changes

 

neighbor 80.72.237.33 remote-as 20870

neighbor 80.72.237.33 description UplinkKTTK

neighbor 80.72.237.33 next-hop-self

neighbor 80.72.237.33 soft-reconfiguration inbound

 

 

zebra.conf

hostname AS58217

password ***

enable password ***

log file /var/log/quagga/zebra.log

!

debug zebra events

debug zebra packet

!

 

interface eth1

ipv6 nd suppress-ra

 

 

interface eth2

ipv6 nd suppress-ra

!

 

 

!

 

ip route 10.0.0.0/8 Null0 254

ip route 172.16.0.0/12 Null0 254

ip route 192.168.0.0/16 Null0 254

 

!

ip forwarding

!

!

line vty

exec-timeout 0 0

 

 

KTTK у себя меня вроде как прописал

remarks: BELCOMSTROY

import: from AS58217 action pref=100; accept AS58217

export: to AS58217 announce ANY

 

Но сессия не поднимается, в логах

2014/09/13 13:04:40 BGP: Import timer expired.

2014/09/13 13:04:44 BGP: 80.72.237.33 [Event] Connect start to 80.72.237.33 fd 14

2014/09/13 13:04:44 BGP: 80.72.237.33 [Event] Connect failed (Operation now in progress)

2014/09/13 13:04:55 BGP: Import timer expired.

Share this post


Link to post
Share on other sites
Что скажет telnet 80.72.237.33 179 ?

telnet 80.72.237.33 179
Trying 80.72.237.33...
telnet: Unable to connect to remote host: Connection refused

 

 

ip ro get 80.72.237.33

ip route get 80.72.237.33
80.72.237.33 dev eth1  src 80.72.237.34 
   cache 

 

 

 

сделвйте дапм tcpdump-ом. может у вас фаервол режет

 

tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes
17:54:19.057456 IP (tos 0xc0, ttl 1, id 6857, offset 0, flags [DF], proto TCP (6), length 60)
   80.72.237.34.33959 > 80.72.237.33.bgp: Flags [s], cksum 0x7b03 (incorrect -> 0x6a46), seq 236137310, win 29200, options [mss 1460,sackOK,TS val 7483799 ecr 0,nop,wscale 7], length 0

Share this post


Link to post
Share on other sites

а .33 пигается?

Да, на этом же канале юзеры висят с ipшниками, ктр мне кттк выдал, сейчас вот решил bgp поднять.

Share this post


Link to post
Share on other sites

"Connection refused" - значит порт TCP 179 на маршрутизаторе КТТК либо закрыт, либо на нем не слушает никакой процесс. До Quagga дело даже не доходит. Не поднимается TCP-соединение.

Share this post


Link to post
Share on other sites

вообще, connection refused это странно, обычно это подразумевает наличие tcp-rst или icmp unreachable, но в дампе нет ни того, ни другого

Share this post


Link to post
Share on other sites

В общем в понедельник буду созваниваться с саппортом и буду уточнять у них.

Share this post


Link to post
Share on other sites

А аплинк вообще в курсе, что он с вами BGP-пиринг поднимает?

Share this post


Link to post
Share on other sites

Конечно знает )

https://apps.db.ripe.net/search/query.html?searchtext=AS20870&search%3AdoSearch=Search#resultsAnchor

remarks: BELCOMSTROY

import: from AS58217 action pref=100; accept AS58217

export: to AS58217 announce ANY

В пятницу созванивался с ними, спросил готово ли все и можно ли будет поднять в субботу, на что мне ответили, что все должно работать, но точно они сказать не могут.

Share this post


Link to post
Share on other sites

может быть дело в файрволе на локальной машине?

Share this post


Link to post
Share on other sites

Фаер я сразу потушил, да и если сделать telnet на порт 179 ip_моего второго шлюза в другом городе, то соединение проходит.

Share this post


Link to post
Share on other sites

Похоже на то, что у аплинка тупо кто-то забыл включить BGP.

Share this post


Link to post
Share on other sites

Скорее всего они не включили у себя BGP.

Но без tcpdump - это гадание на кофейной гуще.

Share this post


Link to post
Share on other sites

Скорее всего они не включили у себя BGP.

Но без tcpdump - это гадание на кофейной гуще.

 

 

Вот вывод Tcpdump

tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes
21:15:09.311670 IP (tos 0xc0, ttl 1, id 62685, offset 0, flags [DF], proto TCP (6), length 60)
   80.72.237.34.36110 > 80.72.237.33.bgp: Flags [s], cksum 0x7b03 (incorrect -> 0x3ab4), seq 2610574518, win 29200, options [mss 1460,sackOK,TS val 32096363 ecr 0,nop,wscale 7], length 0
21:15:09.316328 IP (tos 0x0, ttl 255, id 1463, offset 0, flags [none], proto TCP (6), length 40)
   80.72.237.33.bgp > 80.72.237.34.36110: Flags [R.], cksum 0xd6e8 (correct), seq 0, ack 2610574519, win 0, length 0

Share this post


Link to post
Share on other sites

ну вот теперь нормальный дамп. видно, что .33 шлёт tcp-reset (FLAGS R). этот вывод отправляйте в (?)ТТК. (?) потому что хз кто у них рулит региональными AS. я как-то решал проблему с каким-то локальным ТТК, но ответ приходил из МСК

Share this post


Link to post
Share on other sites

Всем спасибо, открыл утром тикет и через 20 минут все заработало

sh ip bgp neighbors

BGP neighbor is 80.72.237.33, remote AS 20870, local AS 58217, external link

Description: UplinkKTTK

BGP version 4, remote router ID 10.123.0.211

BGP state = Established, up for 00:04:53

Last read 00:00:00, hold time is 180, keepalive interval is 60 seconds

Neighbor capabilities:

4 Byte AS: advertised and received

Route refresh: advertised and received(old & new)

Address family IPv4 Unicast: advertised and received

Message statistics:

Inq depth is 0

Outq depth is 0

Sent Rcvd

Opens: 1 1

Notifications: 0 0

Updates: 1 85894

Keepalives: 6 1

Route Refresh: 0 0

Capability: 0 0

Total: 8 85896

Minimum time between advertisement runs is 30 seconds

 

Но не вижу свои префиксы извне , хотя

 

show ip bgp neighbor 80.72.237.33 advertised-routes

BGP table version is 0, local router ID is 195.206.122.254

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale, R Removed

Origin codes: i - IGP, e - EGP, ? - incomplete

 

Network Next Hop Metric LocPrf Weight Path

*> 193.41.93.0 80.72.237.34 0 32768 i

*> 195.206.122.0/23 80.72.237.34 0 32768 i

 

Edited by Tem

Share this post


Link to post
Share on other sites

Все пошло, нужно было просто подождать.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this