Jump to content
Калькуляторы

cacti + icmp

никто случаем не сталкивался с такой проблемой?

в cacti при добавлении хоста с пингом icmp вылазиет Ping Results ICMP Ping Success (3.510 ms) вроде все хорошо, но вот в списке устройств этот хост оказывается в дауне.

редактирование ping.php по вот этому примеру http://forum.synology.com/enu/viewtopic.php?f=39&t=78853 результатов не дали.

буду благодарен за помощь.

Share this post


Link to post
Share on other sites

для опроса, наверное, используется spine(нейтив опрашивалка), а прав на icmp/raw-сокеты ему не дали

Share this post


Link to post
Share on other sites

а можно подробнее про права для spine.

хотя с cmd тоже самое и проявляется это не на всех хостах

Share this post


Link to post
Share on other sites

так у вас cmd.php используется или spine?

 

если не на всех хостах, то проблема не в правах на spine, а просто нёх какой-то

 

права посмотреть ls -la `which spine`

Share this post


Link to post
Share on other sites

-rwxr-xr-x 1 root root 97344 окт. 21 2013 /usr/sbin/spine

 

используется spine

еще пробовали cmd там тоже самое

Share this post


Link to post
Share on other sites

странно, что у вас нет chmod +s на spine. вы его от рута/через sudo чтоли запускаете?

Share this post


Link to post
Share on other sites

нет, но из коммандной строки все замечательно пингуется

Edited by dimokrzn

Share this post


Link to post
Share on other sites

ИМХО арп протухает.

 

Как вы быстро меняете показания :) Ну если нет, то надо искать дальше.

Share this post


Link to post
Share on other sites

ping требует прав рута. под каким пользвателем у вас отрабатывает php в вебе и spine ? по хорошему ICMP пинг ни там ни там работать не должны, нехрен ему под рутом жить.. (команда ping работает не из под рута так как там стоит SUID бит. если его снять то рабоать не будет, но в cacti пинг реализован на php) Поменяйте тип пинга на UDP и укажите какойнить порт.

Share this post


Link to post
Share on other sites

большое спасибо. отличное решение оказалось. поставил udp на порт 1 и с состоянием в devices все в порядке

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this