Jump to content
Калькуляторы

Cisco 3750G vs D-LINK Undersize frames! Или почему я ненавижу Кошек часть 2-ая!

Имеем С3750G-24TS разруливает VLAN приходящие с разных мест. Так вот на портах подключенных к коммутаторам DLINK накапливается счётчик Undersize frames (тобишь фреймы меньше 64-байт). Покопавшись в сети нашёл что проблема имело место быть на старых IOS на транк портах. IOS у меня 12.2(55) предпоследний выпуск для данной модели.

 

Пробовал опять же по советом и сети менять дуплекс... не помогает... даже снижение до 100 не помогает.

 

Соединение медь экранированная длинна 1 метр.

 

У кого какие размышления по этому поводу?

 

 

Вот вывод с порта, после сброса счётчиков не прошло пары минут уже 302 Undersize frames. Все остальные счётчики ошибок по нулям.

GigabitEthernet1/0/23 is up, line protocol is up (connected)
 Hardware is Gigabit Ethernet, address is 0012.0172.f597 (bia 0012.0172.f597)
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    reliability 255/255, txload 14/255, rxload 2/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
 input flow-control is off, output flow-control is unsupported
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output 00:00:01, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 9205000 bits/sec, 5277 packets/sec
 5 minute output rate 55802000 bits/sec, 6633 packets/sec
    1679536266 packets input, 477212314992 bytes, 0 no buffer
    Received 6110156 broadcasts (394477 multicasts)
    3 runts, 0 giants, 0 throttles
    3 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 394477 multicast, 0 pause input
    0 input packets with dribble condition detected
    1975603167 packets output, 1968975744987 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out

    Transmit GigabitEthernet1/0/23           Receive
  3013072234 Bytes                       1141350215 Bytes
     6927982 Unicast frames                 5590827 Unicast frames
       55758 Multicast frames                   993 Multicast frames
        5153 Broadcast frames                 14468 Broadcast frames
           0 Too old frames              1117870083 Unicast bytes
           0 Deferred frames                  92992 Multicast bytes
           0 MTU exceeded frames             942632 Broadcast bytes
           0 1 collision frames                   0 Alignment errors
           0 2 collision frames                   0 FCS errors
           0 3 collision frames                   0 Oversize frames
           0 4 collision frames                 302 Undersize frames
           0 5 collision frames                   0 Collision fragments
           0 6 collision frames
           0 7 collision frames                 288 Minimum size frames
           0 8 collision frames             4587321 65 to 127 byte frames
           0 9 collision frames              358617 128 to 255 byte frames
           0 10 collision frames             123550 256 to 511 byte frames
           0 11 collision frames              77738 512 to 1023 byte frames
           0 12 collision frames             365507 1024 to 1518 byte frames
           0 13 collision frames                  0 Overrun frames
           0 14 collision frames                  0 Pause frames
           0 15 collision frames
           0 Excessive collisions                 0 Symbol error frames
           0 Late collisions                      0 Invalid frames, too large
           0 VLAN discard frames              93569 Valid frames, too large
           0 Excess defer frames                  0 Invalid frames, too small
         153 64 byte frames                       0 Valid frames, too small
     1430531 127 byte frames
      541870 255 byte frames                      0 Too old frames
      228021 511 byte frames                      0 Valid oversize frames
      173451 1023 byte frames                     0 System FCS error frames
     1137397 1518 byte frames                     0 RxPortFifoFull drop frame
     3477470 Too large frames
           0 Good (1 coll) frames
           0 Good (>1 coll) frames

Share this post


Link to post
Share on other sites

пардон за каламбур, но не смог удержаться....

 

"почему я ненавижу d-link часть 100500-я"

мое размышление таково:

г*вённый длинк шлёт какой-то шлак циске, и циске это не особо нравится...кому ж понравится, когда шлак сыпется...

Share this post


Link to post
Share on other sites

Это всё лирика коллега тем паче что 3612G не такой уж и говёный )

 

Офтопик: моя ненависть к кошкам немного поутихла после обнаружения Циско Нетворк Асистанс, теперь базовые настройки любого кошака уже не стирают мои мальцы в кровь )))

Офтопик2: но ненависть снова вернулось после изучения логики настройки VLAN, не отключаемый Нативный VLAN это взрыв мозга!

Share this post


Link to post
Share on other sites

А что за D-Link ? У меня кошки такие и подобные с D-Link дружат (DES-3200, DGS-3120, DES-1210-28/ME/B2), на большинстве 12.2(53)SE2.

Share this post


Link to post
Share on other sites

А что за D-Link ? У меня кошки такие и подобные с D-Link дружат (DES-3200, DGS-3120, DES-1210-28/ME/B2), на большинстве 12.2(53)SE2.

 

Таки я не спорю что дружат, проблем незамеченно (точнее одна есть но не факт что она с этим связанна), но как бы спать не даёт растущий счётчик ) DGS-3612G.

Share this post


Link to post
Share on other sites

А jumbo включен?

 

Таки Джумбо это наоборот большие кадры, а Кошка ругается что кадры слишком маленькие. Но в любом случае сегодня гляну.

Share this post


Link to post
Share on other sites

Мне бы спать не давало само существование DGS-3612G на сети :D

Я бы еще не поленился попробовать махнуть физику между железками. Одно время часто сталкивался, когда говеный китай не хотел прогонять пакеты, если мту было больше стандартного хотя бы на 4 байта. Правда, в случае с большими пакетами, щелкать начинает счетчик overrun. После замены SFP с двух сторон, проблема полностью исчезала.

Не уверен, что такая же проблема будет актуальной и для мелких пакетов, но чем черт не шутит, махните физику.

Share this post


Link to post
Share on other sites

Мне бы спать не давало само существование DGS-3612G на сети :D

Я бы еще не поленился попробовать махнуть физику между железками. Одно время часто сталкивался, когда говеный китай не хотел прогонять пакеты, если мту было больше стандартного хотя бы на 4 байта. Правда, в случае с большими пакетами, щелкать начинает счетчик overrun. После замены SFP с двух сторон, проблема полностью исчезала.

Не уверен, что такая же проблема будет актуальной и для мелких пакетов, но чем черт не шутит, махните физику.

 

Медью законекчено ) Читал мнение что проблема решается переходом на SFP, сижу думаю...

Share this post


Link to post
Share on other sites

Так что с jumbo?

 

На D-link были включены, выключил, как и ожидалось эффекта НОЛЬ! Счётчик плодится и размножается.

Share this post


Link to post
Share on other sites

cdp? loop detection? сдампите трафик, хоть будет видно, что там такое красивое.

Share this post


Link to post
Share on other sites

CDP OFF. LOOP DETECTION OFF. По поводу сдампить попробую.

Share this post


Link to post
Share on other sites

Офтопик2: но ненависть снова вернулось после изучения логики настройки VLAN, не отключаемый Нативный VLAN это взрыв мозга!

 

Про нативный влан можно подробнее ? Что в вашем понимании означает "не отключаемый" и покажите ваш типовой конфиг порта с неотключаемым нативным вланом.

 

Про счётчики: действительно, попробуйте смиррорить трафик и сниффером разобрать. Вдруг всё и увидите. Может быть это какой-нибудь длинковский протокол окажется илитам lldp или ещё какая хрень, которую забыли выключить.

Share this post


Link to post
Share on other sites

Офтопик2: но ненависть снова вернулось после изучения логики настройки VLAN, не отключаемый Нативный VLAN это взрыв мозга!

 

Про нативный влан можно подробнее ? Что в вашем понимании означает "не отключаемый" и покажите ваш типовой конфиг порта с неотключаемым нативным вланом.

 

Я поржал с "неотключаемого" влана.

Кто-то как всегда инструкции читает ПОСЛЕ а не ДО.

 

В данном конкретном случае ненавидить надо уровень собственных знаний и лень, а не кошек.

 

Про "стертые в кровь пальцы" тоже эпично. Типовые конфигурации цисок настраиваются банальным копипастом из текстовика в cli. В разы быстрее гуйни от длинков.

Edited by myst

Share this post


Link to post
Share on other sites

Про "стертые в кровь пальцы" тоже эпично. Типовые конфигурации цисок настраиваются банальным копипастом из текстовика в cli. В разы быстрее гуйни от длинков.

 

copy tftp startup еще быстрее :)

Share this post


Link to post
Share on other sites

Офтопик2: но ненависть снова вернулось после изучения логики настройки VLAN, не отключаемый Нативный VLAN это взрыв мозга!

 

Про нативный влан можно подробнее ? Что в вашем понимании означает "не отключаемый" и покажите ваш типовой конфиг порта с неотключаемым нативным вланом.

 

Я поржал с "неотключаемого" влана.

Кто-то как всегда инструкции читает ПОСЛЕ а не ДО.

 

В данном конкретном случае ненавидить надо уровень собственных знаний и лень, а не кошек.

 

Ну порадуйте старика молодёжь, расскажите куда попадает не тегированный трафик в транк порту? И как запретить его попадание туда?

 

Про "стертые в кровь пальцы" тоже эпично. Типовые конфигурации цисок настраиваются банальным копипастом из текстовика в cli. В разы быстрее гуйни от длинков.

 

Вы такой смешной, а кто сказал про типовые конфигурации?

Edited by Pritorius

Share this post


Link to post
Share on other sites

Офтопик2: но ненависть снова вернулось после изучения логики настройки VLAN, не отключаемый Нативный VLAN это взрыв мозга!

 

Про нативный влан можно подробнее ? Что в вашем понимании означает "не отключаемый" и покажите ваш типовой конфиг порта с неотключаемым нативным вланом.

 

Я поржал с "неотключаемого" влана.

Кто-то как всегда инструкции читает ПОСЛЕ а не ДО.

 

В данном конкретном случае ненавидить надо уровень собственных знаний и лень, а не кошек.

 

Ну порадуйте старика молодёжь, расскажите куда попадает не тегированный трафик в транк порту? И как запретить его попадание туда?

Никуда он не попадает. ЕМИНП. Если на порту не указан нэйтив.

 

Вы такой смешной, а кто сказал про типовые конфигурации?

Да потому что коммутаторы это в основном типовые конфигурации с типовой же настройкой портов.

Если нужно что-то не типовое, это точно так же решается блокнотом и банальным копипастом.

Edited by myst

Share this post


Link to post
Share on other sites

Про "стертые в кровь пальцы" тоже эпично. Типовые конфигурации цисок настраиваются банальным копипастом из текстовика в cli. В разы быстрее гуйни от длинков.

 

copy tftp startup еще быстрее :)

 

Ну если на то пошло, Browse - Upload это всего два клика мышкой, вместо 17 нажатий на клавиатуру и вбивание имени фала ))))))))))

Share this post


Link to post
Share on other sites

Ну порадуйте старика молодёжь, расскажите куда попадает не тегированный трафик в транк порту? И как запретить его попадание туда?

 

int gX/Y

switchport trunk allowed vlan remove 1

!

 

если хочется совсем бронебойная конструкция (на случай если дефолтные значения перебиты, например)

int gX/Y

switchport trunk native vlan tag

swtichport trunk native vlan 1

switchport trunk allowed vlan remove 1

!

Share this post


Link to post
Share on other sites

Офтопик2: но ненависть снова вернулось после изучения логики настройки VLAN, не отключаемый Нативный VLAN это взрыв мозга!

 

Про нативный влан можно подробнее ? Что в вашем понимании означает "не отключаемый" и покажите ваш типовой конфиг порта с неотключаемым нативным вланом.

 

Я поржал с "неотключаемого" влана.

Кто-то как всегда инструкции читает ПОСЛЕ а не ДО.

 

В данном конкретном случае ненавидить надо уровень собственных знаний и лень, а не кошек.

 

Ну порадуйте старика молодёжь, расскажите куда попадает не тегированный трафик в транк порту? И как запретить его попадание туда?

Никуда он не попадает. ЕМИНП. Если на порту не указан нэйтив.

 

Если мне память не изменяет если неуказать Нитив то попадать будет в 1.

Share this post


Link to post
Share on other sites

В порядке оффтопа - а stp петли вы тоже на dlinke из gui разруливаете? или cli dlinkа круче чем у cisco?

Share this post


Link to post
Share on other sites

Ну порадуйте старика молодёжь, расскажите куда попадает не тегированный трафик в транк порту? И как запретить его попадание туда?

 

int gX/Y

switchport trunk allowed vlan remove 1

!

 

если хочется совсем бронебойная конструкция (на случай если дефолтные значения перебиты, например)

int gX/Y

switchport trunk native vlan tag

swtichport trunk native vlan 1

switchport trunk allowed vlan remove 1

!

 

Да ладно )))))) Теперь два порта с такой конфигурацией соедините петлёй ))))

 

В порядке оффтопа - а stp петли вы тоже на dlinke из gui разруливаете? или cli dlinkа круче чем у cisco?

 

НЕ передёргивайте мои фразы, я сказал то что сказал и не болеее того. В cli длинк заползаю только если чего-то нет в GUI но как ту молодёжь сказала для "типовых конфигураций" в GUI есть всё )))))))))

Share this post


Link to post
Share on other sites

Да ладно )))))) Теперь два порта с такой конфигурацией соедините петлёй ))))

и? ничего не произойдет, линк поднимется.

Share this post


Link to post
Share on other sites

Да не, оно в первый влан итак не попадает

 

test_s1(config)#
vlan 100
test_s1(config)#int vlan 1
test_s1(config-if)#ip address 10.10.10.1 255.255.255.0
test_s1(config)#do sh run int gi 2/0/2
Current configuration : 213 bytes
!
interface GigabitEthernet2/0/2
description # test_s2 PO2 gi 2/0/2 #
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100
switchport mode trunk
channel-group 2 mode active
end

test_s2(config)#
vlan 100
test_s2(config)#int vlan 1
test_s2(config-if)#ip address 10.10.10.2 255.255.255.0
test_s2(config)#do sh run int gi 2/0/2
Current configuration : 213 bytes
!
interface GigabitEthernet2/0/2
description # test_s1 PO2 gi 2/0/2 #
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100
switchport mode trunk
channel-group 2 mode active
end

 

test_s1#ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)

Ради интереса глянул на стенде.

 

Опять кто-то ниасилил документацию. =)))

Edited by myst

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this