Jump to content
Калькуляторы

link agregation. cisco + dlink

Загнулся порт-канал между циской и длинком.

Не поднимается. На циске порты горят желтым. Вывожу их из портканала - 3 из 4х портов загораются зеленым.

Смотрю в это время на длинке в порт-0канале показывает активным как раз тот порт.

 

Конфиги:

 

cisco

interface Port-channel1
switchport access vlan 100
switchport mode access

interface GigabitEthernet1/0/15
switchport access vlan 100
switchport mode access
mls qos cos 4
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/16
switchport access vlan 100
switchport mode access
mls qos cos 4
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/17
switchport access vlan 100
switchport mode access
mls qos cos 4
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/18
switchport access vlan 100
switchport mode access
mls qos cos 4
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active

 

dlink:

 

Command: show link_aggregation

Link Aggregation Algorithm = MAC-destination

Group ID      : 1
Type          : LACP
Master Port   : 3
Member Port   : 3-6
Active Port   : 3-6
Status        : Enabled
Flooding Port : 3

Total Entries : 1

Command: show lacp_ports


Port     Activity

-----    --------
1        Passive 
2        Passive 
3        Active  
4        Active  
5        Active  
6        Active  
7        Passive 
8        Passive 
9        Passive 
10       Passive 

Share this post


Link to post
Share on other sites

des-3200 rev/A использую 4 100мбит порта

cisco 3750G

Share this post


Link to post
Share on other sites

Попробуйте на длинке pvid прописать реально существующего на коммутаторе влана

Share this post


Link to post
Share on other sites

Прописан. Картина такая.

uplink(tagged vlan752, vlan 735) ---> 10 port dlink

3,4,5,6 порты dlink vlan752 untagged <-----> 15,16,17,18 ports cisco access vlan100 (untagged)

 

А началось все довольно-таки при странновато.

За аплинком вышестоящий менял оборудование. Возможно меняли/путали вланы, тем не менее все вланы вернули. Т.е. картина та же, только на новом оборудование. У нас ничего не изменилось, но port-chanel упал и не поднимается.

Share this post


Link to post
Share on other sites

Попробуйте на кошке `channel-group 1 mode passive` на всех портах, на длинке - всё как есть оставьте. По крайней мере у себя я везде именно так настраиваю, с активным lacp с обоих сторон были проблемы в своё время, но подробностей увы не помню

Share this post


Link to post
Share on other sites

Попробуйте на кошке `channel-group 1 mode passive` на всех портах, на длинке - всё как есть оставьте. По крайней мере у себя я везде именно так настраиваю, с активным lacp с обоих сторон были проблемы в своё время, но подробностей увы не помню

Сейчас попробую. Но изначально на длинке был passive на циске active.

Share this post


Link to post
Share on other sites

Wingman, и всё же, по рекомендации длинка active на cisco, passive на длинке.

 

http://www.dlink.ru/ru/faq/62/250.html

Там есть особенность построения между D-Link и Cisco.

Не помогло.

Share this post


Link to post
Share on other sites

а в sh int status порты не suspended случаем?

я б начал с

int range g1/0/15-18

no mls qos cos 4

no mls qos trust dscp

Share this post


Link to post
Share on other sites

Wingman, и всё же, по рекомендации длинка active на cisco, passive на длинке.

Воля ваша.

 

Выставьте на портах с обоих сторон скорость и дуплекс принудительно; даже если не поможет в данном случае - лучше всегда так делать.

Share this post


Link to post
Share on other sites

а в sh int status порты не suspended случаем?

Gi1/0/15                     connected    100        a-full  a-100 10/100/1000BaseTX
Gi1/0/16                     connected    100        a-full  a-100 10/100/1000BaseTX
Gi1/0/17                     connected    100        a-full  a-100 10/100/1000BaseTX
Gi1/0/18                     connected    100        a-full  a-100 10/100/1000BaseTX

 

int range g1/0/15-18

no mls qos cos 4

no mls qos trust dscp

 

Начал.

 

И еще. у меня port-channel access vlan 100 и каждый из портов портканала в vlan 100.

 

Правильно завести только порт-канал, только поты или и то и то?

Share this post


Link to post
Share on other sites

Правильно завести только порт-канал, только поты или и то и то?

если с нуля, обычно делаю так:

conf t

default int range GiX/Y/Z - GiX/Y/ZZ

int range GiX/Y/Z - GiX/Y/ZZ

channel-group 1 mode ...

опционально channel-protocol (если lacp)

int port-channel 1

и уже тут все настраиваю

Share this post


Link to post
Share on other sites

Не помню как делал.

Переделал по новой. Циска сама завела каждый из портов в vlan 100.

 

*Aug 28 01:26:56.786: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
*Aug 28 01:26:56.904: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk Port-channel1 VLAN100.
*Aug 28 01:26:56.904: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking Port-channel1 on VLAN0100. Inconsistent port type.

Почему vlan0100 не пойму.

 

BPDU protection и stp на длинке в disable

Share this post


Link to post
Share on other sites

Received 802.1Q BPDU on non trunk Port-channel1 VLAN100.

 

conf t

int port-c1

switchport trunk enca dot1q

switchport trunk native vlan 100

switchport mode trunk

 

у вас по ту сторону длинка стоит еще одна циска, у которой 100й влан идет как native, и с нее прилетает сквозь длинк bpdu

Share this post


Link to post
Share on other sites

darkagent, о как! Порт-канал завелся, но по ту сторону не 100 vlan, а vlan752, потому пинга до железки в vlan752 нет.

 

может можно зарезать BPDU на длинке?

Share this post


Link to post
Share on other sites

darkagent, о как! Порт-канал завелся, но по ту сторону не 100 vlan, а vlan752, потому пинга до железки в vlan752 нет.

 

может можно зарезать BPDU на длинке?

Это где влан752 то?

Может схемку нарисуете.

Share this post


Link to post
Share on other sites

darkagent, Бог!

Громаднейшее спасибо и низкий поклон!

Всегда знал, что Вы гений!

 

Это где влан752 то?

Может схемку нарисуете.

tag vlan 752 ---> port 10 (Dlink) port 3,4,5,6 (lacp) vlan 752 untag <---> port 15,16,17,18 (lacp) untag vlan100 (cisco)

 

приходит влан 752 на аплинке и конвертируется в влан100 в локалке.

Share this post


Link to post
Share on other sites

Выставьте на портах с обоих сторон скорость и дуплекс принудительно; даже если не поможет в данном случае - лучше всегда так делать.

Пробовал. Всегда и везде?

Share this post


Link to post
Share on other sites

tag vlan 752 ---> port 10 (Dlink) port 3,4,5,6 (lacp) vlan 752 untag <---> port 15,16,17,18 (lacp) untag vlan100 (cisco)

 

приходит влан 752 на аплинке и конвертируется в влан100 в локалке.

А конвертировать то обязательно?

Странно что предыдущий вариант не заработал(native vlan 100) - натив влан то должен не тэгированным ходить и на длинке он у вас не тэгированный.

Если память не изменяет - для bpdufilter киска предупреждает что при старте системы несколько пакетов всё же пройдут.

На сайте длинка как то встречал пример настройки фильтра на pvst bpdu - чтоб их длинк дропал совсем. Тема вроде была - MST между длинк и киско.

Кстати, если настроить на длинке фильтр то имеет смысл ваш каталист перевести с pvst на mst.

Share this post


Link to post
Share on other sites

Выставьте на портах с обоих сторон скорость и дуплекс принудительно; даже если не поможет в данном случае - лучше всегда так делать.

Пробовал. Всегда и везде?

Крайне желательно, особенно почему-то с кошками, помогает избежать непонятной уличной магии с неподнятием портов или поднятием только с одной стороны :)

Share this post


Link to post
Share on other sites

Если память не изменяет - для bpdufilter киска предупреждает что при старте системы несколько пакетов всё же пройдут.

Нет так часто она ребутится. Главное, чтобы потом поднялся порт-канал.

 

На сайте длинка как то встречал пример настройки фильтра на pvst bpdu - чтоб их длинк дропал совсем. Тема вроде была - MST между длинк и киско.

Кстати, если настроить на длинке фильтр то имеет смысл ваш каталист перевести с pvst на mst.

Ок. Спасибо. Поищу...

Спасибо.

Крайне желательно, особенно почему-то с кошками, помогает избежать непонятной уличной магии с неподнятием портов или поднятием только с одной стороны :)

Share this post


Link to post
Share on other sites

Крайне желательно, особенно почему-то с кошками, помогает избежать непонятной уличной магии с неподнятием портов или поднятием только с одной стороны :)

По моему опыту - как раз наоборот, без negotiation часто поднимается только с одной стороны.

А вот тот же Brocade, например, рекомендует включать negotiation; даже называет как-то по-своему - типа failure notification, во как.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this