Jump to content
Калькуляторы

Cisco ASR 901

Хеллоу,

 

Имеется ли у кого-то cisco ASR 901? Интересует производительность pps/Mbps/cpu.

 

 

Спасибо.

Share this post


Link to post
Share on other sites

в пути с полсотни таких девайсов с различным фаршом, ожидаем где-то к марту. как приедут, попробую краткий обзор сделать по ним.

Share this post


Link to post
Share on other sites

Ну а какие то предположения имеете? Какую роль у бас они будут играть? Так как цыска планировала, на мобильных вышках?

Share this post


Link to post
Share on other sites

Там довольно жесткие ограничения по кол-ву svi и префиксов, и нет ни слова о возможности использовать RIPv1/v2. зато mpls + e1 + 10g и пачкой 1g в 1U с очень низким энергопотреблением, вполне пригодно для БС.

Share this post


Link to post
Share on other sites

Там довольно жесткие ограничения по кол-ву svi и префиксов

Нука-нука где вы увидели про svi? Сколько их там может быть? Про роутинг как я понимаю там - IPv4 Routes - 12K, BGP peers - 100, Number of VRF - 128

RIP меня не интересует, только BGP i OSPF

Edited by edgars

Share this post


Link to post
Share on other sites

Да, тоже нашёл это. 250 звучит стрёмно, но должно хватить на пару лет :)

Share this post


Link to post
Share on other sites

Ну вот и март на дворе!

Darkagent ASR901 не появились? :))

Share this post


Link to post
Share on other sites

Итак, прибыло.

первые впечатления - синтаксис комманд больше похож на классическую 7600, нежели аср9к.

команды switchport и все что с ними связано на интерфейсах пока не понимает, но по ? отображает.

нумерация портов типичная: G0/1-G0/24 + Te0/1+ Te0/2; дает поднимать вланы как интерфейсы (svi), но пока разбираемся как это дело прибить к физике (т.к. switchport не катит).

Работа по субинтерфейсам аналогична всяким 2851/7201 и прочим. router rip понимает, но работоспособность пока не щупали. Сейчас будем пробовать вдуть в него вагон mpls меток, чтоб посмотреть что с ним будет после превышения лимитов.

p.s. ток ток распаковали, потому еще даже толком не успели пощупать.

По габаритам вобще красавец - меньше обычных DES-длинков в глубину.

 

http://s020.radikal.ru/i700/1303/9d/2a3605414966.jpg

http://s019.radikal.ru/i602/1303/8e/dd8e72b0860f.jpg

Share this post


Link to post
Share on other sites

Попробуйте прогнать какой-то трафик, сколько может вытянуть. Работа по субинтерфейсам аналогична всяким 2851 - это гуд! RIP не волнует, нету его у нас, только BGP/OSPF

У вас питание 220? Как я понял то железка имеет только 48.

Габариты я видел, и потрогал руками тоже :)

Share this post


Link to post
Share on other sites

У нас пришла партия и на 220V и на 48V (сборную солянку под все нужды брали, в том числе с E1, 10G и прочим). На фотках модель на 220V

Share this post


Link to post
Share on other sites

Ну и как там? :)

+1

Очень интересно что же за девайсы?

Share this post


Link to post
Share on other sites

подводный камень - все повязано на лицензиях.

 

связка svi с физикой делается через service instance:

interface TenGigabitEthernet0/0

cdp enable

service instance 10 ethernet

encapsulation untagged

bridge-domain 100

!

service instance 20 ethernet

encapsulation dot1q 101

bridge-domain 101

!

!

 

interface Vlan100

mtu 1548

ip address 10.1.1.2 255.255.255.252

no ip redirects

no ip proxy-arp

ip mtu 1500

ip ospf authentication message-digest

ip ospf network point-to-point

mpls ip

mpls mtu 1524

!

 

interface Vlan101

ip address 10.100.1.5 255.255.255.252

no ip redirects

no ip proxy-arp

!

...

секции router настраиваются классическим образом.

ip prefix-list привычного для ios формата

 

erps не умеет (походу его среди кошек только asr9000 и умеет)

rep, pvst/rapid-pvst/mst все как у обычных каталюг

 

тунели обещает строить любые

asr901_t1(config-if)#tunnel mode ?

aurp AURP TunnelTalk AppleTalk encapsulation

cayman Cayman TunnelTalk AppleTalk encapsulation

dvmrp DVMRP multicast tunnel

eon EON compatible CLNS tunnel

gre generic route encapsulation protocol

ipip IP over IP encapsulation

ipsec IPSec tunnel encapsulation

iptalk Apple IPTalk encapsulation

ipv6 Generic packet tunneling in IPv6

ipv6ip IPv6 over IP encapsulation

mpls MPLS encapsulations

nos IP over IP encapsulation (KA9Q/NOS compatible)

rbscp RBSCP in IP tunnel

 

но пока руки не дошли проверить.

asn32 умеет.

 

mpls пустили, но полным вдувательством пока не занимались:

asr901_t1# sh mpls memory

Allocator-Name In-use/Allocated Count

----------------------------------------------------------------------------

LDP: Cap Block : 224/3052 ( 7%) [ 7] Chunk

LDP: Cap CCB Block : 84/3052 ( 2%) [ 3] Chunk

LDP: Cap LCB Block : 48/5052 ( 0%) [ 1] Chunk

LDP: LCON peer : 300/352 ( 85%) [ 1]

LDP: LCON peer uid table : 116/168 ( 69%) [ 1]

LDP: LDP LSR addrinf : 11448/15260 ( 75%) [ 318] Chunk

LDP: LDP Message TLV Indi : 0/1764 ( 0%) [ 0] Chunk

LDP: LDP Session DB Entry : 44/1552 ( 2%) [ 1] Chunk

LDP: LDP TCB info : 36/1164 ( 3%) [ 1] Chunk

LDP: LDP adjacency : 184/236 ( 77%) [ 1]

LDP: LDP context block : 332/384 ( 86%) [ 1]

LDP: LDP interface : 32/84 ( 38%) [ 1]

LDP: LDP peer addrinf : 12720/15964 ( 79%) [ 318] Chunk

LDP: LDP ptcl adj : 280/332 ( 84%) [ 1]

LDP: LDP swidb : 104/156 ( 66%) [ 1]

LDP: LIB RB binding array : 831080/1167780 ( 71%) [ 6475]

LDP: LIB RB binding info : 159024/495724 ( 32%) [ 6475]

LDP: LIB adv bmap : 160904/497604 ( 32%) [ 6475]

LDP: LIB prev label info : 100/152 ( 65%) [ 1]

LDP: SAL - Default : 612/1392 ( 43%) [ 15]

LDP: TDP large PIE chunk : 0/65588 ( 0%) [ 0] Chunk

 

кстати, на момент выполнения этой команды процу поплохело:

CPU utilization for five seconds: 30%/0%; one minute: 31%; five minutes: 19%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

5 1335096 238784 5591 14.71% 2.13% 1.55% 0 Check heaps

 

164 45608 10749 4242 2.63% 15.99% 4.90% 3 Virtual Exec

 

59 1550376 569366 2722 2.47% 1.97% 1.91% 0 bcmCNTR.0

 

58 1410860 524386 2690 1.91% 1.86% 1.87% 0 Per-Second Jobs

 

118 108 140 771 1.75% 0.14% 0.02% 4 Virtual Exec

 

9999999999777771111111111 111111111111111 1111122222

777777777733333333335555588888555553333366666888886666622222

100 **********

90 **********

80 **********

70 ***************

60 ***************

50 ***************

40 ***************

30 ***************

20 *************** ***** ***** ***** ********

10 **********************************************************

0....5....1....1....2....2....3....3....4....4....5....5....6

0 5 0 5 0 5 0 5 0 5 0

CPU% per second (last 60 seconds)

 

трафик через железку пока не бегает, поэтому пока не совсем ясно, насколько нормальна волна "10-20%" загрузки проца в моменты простоя.

 

ну и конфигурация подопытного:

License Level: AdvancedMetroIPAccess

License Type: Permanent

Next reload license Level: AdvancedMetroIPAccess

 

Cisco A901-6CZ-F-A (P2020) processor (revision 1.0) with 393216K/131072K bytes of memory.

Processor board ID CAT1651U04U

P2020 CPU at 800MHz, E500v2 core, 512KB L2 Cache

1 FastEthernet interface

12 Gigabit Ethernet interfaces

2 Ten Gigabit Ethernet interfaces

1 terminal line

256K bytes of non-volatile configuration memory.

98304K bytes of processor board System flash (Read/Write)

65536K bytes of processor board RAM Disk (Read/Write)

 

как видим - проц слабоват, памяти маловато. боюсь, это скорее свитч, нежели роутер.

 

когда проц вскочил до 100%, пинг до железе не прерывался и держался ровненько. control-plane не настраивали.

p.s. в углубленное ковыряние пока не ушли, рабочей текучки хватает.

 

еще один момент - 10G порты без активированной 10gigUpgrade лицензии работают как обычные 1G/SFP, порты умеют работать в SyncE. мобильщики ликуют.

 

Честно и откровенно - asr901 полный аналог экстримовскому E4G (200/400). Они даже имеют схожий порядок цен.

Edited by darkagent

Share this post


Link to post
Share on other sites

"P2020" навевает на мысли что там внутри в качестве проца Freescale QorIQ P2020.

 

Кстати, ктонибудь сравнивал ТТХ с ALu 7705 и Jun ACX1x00 ?

Share this post


Link to post
Share on other sites

не шибко разбираюсь в тонкостях чипсетов, но судя по датащиту, не такой уж и ватненький этот проц со всеми его шифрованиями и прочими свистелками.

Share this post


Link to post
Share on other sites

Так системный CPU в data-plane не участвует кроме как, он end-point для обработки пакетов маршрутизации, и.т.п. и производительность его не так важна в целом.

Share this post


Link to post
Share on other sites

Посмотрел этот P2020 он вроде должен быть dual core 1.2ghz а тут 800mhz, как то не понятно. Ну это как бы и не напрягает.

Лицензия Advanced Metro IP License по GPL всего лишь 900$

10G пока не интересуют. Вот пугает - "боюсь, это скорее свитч, нежели роутер". Хотя нам то только ospf/bgp ну и ждём появления vpls.

 

Как про extreme, так вообще ничего не знаю, у нас это в статусе диковинки. А как он себя показал на практике?:)

 

Конфигурация после разных ISR кажется странной, надо будет разбератся.

Share this post


Link to post
Share on other sites

Несколько фактов по ASR901:

 

- Каждый новый IPv6 маршрут будет уменьшать количество доступных IPv4 маршрутов на два.

- очень мало памяти для поглощения burst-ов трафика (около 3 ms)

- 1588 transparent clock не поддерживается, что важно для фазовой синхронизации LTE баз

- архитектура основана на стандартном ethernet switch-e 5-ти летней давности от Broadcom (Enduro BCM56333 или BCM56334)

- поддержка PoE только на AC системах (901S)

- OAM software-based

 

Продукт позиционируется для мобильного бэкхола. Сильно лучше конкурентов не выглядет.

Edited by JoeDoe

Share this post


Link to post
Share on other sites

сколько MPLS меток на нём можно заPUSH'ить ?

Share this post


Link to post
Share on other sites

asr901_t1#sh mpls la ra

Downstream Generic label region: Min/Max label: 16/8191

 

при вдувании сверх лимитов, ему плохеет, но все лишнее можно гнать через префикс-лист или через хост-роуты

asr901_t1(config-ldp-lbl)#allocate global ?

host-routes allocate local label for host routes only

prefix-list Specify a prefix list for local label filtering

<cr>

 

из печального: stp / pvst не умеет, только mst. об этом кстати в конф-гиде указано, но мы же лентяи ))

Share this post


Link to post
Share on other sites

ну мст с одним инстансом волшебным образом превращается в классический rstp

Share this post


Link to post
Share on other sites

там такое порево с ограничениями, что лучше вобще забыть про все эти stp

http://www.cisco.com/en/US/docs/wireless/asr_901/Configuration/Guide/mstp.html#wp1127891

 

Кстати, в том же конф-гиде заявлено: The maximum number of LDP labels supported in Cisco ASR 901router is 4000.

Незнаю для какой конкретно железки эта цифра актуально, но в нашем случае циферка в 2 раза больше получается. В доках найти упоминаний об этом ограничении больше не удалось.

 

особенность навешивания полиси мапов:

policy-map Shape10M

class class-default

shape average 10000000

policy-map Police10M

class class-default

police rate 10000000

exceed-action transmit

violate-action drop

!

 

interface TenGigabitEthernet0/0

service instance 30 ethernet

encapsulation dot1q 30

service-policy input Police10M

service-policy output Shape10M

!

!

 

работает только так. вешать на int vlan XX не дает никак:

%QOS-6-POLICY_INST_FAILED: Service policy installation failed

 

умеет работать с qinq svi:

interface GigabitEthernet0/1

negotiation auto

ethernet dot1ad nni

service instance 35 ethernet

encapsulation dot1ad 35 dot1q 1000

rewrite ingress tag pop 1 symmetric --- без этой команды следующую не ест (Do not support this encapsulation and no rewrite combination for Unknown.)

bridge-domain 1000

!

end

 

interface Vlan1000

ip address 192.168.71.254 255.255.255.0

end

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this