Jump to content
Калькуляторы

Как бы подружить PBR и BGP? ;)

Cat4900M cat4500e-entservicesk9-mz.122-54.SG.bin

 

===

!

interface Loopback0

description Main IP Pool

ip address 2.2.2.2 255.255.255.0 secondary

ip address 1.1.1.1 255.255.255.0

no ip redirects

!

interface Vlan2

description Clients Vlan

ip unnumbered Loopback0 poll

ip policy route-map OutToBGP

!

interface Vlan3

description To-BGP-Link1

ip address 10.10.10.2 255.255.255.252

!

interface Vlan4

description To-BGP-Link2

ip address 10.10.10.6 255.255.255.252

!

router bgp 1234

no synchronization

bgp router-id 10.10.10.2

no bgp enforce-first-as

bgp log-neighbor-changes

network 1.1.1.1 mask 255.255.255.0

network 2.2.2.2 mask 255.255.255.0

neighbor 3.3.3.3 remote-as 4321

neighbor 3.3.3.3 transport path-mtu-discovery

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 10.10.10.1

ip route 0.0.0.0 0.0.0.0 10.10.10.5

!

access-list 10 permit 1.1.1.1 0.0.0.255

access-list 11 permit 2.2.2.2 0.0.0.255

!

route-map OutToBGP permit 10

description NextHop is Link1 Vlan3

match ip address 10

set ip next-hop 10.10.10.1

!

route-map OutToBGP permit 11

description NextHop is Link2 Vlan4

match ip address 11

set ip next-hop 10.10.10.5

!

===

 

PBR игнорирует то, что приперлось по BGP и хреначит все на основании access-list`ов. Как бы дать BGP приоритет? ;)

 

p.s. Сорри, если туплю сильно. Ночные доконфигуривания до добра не доведут. ;)

Edited by tartila

Share this post


Link to post
Share on other sites

Да никак! PBR - это не роутинговый протокол, это маршрутизация на основе политики, в нашем случае route-map'a с ACL =)

В такой ситуации, надо уходить от PBR, либо делать его (PBR) более навороченный.

Но хотел сказать: "PBR - зло!"

Share this post


Link to post
Share on other sites

Да, по определению PBR всегда будет обрабатываться перед маршрутизацией.

Share this post


Link to post
Share on other sites

PBR не должен управлять маршрутизацией трафика в вашей сети, он больше для диагностики.

Не понятна и цель того, что вы делаете =).

Share this post


Link to post
Share on other sites

В PBR есть параметр (вродебы default nexthop) который отправляет на nexthop в случае если нет маршрута на данный адрес в таблице маршрутизации... (если я правильно помню)

Share this post


Link to post
Share on other sites

В PBR есть параметр (вродебы default nexthop) который отправляет на nexthop в случае если нет маршрута на данный адрес в таблице маршрутизации... (если я правильно помню)

 

Вот спасибо, ай спасибо! http://alexandr.sysoev.ru/node/63

 

Попробую в понедельник - отпишусь.

 

p.s. Всем остальным: плохие админы!!! плохие! в циске много всяких трюков спрятано! ;)

Share this post


Link to post
Share on other sites

Программист, использующий трюки в повседневной жизни, а не на Олимпиаде - плохой программист.

Админ, использующий трюки - плохой админ.

Share this post


Link to post
Share on other sites

Уря! Работает! ;)

 

2 martini: Спасибо большое!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this