Jump to content
Калькуляторы

Помогите с OSPF

Типовая конфигурация, 2 зоны. Задача не передавать между зонами маршруты.

Если делаю на всех узлах area1, тип зоны stub, то маршруты перестают распределяться даже в пределах зоны. При stub=off, все маршруты из area1 улетают так же и в магистральную зону, чего мне очень не нужно.

Подскажите плз как это сделать, можно на примерах с cisco. :)

post-44829-1273764045_thumb.png

Share this post


Link to post
Share on other sites

если летают не LSA5(нету всяких редистрибьютов), то можно с помощью фильтров почикать между зон префиксы

Share this post


Link to post
Share on other sites

если на примере циски - можно запустить два ospf process без редистрибутов

 

Share this post


Link to post
Share on other sites

запихнуть в разные vrf-ы.

Share this post


Link to post
Share on other sites

 

 

Типовая конфигурация, 2 зоны. Задача не передавать между зонами маршруты.

Если делаю на всех узлах area1, тип зоны stub, то маршруты перестают распределяться даже в пределах зоны. При stub=off, все маршруты из area1 улетают так же и в магистральную зону, чего мне очень не нужно.

Подскажите плз как это сделать, можно на примерах с cisco. :)

зачем тебе вообше тогда эти зоны если ты не собираешся обмениватса маршрутами?

как на счет сделать Ареа1 тотал стаб? На примере циски:

 

router ospf 1

router-id x.x.x.x

network x.x.x.x x.x.x.x area 0

network x.x.x.x x.x.x.x area 1

area 1 stub no summary

 

Фильтруем ЛСА 3,4,5.

 

Тоже самое делаем с обратной стороны только фильтруем сети из ареа 1 в ареа 0 (лса3):

 

area 1 filter-list prefix "Название Префикс листа" out

 

 

 

Share this post


Link to post
Share on other sites

Сама сетка на OSPF работает + несколько PPTP серверов. Нехочется чтобы в сетку улетали /32 с PPTP серверов.

Спасибо за советы. Буду пробовать.

Edited by SokolovS

Share this post


Link to post
Share on other sites
Сама сетка на OSPF работает + несколько PPTP серверов. Нехочется чтобы в сетку улетали /32 с PPTP серверов.

iBGP - скорость сходимости таже, рычагов управления на порядок больше.

Share this post


Link to post
Share on other sites

BGP лицензии на телесин к сожалению нет :(

В общем то все получилось, пришлось перевернуть все, т.е. backbone,ом сделать сетку в которой находится BGP-бордер с внешними аплинками. Тогда в тотал стаб ничего не улетает как и положено и фильтровать ничего не надо.

 

Есть одна ситуация которую я не понимаю. Объясните плз.

Вот конфиги 2-х каталист:

Первая (она же центр)

router ospf 100
router-id 255.255.255.255
log-adjacency-changes
area 100 stub
redistribute connected subnets
redistribute static subnets
passive-interface default
no passive-interface Vlan2
network 192.168.0.0 0.0.255.255 area 100
default-information originate

 

Вторая (переферия, отвечает за сеть 192.168.160.0/20, которая бьется на более мелкие - сегмент на здание)

router ospf 100
router-id 192.168.2.6
log-adjacency-changes
area 100 stub
redistribute connected subnets
redistribute static subnets
passive-interface default
no passive-interface Vlan2
network 192.168.0.0 0.0.255.255 area 100

 

По Vlan2 у них линковая сеть 192.168.2.6/30.

Так вот все работает, но на центральный узел приходят маршруты на мелкие сети и суммировать маршрут до 192.168.160.0/20 никак не получается, т.к. summary-adress работает только для ASBR, а area 100 range x.x.x.x x.x.x.x работает только для ABR. Ни тем ни другим переферийный узел не является.

Подскажите как быть?

Edited by SokolovS

Share this post


Link to post
Share on other sites

как на счет переделать стаб в нсса?

таким образом ваш router/switch становится ASBR

 

router-id х.х.х.х.

log-adjacency-changes

area 100 nssa <<<<<<<<<<<<<<<<<<<<<

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface Vlan2

network 192.168.0.0 0.0.255.255 area 100

default-information originate

 

 

Share this post


Link to post
Share on other sites
если на примере циски - можно запустить два ospf process без редистрибутов
Я так и делаю. ИМХО, простое и изящное решение.

 

Share this post


Link to post
Share on other sites
как на счет переделать стаб в нсса?

таким образом ваш router/switch становится ASBR

 

router-id х.х.х.х.

log-adjacency-changes

area 100 nssa <<<<<<<<<<<<<<<<<<<<<

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface Vlan2

network 192.168.0.0 0.0.255.255 area 100

default-information originate

В NSSA не может не посылаться Summary LSA, а это значит в area 100 будут уходить маршруты из backbone.

Решение гораздо проще оказалось, зона area 100 стандартная, а на границе зон сделал суммирование маршрутов :)

Всем спасибо за помощь!

Share this post


Link to post
Share on other sites

Отпишу тут, возможно кому то пригодится.

Если для кваги в секции router ospf, написать redistribute connected, то для интерфейсов ppp* будут гененироваться Type 5 LSA (т.е. считатеся что изменился статус канала внешнего по отношению к AS), что в общем то и написано в доках. Этот анонс успешно уйдет и в другие area, если они конечно не total stub. Если redistribute connected не прописывать, то генерируются Type 1 LSA, а в остальные area уходит анонс суммарного маршрута который настроен на ABR (area XXX range ... в цисках). Пригодится тем у кого на BRAS-ах OSPF и в остальной сетке OSPF.

Share this post


Link to post
Share on other sites
как на счет переделать стаб в нсса?

таким образом ваш router/switch становится ASBR

 

router-id х.х.х.х.

log-adjacency-changes

area 100 nssa <<<<<<<<<<<<<<<<<<<<<

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface Vlan2

network 192.168.0.0 0.0.255.255 area 100

default-information originate

В NSSA не может не посылаться Summary LSA, а это значит в area 100 будут уходить маршруты из backbone.

Решение гораздо проще оказалось, зона area 100 стандартная, а на границе зон сделал суммирование маршрутов :)

Всем спасибо за помощь!

 

не вопрос, на ABR:

 

area 100 nssa no-summary

 

таким образом получаем default route в area 100

Share this post


Link to post
Share on other sites

Телесин на такое ругается :) Там set ospf area=0.0.0.100 stub=nssa summary=off не прокатывает :(

Share this post


Link to post
Share on other sites

nssa total stub это цискина проприетарщина

Edited by DelSt

Share this post


Link to post
Share on other sites

Да, в описании стандарта такого нет :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this