Jump to content
Калькуляторы

Два Cisco PPPoE роутера

Схемка:

4444.gif

 

Нужно чтобы /20 подсеть, которая отдается клиентам жила на обоих 7301, ну и естественно чтобы 3825 знал на каком из нас-ов поднят тот или иной /32. Сходу придумать что-то не могу :(

Share this post


Link to post
Share on other sites

подсказка - протокол динамической маршрутизации.

 

Share this post


Link to post
Share on other sites

подсказка - протокол динамической маршрутизации.

Коню понятно. Что лучше использовать? RIP, OSPF, BGP? Основные моменты? просто я не представляю как анонсить /32 на соседей...

Share this post


Link to post
Share on other sites

Если хотите анонсировать /32 - то лучше BGP. Все остальное может задохнуться.

А лучше вообще анонсировать /20 в виде двух /21 (по одной с каждой 7301) + /20 с каждого 7301 для резервирования. Статические адреса выдаете?

Share this post


Link to post
Share on other sites
Если хотите анонсировать /32 - то лучше BGP. Все остальное может задохнуться.

А лучше вообще анонсировать /20 в виде двух /21 (по одной с каждой 7301) + /20 с каждого 7301 для резервирования. Статические адреса выдаете?

В том то и дело, что статические адреса раздаем...

Share this post


Link to post
Share on other sites

Vicus, телепаты стали возвращаться.

router ospf 1

router-id x.x.x.x

log-adjacency-changes

area 0 authentication message-digest

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface GigabitEthernet0/0.xxx

network x.x.x.x 0.0.0.x area 0

distribute-list 11 out

 

 

Share this post


Link to post
Share on other sites
Коню понятно. Что лучше использовать? RIP, OSPF, BGP? Основные моменты? просто я не представляю как анонсить /32 на соседей...

Типа того?

 

....
router bgp XXX
neighbor xx.xx.xx.xx prefix-list BGP-OUT out
....
ip prefix-list BGP-OUT seq 5 permit xx.xx.xx.xx le 32

 

Share this post


Link to post
Share on other sites

redefine

прошу прощения, но вы что - с ума посходили... BGP, ну надо же ((((

 

 

OSPF решит вашу проблему, если не разберетесь сами (хотя тут не в чем разбираться) помогу с конфигом...

Share this post


Link to post
Share on other sites
redefine

прошу прощения, но вы что - с ума посходили... BGP, ну надо же ((((

OSPF решит вашу проблему, если не разберетесь сами (хотя тут не в чем разбираться) помогу с конфигом...

У топикстартера может быть до 4000 /32. Лично я бы не хотел видеть столько маршрутов в OSPFе ввиду его возможной большой загрузки. Отсюда и совет.

Если у Вас есть другое мнение - welcome.

Edited by redefine

Share this post


Link to post
Share on other sites

может, лучше цискин EIGRP использовать?

 

Share this post


Link to post
Share on other sites
У топикстартера может быть до 4000 /32. Лично я бы не хотел видеть столько маршрутов в OSPFе ввиду его возможной большой загрузки. Отсюда и совет.

Если у Вас есть другое мнение - welcome.

вы их куда то еще гонять собрались? собрали на ближайшем роутере, а дальше summary-address по /20-й

совсем плохо при таком раскладе может стать только в одном теоретическом случае - произошел срыв сессий (например по питалову) и все 4к абонентов переподключаются единовременно.

на практике вероятность такого случая - ничтожно минимальна. хотя бы потому, что радиусу тоже нужно время на обработку подключений.

за это время ospf прекрасно прожуется.

 

 

Share this post


Link to post
Share on other sites

Всем привет опять. Все ближе реализация вышеописанной задачи. Сижу кручу конфигурацию.

прописываю:

router bgp xxx70
no synchronization
no bgp fast-external-fallover
bgp log-neighbor-changes
network xx.xxx.144.0 mask 255.255.240.0
redistribute connected
neighbor xx.xxx.144.160 remote-as xxx70
neighbor xx.xxx.144.160 description iBGP with core-1
neighbor xx.xxx.144.160 update-source GigabitEthernet0/1
neighbor xx.xxx.144.160 version 4
neighbor xx.xxx.144.160 next-hop-self
neighbor xx.xxx.144.160 soft-reconfiguration inbound
neighbor xx.xxx.149.1 remote-as xxx70
neighbor xx.xxx.149.1 description iBGP with land2
neighbor xx.xxx.149.1 update-source GigabitEthernet0/0
neighbor xx.xxx.149.1 version 4
neighbor xx.xxx.149.1 next-hop-self
neighbor xx.xxx.149.1 soft-reconfiguration inbound
no auto-summary
!

 

Далее смотрю, что у меня в таблице и вижу:

land1#sh ip bgp
BGP table version is 492, local router ID is xx.xxx.144.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          xx.xxx.149.1             0    100      0 i
*> xx.xxx.144.0/24  0.0.0.0                  0         32768 ?
*> xx.xxx.144.0/20  0.0.0.0                  0         32768 i
*> xx.xxx.144.12/32 0.0.0.0                  0         32768 ?
*> xx.xxx.144.13/32 0.0.0.0                  0         32768 ?
*> xx.xxx.144.14/32 0.0.0.0                  0         32768 ?
......

Подскажите, что я упускаю? как из incomplete сделать IGP? :)

Share this post


Link to post
Share on other sites
router bgp xxx70

no synchronization

no bgp fast-external-fallover

bgp log-neighbor-changes

network xx.xxx.144.0 mask 255.255.240.0

redistribute connected route-map i-want-igp

neighbor xx.xxx.144.160 remote-as xxx70

neighbor xx.xxx.144.160 description iBGP with core-1

neighbor xx.xxx.144.160 update-source GigabitEthernet0/1

neighbor xx.xxx.144.160 version 4

neighbor xx.xxx.144.160 next-hop-self

neighbor xx.xxx.144.160 soft-reconfiguration inbound

neighbor xx.xxx.149.1 remote-as xxx70

neighbor xx.xxx.149.1 description iBGP with land2

neighbor xx.xxx.149.1 update-source GigabitEthernet0/0

neighbor xx.xxx.149.1 version 4

neighbor xx.xxx.149.1 next-hop-self

neighbor xx.xxx.149.1 soft-reconfiguration inbound

no auto-summary

 

route-map i-want-igp

set origin igp

Share this post


Link to post
Share on other sites

как по мне то бгп не совсем для того !

то есть тут реально оспф должен работать!

 

 

Если хотите анонсировать /32 - то лучше BGP. Все остальное может задохнуться.
что то в этом конечно есть

оспфу точно будет нехорошо от большого количества маршрутов и будет ещё хуже если будет соседей много - но так как сейчас схема то думаю нормально он будет хавать это

Edited by Lynx10

Share this post


Link to post
Share on other sites
redefine

прошу прощения, но вы что - с ума посходили... BGP, ну надо же ((((

OSPF решит вашу проблему, если не разберетесь сами (хотя тут не в чем разбираться) помогу с конфигом...

У топикстартера может быть до 4000 /32. Лично я бы не хотел видеть столько маршрутов в OSPFе ввиду его возможной большой загрузки. Отсюда и совет.

Если у Вас есть другое мнение - welcome.

Не будет 4000 маршрутов, если на кошке роут прописать в Null0

Мы для PPPoE по /24 нарезаем и выглядит на других роутерах это так:

Cisco#sh ip route | inc 10.0.152.
O E2    10.0.152.0/24 [110/20] via 10.0.0.X, 00:00:18, GigabitEthernet0/0

 

 

Share this post


Link to post
Share on other sites
Не будет 4000 маршрутов, если на кошке роут прописать в Null0

Мы для PPPoE по /24 нарезаем и выглядит на других роутерах это так:

Cisco#sh ip route | inc 10.0.152.
O E2    10.0.152.0/24 [110/20] via 10.0.0.X, 00:00:18, GigabitEthernet0/0

А если у тебя несколько брасов, то что делать с юзерами со статик IP?

Share this post


Link to post
Share on other sites

В общем спасибо за наводку, в итогде сделал так:

router bgp xxx70
no synchronization
no bgp fast-external-fallover
bgp log-neighbor-changes
network xx.xxx.144.0 mask 255.255.240.0
redistribute connected route-map set-origin-igp
neighbor xx.xxx.144.160 remote-as xxx70
neighbor xx.xxx.144.160 description iBGP with core-1
neighbor xx.xxx.144.160 update-source GigabitEthernet0/1
neighbor xx.xxx.144.160 version 4
neighbor xx.xxx.144.160 next-hop-self
neighbor xx.xxx.144.160 soft-reconfiguration inbound
neighbor xx.xxx.144.160 prefix-list dyn-announce out
neighbor xx.xxx.149.1 remote-as xxx70
neighbor xx.xxx.149.1 description iBGP with land2
neighbor xx.xxx.149.1 update-source GigabitEthernet0/0
neighbor xx.xxx.149.1 version 4
neighbor xx.xxx.149.1 next-hop-self
neighbor xx.xxx.149.1 soft-reconfiguration inbound
neighbor xx.xxx.149.1 prefix-list dyn-announce out
no auto-summary
!
ip prefix-list dyn-announce seq 10 permit xx.xxx.144.0/20
ip prefix-list dyn-announce seq 20 permit xx.xxx.144.0/20 ge 32
ip prefix-list dyn-announce seq 30 deny 0.0.0.0/0 le 32
!
route-map set-origin-igp permit 10
set origin igp

 

на соседнем роутере получил, что хотел:

land2#sh ip bgp neighbors xx.xxx.149.2 received-routes 
BGP table version is 45259, local router ID is yyy.yyy.57.229
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>ixx.xxx.144.0/20  xx.xxx.149.2             0    100      0 i
*>ixx.xxx.144.12/32 xx.xxx.149.2             0    100      0 i
*>ixx.xxx.144.13/32 xx.xxx.149.2             0    100      0 i
*>ixx.xxx.144.44/32 xx.xxx.149.2             0    100      0 i
*>ixx.xxx.144.50/32 xx.xxx.149.2             0    100      0 i
*>ixx.xxx.144.52/32 xx.xxx.149.2             0    100      0 i
*>ixx.xxx.144.55/32 xx.xxx.149.2             0    100      0 i
*>ixx.xxx.144.57/32 xx.xxx.149.2             0    100      0 i
..............

Share this post


Link to post
Share on other sites

возможно лучше отказаться от префикс-листа и выбирать нужные маршруты в route-map?

 

карта будет выглядеть так:

route-map set-origin-igp permit 10

match ip address dyn-announce

set origin igp

Edited by DelSt

Share this post


Link to post
Share on other sites
возможно лучше отказаться от префикс-листа и выбирать нужные маршруты в route-map?

 

карта будет выглядеть так:

route-map set-origin-igp permit 10

match ip address dyn-announce

set origin igp

тогда получится, что соседям будет прилетать всякое incomplete дерьмо из разряда connected интерфейсов (xx.xxx.144.0/24) и приват-сетей...

Да и чем плох префикс-лист?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this