Jump to content
Калькуляторы

Cisco 2950 Vlan с D-Link Vlan cisco and D-Link

С наступающим господа и дамы ) я очень надеюсь что не все еще пьяны и смогут мне помочь)

 

схема :

от провайдера (D-Link 3526 ) приходит vlan98 и не тегированный трафик (назовем vlan 1) в порт 1 catalyst 2950.

 

задача такая:

на 2 порту кошака поймать все что идет в vlan 98 а на 19 порту - все что идет нетегированное (задача проста, но не взлетает (((

 

конф кошки :

version 12.1


interface FastEthernet0/1
description Uplink
switchport mode trunk
switchport nonegotiate
load-interval 60
macro description cisco-switch
!
interface FastEthernet0/2
 switchport access vlan 98
switchport mode access
macro description MoXa
!
interface FastEthernet0/19
description FreeBSD
switchport mode access
macro description cisco-desktop
!
interface Vlan98
ip address 192.168.169.1 255.255.255.0
no ip route-cache
!

 

вижу только нетегированный, все что в теге не идет. Вводил свободный порт в 98 влан и подключал второй тестовый бук (два бука в пределах одного комутатора в 98 влане. друг друга видят).

подскажите где собака порылась....

Share this post


Link to post
Share on other sites
interface FastEthernet0/1
switchport trunk allowed vlan 98

Share this post


Link to post
Share on other sites

к сожалению.... если не указано allowed vlans , по умолчанию в транк попадают все ) не спасло отца русской демократии))

Edited by Kazam

Share this post


Link to post
Share on other sites

sh spanning-tree blockedports

Edited by PooFF

Share this post


Link to post
Share on other sites
sh spanning-tree blockedports

Name                 Blocked Interfaces List
-------------------- ------------------------------------

Number of blocked ports (segments) in the system : 0

Share this post


Link to post
Share on other sites

fe 0/1

switchport mode multi чтото там

fe 0/2

swport mode access

swport access vlan 98

fe 0/19

swport mode access

swport access vlan 1

 

ps - мешать тегированный трафик с нетегированным в одном линке не гут

Edited by dIMbI4

Share this post


Link to post
Share on other sites

sh vlan id 98 кажет наличие 98го влана?

sh spanning-tree vlan 98 что кажет?

 

в кратце все это вбивается как то так:

conf t

vlan 98

!

int fa0/1

switchport mode trunk

switchport trunk allowed vlan 98

spanning-tree bpdufilter enable (зачастую спасает отца русской демократии)

!

 

Share this post


Link to post
Share on other sites

fe 0/1
switchport mode multi чтото там

не умеет

cisco(config-if)#switchport ?
  access         Set access mode characteristics of the interface
  host           Set port host
  mode           Set trunking mode of the interface
  nonegotiate    Device will not engage in negotiation protocol on this
                 interface
  port-security  Security related command
  priority       Set appliance 802.1p priority
  protected      Configure an interface to be a protected port
  trunk          Set trunking characteristics of the interface
  voice          Voice appliance attributes

 

ps - мешать тегированный трафик с нетегированным в одном линке не гут
вариантов других нет ( есть линк, и он один....

 

sh vlan id 98 кажет наличие 98го влана?

sh spanning-tree vlan 98 что кажет?

cisco#sh vlan id 98

004267: Dec 30 11:00:33: %SYS-5-CONFIG_I: Configured from console by console

 

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

98 MoXa active Fa0/1, Fa0/3, Fa0/8, Fa0/18

 

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

98 enet 100098 1500 - - - - - 0 0

 

Remote SPAN VLAN

----------------

Disabled

 

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

 

cisco#sh spanning-tree vlan 98

 

VLAN0098

Spanning tree enabled protocol ieee

Root ID Priority 32866

Address 000e.384d.13c0

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

 

Bridge ID Priority 32866 (priority 32768 sys-id-ext 98)

Address 000e.384d.13c0

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

 

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Desg FWD 19 128.1 P2p

Fa0/8 Desg FWD 19 128.8 P2p

 

Share this post


Link to post
Share on other sites

попробуй еще

conf t

no spanning-tree vlan 98

или попроси аплинка, чтоб тебе stp restrict tcn/restrict role/edge true/fbpdu dis воткнули на порт 3526

Share this post


Link to post
Share on other sites

да, порт поменял на 0/3 где нужно ловить вилан.... полет не состоялся)))

 

попробуй еще

conf t

no spanning-tree vlan 98

или попроси аплинка, чтоб тебе stp restrict tcn/restrict role/edge true/fbpdu dis воткнули на порт 3526

попробовал - не взлетело

 

 

аплинка смогу попинать только после 4 числа.... а связь нужна сегодня )))

Share this post


Link to post
Share on other sites

# 99 идет clear

# 98 тегированный

int f0/1

sw mode trunk

sw tr all vl 98,99

sw tr nat vl 99

int f0/2

sw mo acc

de acc vl 98

int f0/19

sw mo acc

sw acc vl 99

Share this post


Link to post
Share on other sites

как я понял, надо принять на 1 порт 1йвлан антегом и 98й влан тэгом.

покажи что у 2950 лежит в свичпорт моде ...... под руками нету

Share this post


Link to post
Share on other sites

Если ничего не помогает - надо пинать провайдера ;)

Похоже он тупо не отдает тебе 98 влан.

Share this post


Link to post
Share on other sites

тьфу меня....

кароче

 

входящий порт

fe 0/1

switchport mode trunk

switchport trunk allow vlan 98 (тот который тэгом)

switchport native vlan 2 (тот который антэг)

 

далее выводим

fe 0/2

switchport mode access

switchport access vlan 98 (выводим который пришел тэгом)

 

fe 0/19

switchport mode access

switchport access vlan 2 (выводим который пришел антэгом)

 

обязательно!перед этим не забываем создать вланы в влан датабэйзе и докучи на тегированном порту написать энкапсюлэйшен dot1q

Share this post


Link to post
Share on other sites
и докучи на тегированном порту написать энкапсюлэйшен dot1q
требуется только на L3 железках.

непосредственно на L2 (2950/2960) оно нафиг нигде не нужно, ибо кроме как так оно там иначе не происходит.

Share this post


Link to post
Share on other sites
входящий порт

fe 0/1

switchport mode trunk

switchport trunk allow vlan 98 (тот который тэгом)

switchport native vlan 2 (тот который антэг)

а разве не так?

switchport trunk allow vlan 98,2

 

и докучи на тегированном порту написать энкапсюлэйшен dot1q
требуется только на L3 железках.

непосредственно на L2 (2950/2960) оно нафиг нигде не нужно, ибо кроме как так оно там иначе не происходит.

а ISL?

Правда, 2950 вроде не поддерживает isl и указывать инкапсуляцию не надо.

Share this post


Link to post
Share on other sites
а разве не так?

switchport trunk allow vlan 98,2

честно говоря неуверен, ибо ни разу не делал. возможно что надо. сертификата циски у меня нет, право на ошибку есть.

энкапсюлейшен привык писать на 3500 серии, ибо бывает что не работает

Edited by dIMbI4

Share this post


Link to post
Share on other sites
а разве не так?

switchport trunk allow vlan 98,2

честно говоря неуверен, ибо ни разу не делал. возможно что надо. сертификата циски у меня нет, право на ошибку есть.

Да тут не сертификат нужен, а практика или небольшой тест.

Share this post


Link to post
Share on other sites

согласен, практики мало.. у топикстартера заработало?

дак всетаки нэйтив влан надо указывать в аллоуд вланс на транке?

Share this post


Link to post
Share on other sites
у топикстартера заработало?

нет господа и дамы, не взлетело. Секс с СТП не помог, уверяют что vlan передают на мой порт и все шоколадно. Курим маны.

Share this post


Link to post
Share on other sites

vlan 98
name MoXa
!
vlan 100
name VlanOffice
!
interface FastEthernet0/1
description Uplink
switchport trunk native vlan 100
switchport trunk pruning vlan none
switchport mode trunk
switchport nonegotiate
load-interval 60
macro description cisco-switch
no cdp enable
!

vlan98 - tag

vlan100 - untag в него гоним весь не маркированный траффик и забираем его акцессом на 19 порту

!
interface FastEthernet0/2
switchport access vlan 98
switchport mode access
switchport nonegotiate
macro description cisco-switch | Vlan2
!

на 2 порту ловим акцессом все что было в 98 вилане

interface FastEthernet0/19
description FreeBSD
switchport access vlan 100
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
mls qos cos override
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!

 

и как результат - опять вернулись к началу )) баран овца блин) видим untag. tag не видим ни разу )))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this