Jump to content
Калькуляторы

Cisco 3550 проблемы

На циску 3550 подается тегированный влан управления с коммутатора другой марки(dell). Как настроить интерфейс циски чтоб этот влан принять и была возможность управлять циской?

Edited by iMax

Share this post


Link to post
Share on other sites

на порту добавляешь switchport trunk allowed vlan такойтовлан. И делаешь interface Vlanтакойтовлан и на него айпишник.

Share this post


Link to post
Share on other sites

вот как у меня настроено было:

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

no ip address

speed nonegotiate

no cdp enable

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

ip address 10.1.10.205 255.255.255.0

no ip route-cache

!

и не работает в этом случае. работает только если нетегированный.

 

поправка. сделал:

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

no ip address

speed nonegotiate

no cdp enable

!

и заработало с тегированным.

 

 

Share this post


Link to post
Share on other sites

Всё правильно. Потому что "switchport trunk native vlan 2" означает что если трафик пришёл нетегированный, то он тегируется вланом 2. А если пришёл с вланом 2, то тэг с этого трафика снимается.

 

Если сделать к примеру switchport trunk native vlan 10(т.е. любой влан кроме влана 2) - то тоже будет работать

Edited by n1k3

Share this post


Link to post
Share on other sites

задача усложнилась. необходимо подружить циску 3550 с 3com 3300, 4400. Данные трикомы управляются только по первому влану.

 

 

схема такая. циска принимает на аплинковом порту нетегированный первый влан и остальные тегированные и далее эта циска должна раздать первый влан либо тегированным либо нетегированным(этим самым трикомам). Сама циска управляется по второму влану.

Edited by iMax

Share this post


Link to post
Share on other sites
задача усложнилась. необходимо подружить циску 3550 с 3com 3300, 4400. Данные трикомы управляются только по первому влану.
если конфиг не изменился, то на кошке

int Vlan1

no shutdown

Share this post


Link to post
Share on other sites

вообще многие железки управляются с 1го влана (дефолтного), а вот вывели вы данные или нет в отдельные вланы - зависит только от вас. некоторые администраторы практикуют вывод управления в отдельный влан, хотя на мой взгляд корректней будет выводить в отдельные вланы данные. при таком раскладе если вдруг чего случается с конфигурацией устройства - до него можно будет достучаться, все через тот же дефолтный влан.

ну а для полной изоляции управление еще неплохо б выводить в отдельный vrf.

Share this post


Link to post
Share on other sites
задача усложнилась. необходимо подружить циску 3550 с 3com 3300, 4400. Данные трикомы управляются только по первому влану.
если конфиг не изменился, то на кошке

int Vlan1

no shutdown

тогда циска будет управляться по первому влану. а я решил чтоб по второму. если я не так решил то скажите.

 

Схема вообще такая:

схема такая. циска принимает на аплинковом порту нетегированный первый влан и остальные тегированные и далее эта циска должна раздать первый влан либо тегированным либо нетегированным(этим самым трикомам). Сама циска управляется по второму влану.

 

конфиг:

 

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,1104

switchport mode trunk

no ip address

speed nonegotiate

no cdp enable

!

interface GigabitEthernet0/2

no ip address

no cdp enable

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

ip address 10.100.10.205 255.255.255.0

no ip route-cache

!

пишу в interface GigabitEthernet0/1

 

switchport trunk native vlan 1

 

и команда не проходит. просто не появляется в sh run потом.

Edited by iMax

Share this post


Link to post
Share on other sites
пишу в interface GigabitEthernet0/1

 

switchport trunk native vlan 1

 

и команда не проходит. просто не появляется в sh run потом.

Проходит. Просто это дефолтная конфигурация, в конфиге не отображается. Нативный влан при этом действительно первый.

Share this post


Link to post
Share on other sites

switchport trunk native vlan 1 = no switchport trunk native vlan

аналогично с switch access vlan 1 = no switch access vlan

что то вроде "по умолчанию".

Share this post


Link to post
Share on other sites

Адреса управления трикомов у вас тоже должны быть в сети 10.100.10.0/24 ? Тогда просто на портах циски, куда воткнуты эти трикомы сделайте sw tr nat vl 2. Помимо "switchport mode trunk" и "switchport trunk allowed vlan 2" разумеется

 

И в какие порты воткнуты трикомы, а в каком порту аплинк циски?

Edited by n1k3

Share this post


Link to post
Share on other sites

вопрос такой. может ли вообще циска пускать первый влан тегированным?

 

 

Адреса управления трикомов у вас тоже должны быть в сети 10.100.10.0/24 ? Тогда просто на портах циски, куда воткнуты эти трикомы сделайте sw tr nat vl 2. Помимо "switchport mode trunk" и "switchport trunk allowed vlan 2" разумеется

 

И в какие порты воткнуты трикомы, а в каком порту аплинк циски?

раньше небыло такого оборудования управляемого только первом влане, и поэтому делали во втором. появились когда трикому и пришлось заниматься придруживанием.

 

аплинг циски на первом гигабитном порту, триком воткнут в 13 порт. На аплинке стоит dell 6024(он не умеет раздавать первый влан тегированным).

 

все получилось как ввел

sw tr nat vl 2

 

!

interface FastEthernet0/13

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport trunk allowed vlan 1,2,1104

switchport mode trunk

no ip address

no cdp enable

!

___

 

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,1104

switchport mode trunk

no ip address

speed nonegotiate

no cdp enable

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

ip address 10.1.10.205 255.255.255.0

no ip route-cache

!

Edited by iMax

Share this post


Link to post
Share on other sites
вопрос такой. может ли вообще циска пускать первый влан тегированным?

vlan dot1q tag native

но это только на транковых портах.

Share this post


Link to post
Share on other sites

Еще одна мистическаЯ непонятно с цисками 2950, 3550. Промежутками отрабатывается именно 10 Vlan. Т.е. покеты походят, потом перестают, опять походят и опять перестают. С чем это может быть связано?

Share this post


Link to post
Share on other sites
sh int порта на 2950 и на 3550 в студию.

вот 3550

cisco3550#show interfaces fastEthernet 0/13

FastEthernet0/13 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 000d.2964.030d (bia 000d.2964.030d)

Description: Kostomarovskaya5-SW(5)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:13:34, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute ouxtput rate 0 bits/sec, 0 packets/sec

968388 packets input, 106403214 bytes, 0 no buffer

Received 16725 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 160 multicast, 0 pause input

0 input packets with dribble condition detected

1453538 packets output, 1445048992 bytes, 0 underruns

4864 output errors, 5378 collisions, 1 interface resets

0 babbles, 4864 late collision, 675 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

вот 2950

cisco-max#show interfaces fastEthernet 0/24

FastEthernet0/24 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0011.20bf.c9d8 (bia 0011.20bf.c9d8)

Description: UPLINK

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 74000 bits/sec, 30 packets/sec

5 minute output rate 216000 bits/sec, 28 packets/sec

17263749 packets input, 3449486193 bytes, 0 no buffer

Received 1370406 broadcasts (451386 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 451386 multicast, 0 pause input

0 input packets with dribble condition detected

15447949 packets output, 3173629858 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Share this post


Link to post
Share on other sites

4864 output errors, 5378 collisions, 1 interface resets

0 babbles, 4864 late collision, 675 deferred

да у вас батенька полный п-ц на порту 3550. патчкорд замените для начала.

я уже не говорю о том что на одном порту half-duplex, а на другом - full-duplex.

Edited by darkagent

Share this post


Link to post
Share on other sites
4864 output errors, 5378 collisions, 1 interface resets

0 babbles, 4864 late collision, 675 deferred

да у вас батенька полный п-ц на порту 3550. патчкорд замените для начала.

я уже не говорю о том что на одном порту half-duplex, а на другом - full-duplex.

поставил full duplex, пачкорд здесь оптический. его заменить?

 

ошибок больше нет но все равно именно во дном влане десятом пакеты ходят непойми как, то ходят то нет:

FastEthernet0/13 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 000d.2964.030d (bia 000d.2964.030d)

Description: Kostomarovskaya5-SW(5)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:14:24, output 00:00:01, output hang never

Last clearing of "show interface" counters 00:00:33

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute ouxtput rate 0 bits/sec, 0 packets/sec

40 packets input, 3196 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

238 packets output, 17985 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Edited by iMax

Share this post


Link to post
Share on other sites

оптический патчкорд? на портах коммутаторов конверторы?

обнули счетчики ошибок (clear counters fa0/13) и понаблюдай за появлением оных втечение некоего интервала времени (втечение часа каждые 5 минут например).

 

Share this post


Link to post
Share on other sites
оптический патчкорд? на портах коммутаторов конверторы?

обнули счетчики ошибок (clear counters fa0/13) и понаблюдай за появлением оных втечение некоего интервала времени (втечение часа каждые 5 минут например).

на портах нет конверторов. напрямую, порт-порт. Счетчики сбросил. Пока наблюдаю. Ошибок вроде пока не валится. Работает так же как и было. То ходят пакеты в 10 влане, то нет.

Share this post


Link to post
Share on other sites

подключил вот только что еще в 10 порт устройство которое работает в 10 влане и один в один так же пакеты то ходят то не ходят. Такая хрень только с 10 вланом. Как можно вычислить из за чего это может быть? Такое происходит только на циске 3550, 2950. Если возвращаю в триком все то пакеты ходят нормально.

Share this post


Link to post
Share on other sites
на портах нет конверторов. напрямую, порт-порт.
sh ver покажи с каталистов, или хотя бы строчку "model number"

Уж очень хочется посмотреть на 3550 со встроеным 13ым оптическим портом, и на 2950 со встроенным 24ым оптическим портом, у котрого медиатайп пишеться 100BaseTX

Плюс еще на 2950 трафик есть, а на 3550 трафик по нулям.

Сдается мне, что вы совсем запутались.

Share this post


Link to post
Share on other sites

sh spanning-tree vlan 10 detail

sh spanning-tree int порт detail

следи за bpdu sent/receive счетчиками, а так же за состоянием порта, может где какой bpdu пакет возвращается по кольцу, и коммутатор блочит его по спанингу.

p.s. согласен с мнением Lucky SB. может вы путаете с "заводским" патчкордом, который как бы все так же медный?

Edited by darkagent

Share this post


Link to post
Share on other sites

обнулил счетчики, ошибок нет и ситуация не изменилась. Вот как это выглядит:

 

 

10.109.1.3 это узел подключенный к циске, а 10.109.1.1(его пингую) это узел подключенный с другой стороны через кучу оборудования другой марки.

Ответ от 10.109.1.1: число байт=32 время<1мс TTL=63

Ответ от 10.109.1.1: число байт=32 время<1мс TTL=63

Ответ от 10.109.1.1: число байт=32 время<1мс TTL=63

Превышен интервал ожидания для запроса.

Превышен интервал ожидания для запроса.

Превышен интервал ожидания для запроса.

Превышен интервал ожидания для запроса.

Превышен интервал ожидания для запроса.

Ответ от 10.109.1.3: Заданный узел недоступен.

Ответ от 10.109.1.3: Заданный узел недоступен.

Ответ от 10.109.1.3: Заданный узел недоступен.

Ответ от 10.109.1.3: Заданный узел недоступен.

Ответ от 10.109.1.3: Заданный узел недоступен.

Ответ от 10.109.1.3: Заданный узел недоступен.

Ответ от 10.109.1.3: Заданный узел недоступен.

Ответ от 10.109.1.1: число байт=32 время=2009мс TTL=63

Ответ от 10.109.1.1: число байт=32 время<1мс TTL=63

Ответ от 10.109.1.1: число байт=32 время<1мс TTL=63

Edited by iMax

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this