Jump to content
Калькуляторы

Planet WAP-4033 Wive & Wive-NG

Всем вечера.

Достались мне в наследство куча Planet WAP-4033. Так как родные прошивки - для лохов ;), то решил залить wive-ng. Не льётся она ни в какую. Через веб - просто пустая страница и отваливается веб-сервер; через tftp - принимает прошивку и висит.

В то же время wive залился отлично.

Что я делаю не так?

Share this post


Link to post
Share on other sites

Если что-то получиться реальное, да еще и с веб интерфейсом как в DD/WRT то напишите пожалуйста.

Хотя эти точки и в своем виде нормально работают, конечно туда бы добавить парочку пунктиков.

Share this post


Link to post
Share on other sites

Так как родные прошивки - для лохов ;), то решил залить wive-ng.

Я видимо лох, если уже 3 года пользуюсь такими железками с родными прошивками... А перепробывал все!

Share this post


Link to post
Share on other sites
Я видимо лох, если уже 3 года пользуюсь такими железками с родными прошивками... А перепробывал все!
Я уже родных перепробовал овер 9к. И от Edimax пробовал. Самая стабильная, имхо - 1.22.

А ты сделай так:

точку А ставишь в AP Bridge Point to Multipoint,

точку В ставишь в Point to Point.

Две точки соединяются. Потом в А меняешь скорость. Всё, линк дохлый, коробки не поднимутся. Ещё их надо время от времени ребутить. В чём соль?

 

Wive нужен в основном из-за пингера, как в овисах. Ну и, конечно же, хочется нормально на логи посмотреть и настроить всё ручками.

 

2Saab95: Web-морда в Wive есть. Отключена. Пробовал включить, посмотрел - понял, почему отключена, выключил назад :-D. Да и зачем она? Во-первых, не тот класс устройств, во-вторых, в конфигах всё быстрее и проще настроить. Набросал что надо, сделал fs save && reboot.

Edited by Abram

Share this post


Link to post
Share on other sites
Всем вечера.

Достались мне в наследство куча Planet WAP-4033. Так как родные прошивки - для лохов ;), то решил залить wive-ng. Не льётся она ни в какую. Через веб - просто пустая страница и отваливается веб-сервер; через tftp - принимает прошивку и висит.

В то же время wive залился отлично.

Что я делаю не так?

Планеты это RevA перед заливкой нужно конвертировать имидж перл скриптом из комплекта.

Share this post


Link to post
Share on other sites

Нет некакого смысла шить 4033!Она и так работает замечательно!стоит порядка 300 штук!поставил и забыл!если раз в пол года одна загалит,ребутнёшь и всё гуд!

Share this post


Link to post
Share on other sites
Планеты это RevA перед заливкой нужно конвертировать имидж перл скриптом из комплекта.
Пробовал. Не работает.
Нет некакого смысла шить 4033!Она и так работает замечательно!стоит порядка 300 штук!поставил и забыл!если раз в пол года одна загалит,ребутнёшь и всё гуд!
Как минимум - есть смысл лить прошивку от Edimax, там пингер есть. А виснут они таки часто. Пингер помогает.
Edited by Abram

Share this post


Link to post
Share on other sites
Пробовал. Не работает.

Плохо пробовали. Надеюсь не под виндой пробовали?

 

 

Share this post


Link to post
Share on other sites

не могли бы вы привести ссылочку на эту прошивку от edimax?

Share this post


Link to post
Share on other sites

Решился поднять старую тему, так как личка почему-то отключена.

 

Планеты это RevA перед заливкой нужно конвертировать имидж перл скриптом из комплекта.
Приветствую!

Пробовал на единственной доступной на данный момент версии wive-ng-0.3.18. Скрипт неправильно работает, выдаёт:

its seems wive.bin is black_fw...
all done.

Полученный образ отличается от wive.bin только 4мя байтами. С ним точка доступа не работает.

Попробовал закомментировал кусок кода

if ($a == "1") {
    print "its seems $fread is black_fw...\n";
    print FW $x                # write checksum as is
    or die "write to $fwrite failed : $!";    
    seek(FR, 16, 0);            # seek to 16 byte
    read(FR, $x, $fs-16);            # read to end
    print FW $x                # write to file
    or die "write to $fwrite failed : $!";
    close FR or die "error closing $fread : $!";
    close FW or die "error closing $fwrite : $!";
    print "all done.\n";
    exit(0);                # nothing to do, exit
}

Всё равно получил неработоспособную прошивку на выходе.

 

PS: Заливал оригинальную wive прошивку (там для revA лежит готовый файл) - точка доступа с ней работает.

Share this post


Link to post
Share on other sites

Ложная тревога. Скрипт работает. Смутило то, что точка доступа мигала после прошивки лампочками, как новогодняя елка. Да IP адрес у неё стал 192.168.0.50 вместо обещанного 10.200.200.249.

 

Добавлено.

 

Оказывается, адрес остался от прошивки wive!

Нужно было сначала очистить командой

tftp -i 192.168.1.6 put black_fw-rev-a.bin

а уж потом лить.

tftp -i 192.168.1.6 put wive-rev-a.bin

 

Edited by Sonya

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this