Jump to content
Калькуляторы

cisco 10k помогите с набивкой

Требуется подобрать примерный конфиг под следующие цели: терминирование 10000-15000 pptp, 4гбит/с на входе, столько же на выход, больше ничего не надо.

Я так понял, что железка должна содержать в себе как минимум:

шассик (10005 или 10008, это не особо важно, но лучше 10005)

пару питальников

для начала один проц PRE2

 

а вот с портами уже непонимание страшное:

видел, что существуют некие

Cisco ESR-1GE - тут все ясно - один порт в одном слоте, стоит по-божески около 3к$ вроде бы (поправьте если не так)

Cisco ESR-1GE HH (необходимо Cisco ESR-HH-CARRIER) - один модуль занимает половину слотов, т.е. затолкать можно в два раза больше, но стоит уже 10к$ за штуку

и SPA, вот тут я не понимаю, но видел, что есть вот такие:

Cisco 2-Port Gigabit Ethernet Shared Port Adapter SPA-2X1GE-V2

Cisco 2-Port Gigabit Ethernet Shared Port Adapter, Spare SPA-2X1GE-V2=

Cisco 5-Port Gigabit Ethernet Shared Port Adapter SPA-5X1GE-V2

Cisco 5-Port Gigabit Ethernet Shared Port Adapter, Spare SPA-5X1GE-V2=

Cisco 8-Port Gigabit Ethernet Shared Port Adapter SPA-8X1GE-V2

Cisco 8-Port Gigabit Ethernet Shared Port Adapter, Spare SPA-8X1GE-V2=

Cisco 10-Port Gigabit Ethernet Shared Port Adapter SPA-10X1GE-V2

Cisco 10-Port Gigabit Ethernet Shared Port Adapter, Spare SPA-10X1GE-V2=

 

К этому SPA необходимо купить некий SIP-600, который в совокупности с SPA являются просто портами, я правильно понимаю (и еще с SIP работает только PRE3)?

 

Итого:

Вариант 1:

шасси 10005

2 питания

SIP600+SPA(5 или 8 гиговых портов)

PRE3

 

Вариант 2:

шасси 10005

2 питания

PRE2

4 порта Cisco ESR-1GE

 

Вариант 3:

шасси 10005

2 питания

PRE2

2 штуки Cisco ESR-HH-CARRIER

4 штуки Cisco ESR-1GE HH

 

 

Из всех вариантов наиболее привлекательными выглядят 1 (хороший запас по мощности, есть просто для расширения) и 2 (относительная дешевизна, но забиваются все слоты).

 

Кому не жалко, поделитесь вашими набивками

Share this post


Link to post
Share on other sites

pptp оно не умеет, l2tp умеет.

более того во всех иосах которые есть стоит ограничение в 2к сессий на пптп соединения.

Share this post


Link to post
Share on other sites

фич навигатор считает иначе, да и тут не раз видел, как писали, что умеет

Share this post


Link to post
Share on other sites
фич навигатор считает иначе, да и тут не раз видел, как писали, что умеет
Не умеет, pptp зло. PRE-2 имеет ограничения по фичам.

 

Share this post


Link to post
Share on other sites

а в каком иосе фн показывает наличие?

оно знаете врёт иногда :)

Share this post


Link to post
Share on other sites

SIP/SPA можно ставить только начиная с PRE-3 и то с ограничениями.

Один SIP занимает ДВА слота в шасси, 3.2Г на слот в PRE-3 никто не отменял, поэтому в SIP пойдёт только 6.4 гигабита.

 

Учтите, что трафика он пропрёт практически wire-speed, а вот юзеров на нём затерминировать больше 32К уже проблематично - CPU начинает сдыхать.

Share this post


Link to post
Share on other sites
а в каком иосе фн показывает наличие?

оно знаете врёт иногда :)

если я правильно научился им пользоваться, то вот:

 

12.2(16)BX3 SERVICE PROVIDER/SECURED SHELL 3DES c10k2-k9p11-mz.122-16.BX3.bin 512 40

12.2(16)BX2 SERVICE PROVIDER/SECURED SHELL 3DES c10k2-k9p11-mz.122-16.BX2.bin 512 40

12.2(16)BX1 SERVICE PROVIDER/SECURED SHELL 3DES c10k2-k9p11-mz.122-16.BX1.bin 512 40

12.2(16)BX SERVICE PROVIDER/SECURED SHELL 3DES c10k2-k9p11-mz.122-16.BX.bin 512 40

12.2(15)BX SERVICE PROVIDER/SECURED SHELL 3DES c10k2-k9p11-mz.122-15.BX.bin 512 40

 

Один SIP занимает ДВА слота в шасси, 3.2Г на слот в PRE-3 никто не отменял, поэтому в SIP пойдёт только 6.4 гигабита.

это не так страшно, ибо большему количеству трафика неоткуда взяться

Share this post


Link to post
Share on other sites
если я правильно научился им пользоваться, то вот:

 

12.2(16)BX3 SERVICE PROVIDER/SECURED SHELL 3DES c10k2-k9p11-mz.122-16.BX3.bin 512 40

Это PRE-2.

Share this post


Link to post
Share on other sites

я в курсе, поэтому и для pre2 и для pre3 варианты комплектаций писал

Share this post


Link to post
Share on other sites
я в курсе, поэтому и для pre2 и для pre3 варианты комплектаций писал

На 10005 ты не поставишь PRE3. PRE2 - это потолок для шасси 10005.

 

p.s. У нас стоит 10008 и набита большими однопортовыми ESR-1GE платами - самый недорогой вариант.

Edited by KoloBok

Share this post


Link to post
Share on other sites
я в курсе, поэтому и для pre2 и для pre3 варианты комплектаций писал

На 10005 ты не поставишь PRE3. PRE2 - это потолок для шасси 10005.

 

p.s. У нас стоит 10008 и набита большими однопортовыми ESR-1GE платами - самый недорогой вариант.

а можно показать ваш sh inv

 

вот например набивка браса провайдера iinet.au

 

NAME: "Chassis", DESCR: "C10000 Edge Service Router (ESR) Chassis"
PID: ESR10008-CHASSIS  , VID: V02 , SN: FOX113505EB

NAME: "module 1/0", DESCR: "1 port Gigabit Ethernet Half-Slot Line Card"
PID: ESR-HH-1GE        , VID: V01 , SN: CAT1149F05J

NAME: "module 1/1", DESCR: "1 port Gigabit Ethernet Half-Slot Line Card"
PID: ESR-HH-1GE        , VID: V01 , SN: CAT1149F07T

NAME: "module 2/0", DESCR: "1 port Gigabit Ethernet Half-Slot Line Card"
PID: ESR-HH-1GE        , VID: V01 , SN: CAT1149F02A

NAME: "module 2/1", DESCR: "1 port Gigabit Ethernet Half-Slot Line Card"
PID: ESR-HH-1GE        , VID: V01 , SN: CAT1149F02H

NAME: "RP A", DESCR: "Performance Routing Engine"
PID: ESR-PRE3          , VID: V02 , SN: CAT1152F0C0

NAME: "RP A flash card 0", DESCR: "Flash Card"
PID: ESR-PRE-MEM-FD128 , VID:    , SN:            

NAME: "RP A flash card 1", DESCR: "Flash Card"
PID: ESR-PRE-MEM-FD128 , VID:    , SN:            

NAME: "RP B", DESCR: "Performance Routing Engine"
PID: ESR-PRE3          , VID: V02 , SN: CAT1152F0DV

NAME: "RP B flash card 0", DESCR: "Flash Card"
PID: ESR-PRE-MEM-FD128 , VID:    , SN:            

NAME: "RP B flash card 1", DESCR: "Flash Card"
PID: ESR-PRE-MEM-FD128 , VID:    , SN:            

NAME: "power-supply 1", DESCR: "AC power entry module for ESR10008"
PID: ESR-PWR-AC        , VID:    , SN:            

NAME: "fan-tray", DESCR: "BLOWER ASSEMBLY FOR ESR10008"
PID: ESR-BLOWER        , VID:    , SN:

Edited by fozz

Share this post


Link to post
Share on other sites

NAS10k#show inv
NAME: "Chassis", DESCR: "C10000 Edge Service Router (ESR) Chassis"
PID: ESR-CHASSIS       , VID: N/A , SN: 00023690706

NAME: "module 1/0", DESCR: "1 pt Gigabit Ethernet line card (requires a GBIC)"
PID: ESR-1GE           , VID: N/A , SN: CAB0445FP9U

NAME: "module 2/0", DESCR: "1 pt Gigabit Ethernet line card (requires a GBIC)"
PID: ESR-1GE           , VID: N/A , SN: CAB0432BM93

NAME: "RP B", DESCR: "Performance Routing Engine"
PID: ESR-PRE2          , VID: V01 , SN: CAT0844026A

NAME: "RP B flash card 0", DESCR: "Flash Card"
PID: ESR-PRE-MEM-FD128 , VID: N/A , SN: N/A        

NAME: "power-supply 0", DESCR: "AC power entry module for ESR10008"
PID: ESR-PWR-AC        , VID: N/A , SN: N/A        

NAME: "power-supply 1", DESCR: "AC power entry module for ESR10008"
PID: ESR-PWR-AC        , VID: N/A , SN: N/A        

NAME: "fan-tray", DESCR: "BLOWER ASSEMBLY FOR ESR10008"
PID: ESR-BLOWER        , VID: N/A , SN: N/A

 

NAS10k#show processes cpu sorted
CPU utilization for five seconds: 44%/13%; one minute: 49%; five minutes: 49%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  31    45098868  46041581        979 17.11% 14.87% 14.63%   0 ARP Input        
214    30304440   1231726      24603  4.23%  3.48%  3.40%   0 c10k_periodic_st 
216    47766780 142267177        335  3.03%  2.28%  2.13%   0 C10K Netflow Toa 
  51    40992284   2444896      16766  1.67%  3.83%  3.96%   0 Per-Second Jobs  
215     4275328    260944      16384  1.19%  0.57%  0.51%   0 STATS DMA Daemon 
300     1949704   2927662        665  0.63%  0.31%  0.29%   0 OSPF-1 Router    
143     4451876   9850703        451  0.47%  0.45%  0.44%   0 SSS Manager      
297     2731384   1477559       1848  0.39%  0.40%  0.37%   0 VTEMPLATE Backgr 
209     3433304   1965092       1747  0.39%  0.45%  0.45%   0 CEF: IPv4 proces 
293     3867352  62756768         61  0.31%  0.43%  0.43%   0 RADIUS           
134     3536552  46208615         76  0.23%  0.17%  0.17%   0 IP Input         
154     3410956  20259607        168  0.23%  0.39%  0.36%   0 SSM connection m 
280     6487852  54224910        119  0.23%  0.39%  0.45%   0 PPP Events       
182      264744    471433        561  0.15%  0.05%  0.04%   0 IP RIB Update    
278     2076980  12504856        166  0.15%  0.19%  0.20%   0 PPPoE Discovery  
131      490856  36438250         13  0.15%  0.11%  0.08%   0 ACCT Periodic Pr 
145      187536   2765863         67  0.07%  0.02%  0.00%   0 SSS Feature Mana 
  73       26592   2434544         10  0.07%  0.00%  0.00%   0 C10K OIR process 
130      531888   6772540         78  0.07%  0.12%  0.11%   0 AAA ACCT Proc    
129      687632   2147825        320  0.07%  0.08%  0.06%   0 AAA Server

 

Текущая загрузка:

 

6 тысяч сессий PPPoE, на одном интерфейсе - 900, на втором - 700 Мбит/с, 8 правил на сессию, загрузка - 90%. Подробности - на приведенных графиках. "show processes cpu sorted" - показано при загрузке 50% (не пиковой). Графики загрузки интерфейсов снимаем с Cisco76XX, т.к. snmp-счетчики на интерфейсах 10К - безбожно врут. (Тоже вопрос - почему?)

 

Вопрос: реально ли повысить производительность до 10 тысяч сессий путем настройки?

Что делаю не так или хочу невозможного?

 

 

post-255-1243484801_thumb.png

post-255-1243484810_thumb.png

post-255-1243484819_thumb.png

post-255-1243484823_thumb.png

Share this post


Link to post
Share on other sites

а чиво арп так много жрёт, может ктото флудит?

Так мне самому интересно, что он так много жрет! Как узнать то?

Share this post


Link to post
Share on other sites
Графики загрузки интерфейсов снимаем с Cisco76XX, т.к. snmp-счетчики на интерфейсах 10К - безбожно врут. (Тоже вопрос - почему?)
Тоже снимаю с коммутатора, но счётчики не врут, просто 10К отдаёт их через раз, а MRTG этого не любит...

ЗЫ. PRE-3

Share this post


Link to post
Share on other sites

На PRE2 без ISG думаю вполне реально получить до 32К сессий.

С ISG, где 3 сервиса на сессию фактический потолок где-то в районе 23К сессий.

ARP действительно что-то много жрет. Конфиг интерфейсов покажи.

Share this post


Link to post
Share on other sites
NAS10k#show processes cpu sorted
CPU utilization for five seconds: 44%/13%; one minute: 49%; five minutes: 49%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  31    45098868  46041581        979 17.11% 14.87% 14.63%   0 ARP Input

а такой вопрос: все ваши 6k пользователей из одного vlan'а приходят в ESR?

и еще - ADSL? (это чтоб не нужных вопросов не задавать)

 

Вопрос: реально ли повысить производительность до 10 тысяч сессий путем настройки?

Что делаю не так или хочу невозможного?

Вполне. На рельсы не лягу :) но ARP Input ведет себя не по джентльменски.

 

Share this post


Link to post
Share on other sites
а чиво арп так много жрёт, может ктото флудит?
Так мне самому интересно, что он так много жрет! Как узнать то?

можно порт отзеркалировать и сниффером поглядеть чекаво

Share this post


Link to post
Share on other sites
NAS10k#show processes cpu sorted
CPU utilization for five seconds: 44%/13%; one minute: 49%; five minutes: 49%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  31    45098868  46041581        979 17.11% 14.87% 14.63%   0 ARP Input

а такой вопрос: все ваши 6k пользователей из одного vlan'а приходят в ESR?

и еще - ADSL? (это чтоб не нужных вопросов не задавать)

 

Не ADSL - FTTH. Соответственно VLAN'ов много. Реально - несколько сотен.
Вопрос: реально ли повысить производительность до 10 тысяч сессий путем настройки?

Что делаю не так или хочу невозможного?

Вполне. На рельсы не лягу :) но ARP Input ведет себя не по джентльменски.

Arp смотрим.

Share this post


Link to post
Share on other sites

кстати, мне тут старшие товарищи доступно объяснили, что я мудак, в том плане, что парюсь по поводу pptp. В винде ведь автоматом выбирается юзать pptp или l2tp, поэтому при замене 7301 на десятитонник для виндовых клиентов ничего не изменится, пострадают лишь линуксоиды и владельцы роутеров, которых в основной массе можно будет за пару дней работы техподдержки пересадить на l2tp.

Share this post


Link to post
Share on other sites

interface Loopback0
ip address 10.254.254.254 255.255.255.0
!
interface GigabitEthernet1/0/0
description Inet
ip address 217.25.208.166 255.255.255.252
no ip proxy-arp
negotiation auto
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet2/0/0
no ip address
no ip proxy-arp
ip route-cache policy
negotiation auto
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet2/0/0.2000
encapsulation dot1Q 2000
no ip proxy-arp
pppoe enable group global
pppoe max-sessions 500
!
....................................................

interface GigabitEthernet2/0/0.2600
encapsulation dot1Q 2600
no ip proxy-arp
pppoe enable group global
pppoe max-sessions 500
!

 

т.е. всего на циске 600 вланов, не во всех работают пользователи, но в 3-4 сотнях точно,

 

NAS10k#show processes cpu sorted 
CPU utilization for five seconds: 81%/24%; one minute: 67%; five minutes: 68%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  31    49149860  47565954       1033 17.51% 19.68% 19.40%   0 ARP Input        
  51    42370276   2540532      16677 12.23%  5.62%  5.26%   0 Per-Second Jobs  
287     3177884    874612       3633  5.75%  0.76%  2.31%   0 SNMP ENGINE      
214    31465732   1255511      25062  4.55%  4.64%  4.57%   0 c10k_periodic_st 
  94    18544064   1185702      15639  4.23%  1.97%  1.93%   0 Compute load avg 
102    11438168    245201      46648  3.83%  1.96%  1.91%   0 HC Counter Timer 
216    51203584 148804855        344  2.95%  2.87%  2.82%   0 C10K Netflow Toa 
293     4015216  64141915         62  0.95%  0.62%  0.53%   0 RADIUS           
297     2848160   1537551       1852  0.95%  0.58%  0.48%   0 VTEMPLATE Backgr 
280     6829676  55158328        123  0.79%  0.63%  0.62%   0 PPP Events       
209     3581848   2007574       1784  0.55%  0.67%  0.66%   0 CEF: IPv4 proces 
134     3673416  47202833         77  0.31%  0.31%  0.31%   0 IP Input         
131      535120  37081646         14  0.31%  0.16%  0.19%   0 ACCT Periodic Pr 
301      109428     45036       2429  0.31%  0.05%  1.46%   2 Virtual Exec     
130      578436   7007859         82  0.23%  0.18%  0.20%   0 AAA ACCT Proc    
182      284792    489399        581  0.15%  0.07%  0.06%   0 IP RIB Update    
  93      596548  36307379         16  0.15%  0.02%  0.00%   0 Net Input        
154     3510328  20633834        170  0.15%  0.36%  0.34%   0 SSM connection m 
180      500284    149250       3351  0.15%  0.07%  0.06%   0 Hardware API bac 
143     4555600  10026402        454  0.07%  0.39%  0.36%   0 SSS Manager      
286       48336    802280         60  0.07%  0.00%  0.00%   0 PDU DISPATCHER   
285      186744   1606089        116  0.07%  0.01%  0.00%   0 IP SNMP          
279      182360  41502654          4  0.07%  0.01%  0.00%   0 PPP manager      
125       31484    265036        118  0.07%  0.02%  0.00%   0 ADJ resolve proc 
  89      184072   1001864        183  0.07%  0.04%  0.02%   0 DHCPD Receive    
  75      172912   3217169         53  0.07%  0.01%  0.00%   0 Flash Card Monit

 

вот такая вот ситуация с загрузкой процессора, на момент выполенения команды было 4к пользователей.... может кто чего подскажет?

Share this post


Link to post
Share on other sites

interface Virtual-Template1 
mtu 1492
ip unnumbered Loopback0
ip flow ingress
ip flow egress
no logging event link-status
no snmp trap link-status
random-detect 
keepalive 5
ppp mtu adaptive
ppp authentication chap callin
ppp ipcp dns 217.25.209.2 217.25.208.6

 

добавил в interface Virtual-Template1 команду no ip proxy-arp и теперь в выводе sh ip int в виртуал-акцесах Proxy ARP стало disabled а было enabled, Local Proxy ARP уже было в disabled

 

Virtual-Access4864 is up, line protocol is up
  Interface is unnumbered. Using address of Loopback0 (10.254.254.254)
  Broadcast address is 255.255.255.255
  Peer address is 94.137.14.157
  MTU is 1480 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is disabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF switching turbo vector
  IP CEF turbo switching turbo vector
  Associated unicast routing topologies:
        Topology "base", operation state is UP
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  Input features: iEdge
  Output features: iEdge, Post-Ingress-NetFlow

 

В загрузке проца изменений нет

 

NAS10k#show processes cpu sorted 
CPU utilization for five seconds: 66%/20%; one minute: 65%; five minutes: 65%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  31    49548636  47701985       1038 18.47% 17.15% 17.49%   0 ARP Input        
  51    42499684   2550623      16662 13.75%  5.90%  5.57%   0 Per-Second Jobs  
214    31578476   1257522      25111  4.63%  4.87%  4.83%   0 c10k_periodic_st 
216    51530740 149338855        345  3.19%  2.92%  2.97%   0 C10K Netflow Toa 
215     4454364    273024      16314  1.59%  0.76%  0.72%   0 STATS DMA Daemon 
297     2864664   1544422       1854  0.79%  1.34%  1.21%   0 VTEMPLATE Backgr 
209     3596608   2011294       1788  0.71%  0.70%  0.71%   0 CEF: IPv4 proces 
293     4029180  64259204         62  0.55%  0.58%  0.55%   0 RADIUS           
130      584052   7029799         83  0.55%  0.23%  0.22%   0 AAA ACCT Proc    
280     6868288  55232899        124  0.47%  0.55%  0.61%   0 PPP Events       
278     2124108  12731276        166  0.15%  0.13%  0.13%   0 PPPoE Discovery  
134     3681920  47267611         77  0.15%  0.28%  0.30%   0 IP Input

Share this post


Link to post
Share on other sites

Дак оно же вроде при изменении шаблона не сразу на всех Virtual-Access в силу вступает.

Share this post


Link to post
Share on other sites
Дак оно же вроде при изменении шаблона не сразу на всех Virtual-Access в силу вступает.

сразу!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this