Jump to content
Калькуляторы

HAP AC 2. Скорость WiFi в инет меньше чем по локалке

Добрый день, уважаемые форумчане!

 

Обновил себе дома старенький Hap lite на Hap AC2 чтобы пользоваться гигабитными портами и более скоростным wifi.

И не могу решить одну загадку.

У меня есть локальный NAS, подключенный в микрот по 1Гб порту. Есть макбук про, поддерживающий MIMO.

Микрот настроен на 5Г диапазон, мощность небольшая, все по учебнику. Вайфай бегает, ноут показывает 400 Мбит канальную скорость. Все ок.

Запускаю копирование большого файла с NAS на ноутбук. WiFi интерфейс на микротике показывает честные 200 Мбит. То есть, все хорошо, вайфай работает как надо.

Далее, включаю ноут кабелем в микрот, запускаю спитдест на провайдера. Скорость 95 Мбит на прием и отдачу. Провайдер дает 100 Мбит, так что тоже все честно.

Теперь главное - запускаю на ноуте, подключенном к тому же wifi что и для тестов по локалке, и включаю тот же спидтест - и получаю 40Мбит на прием и 95 на отдачу. 

Какого ?? Грешил на fast track. Пробовал включать/выключать. Никакой разницы. Сброс конфигов, настройка заново ничего не дали. Прошивка, естественно, самая свежая.

 

В итоге, я в тупике. Это не проблемы настройки wifi, ибо по локалке все бегает как надо. Это не проблемы провайдера, ибо он отдает все честно. Почему именно в цепочке wifi-интернет скорость падает, а в любых других вариантах все ок?

Целый день гугления не дал даже похожей темы где-то на форумах.

 

Так что, может кто подскажет разумную идею? 

 

Дмитрий

 

Share this post


Link to post
Share on other sites

убей все настройки файервола на микротике полным сбросом настроек, подними соединение до провайдера, маскардинг и проверь

Share this post


Link to post
Share on other sites
9 минут назад, chetkiyparen сказал:

убей все настройки файервола на микротике полным сбросом настроек, подними соединение до провайдера, маскардинг и проверь

Так я и работаю сейчас после полного сброса настроек. Правила файервола на дефолте.

 

[admin@MikroTik] > /ip firewall export 

# nov/09/2019 18:13:17 by RouterOS 6.45.7

# software id = P1BB-0WFQ

#

# model = RBD52G-5HacD2HnD

 

/ip firewall filter

add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked

add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid

add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp

add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1

add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN

add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec

add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec

add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related

add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked

add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid

add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN

/ip firewall nat

add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN

Share this post


Link to post
Share on other sites

я тебе и говорю убить эту дефолтную настройку полностью и настроить соединение и nat вручную. Полный сброс -  это когда при сбросе ставишь галочку на No Default Configuration !

Edited by chetkiyparen

Share this post


Link to post
Share on other sites
10 минут назад, chetkiyparen сказал:

я тебе и говорю убить эту дефолтную настройку полностью и настроить соединение и nat вручную. Полный сброс -  это когда при сбросе ставишь галочку на No Default Configuration !

 

Убил все, оставил один нат. Разницы никакой. 

 

# nov/09/2019 18:25:32 by RouterOS 6.45.7

# software id = P1BB-0WFQ

#

# model = RBD52G-5HacD2HnD

 

/ip firewall nat

add action=masquerade chain=srcnat  out-interface-list=WAN

Share this post


Link to post
Share on other sites

1. в ip filter и mangle  точно ничего нет? 

 

2. попробуй откатить на прошивку long-term 6.44.6, чтобы исключить косяки в прошивке... на 6.44.6 такой проблемы не замечал точно

 

3. отрубить все устройства от микротика, кроме ноута для теста, т.к. по локалке бриджа может летать трафик, который может на это повлиять

 

Share this post


Link to post
Share on other sites
17 минут назад, chetkiyparen сказал:

1. в ip filter и mangle  точно ничего нет? 

 

2. попробуй откатить на прошивку long-term 6.44.6, чтобы исключить косяки в прошивке... на 6.44.6 такой проблемы не замечал точно

 

3. отрубить все устройства от микротика, кроме ноута для теста, т.к. по локалке бриджа может летать трафик, который может на это повлиять

 

1. Там только одно правило маскарадинга и все. Остальные удалены. Специально просканил себя из мира - роутер голый светится всеми портами

2. MikroTik RouterOS 6.44.6 (c) 1999-2019  Откатил. 

3. Вырубил все.

 

Изменений никаких... :( Мистика. 

Share this post


Link to post
Share on other sites
7 минут назад, dtep сказал:

1. Там только одно правило маскарадинга и все. Остальные удалены. Специально просканил себя из мира - роутер голый светится всеми портами

2. MikroTik RouterOS 6.44.6 (c) 1999-2019  Откатил. 

3. Вырубил все.

 

Изменений никаких... :( Мистика. 

настройки wi-fi в студию и скрины состояния с подключенным клиентом-ноутом и что там с mtu ?

Edited by chetkiyparen

Share this post


Link to post
Share on other sites
2 минуты назад, chetkiyparen сказал:

настройки wi-fi в студию

/caps-man channel

add band=2ghz-g/n control-channel-width=20mhz name=2G tx-power=12

add band=5ghz-n/ac control-channel-width=20mhz extension-channel=Ceee name=5G tx-power=12

/caps-man datapath

add bridge=bridge client-to-client-forwarding=yes local-forwarding=yes name=datapath1

/caps-man security

add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=security1 passphrase=12345

/caps-man configuration

add channel=2G country=ukraine datapath=datapath1 distance=indoors hw-protection-mode=rts-cts installation=indoor mode=ap name=Config_2G rx-chains=0,1,2,3 security=security1 ssid=AP_106 tx-chains=0,1,2,3

add channel=5G country=ukraine datapath=datapath1 distance=indoors installation=indoor mode=ap name=Config_5G rx-chains=0,1,2,3 security=security1 ssid=AP5_106 tx-chains=0,1,2,3

/caps-man manager

set enabled=yes

/caps-man manager interface

add disabled=no interface=ether2

add disabled=no interface=ether3

add disabled=no interface=bridge

add disabled=no interface=ether4

add disabled=no interface=ether5

/caps-man provisioning

add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=Config_2G

add action=create-dynamic-enabled hw-supported-modes=an master-configuration=Config_5G

 

/interface wireless

# managed by CAPsMAN

# channel: 2452/20-Ce/gn(12dBm), SSID: AP_106, local forwarding

set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX disabled=no distance=indoors frequency=auto installation=indoor mode=ap-bridge ssid=MikroTik-E5DFE1 wireless-protocol=802.11

# managed by CAPsMAN

# channel: 5180/20-Ceee/ac(12dBm), SSID: AP5_106, local forwarding

set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=ukraine disabled=no frequency-mode=regulatory-domain hw-protection-mode=rts-cts mode=ap-bridge ssid=MikroTik tx-power-mode=all-rates-fixed

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=12345

/interface wireless cap

# 

set bridge=bridge caps-man-addresses=127.0.0.1 enabled=yes interfaces=wlan1,wlan2

Share this post


Link to post
Share on other sites

а откуда капсман, если только один роутер hap ac2 ?

Share this post


Link to post
Share on other sites
11 минут назад, chetkiyparen сказал:

а откуда капсман, если только один роутер hap ac2 ?

Что за прикол.. Похоже, новичкам на форуме ограничение по числу сообщений? Хотя нигде в правилах этого нет..

 

Я и не говорил что роутер один ;) У меня было три hap light разбросанные по квартире, так как одна точка не пробивала через толстые стены. Сейчас я light заменил на ac2 чтобы можно было до гигабита проапгрейдиться. Проблема с низкой скоростью была и раньше, но я все грешил что это старые роутеры, которые просто не тянули даже на 5Г нормально ничего.

 

Что касается настроек, то после замены роутера, я и с капсманом и без него тестировал. Эффект тот же самый. 

Вот настройки без капсмана. Работает только интерфейс 5G.  Эффект по скорости точно такой же. 

 

/interface bridge

add admin-mac=74:4D:28:E5:DF:DD auto-mac=no comment=defconf name=bridge

 

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX distance=indoors frequency=auto installation=indoor mode=ap-bridge ssid=MikroTik-E5DFE1 wireless-protocol=802.11

set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=ukraine disabled=no frequency=auto frequency-mode=regulatory-domain hw-protection-mode=rts-cts installation=indoor mode=ap-bridge ssid=MikroTik \

    tx-power-mode=all-rates-fixed

/interface list

add comment=defconf name=WAN

add comment=defconf name=LAN

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=12345

/interface bridge port

add bridge=bridge comment=defconf interface=ether2

add bridge=bridge comment=defconf interface=ether3

add bridge=bridge comment=defconf interface=ether4

add bridge=bridge comment=defconf interface=ether5

add bridge=bridge comment=defconf interface=wlan1

add bridge=bridge comment=defconf interface=wlan2

/interface list member

add comment=defconf interface=bridge list=LAN

add comment=defconf interface=ether1 list=WAN

 

Share this post


Link to post
Share on other sites

1. если есть возможность протесть через другое устройство, кроме ноута

2. спектрал скан сделай, и поиграйся с частотами, выставляя вручную

3. оставь только режим N/AC в настройках

4. скрины скинь wireless registration

Share this post


Link to post
Share on other sites
2 часа назад, chetkiyparen сказал:

1. если есть возможность протесть через другое устройство, кроме ноута

2. спектрал скан сделай, и поиграйся с частотами, выставляя вручную

3. оставь только режим N/AC в настройках

4. скрины скинь wireless registration

Тестил еще с телефона. Galaxy Note 8. Таблица регистрации ниже. Видно что канальная скорость и там и там хорошая.

С частотами игрался, становилось только хуже. Сейчас канал оптимальный. 

image.thumb.png.52fbffb75e7db8dc685798d370f713f9.png

 

Опять же, вопрос в том, что чисто вайфай с файлами по локалке работает на хорошей скорости. Тут какая то проблема при выходе с вайфая во внешний мир. Действительно, похоже на файервол, но отключение всех правил ничего не меняет. 

Как вариант, попробую как будет время, сделать из второго микрота еще один роутер, а эту железку воткнуть в него. Чтобы зайти на хранилку через роутер, и проверить какая будет в этом случае скорость. То есть, проверю роутер и файервол, но без реального интернета. 

Share this post


Link to post
Share on other sites

Для начала воткните вместо микротика вообще что-то другое. Так хоть будет понятно проблема в микротике или вовсе не в нём.

А то так и будете "долго искать чёрную кошку в тёмной комнате...".

Share this post


Link to post
Share on other sites
10 часов назад, sdy_moscow сказал:

Для начала воткните вместо микротика вообще что-то другое. Так хоть будет понятно проблема в микротике или вовсе не в нём.

А то так и будете "долго искать чёрную кошку в тёмной комнате...".

Так подключал другие роутеры. В чем и загадка. Нет проблем с интернет каналом, нет проблем с клиентскими устройствами. 

Проблема исключительно на стыке wifi и выхода в интернет с микрота. 

По локалке wifi работает на максимуме, по проводу интернет канал работает на максимуме. А с wifi выхожу в интернет - и режет именно вход. Причем на графике интерфейса микрота четко видна полочка в 60 Мбит. Как будто шейпер какой-то работает. 

Share this post


Link to post
Share on other sites
1 час назад, d_tep сказал:

... Так подключал другие роутеры ....

Без микротиков в цепочке? И какие результаты? Если то-же самое (есть проблемы), то при чем тут настройки микротика? Копайте в сторону размера пакетов, качества связи, настроек протоколов, сниферните трафик "до" и "после".

Share this post


Link to post
Share on other sites
2 часа назад, sdy_moscow сказал:

Без микротиков в цепочке? И какие результаты? Если то-же самое (есть проблемы), то при чем тут настройки микротика? Копайте в сторону размера пакетов, качества связи, настроек протоколов, сниферните трафик "до" и "после".

Нет, при установке другого роутера вместо микрота, по цепочке: Ноут (вайфай) -> Интернет, все работает стабильно. Ноут показывает честные 100 Мбит. 

Опять же, если бы была проблема с вайфай, то у меня скорость была бы плохой хоть при выходе в интернет, хоть при работе с локальной хранилкой. Загрузка же с  хранилки отдает 250 Мбит без проблем. А в интернет 60 максимум. То есть, не похоже на то, что проблемы с радио частью. 

 

Share this post


Link to post
Share on other sites
19 часов назад, dtep сказал:

/caps-man manager interface

add disabled=no interface=ether2

add disabled=no interface=ether3

add disabled=no interface=bridge

add disabled=no interface=ether4

add disabled=no interface=ether5

 

19 часов назад, d_tep сказал:

/interface bridge port

add bridge=bridge comment=defconf interface=ether2

add bridge=bridge comment=defconf interface=ether3

add bridge=bridge comment=defconf interface=ether4

add bridge=bridge comment=defconf interface=ether5

Если все порты в бридже то зачем capsman искать на каждом порту отдельно оставьте только искать в бридже 

/caps-man manager interface

add disabled=no interface=bridge 

А еще лучше вообще настроить по IP

 

Копайте в сторону MTU у Вас в локалке и у провайдера он разный. Вероятно у провайдера чуть меньше посмотрите на вкладке Interface list. 

 

PS Что бы исключить радиочасть смотрим на параметры подключения в момент теста скорости, если нет провала то радио не причем. (При условии что в цепочке это единственный радиоканал.)

При Capsman ширину канала выбирать только 20 в 2.4G и 20/40 в 5G и при этом все устройства на каналах 1-6-11 или им подобных не пересекающихся тройках.

Edited by Корпич

Share this post


Link to post
Share on other sites
6 часов назад, Корпич сказал:

 

Если все порты в бридже то зачем capsman искать на каждом порту отдельно оставьте только искать в бридже 

/caps-man manager interface

add disabled=no interface=bridge 

А еще лучше вообще настроить по IP

 

Копайте в сторону MTU у Вас в локалке и у провайдера он разный. Вероятно у провайдера чуть меньше посмотрите на вкладке Interface list. 

 

PS Что бы исключить радиочасть смотрим на параметры подключения в момент теста скорости, если нет провала то радио не причем. (При условии что в цепочке это единственный радиоканал.)

При Capsman ширину канала выбирать только 20 в 2.4G и 20/40 в 5G и при этом все устройства на каналах 1-6-11 или им подобных не пересекающихся тройках.

 

Капсман я уже убрал, настроил все просто на интерфейсе, так как нашел обсуждения, где упоминалось возможное влияние капсмана на скорость.

С радио перебрал кучу параметров. Сейчас у меня стоят наиболее оптимальные, потому что другие частоты или параметры только снижали скорость загрузки.

 

МTU проверил. У провайдера 1500. В микроте везде 1500. Тест пингами также показал, что по локалке, в интернет, с вайфая или провода везде одно и то же значение. MTU было бы логичным объяснением, но оно одинаковое. 

Share this post


Link to post
Share on other sites
12 минут назад, sdy_moscow сказал:

Попробуйте уменьшить MTU.

1450. Разницы никакой. 

1400 скорость упала до 40 Мбит.. :( 

Share this post


Link to post
Share on other sites

вы сбрасывали роутер с удалением дефолтных настроек или просто выключили правила в файерволе?

Share this post


Link to post
Share on other sites

@d_tep 

Однопоточный спидтест по кабелю равен многопоточному ?

Share this post


Link to post
Share on other sites
10 часов назад, chetkiyparen сказал:

вы сбрасывали роутер с удалением дефолтных настроек или просто выключили правила в файерволе?

Сбрасывал на дефолтные настройки, но при тестах пробовал и удалять правила целиком, и потом просто отключать их. 

Цитата


Однопоточный спидтест по кабелю равен многопоточному ?

 

Да, равен. 

Share this post


Link to post
Share on other sites

Между локальным трафиком и интернетом всего одна разница - NAT. Попробуйте для теста разнести задачи - wifi на одном микротике, а NAT на другом, через провод. Как говорил один небезызвестный человек на форуме - нужно больше микротиков. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this