Jump to content
Калькуляторы

Mikrotik CCR1072 PPPoE QinQ

Добрый день!
Стоит задача заменить циску на микротик, но всплывают нюансы :)

Сейчас на циске есть несколько интерфейсов для терминации клиентов, используя qinq, с настройками типа:
interface GigabitEthernet0/1.100

encapsulation dot1Q 100 second-dot1q 1-2000


Коллеги, подскажите как на микротике реализовать подобную терминацию?
 

Share this post


Link to post
Share on other sites

Может так?:

 

/interface vlan
add name=vlan1 vlan-id=11 interface=ether1
add name=vlan2 vlan-id=12 interface=vlan1

Share this post


Link to post
Share on other sites

Кофе попил на дне предсказание ТС хочет поднять IPoE QnQ на микротике.

 

З.Ы. Костыли и скрипты. 

Share this post


Link to post
Share on other sites
10 hours ago, maxkst said:

Может так?:

 


/interface vlan
add name=vlan1 vlan-id=11 interface=ether1
add name=vlan2 vlan-id=12 interface=vlan1

С одним вторым тегом всё понятно, но это получается тысячи интерфейсов.
Мне надо диапазон...

Share this post


Link to post
Share on other sites

Делайте тысячу интерфейсов, все будет отлично работать.

 

Думаете циска как-то по другому работает? Она так же все это создает, только внутри себя.

Share this post


Link to post
Share on other sites
29 minutes ago, Saab95 said:

Делайте тысячу интерфейсов, все будет отлично работать.

 

Думаете циска как-то по другому работает? Она так же все это создает, только внутри себя.

Вот я и хотел, чобы микротик сам создал эти интерфейсы :)
Я так понял дургих вариантов нет, только создавать каждый интерфейс.

Share this post


Link to post
Share on other sites

нужно поставить больше микротиков (с)

Share this post


Link to post
Share on other sites

@PashaNN С циской не работал на Juniper можно сделать автоматическое создание влана(и qnq) и выдачу IP клиенту через demux интерфейс.  В большинстве билингов такого фунционала нет, собирают через костыли(по крайней мере, что мне известно) 

 

На микротике такого функционала нет. Либо все пилить статикой, либо скрипты. 

Share this post


Link to post
Share on other sites
5 часов назад, PashaNN сказал:

Вот я и хотел, чобы микротик сам создал эти интерфейсы :)
Я так понял дургих вариантов нет, только создавать каждый интерфейс.

Делаете в екселе или блокноте список команд с вланами

 

/interface vlan
add arp=reply-only interface=bridge_vlan name=vlan_2 vlan-id=2
add arp=reply-only interface=bridge_vlan name=vlan_3 vlan-id=3
/ip pool
add name=dhcp_pool_2 ranges=10.11.12.2
add name=dhcp_pool_3 ranges=10.11.12.3
/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool_2 disabled=no interface=vlan_2 lease-time=5m name=dhcp_2
add add-arp=yes address-pool=dhcp_pool_3 disabled=no interface=vlan_3 lease-time=5m name=dhcp_3
/ip address
add address=10.11.12.1 interface=vlan_2 network=10.11.12.2
add address=10.11.12.1 interface=vlan_3 network=10.11.12.3
/ip dhcp-server network
add address=10.11.12.0/24 dns-server=17.1.0.2,17.1.0.3 gateway=10.11.12.1

/system scheduler
add name=vlans on-event=":foreach i in=[/interface vlan find] do={/interface vlan disable \$i}\r\
    \n\r\
    \n:foreach i in=[/interface vlan find] do={/interface vlan enable \$i}\r\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup

Вланы лучше лепить не на интерфейс, а на бридж. Так всегда можно легко менять интерфейсы, не трогая настройки тысяч вланов, создавать какие-то фильтры, если нужно.

Такая схема отлично работает, если не забыть добавить скрипт включения и выключения вланов при загрузки. Естественно ограничения скорости идут отдельно. Нормально работает и на 1000, и на 2000, и на 5000 вланах.

Share this post


Link to post
Share on other sites
6 часов назад, Saab95 сказал:

Вланы лучше лепить не на интерфейс, а на бридж. Так всегда можно легко менять интерфейсы, не трогая настройки тысяч вланов, создавать какие-то фильтры, если нужно.

Хорошая подсказка, надо взять на заметку. А это не отразится негативно на CPU LOAD??

Share this post


Link to post
Share on other sites

@PashaNN посмотрите в сторону accel-ppp, микротик в качестве браса - крайне плохая затея

Share this post


Link to post
Share on other sites

@EShirokiy все зависит от модели сети если у тебя каждый кусок сети далеко и находится на расстоянии 1к+ км прозодит, через пачку свичей мплс двдм и т.д. выгодно(по деньгам) поставить 1036 настроить и забыть 300-500 клиентов без ната норм + нетфлоу удобный

 

Share this post


Link to post
Share on other sites
5 часов назад, pingz сказал:

@EShirokiy все зависит от модели сети если у тебя каждый кусок сети далеко и находится на расстоянии 1к+ км прозодит, через пачку свичей мплс двдм и т.д. выгодно(по деньгам) поставить 1036 настроить и забыть 300-500 клиентов без ната норм + нетфлоу удобный

 

Я наверно один тягаю в радиусе 200км в центр абонов :) MPLS в МТ за 170 баксов для резервирования L2(это если есть 2 путя). Все вланы тянутся в центр на пару брасов на акселе с ценником 300 баксов каждый.  Накой вы среду передачи(двдм) приплели к другим уровням - для меня загадка :) 300-500 клиентов терминировать на железке в 700 баксов? кхм. Богатый вы человек.... Я тут в шейпинг на чистом НАТе уперся на серваке за 300 баксов. 2К онлайна, все НАТ. После 3,5Гб начинают плавать пинги и скорость. А вы предлагаете за 700 бачей терменировать 500 абонов без НАТа.

Edited by TriKS

Share this post


Link to post
Share on other sites

@pingz так можно поднять на 1009 мплс и отправить на центральный узел, гигабит 5 прожуёт

Share this post


Link to post
Share on other sites
11 минут назад, EShirokiy сказал:

так можно поднять на 1009 мплс и отправить на центральный узел, гигабит 5 прожуёт

Зачем? Можно 3011. Можно вообще на РБэхах. От кол-ва трафла зависит в конкретном селе. Шаровой MPLS - наверное единственная классная весч в поделках МТ

Edited by TriKS

Share this post


Link to post
Share on other sites
11 часов назад, EShirokiy сказал:

посмотрите в сторону accel-ppp, микротик в качестве браса - крайне плохая затея

Микротик можно за 10-15 минут настроить и все. А связываться с серверами, линуксом и прочим - на любителя. И не всегда быстрее по производительности. Для новичков так и вообще темный лес.

 

26 минут назад, TriKS сказал:

Я наверно один тягаю в радиусе 200км в центр абонов :) MPLS в МТ за 170 баксов для резервирования L2(это если есть 2 путя). Все вланы тянутся в центр на пару брасов на акселе с ценником 300 баксов каждый. 

Это какая-то дикая схема. Тут многие любят продвигать схемы за копейки на б/у оборудовании, б/у сервера, б/у коммутаторы и т.п. Но не все операторы стремятся работать со старым барахлом, многие покупают только новое оборудование и ставят его на баланс.

 

И зачем тянуть все по L2 в центр (кроме pppoe), если можно абонентов терминировать рядом с их точкой подключения?

Share this post


Link to post
Share on other sites

@TriKS у меня на rb750gr3 ходит до 400 мегабит трафика, на 3011 до гигабита думаю вытянет. В целом соглашусь, что мплс на микротах хорошая вещь, не без недостатков конечно. 

Share this post


Link to post
Share on other sites
1 час назад, Saab95 сказал:

Это какая-то дикая схема.

Дикая схема - это 1036 в село для 300-500 абонов без НАТа.

а так в селе стоит ОЛТ, стоит свич и стоит МТ для VPLS. Приходит 2 канала опты, ну или один оптой, другой релейкой.

Давай сюда схему, что выйдет дешевле предложенной мной с резервированием по 2-м каналам, в кольце по опте 5-7 сел, в каждом 100-500 абонов.

1 час назад, EShirokiy сказал:

на 3011 до гигабита думаю вытянет

В порт быстрее упрется. Как упрется воткнешь 4011 с SFP+.

 

1 час назад, Saab95 сказал:

И зачем тянуть все по L2 в центр (кроме pppoe), если можно абонентов терминировать рядом с их точкой подключения?

Нахуя? Чтоб впарить пачку ССР по 700 баксов? Да не, болейте сами.

Настроили МПЛС, 2 влана в кольце. В эти вланы на микроте заворачиваешь вланы с qnq. Все. Но это нужно в голову не только кушать. И не надо ексели с недоскриптами для cvlan. А всего пару строк regexp :)

Не болейте.

Edited by TriKS

Share this post


Link to post
Share on other sites

Что мешает в каждом селе перед OLT поставить микротик вида 3011, 4011 или что-то с нужной производительностью, на OLT завести вланы на подключенных клиентов, и эти же вланы сразу терминировать на локальном микротике - выдать абонентам IP адреса, без ната и шейперов. Анонсируете маршруты через OSPF, далее подключаете какие угодно каналы и в центр, и в кольцо, да куда угодно, все будет отлично работать. Более всего - если 2 или 3 канала, то трафик сам распределиться, если правильно веса маршрутов настроить.

 

Из плюсов такой схемы полностью идентичные конфигурации OLT и микротиков перед ними, с раздачей вланов с номера 2 и выше. В центре работа только с IP абонентов. Легкое резервирование центрального узла, т.к. можно сливать абонентский трафик в интернет в любом месте сети. Не обязательно его в единый центр тащить.

Share this post


Link to post
Share on other sites

Ну-ну. Поставил. А 2 оптики куда пхать в 3011\4011? В жопу? :)

 

Зачем это велосипед с локальной терминацией? Чтоб обслужить мульон поделок? А еще и метрики с них снимать костылями? А потом еще и ОСПФ развалилось? Кстати, что там микротик с BGP-MPLS? Никак? Конечно никак. Да ну в пень. А так балалайка просто паеты перикидывает и алилуя. Упирается обычно тупо в порт. Никаких тебе причуд от литовцев.

А вот если с ипишками не сложилось, да и не нужны они особо, НАТ вполне устраивает, что тогда? Не натить, ибо нат - устаревшая технология?

 

Из минусов - дрочилово с тыщами абонвланов. Ай, забыл. qinq - устаревшая технология.

 

Edited by TriKS

Share this post


Link to post
Share on other sites
11 минут назад, TriKS сказал:

что там микротик с BGP-MPLS

Работает, но MTU 1500 на VPLS всё портит)

Share this post


Link to post
Share on other sites

@EShirokiy  мне и с OSPF нормально. Вы пробовали на 1к+ км через mpsl гонять трафик pppoe? 

Share this post


Link to post
Share on other sites
3 часа назад, pingz сказал:

Вы пробовали на 1к+ км через mpsl гонять трафик pppoe? 

Конкретно PPPoE не гонял, но гоняю vlan-per-user на 80+ км, проблем не вижу

Share this post


Link to post
Share on other sites

@EShirokiy Есть небольшое наблюдение, когда через mpls(в моем случае чужой и расстояние 1к(Карл 1000)+ км)  гоняешь трафик pppoe(это у нас чистый L2 если я не ошибаюсь) то наблюдается такая проблема. 

 

Пример не из лучших пакет отправленные первый приходит позже второго. Выглядит на примере игры CS выпущено 5 пуль, но попали всего 3. 

 

З.Ы. сейчас схема клиент --- pppoe---- mikrotik----ospf ---- чужой mpls----  шлюз 

Share this post


Link to post
Share on other sites

Ну 21-й век на дворе. Зачем pppoe? А вообще - траблшутить. Может пакеты по "чужой mpls" просто бегут разными путями?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this