Jump to content
Калькуляторы

Mikrotik редистрибуция RIP-маршрутов через OSPF с использованием VRF

Всем здравия!

Собственно проблема: нужно настроить на микротике связку: RIP->OSPF (VRF). На схеме все роутеры соединены между собой IPIP-туннелями. Между роутерами R1-R2-R3 поднят RIP, там управляет другой админ, R4 - мой роутер. Поскольку адресное пространство одинаково. понимаю, что необходимо использовать VRF, причем делать несколько OSPF-инстансов, каждый из которых будет работать для своей VRF-таблицы. Мне необходимо сделать доступ ксетям, обслуживаемыми роутерами R1-R2-R3. Ссылки на разбор соответствующих примеров приветствуются.

 

network.thumb.jpg.0fde4400176cc1b77dd762e7d55e47d7.jpg

Edited by pin

Share this post


Link to post
Share on other sites

Дык, а что не получается то? Вы все правильно расписали. Запихиваете это все в отдельный псевдо-ВРФ на микротике и фперед, в чем проблема?

Share this post


Link to post
Share on other sites
29 минут назад, VolanD666 сказал:

Дык, а что не получается то? Вы все правильно расписали. Запихиваете это все в отдельный псевдо-ВРФ на микротике и фперед, в чем проблема?

 Со стороны R4 все пучком - маршруты появляются в отдельной VRF, со стороны R1-R2-R3 моя сетка не анонсится, естественно, под это дело выделена другая  сеть - 192.168.24.0/24 и она прописана в OSPF

Со стороны R4:

/ip route vrf
add interfaces=ipip-tunnel16 routing-mark=VRF1_r

/routing ospf instance
set [ find default=yes ] redistribute-other-ospf=as-type-1 use-dn=no
add name=ospf1 redistribute-other-ospf=as-type-1 router-id=10.1.4.1 routing-table=VRF1_r use-dn=no

/routing ospf area
.....
add area-id=192.168.24.0 instance=ospf1 name=vrf-area1

/ip address export
/ip address
....
add address=192.168.24.1/24 comment="VRF1" interface=vlan24 network=192.168.24.0
add address=10.1.4.1/30 interface=ipip-tunnel16 network=10.1.4.0

Вопрос в том, что нужно прописать со стороны R2? Конфиг R2 могу выложить только завтра

Share this post


Link to post
Share on other sites

ИМХО, в данной схеме для R4 имеет смысл маску поуже сделать: /21 --> /22.

(Если конечно где-то подсети 192.168.4.0/24 --:-- 192.168.7.0/24 не прилеплены).

Меньше места для бродкаста.

Edited by DAF

Share this post


Link to post
Share on other sites
7 часов назад, DAF сказал:

ИМХО, в данной схеме для R4 имеет смысл маску поуже сделать: /21 --> /22.

(Если конечно где-то подсети 192.168.4.0/24 --:-- 192.168.7.0/24 не прилеплены).

Меньше места для бродкаста.

К сожалению, подсети используются вплоть до 192.168.6.0/24, Вообще, надо бы уходить уже в диапазон 172.16.0.0/21, но по политическим причинам это сделать пока не удается.

Конфиг роутера R2:

/routing ospf instance
set [ find default=yes ] redistribute-other-ospf=as-type-1 router-id=10.1.2.58
add name=vrf-ospf1 redistribute-other-ospf=as-type-1 redistribute-rip=as-type-1 router-id=10.1.4.2 use-dn=no

/routing ospf area
add area-id=192.168.24.0 instance=vrf-ospf1 name=VRF1_area

/routing ospf network
add area=VRF1_area network=192.168.1.0/24
add area=VRF1_area=10.1.4.0/30

/ip address
....
add address=192.168.1.1/24 interface=bridge-local network=192.168.1.0
add address=10.1.4.2/30 interface=ipip-tunnel3 network=10.1.4.0

 

Share this post


Link to post
Share on other sites

Конечно: point-to-point, проблема в том, что как только со стороны R4 помещаешь интерфейс туннеля в VRF, то у него маршруты появляются, но пропадают со стороны R2, а если не ставить интерфейс в VRF, то наоборот, сетка 192.168.24/0 появляется в маршрутах на R1-R2-R3,но на R4 их сети пропадают

Share this post


Link to post
Share on other sites

Можно больше контекста? 

 

@pin  Это оператор?

Если да тип подключения клиентов? 

Share this post


Link to post
Share on other sites

Это не оператор, просто партнер по бизнесу, возникла необходимость добираться до ресурсов их сетей (port-forwarding не предлагать!!!!), WAN'ы всех роутеров подключены по оптике через медиаконвертеры, провайдер везде один и тот же. Что еще интересует?

Share this post


Link to post
Share on other sites

@pin Есть правила игры в OSPF, если интерфейсы собраны тунелями то работает LSA 1.

ИМХО для начала, нужно разные IP пулы. Да больно, но будет потом в разы проще. 

Можно выхлоп увидеть. 

ip route print

routing ospf route print

Share this post


Link to post
Share on other sites

Пулы поменять, по крайней мере до конца года не реально, задачу надо решить как можно быстрее.

R4:

 /ip route print       
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  10.0.2.8/30                        10.1.4.2                110
 1 ADC  10.1.4.0/30        10.1.4.1        ipip-tunnel16             0
 2 ADo  192.168.0.0/24                     10.1.4.2                110
 3 ADo  192.168.1.0/24                     10.1.4.2                110
 4 ADo  192.168.2.0/24                     10.1.4.2                110
.......
19 ADC  10.1.1.254/32      10.1.1.1        <l2tp-pin>                0
20 ADC  10.1.2.0/30        10.1.2.1        ipip-tunnel1              0
21 ADC  10.1.2.4/30        10.1.2.5        ipip-tunnel2              0
22 ADC  10.1.2.8/30        10.1.2.9        ipip-tunnel3              0
23 ADC  10.1.2.12/30       10.1.2.13       ipip-tunnel4              0
24 ADC  10.1.2.16/30       10.1.2.17       ipip-tunnel10             0
25 ADC  10.1.2.20/30       10.1.2.21       ipip-tunnel6              0
26 ADC  10.1.2.24/30       10.1.2.25       ipip-tunnel5              0
27 ADC  10.1.2.28/30       10.1.2.29       ipip-tunnel8              0
28 ADC  10.1.2.32/30       10.1.2.33       ipip-tunnel9              0
29 ADC  10.1.2.36/30       10.1.2.37       ipip-tunnel11             0
30 ADC  10.1.2.40/30       10.1.2.41       ipip-tunnel12             0
31 ADC  10.1.2.44/30       10.1.2.45       ipip-tunnel13             0
32  DC  10.1.2.48/30       10.1.2.49       ipip-tunnel14           255
33 ADC  10.1.2.52/30       10.1.2.53       ipip-tunnel15             0
34 ADo  10.1.3.0/30                        10.1.2.18               110
35 ADo  10.1.3.4/30                        10.1.2.18               110
36 ADo  10.1.3.8/30                        10.1.2.2                110
                                           10.1.2.18         
37 ADo  10.1.3.12/30                       10.1.2.6                110
                                           10.1.2.18         
38 ADo  10.1.3.16/30                       10.1.2.22               110
                                           10.1.2.18         
39 ADo  10.1.3.20/30                       10.1.2.10               110
                                           10.1.2.18         
40 ADo  10.1.3.24/30                       10.1.2.18               110
41 ADo  10.1.3.32/30                       10.1.2.18               110
42 ADC  10.1.6.0/24        10.1.6.1        vlan1016                  0
43 ADo  10.1.7.1/32                        10.1.2.18               110
44 ADo  10.1.7.2/32                        10.1.2.18               110
45 ADo  10.2.0.0/30                        10.2.0.85               110
46 ADo  10.2.0.4/30                        10.2.0.85               110
47 ADo  10.2.0.12/30                       10.2.0.85               110
48 ADo  10.2.0.16/30                       10.2.0.85               110
49 ADo  10.2.0.20/30                       10.2.0.85               110
50 ADo  10.2.0.24/30                       10.2.0.85               110
51 ADo  10.2.0.28/30                       10.2.0.85               110
52 ADo  10.2.0.32/30                       10.2.0.85               110
53 ADo  10.2.0.36/30                       10.2.0.85               110
54 ADo  10.2.0.40/30                       10.2.0.85               110
55 ADo  10.2.0.44/30                       10.2.0.85               110
56 ADo  10.2.0.48/30                       10.2.0.85               110
57 ADo  10.2.0.52/30                       10.2.0.85               110
58 ADo  10.2.0.56/30                       10.2.0.85               110
59 ADo  10.2.0.60/30                       10.2.0.85               110
60 ADo  10.2.0.64/30                       10.2.0.85               110
61 ADo  10.2.0.68/30                       10.2.0.85               110
62 ADo  10.2.0.72/30                       10.2.0.85               110
63 ADo  10.2.0.76/30                       10.2.0.85               110
64 ADo  10.2.0.80/30                       10.2.0.85               110
                                           10.1.2.10         
65 ADC  10.2.0.84/30       10.2.0.86       ipip-tunnel7              0
66 ADo  10.2.0.88/30                       10.2.0.85               110
                                           10.1.2.18         
67 ADo  10.2.0.92/30                       10.2.0.85               110
68 ADo  10.2.0.100/30                      10.2.0.85               110
69 ADo  10.2.0.104/30                      10.2.0.85               110
70 ADo  10.2.0.108/30                      10.2.0.85               110
71 ADo  10.2.0.112/30                      10.2.0.85               110
72 ADo  10.2.0.116/30                      10.2.0.85               110
........
84 A S  172.16.100.0/22                    172.16.0.12               1
85 ADo  172.17.0.0/28                      10.2.0.85               110
86 ADo  172.17.1.0/24                      10.2.0.85               110
87 ADo  172.17.2.0/26                      10.2.0.85               110
88 ADo  172.17.4.0/26                      10.2.0.85               110
89 ADo  172.17.5.0/26                      10.2.0.85               110
90 ADo  172.17.6.0/26                      10.2.0.85               110
91 ADo  172.17.7.0/26                      10.2.0.85               110
92 ADo  172.17.8.0/26                      10.2.0.85               110
93 ADo  172.17.9.0/26                      10.2.0.85               110
94 ADo  172.17.10.0/26                     10.2.0.85               110
95 ADo  172.17.11.0/26                     10.2.0.85               110
96 ADo  172.17.12.0/26                     10.2.0.85               110
97 ADo  172.17.13.0/26                     10.2.0.85               110
98 ADo  172.17.14.0/26                     10.2.0.85               110
99 ADo  172.17.15.0/26                     10.2.0.85               110
100 ADo  172.17.16.0/26                     10.2.0.85               110
101 ADo  172.17.17.0/26                     10.2.0.85               110
102 ADo  172.17.18.0/26                     10.2.0.85               110
103 ADo  172.17.19.0/26                     10.2.0.85               110
104 ADo  172.17.20.0/26                     10.2.0.85               110
105 ADo  172.17.21.0/26                     10.2.0.85               110
106 ADo  172.17.22.0/26                     10.2.0.85               110
107 ADo  172.17.23.0/24                     10.2.0.85               110
108 ADo  172.17.24.0/26                     10.2.0.85               110
109 ADo  172.17.25.0/26                     10.2.0.85               110
110 ADo  172.17.26.0/26                     10.2.0.85               110
111 ADo  172.17.27.0/26                     10.2.0.85               110
.......
118 ADC  192.168.8.0/27     192.168.8.1     vlan8                     0
119 X S  192.168.8.11/32                    172.16.0.12               1
120 ADo  192.168.12.0/24                    10.1.2.34               110
121 ADC  192.168.14.0/29    192.168.14.1    vlan14                    0
122 ADC  192.168.16.0/26    192.168.16.1    vlan16                    0
123 A S  192.168.16.64/26                   172.16.0.12               1
124 ADo  192.168.17.0/24                    10.1.2.18               110
125 X S  192.168.17.0/24                    172.16.0.12               1
126 ADo  192.168.18.0/24                    10.1.2.2                110
127 ADC  192.168.19.0/27    192.168.19.1    vlan19                    0
128 A S  192.168.19.32/27                   172.16.0.12               1
129 ADo  192.168.20.0/24                    10.1.2.6                110
130 ADo  192.168.22.0/24                    10.1.2.10               110
131 ADo  192.168.23.0/24                    10.1.2.38               110
132 ADC  192.168.24.0/24    192.168.24.1    vlan24                    0
133 ADo  192.168.31.0/24                    10.1.2.30               110
134 ADC  192.168.0.0/21     192.168.0.1     bridge1-LAN               0
135   S  192.168.89.0/24                    10.1.1.45                 1
136 ADC  192.168.100.0/24   192.168.100.1   vlan100                   0
/routing ospf route print
 # DST-ADDRESS        STATE          COST                                                                                               GATEWAY         INTERFACE                                                                                          
 0 10.0.2.8/30        ext-1          30                                                                                                 10.1.4.2        ipip-tunnel16                                                                                      
 1 10.1.4.0/30        intra-area     10                                                                                                 0.0.0.0         ipip-tunnel16                                                                                      
 2 192.168.0.0/24     ext-1          30                                                                                                 10.1.4.2        ipip-tunnel16                                                                                      
 3 192.168.1.0/24     intra-area     20                                                                                                 10.1.4.2        ipip-tunnel16                                                                                      
 4 192.168.2.0/24     ext-1          30                                                                                                 10.1.4.2        ipip-tunnel16                                                                                      
 5 10.1.2.0/30        intra-area     10                                                                                                 0.0.0.0         ipip-tunnel1                                                                                       
 6 10.1.2.4/30        intra-area     10                                                                                                 0.0.0.0         ipip-tunnel2                                                                                       
 7 10.1.2.8/30        intra-area     10                                                                                                 0.0.0.0         ipip-tunnel3     
........

для R2 будут завтра

Edited by pin

Share this post


Link to post
Share on other sites

На R2 в конфиге точно есть команда назначения инт-са в врф? Что в ospf db на обоих роутерах? Состояние соседства на обоих фул?? Что в логах? Роутеры на МТУ не ругаются?

Share this post


Link to post
Share on other sites
1 час назад, VolanD666 сказал:

На R2 в конфиге точно есть команда назначения инт-са в врф? Что в ospf db на обоих роутерах? Состояние соседства на обоих фул?? Что в логах? Роутеры на МТУ не ругаются?

1. Если на R2 добавляешь инстанс в VRF, маршруты исчезают из таблицы R4

2. какой командой глянуть?

3. Пров торой роутер пока не скажу, отправил запрос админу

4. В логах - тишина, только записи о смене правил админом

5. Нет, не ругаются, по связи как раз все пучком

Share this post


Link to post
Share on other sites

@pin image.thumb.png.e27b49171800148ab2bbcb6733c694e9.png

 

 

Покажи маршруты для 

192.168.0.0/24

192.168.1.0/24

192.168.2.0/24

 

И для 

 

192.168.0.0/21

 

Скринами. 

 

С пересекающими IP адресами, скорее всего придется собирать всё через нат. 

Share this post


Link to post
Share on other sites
1 минуту назад, pin сказал:

1. Если на R2 добавляешь инстанс в VRF, маршруты исчезают из таблицы R4

2. какой командой глянуть?

3. Пров торой роутер пока не скажу, отправил запрос админу

4. В логах - тишина, только записи о смене правил админом

5. Нет, не ругаются, по связи как раз все пучком

5) А логинг оспфа точно включен?

Share this post


Link to post
Share on other sites
В 03.10.2018 в 08:52, pingz сказал:

@pin image.thumb.png.e27b49171800148ab2bbcb6733c694e9.png

 

 

Покажи маршруты для 

192.168.0.0/24

192.168.1.0/24

192.168.2.0/24

 

И для 

 

192.168.0.0/21

 

Скринами. 

 

С пересекающими IP адресами, скорее всего придется собирать всё через нат. 

192_168.0.0.thumb.jpg.65ca42e3b3912e4d1d5843c2d99dbf28.jpg192_168.0.0_R4.thumb.jpg.3497fc5e62f39e51a49102b6dcd736b0.jpg192_168.1.0.thumb.jpg.82f77cbafe5f46c36286dbeec2eabeb8.jpg192_168.2.0.thumb.jpg.cf7f04fc9d7b7e4c1577f69095fff5c4.jpg

изменил название VRF-таблицы на более понятное для меня

 

В 03.10.2018 в 08:53, VolanD666 сказал:

5) А логинг оспфа точно включен?

Конечно

Edited by pin

Share this post


Link to post
Share on other sites

@pin По всем правилам работать и не должно выбирается маршрут у которого дистанция меньше. 

Share this post


Link to post
Share on other sites

Изначально вопрос был: почему сетка 192.168.24.0/24не анонсируется на R2?

Share this post


Link to post
Share on other sites

@pin 

Как я понял 192.168.24.0/24 находится за R4 если не прав поправь. 

В  оспф нетворках нету 192.168.24.0/24 на R4 

В /routing ospf route print его то же нет. 

 

Share this post


Link to post
Share on other sites

Все правильно, он там есть:

/routing ospf network print 
Flags: X - disabled, I - invalid 
 #   NETWORK            AREA                                                                                                                                                                                                                               
 .....                                                                                                                                                                                                                      
 7   192.168.24.0/24    vrf-area1                                                                                                                                                                                                                          
 8   10.1.4.0/30        vrf-area1                                                                                                                                                                                                                          
 .......

В /routing ospf route print см. выше

...
132 ADC  192.168.24.0/24    192.168.24.1    vlan24                    0
...

 

Share this post


Link to post
Share on other sites

@pin  

 

routing ospf interface print

routing ospf lsa print c R2

 

Дублирующие сети есть 192.168.24.0/24? на других маршутизаторах? 

 

Небольшое отступление: 

 

Тяжеловато объяснять, но попробую у пакета есть адрес назначения и адрес отправления. (порой я очень плохо разжёвываю, нужно перефразировать)

Есть прямой маршут и обратный(да это не профессионально, но проще понимать) 

В пакете есть адрес назначения и адрес отправителя. 

Допустим с 192.168.0.2 со шлюзом 192.168.0.1  отправился пакет на 192.168.24.2 

192.168.24.2 находится за сетью OSPF из 3х маршутизаторов(тут своя движука и отдельное разжевывание) 

Допустим пакет от 192.168.0.2 дошел до 192.168.24.2 

192.168.24.2 ответил 192.168.0.2, но так как в его сети с префиксом /24  нет 192.168.0.2 он отправил на шлюз 192.168.24.1 

У шлюза 192.168.24.0/24 есть два маршута 192.168.0.0/21(обратный маршрут) с дистанцией 10 и 192.168.0.0/24(обратный маршрут) c дистанцией 110 как думаешь, куда пойдет пакет? 

 

Возможно я не понял всю суть сети, но без ната и маркировки тут не разобраться(у микратика нет полноценного VRF как у полноценных маршутизаторах)

 

Ты потеряешь 1-3 месяца и придешь к выводу, что за 1 неделю бы переписал IP  пространство и через 2-3 дня у тебя все бы летало. 

 

ИМХО Городить кривой огород из костылей, не самое благородное дело. 

 

Share this post


Link to post
Share on other sites
9 минут назад, pingz сказал:

Возможно я не понял всю суть сети, но без ната и маркировки тут не разобраться(у микратика нет полноценного VRF как у полноценных маршутизаторах)

 

Ты потеряешь 1-3 месяца и придешь к выводу, что за 1 неделю бы переписал IP  пространство и через 2-3 дня у тебя все бы летало. 

 

ИМХО Городить кривой огород из костылей, не самое благородное дело. 

 

Полностью согласен, НО:

- то, что придется использовать NAT,я понимаю, вопрос в том, почему не появляется маршрут, как только эту проблему решим, дальшея знаю, как делать, я настроивал раньше, но только для статики, сейчас динамику хочется, очень хочется. Сети сейчас переименовать вообще не вариант - начальство не даст до нового года.

Share this post


Link to post
Share on other sites

@pin 

ospf на первый взгляд прост, но на самом деле очень тяжелый для понимания. Из советов я тебе могу порекомендовать прочитать 3-6 статей по OSPF и разобраться с LSA(Очень тяжело заходит мне с 5-6 раза только начало доходить, что это и как с ним работать.) 

 

Тогда лучше для себя сформулировать конкретней задачу. 

 

Возможно стоит решить проблему через тунел по верх OSPF. 

 

Если тебе требуется попадать в 192.168.0.0/24 192.168.1.0/24 192.168.2.0/24 из 192.168.24.0/24 это одно.

А если требе требуется с 192.168.24.100 попасть в эти сети, то это уже другое. 

 

Для начало, нужно посмотреть на LSA с R2

Share this post


Link to post
Share on other sites

@pin В шапке доведи схему примерно в это состояние, а то я вижу одно, а на деле другое. 

С R4 ты показал LSA которые на него прилетают. А раз ты анонсиш с R4 в сторону R2, то нужно посмотреть, что прилетает на R2. Либо собирать дамп и искать, нужный пакет LSA от R4 в сторону R2

i16^cimgpsh_orig.png

 

На втором скрине только 3 строки или еще есть? Там должен быть 192.168.24.0/24

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this