Перейти к содержимому
Калькуляторы

DAF

Пользователи
  • Публикации

    183
  • Зарегистрирован

  • Посещение

О DAF

  • Звание
    Студент
  1. bonding и микротик

    Пользую бондинг между rb2011 и омнитиком по 3-м линкам (метров по 25), также пробовал мультиPPPoE - показалось что подтормаживает (субъективно, по Btest всё было красиво). Решил, что дело в МТУ ПППоЕ-шном. Или я что-то недонастроил? С бондингом же всё ОК, правда после ребута линк поднимается подольше, но это не критично.
  2. Имеется: - Mikrotik rb2011 с 3-мя WAN: - WAN1 - основной, белая статика, провайдер ISP1 - WAN2 - резерв + некоторые "полезности" -> немаленькая внутренняя локалка 10.х.х.х, провайдер ISP2 - WAN3 - резерв, белая динамика (смена IP примерно раз в сутки), настроен DDNS (hldns.ru), провайдер ISP3 Проблема: При отключениях электроэнергии ВОЛС-провайдеры ISP1 и ISP2 отваливаются, ISP3 подолжает работать (ADSL от РТ). Мой rb2011+прочее запитаны от SKAT-UPS 1000 (3 АКБ 40 А/ч, хватает на ~12+ часов). WAN2 и WAN3 взяты из локалок сеседних офисов (хорошие знакомые + некоторый бартер), оба роутера TP-Link с ИБП (PoE от меня). Периодически то там то там зачем-то нажимают RESET на роутере, и на моем микротике WAN2 и WAN3 получают адреса из подсети 192.168.0.0/24,также слетает назначение определенного IP по MAC. Приходится самому влезать в TP-Link и менять подсеть, однако злоупотреблять доверием не хочется, да и не всегда admin:admin оставляют (к тому же в одном из офисов появились хосты с вручными IP). Что я пробовал: Изучил мануал и попробовал настроить VRF в МТ но что-то недопонял и положил на недолго все три сетки (настраивал удаленно, safe mode спас:)). Ещё скачал исходники GPL с TP-Link и попробовал скомпилить прошивку с другим дефолтным IP для LAN. (НЕ 192.168.0.1). Не получилось, собирается с ошибкой и всё тут, хотя не раз приходилось собирать OpenWRT под себя и проблем не было. Прошу подсказать, как настроить VRF в микротике, чтобы WAN2 и WAN3 могли корректно работать, имея адреса из одной подсети (192.168.0.0/24). Сейчас в rb2011 адрес у WAN2 192.168.0.254, у WAN3 172.16.0.254 (МАС-адреса прописаны в назначениях DHCP-сервера обоих TP-Link-ов). DNS только от ISP1 по DHCP + 8.8.8.8.   P.S. Ещё пробовал создать виртуальный МТ в Metarouter, а там NAT+vlan. Работает, но слишком костыльное решение ИМХО. :)
  3. D-Link DWL-P200 два комплекта - дешево и сердито. У меня 6компл. таких уже 8 лет в работе (тоже ИП-камеры) - ни разу не побеспокоили
  4. L2TP на свой WAN

    УПС... Только сейчас дошло, что в чужую тему портянку неслабую затащил. Ув. Т.С. Если напрягает -уберу, но вроде заботы у нас вельма схожи.
  5. L2TP на свой WAN

    Изящное решение, тоже хочу на VRF свой опухший гордурас конфиг переделать но опасаюсь (прадакшн типа) rb951G-2HnD /ip addr=192.168.10.254/24 int=lan-bridge- (eth 3-5) --------- ~40-50 хостов dhcp-clients - 3шт к 3 роутерам addr=192.168.9.254/24 int=vlan1 по lan-bridge ---------------- инет до 150М пров1 белая статика addr=192.168.0.254/24 int=wan2 (eth1) байпаст1-------------- инет до 20М провайдерская локалка 10.39.х.х/24 некоторые ВПН в ней addr=172.16.0.254/24 int=wan3 (eth2) байпаст2 -------------100M TP-Link в инет до 50М пров2 PC-based proxy /ip firewall nat add action=src-nat chain=srcnat out-interface=vlan1 to-addresses=192.168.9.254 add action=src-nat chain=srcnat out-interface=wan2 to-addresses=192.168.0.254 add action=src-nat chain=srcnat out-interface=wan3 to-addresses=172.16.0.254 add action=src-nat chain=srcnat out-interface=all-ppp to-addresses=10.11.12.254 /ip route add check-gateway=arp distance=1 gateway=192.168.9.1 add check-gateway=arp distance=2 gateway=192.168.0.1 add check-gateway=arp distance=3 gateway=172.16.0.1 add distance=1 gateway=192.168.0.1 routing-mark=w2 add distance=1 gateway=172.16.0.1 routing-mark=w3 /ppp profile set only-one=yes use-compression=no use-encryption=no use-mpls=no use-upnp=no add change-tcp-mss=yes local-address=10.11.12.254 /ppp secret add name=test profile=vpn remote-address=10.11.12.100 service=pptp add name=kee profile=vpn remote-address=10.11.12.212 service=pptp add name=nex profile=vpn remote-address=10.11.12.234 routes="10.30.20.0/24 10.11.12.234 1, 192.168.11.0/24 10.11.12.234 1" service=l2tp add name=nai profile=vpn remote-address=10.11.12.242 routes="192.168.8.0/24 10.11.12.242 1" service=ovpn add name=klp profile=vpn remote-address=10.11.12.241 routes="172.17.72.0/24 10.11.12.241 1, 10.0.26.0/24 10.11.12.241 1" service=ovpn add name=ngr profile=vpn remote-address=10.11.12.213 routes="192.168.2.0/24 10.11.12.213 1" service= pptp add name=viz profile=vpn remote-address=10.11.12.244 routes="192.168.7.0/24 10.11.12.244 1" service=ovpn add name=las profile=vpn remote-address=10.11.12.214 routes="192.168.4.0/24 10.11.12.214 1" service= pptp add name=xyz profile=vpn remote-address=10.11.12.243 routes="10.10.17.0/24 10.11.12.243 1" service= ovpn add name=sus profile=vpn remote-address=10.11.12.210 routes="192.168.1.0/24 10.11.12.210 1" service=pptp add name=x86 profile=vpn remote-address=10.11.12.245 routes="192.168.5.0/24 10.11.12.245 1, 192.168.82.0/24 10.11.12.245 1, 192.168.88.0/24 10.11.12.245 1, 192.168.201.0/24 10.11.12.245 1, 192.168.202.0/24 10.11.12.245 1" service=ovpn /ip route add comment="nah" distance=249 dst-address=10.0.0.0/8 type=blackhole add comment="nah" distance=249 dst-address=172.16.0.0/12 type=blackhole add comment="nah" distance=249 dst-address=192.168.0.0/16 type=blackhole скрипт раз в 3 мин тестит и дропит неактивные РРР, и потерявшие ВПН-связность хосты те остаются без роутов и не гадят покетами в Инет (а в blackhole) /sys script :local pppTest value=[/ppp active find]; :local pingNumber value=5; :local pingMin value=2; :foreach userTest in=$pppTest do={ :local pingOk value=[:ping [/ppp active get $userTest value-name=address] count=$pingNumber] :if ($pingOk < $pingMin) do={ :log warning message=([/ppp active get $userTest value-name=service] . " auto disconnected: ". $pingOk . " ping ok over " . $pingNumber . " " . [/ppp active get $userTest value-name=name] . " " . [/ppp active get $userTest value-name=address]) /ppp active remove $userTest } }; /interface sstp-client add authentication=mschap2 connect-to=к домашнему МТ disabled=no name=beg pfs=yes user=rdn verify-server-address-from-certificate=no =============My-Home-MTik /int sstp-server /tool netwatch add down-script="/log warning message=\"beg reconnect \" /int set [ find name=beg ] dis=yes :delay 1; /int set [ find name=beg ] dis=no host=10.11.12.1 interval=3m
  6. L2TP на свой WAN

    спасиб
  7. Или живность завелась. Лечил тут такого - левый скрипт появился - удаляешь, а после ребута он опять на месте - netinstall помог.
  8. Подвисает интернет

    Ну да, и потом возможно будет чем заняться (netinstall-ом) est sait.backup это бинарный файл, только в твой МТ безблезненно влезет. Надо в терминале набрать /export compact <Ent> ПКМ copy all и скопипастить CPU загрузка какая? Кэш DNS не пухнет?
  9. Или наоборот - другое устройство ID попутало.... Сравнить бы на наклейке и на экране... Логин/пароль поменять - с мобиле тоже.... Включить через несильно тупой роутер (ПК с 2-мя ЛАН) и трафф по контенту подменить :) ...а моему столику больше не наливать
  10. uart->u-boot->printenv (возможно ИД в env но не факт)->или выгрузить прошивку по tftp, hex-редактором посмотреть что не так с ИД/МАС -> залить обратно по tftp !!!U-boot не затрите!!!
  11. L2TP на свой WAN

    Если нетрудно - я бы взглянул на ip/routes/rules+vrf
  12. Mikrotik и Usb ethernet

    Немного оффтоп, но.... Имею такой одноплатник x86: AMD Geode300 256RAM CF-card512Mb 1-ehernet 2-Serial 2-usb. Комп старый, но очень стабильный - по 200+ дней с бесперебойником аптайм. От игрового автомата (надежность такая наверно чтобы при выигрыше не завис :), с гордой надписью на плате made in USA). Стоит RoS level 1, ВПН пробрасывает на центральный офис из под серого ИП в филиале уже 3-й год. Но онборд Davicom-DM9x0x езернет только под v4.17 работает, под v5.xx/6.хх езернет интерфейса не видит. Летом руки дошли, написал в саппорт, аргументированно доказал, что косяк в прошивке. Через 2 дня на мыло прислали v6.43rc3 с предложением потестить. Все оказалось ОК, драйвер ethernet поправили. Самая мякотка в том, что слетела часть ограничений level-1 (обновляться стала), + Dude там поселился. Я больше часа в гугл транслейте восхищенный отзыв набирал.:)
  13. Не могу установить режим b/g/n (после обновления)

    гм... однако...https://mikrotik.com/download
  14. Не могу установить режим b/g/n (после обновления)

    На офф. форуме тоже немало про рандомные странности 6.43.2 в некоторых конфигурациях , рекомендуют последнюю версию из багфикс-ветки.
  15. А в кабеле подземном всего одна пара или несколько? инет со спутника что ли? Имелось в виду Ethernet по сети 220в. Там вроде от 100 вольт и до 500м сегмент. upd ошибся я: до 500Mbps до 300м (Powerline-модем).