Jump to content
Калькуляторы

Asterisk + Huawei Чудеса с входящими от абонентов МТС

В небольшом офисе не первый год юзаем мини-АТС на Asterisk (Elastix).

Три шлюза: один с ФОП и два GSM на Huawei E3131. На одном модеме SIM Beeline, на втором MTS.

До некоторого неопределённого момента всё работало без проблем, далее начались необъяснимые чудеса с каналом от МТС.

Выглядит это так: если на МТС поступает входящий вызов с телефонов Beeline, Megafon, то никаких проблем не возникает.

А вот если звонящий имеет номер МТС, начинающийся с 910, или 915, то звонок принимается АТС, но после "поднятия" у оператора в трубке сначала тишина, затем через несколько секунд, вызов сбрасывается. У звонящего же ответа не наблюдается, вместо этого продолжается вызов ("длинные гудки").

При этом на АТС модем "отваливается" и перезагружается.

НО! Если звонящий имеет номер МТС, начинающийся на 980, то чудесным образом вызов проходит и разговор происходит без каких-либо эксцессов.

Пробовал заменить SIM-карту, оставив тот же номер (кстати, также начинающийся на 910) - результат аналогичный..

Сломал весь ум себе и всем, кто что-то в этом понимает.. Две недели гугления и всевозможного шаманства с модемами (пробовал менять усб кабели, подключить через усб хаб) ничего не дали..

Прошу помощь зала...

Share this post


Link to post
Share on other sites

Зашейте модемы последними прошивками, для начала.

Share this post


Link to post
Share on other sites

Зашейте модемы последними прошивками, для начала.

Забыл написать, что перешивал. Возможно конечно, не самой последней - 21.158.00.00.1020.

Плюс к этому, ещё пытался запускать этот канал на E1550 с прошивкой 11.608.14.15.311.

Результат 100% аналогичный..

Share this post


Link to post
Share on other sites

А проблему в диалплане не искали? логи вызова на asterisk не снимали?

Edited by ARMADIK

Share this post


Link to post
Share on other sites

А проблему в диалплане не искали? логи вызова на asterisk не снимали?

А что может быть в диалплане? Что ему может "не нравится" в КОНКРЕТНЫХ ВХОДЯЩИХ номерах?

Почему 8-910...и 8-915.. не идёт, а 8-980.. и 8-903/906.. и т.д - без проблем?

Блеклист пустой. Притом, при "глючном" входящем модем перезагружается!

Больше похоже на проблему chan_dongle, или прошивки модемов. Только вот что именно.. ?

 

P.S. Лог вызова могу запостить, если это поможет..

Share this post


Link to post
Share on other sites

Пишите, чего уж...

 

Что-то происходит непонятное. Любая инфа будет не лишней.

Share this post


Link to post
Share on other sites

Пишите, чего уж...

 

Что-то происходит непонятное. Любая инфа будет не лишней.

Там такая великая портянка получается..

Пока подожду ответа от МТС. Достучался до их ТП, обещали передать технарям и отзвониться.

Дело похоже, всё же на их стороне.

Возможно, что-то связанное с тарифом, либо тариф+модем т.к. с другой SIM, также МТС, но с номером 980-.. всё работает.

И в обычном телефоне "глючная" SIM тоже работает.

Share this post


Link to post
Share on other sites

В результате проведённых экспериментов с участием технарей МТС, выяснилось следующее -

если на телефоне ВЫЗЫВАЮЩЕГО принудительно включить режим 2G, то звонок проходит, если 3G - наблюдаем описанное выше.

По-видимому, при вызове с 3G, либо сам модем, либо оператор пытается переключить модем в 3G, который ему (модему) не по зубам.

Принудительный перевод МОДЕМА в "2G only" не помогает - при вызове ("глючном") модем всё одно уходит в ребут, после которого "2G only" также "слетает"..

Возможно, из-за малого уровня сигнала (на "2G only" модем показывает RSSI = 18 (-77dbm), в "дефолтном режиме" - 13 (-87 dbm)).

Хотя, -87dbm - это вроде как не критичный уровень? Или для 3G мало? Плюс ко всему не понятно, почему игнорируется 2G only на модеме..

Вот такие чудеса.. Пока жду рекомендаций от оператора..

Share this post


Link to post
Share on other sites

Забавно.

А если ваш ранее упомянутый 1550 залочить на 2г и проверить повтор?

Что если подключить модем через активный хаб?

Edited by MESB

Share this post


Link to post
Share on other sites

А если ваш ранее упоиянутый 1550 залочить на 2г и проверить повтор?

Возможно, это и помогло, хотя до замены сим-карты, я ставил "старую" сим в Е1550 - результат был отрицательный.

На данный момент работает в Е1550. Но перед этим технари МТС что-то пытались подшаманить со своей стороны.

Вообщем, сейчас уже никто - ни я, ни МТС - не может назвать причину, из-за которой не работало, равно как и отчего конкретно заработало сейчас.. :(

Ну и у меня лично почему-то остались сомнения, что это всё не надолго.. Хотелось бы, конечно, ошибиться..

Что если подключить модем через активный хаб?

.. Две недели гугления и всевозможного шаманства с модемами (пробовал менять усб кабели, подключить через усб хаб) ничего не дали..

Share this post


Link to post
Share on other sites

скорее всего, это hd voice так "работает"

Share this post


Link to post
Share on other sites

скорее всего, это hd voice так "работает"

Как-то лечится, или "случай безнадёжный"?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this