Jump to content
Калькуляторы

Не поднимается OSPF Juniper - Extreme наверное неправильно настроены таймеры

Доброго дня,

собираю p2p ospf extreme x460 - extreme x460 - juniper ex 4200

Между extreme все ок, между juniper и остальной сеткой тоже,

а вот сессия между extreme и juniper не поднимается, л3 связность есть.

Скорее всего дело в таймерах, попробовал со стороны ех'a выставить дефолтные экстрима (hello - 10, dead - 40, spf holddown -5) не помогло, видимо что то упускаю.

В логах все чисто.

Прошу подсказать что упустил, спасибо.

Share this post


Link to post
Share on other sites

stranger.rus, а как вы логи смотрели то?

 

Обратите внимание на пост rdntw

Share this post


Link to post
Share on other sites

Extreme у нас работает с juniper mx. OSPF и OSPFv3 летают. Никаких особых настроек не делали. MTU по-умолчанию

Share this post


Link to post
Share on other sites

Прошу подсказать что упустил, спасибо.

Ни разу такую связку не настраивал, но, если верить книжкам, то у двух смежных маршрутизаторов должны совпадать следующие параметры:

1. Маска подсети

2. Адрес подсети

3. Hello Interval

4. Dead Interval

5. Area ID

6. Параметры аутентификации (если настроены)

7. Флаг stub area

Share this post


Link to post
Share on other sites

1. Маска подсети

2. Адрес подсети

3. Hello Interval

4. Dead Interval

5. Area ID

6. Параметры аутентификации (если настроены)

7. Флаг stub area

 

никогда до такого не траблшутил :)

 

всегда ограничивалось MTU

Share this post


Link to post
Share on other sites

Забыли про network type. Если будет мисматч, то в фул не перейдет)

Share this post


Link to post
Share on other sites

А что, у жунипера по умолчанию таймеры не стандартные? Для чего их было крутить?

Сам с junos не работал, но при настройке ospf линков extreme с разношерстным оборудованием (cisco, dlink, всевозможный китай) - никогда проблем не возникало, и уж тем более ни когда не возникало необходимости крутить таймеры.

В случае, если проблема возникает из-за mtu, в логах экстрима можно увидеть сообщения про DD retransmit (точно текст не припомню, но уж точно тишины не будет). Тишина в логах, как правило, бывает в случае если неверны настройки ареи и аутентификации. В случае с несовпадением link-type можно наблюдать появление нейбора в sh ospf neighbor.

Сверяйте настройки, если глаз замылился - включайте подробное логирование:

conf log filter "DefaultFilter" add events ospf severity debug-verbose

Share this post


Link to post
Share on other sites

create vlan "r1-vost92"
enable ipforwarding ipv6 vlan r1-vost92
configure vlan r1-vost92 tag 728
configure vlan r1-vost92 add ports 17 tagged  
configure vlan r1-vost92 ipaddress 11.11.11.11 255.255.255.252
enable ipforwarding vlan r1-vost92
configure r1-vost92 ipaddress eui64 fe80::/64
configure r1-vost92 ipaddress 2111:1111:0:1001::2/64
disable igmp snooping vlan "r1-vost92"
enable ipmcforwarding vlan "r1-vost92"
configure mpls add vlan "r1-vost92"
enable mpls vlan "r1-vost92"
enable mpls ldp vlan "r1-vost92"
configure ospf add vlan r1-vost92 area 0.0.0.0 
configure ospf vlan r1-vost92 cost 10
configure ospfv3 add vlan r1-vost92 instance-id 0 area 0.0.0.0 link-type broadcast

 

set routing-options router-id 10.10.10.20

set protocols ospf traceoptions file ospf.log
set protocols ospf traceoptions file size 1000k
set protocols ospf traceoptions file files 10
set protocols ospf traceoptions flag state
set protocols ospf traceoptions flag normal


set interfaces ae1 unit 728 description c0-vost92-1
set interfaces ae1 unit 728 vlan-id 728
set interfaces ae1 unit 728 family inet address 11.11.11.11/30
set interfaces ae1 unit 728 family inet6 address 1111:1111:0:1001::1/64
set interfaces ae1 unit 728 family mpls
set protocols mpls interface ae1.728
set protocols ospf area 0.0.0.0 interface ae1.728
set protocols ospf3 area 0.0.0.0 interface ae1.728
set protocols ldp interface ae1.728
set protocols pim interface ae1.728 mode sparse

Share this post


Link to post
Share on other sites

Пытаюсь отгрузить коннектед-сети по OSPF с A10-3030S в BD-8810, но ничего не выходит.

 

P2P: A10-3030S (10.0.1.86) <--> BD-8810 (10.0.1.85)

 

OSPF на A10-3030S:

 

!router ospf 1  neighbor 10.0.1.85  router-id 10.0.1.86  redistribute connected route-map TO-OSPF  redistribute static route-map TO-OSPF !!ip prefix-list ospf-new seq 10 permit X.Y.Z.0/22 le 32 !ip prefix-list ospf-new seq 400 deny any !!route-map TO-OSPF permit 10  match ip address prefix-list ospf-new !

 

 

OSPF на BD-8810

 

configure ospf routerid 10.0.1.249enable ospfconfigure ospf add vlan cgn1-outside area 0.0.0.0 passiveconfigure ospf vlan cgn1-outside priority 0

 

 

Связность через P2P есть:

 

a10-3030s>ping 10.0.1.85PING 10.0.1.85 (10.0.1.85) 56(84) bytes of data.64 bytes from 10.0.1.85: icmp_seq=1 ttl=64 time=8.92 ms64 bytes from 10.0.1.85: icmp_seq=2 ttl=64 time=11.0 ms64 bytes from 10.0.1.85: icmp_seq=3 ttl=64 time=6.67 ms^C--- 10.0.1.85 ping statistics ---3 packets transmitted, 3 received, 0% packet loss, time 2013msrtt min/avg/max/mdev = 6.670/8.878/11.040/1.787 ms

 

 

В debug logs на A10-3030S:

 

a10-3030s>show log debugLog Buffer: 30000Sep 21 2015 12:39:37 Debug   [Router]:OSPF: LSA[Refresh]: timer expiredSep 21 2015 12:39:27 Debug   [Router]:OSPF: LSA[Refresh]: timer expiredSep 21 2015 12:39:17 Debug   [Router]:OSPF: LSA[Refresh]: timer expired...

 

 

BD-8810:

 

BD-8810.4 # show ospf area 0.0.0.0Area: 0.0.0.0 Type: NormalRouter Id: 10.0.1.249Spf Runs: 439 Num ABR: 1 Num ASBR: 0 Num LSA: 283 LSA Chksum:0x967d52Interfaces:  IP addr          Ospf  State     DR IP addr      BDR IP addr10.0.1.85      /30   E    ODR       0.0.0.0         0.0.0.0...Inter-Area route Filter:External route Filter:Configured Address Ranges:

 

 

В BD-8810 по "show ospf neighbor" A10-3030S отсутствует.

Share this post


Link to post
Share on other sites

В BD-8810 по "show ospf neighbor" A10-3030S отсутствует.

 

естественно, ведь у вас интерфейс...

configure ospf add vlan cgn1-outside area 0.0.0.0 passive

 

passive...

Share this post


Link to post
Share on other sites

configure ospf add vlan cgn1-outside area 0.0.0.0 passive

 

passive...

 

Без passive тоже не принимает ничего.

 

configure ospf add vlan cgn1-outside area 0.0.0.0

 

Share this post


Link to post
Share on other sites

darkagent, пытаюсь отдебажить на BD-8810:

enable log debug-mode
configure log filter "DefaultFilter" add events "ospf.hello.PktInv"

* BD-8810.35 # show log configuration filter

Log Filter Name: DefaultFilter
I/                                                 Severity
E Component   SubComponent Condition               CEWNISVD
- ----------- ------------ ----------------------- --------
E AAA                      logout                  ----I---
E AAA                      authPass                ----I---
I ospf        hello        PktInv                  --W-----
I All                                              ********

Но в логах по OSPF ничего нет :(

* BD-8810.36 # show log | include ospf
* BD-8810.37 #

Share this post


Link to post
Share on other sites

Без passive тоже не принимает ничего.

Еще бы посмотреть настройки с обеих сторон, на предмет совпадения link-type, mtu и т.п.

Share this post


Link to post
Share on other sites

Еще бы посмотреть настройки с обеих сторон, на предмет совпадения link-type, mtu и т.п.

 

* BD-8810.37 # show "cgn1-outside"
VLAN Interface with name cgn1-outside created by user
   Admin State:         Enabled     Tagging:   802.1Q Tag 17
   Description:         None
   Virtual router:      VR-Default
   IPv4 Forwarding:     Enabled
   IPv4 MC Forwarding:  Disabled
   Primary IP:          10.0.1.85/30
   IPv6 Forwarding:     Disabled
   IPv6 MC Forwarding:  Disabled
   IPv6:                None
   STPD:                None
   Protocol:            Match all unfiltered protocols
   Loopback:            Disabled
   NetLogin:            Disabled
   OpenFlow:            Disabled
   TRILL:               Disabled
   QosProfile:          None configured
   Egress Rate Limit Designated Port: None configured
   Flood Rate Limit QosProfile:       None configured
   Ports:   1.           (Number of active ports=1)
      Tag:     *1:41
       Flags:    (*) Active, (!) Disabled, (g) Load Sharing port
                 (b) Port blocked on the vlan, (m) Mac-Based port
                 (a) Egress traffic allowed for NetLogin
                 (u) Egress traffic unallowed for NetLogin
                 (t) Translate VLAN tag for Private-VLAN
                 (s) Private-VLAN System Port, (L) Loopback port
                 (x) VMAN Tag Translated port
                 (G) Multi-switch LAG Group port
                 (H) Dynamically added by MVRP
                 (D) TRILL Designated, (A) TRILL Appointed Forwarder
                 (I) Dynamically added by IDM
                 (U) Dynamically added uplink port
                 (V) Dynamically added by VM Tracking

 

a10-3030s#show interfaces ve 17
VirtualEthernet 17 is up, line protocol is up
 Hardware is VirtualEthernet, Address is 001f.a011.53b6
 Internet address is 10.0.1.86, Subnet mask is 255.255.255.252
 Router Interface for L2 Vlan 17 
 IP MTU is 1500 bytes
 0 packets input  0 bytes
 Received  0 broadcasts, Received 0 multicasts, Received 0 unicasts  
 0 packets output  0 bytes
 Transmitted  0 broadcasts, Transmitted 0 multicasts, Transmitted 0 unicasts  
 Source NAT interface direction is outside
 Source IPv6 NAT interface direction is outside
 Interface name is BD-8810-L3-outside 
 300 second input rate: 0 bits/sec, 0 packets/sec 
 300 second output rate: 0 bits/sec, 0 packets/sec 

Share this post


Link to post
Share on other sites

не то.

со стороны экстрима:

sh ipconfig vlan "cgn1-outside"

sh conf ospf | i cgn1-outside

На a10:

sh run int ve 17 (или что там по аналогии будет)

Share this post


Link to post
Share on other sites

не то.

со стороны экстрима:

sh ipconfig vlan "cgn1-outside"

sh conf ospf | i cgn1-outside

На a10:

sh run int ve 17 (или что там по аналогии будет)

 

* BD-8810.39 # sh ipconfig vlan "cgn1-outside"
Router Interface on cgn1-outside is enabled and up.
   inet 10.0.1.85/30   broadcast 10.0.1.87  Mtu 1500

   Flags:
      AddrMaskRly  NO     BOOTP Host  NO   DirBcstHwFwd  NO      Fwd Bcast  NO
      IgnoreBcast  NO      IP Fwding YES       IPmc Fwd  NO Multinetted VLAN  NO
      IRDP Advert  NO      SendParam YES     SendPortUn YES     Send Redir YES
     SendTimxceed YES    SendUnreach YES   TimeStampRly  NO           VRRP  NO
      Unicast RPF  NO

 

* BD-8810.40 # sh conf ospf | i cgn1-outside
configure ospf add vlan cgn1-outside area 0.0.0.0
configure ospf vlan cgn1-outside priority 0

 

a10-3030s#show config interface ve 17
!Section configuration: 134 bytes       
!
interface ve 17 
 name BD-8810-L3-outside 
 enable 
 ip address 10.0.1.86 255.255.255.252 
 ip nat outside 
 ipv6 nat outside 
!

Share this post


Link to post
Share on other sites

на стороне экстрима:

conf ospf del vlan cgn1-outside
conf ospf add vlan cgn1-outside area 0.0.0.0 link-type point-to-point

на стороне A10

router ospf 1
no neighbor 10.0.1.85 
network 10.0.1.84 0.0.0.3 area 0.0.0.0 
!
interface ve 17 
ip ospf network point-to-point
!

- за синтаксис а10 не ручаюсь, не знаком, полагаюсь на cisco-cli.

 

p.s. при соседстве с очень капризными железками, еще можно сделать dis igmp vlan cgn1-outside на экстриме - какая-то из cisco asr у меня очень не хотела договариваться при включенном igmp, только igmp snooping.

Share this post


Link to post
Share on other sites

darkagent, успех, обменялись сетями.

Как запретить отгружать сети на А10? Мне нужно только от А10 принять.

 

* BD-8810.62 # show iproute | include cgn1-outside
#d   10.0.1.84/30       10.0.1.85       1    U------um--f- cgn1-outside 3d:6h:0m:33s
#o2  X.Y.Z.0/22    10.0.1.86       20   UG-D---um--f- cgn1-outside 0d:0h:3m:54s

* BD-8810.65 # show ospf neighbor | include cgn1-o
10.0.1.86         1 FULL      /DROTHER 00:00:04:51/00:00:00:10  10.0.1.86       cgn1-outs

Share this post


Link to post
Share on other sites

очевидные варианты:

1) фильтровать экспорт на экстриме

2) фильтровать импорт на а10

Share this post


Link to post
Share on other sites

А можно мне со своим OSPF вклинится? :)

 

У заказчика теряются hello пакеты на довольно "кривом" L2 канале из цепочки операторов:

 

М1-(ОП1)- М9(ОП2) - М9(ОП3) - Серпухов (ОП4) - WiFi радиомост - Клиент (Завод).

 

Симптомы: На заводе падает OSPF на этом канале до М1. Причем есть другой канал через одного оператора до М9 - там все работает. И из других spoke до М1 все работает. OSPF - бродкастового типа.

 

По дебагу на заводе:

 

Sep  4 16:39:23.813: %OSPF-5-ADJCHG: Process 1, Nbr 10.5.10.15 on Vlan566 from FULL to DOWN, Neighbor Down: Dead timer expired
Sep  4 16:39:26: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.15
     aid:0.0.0.0 chk:7437 aut:0 auk: from Vlan566
Sep  4 16:39:26: OSPF: rcv. v:2 t:2 l:32 rid:10.5.10.15
     aid:0.0.0.0 chk:1B7B aut:0 auk: from Vlan566
Sep  4 16:39:26: OSPF: rcv. v:2 t:2 l:232 rid:10.5.10.15
     aid:0.0.0.0 chk:9441 aut:0 auk: from Vlan566
Sep  4 16:39:26.724: %OSPF-5-ADJCHG: Process 1, Nbr 10.5.10.15 on Vlan566 from LOADING to FULL, Loading Done
Sep  4 16:39:26: OSPF: rcv. v:2 t:3 l:36 rid:10.5.10.15
     aid:0.0.0.0 chk:C1A3 aut:0 auk: from Vlan566
Sep  4 16:39:34: OSPF: rcv. v:2 t:5 l:44 rid:10.5.10.15
     aid:0.0.0.0 chk:A945 aut:0 auk: from Vlan566
Sep  4 16:39:34: OSPF: rcv. v:2 t:5 l:44 rid:10.5.10.15
     aid:0.0.0.0 chk:12D9 aut:0 auk: from Vlan566
Sep  4 16:40:14.237: %OSPF-5-ADJCHG: Process 1, Nbr 10.5.10.15 on Vlan566 from FULL to DOWN, Neighbor Down: Dead timer expired
Sep  4 16:40:16: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.15
     aid:0.0.0.0 chk:7437 aut:0 auk: from Vlan566
Sep  4 16:40:16: OSPF: rcv. v:2 t:2 l:32 rid:10.5.10.15
     aid:0.0.0.0 chk:1B78 aut:0 auk: from Vlan566
Sep  4 16:40:16: OSPF: rcv. v:2 t:2 l:232 rid:10.5.10.15
     aid:0.0.0.0 chk:9AA6 aut:0 auk: from Vlan566
Sep  4 16:40:16.746: %OSPF-5-ADJCHG: Process 1, Nbr 10.5.10.15 on Vlan566 from LOADING to FULL, Loading Done
Sep  4 16:40:16: OSPF: rcv. v:2 t:3 l:36 rid:10.5.10.15
     aid:0.0.0.0 chk:C1A3 aut:0 auk: from Vlan566
Sep  4 16:40:24: OSPF: rcv. v:2 t:5 l:64 rid:10.5.10.15
     aid:0.0.0.0 chk:DA47 aut:0 auk: from Vlan566
Sep  4 16:40:32: OSPF: rcv. v:2 t:5 l:44 rid:10.5.10.15
     aid:0.0.0.0 chk:79AB aut:0 auk: from Vlan566

 

Ну да, t:1 как то странно доходят. Через 2-3 секунды после срабатывания dead-dimer. 50 секунд интервал между hello.

 

Причем в ЦОД на М1 все шататно, каждые 10 секунд.

 

id:0.0.0.0 chk:9C52 aut:0 auk: from Vlan566
Sep  4 16:40:47: OSPF: rcv. v:2 t:5 l:64 rid:10.5.10.6
     aid:0.0.0.0 chk:D256 aut:0 auk: from Vlan566
Sep  4 16:40:49: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.15
     aid:0.0.0.0 chk:7437 aut:0 auk: from Vlan566
Sep  4 16:40:56: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.6
     aid:0.0.0.0 chk:73D4 aut:0 auk: from Vlan566
Sep  4 16:40:57: OSPF: rcv. v:2 t:1 l:48 rid:10.5.10.11
     aid:0.0.0.0 chk:9C52 aut:0 auk: from Vlan566
Sep  4 16:40:59: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.15
     aid:0.0.0.0 chk:7437 aut:0 auk: from Vlan566
Sep  4 16:41:06: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.6
     aid:0.0.0.0 chk:73D4 aut:0 auk: from Vlan566
Sep  4 16:41:07: OSPF: rcv. v:2 t:1 l:48 rid:10.5.10.11
     aid:0.0.0.0 chk:9C52 aut:0 auk: from Vlan566
Sep  4 16:41:08: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.15
     aid:0.0.0.0 chk:7437 aut:0 auk: from Vlan566
Sep  4 16:41:16: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.6
     aid:0.0.0.0 chk:73D4 aut:0 auk: from Vlan566
Sep  4 16:41:17: OSPF: rcv. v:2 t:1 l:48 rid:10.5.10.11
     aid:0.0.0.0 chk:9C52 aut:0 auk: from Vlan566
Sep  4 16:41:18: OSPF: rcv. v:2 t:1 l:56 rid:10.5.10.15
     aid:0.0.0.0 chk:7437 aut:0 auk: from Vlan566

 

Все подозрения на wifi радиомост, но исключить его из схемы не можем. Куда копать, кого копать? :)

Share this post


Link to post
Share on other sites

Если повлиять на качество радио нельзя, то от броадкаста лучше сразу отказаться, а в идеале и вовсе через этот радиомост сделать на p2p линке.

Share this post


Link to post
Share on other sites

Куда копать, кого копать? :)

Marvel-Distribution :) шучу

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this