Jump to content
Калькуляторы

Настройка iptv (multicast) не могу настроить роутер на iptv (мультикаст)

Добрый день подскажите пожалуйста как можно настроить iptv на провайдере ростелекома через IGMP PROXY. Я пользовался этими руководствами для настройки.

http://asp24.com.ua/blog/nastrojka-mikrotik-routeros-dlja-prosmotra-iptv-ot-provajdera/

http://mstream.com.ua/mikrotik-tipichnie-problemi-i-ih-resheniay.html#glava_6.9

http://www.lanta-net.ru/manual/cifrovoe-televidenie/nastrojka-routerov-dlya-ip-tv/nastrojka-routera-mikrotik/

 

igmp proxy

во вкладке interface пакеты не уходят и не приходят все по нулям.

во вкладке mfc пусто

 

через бридж и напрямую все работает.

 

Роутер Mikrotik RB2011UiAS-RM

Share this post


Link to post
Share on other sites

пройдет ли мультикаст трафик через простой бридж, если не настраивать igmp ?

Share this post


Link to post
Share on other sites

Да через бридж пройдет. Это все равно что зделать отдельный vlan.

Share this post


Link to post
Share on other sites

Конфиг в студию.

/routing igmp-proxy export

/ip ad exp

/ip fi fi exp

Share this post


Link to post
Share on other sites

Вот конфигурация.

 

# jan/02/1970 00:19:25 by RouterOS 6.27
# software id = F2V8-MWKI
#
/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add interface=ether5
add alternative-subnets=0.0.0.0/0 interface=ether7 upstream=yes
[admin@MTK] > /ip ad exp
# jan/02/1970 00:20:35 by RouterOS 6.27
# software id = F2V8-MWKI
#
/ip address
add address=192.168.88.1/25 interface=ether2 network=192.168.88.0
[admin@MTK] > /ip fi fi exp   
# jan/02/1970 00:20:53 by RouterOS 6.27
# software id = F2V8-MWKI
#
/ip firewall filter
add chain=input protocol=igmp
add chain=input protocol=udp

post-125587-020123100 1424786354_thumb.png

Share this post


Link to post
Share on other sites

Повесте любой IP на ether7 и проверьте еще раз как работает.

И если eсли у вас на ether2 не указан мастер порт то и на наего ip.

Share this post


Link to post
Share on other sites

ip адреса должны быть на обоих интерфейсах. и на апстриме и на даунстриме. если на одном из них не будет ip адреса - igmp proxy не будет работать. насколько я понимаю тут интерфейсы ether5 и ether7. и судя по всему на обоих нет адресов. поэтому и не работает

Share this post


Link to post
Share on other sites

У меня настроено так:

 

/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
add alternative-subnets=192.168.5.0/24 interface=ether2

 

1 и 2 eth порты не в бридже, на 2 порт повесил отдельную подсеть, иначе IGMP трафик "срет" во всю сеть и если еще вайфай в этой сети, то вайфай медленно умирает...

Share this post


Link to post
Share on other sites

divxl поискать на форуме ответ или создать тему отдельно на форуме.

 

По поводу моей проблемы настроил так

 

eth3,4,5 мастер на eth2

на 7 порт повесил ppoe. Шлюз и днс адреса пингуются.

post-125587-050097600 1424882199_thumb.jpg

Edited by lugair

Share this post


Link to post
Share on other sites

lugair

Сделайте так

/ip ad add address=192.168.255.1/30 interface=ether7

/routing igmp-proxy interface

add alternative-subnets=0.0.0.0/0 interface=ether7 upstream=yes

add interface=ether2

Share this post


Link to post
Share on other sites

Artur-t Бальшое спасибо + 10 к карме.

 

Тему можно закрывать.

Edited by lugair

Share this post


Link to post
Share on other sites

lugair

Сделайте так

/ip ad add address=192.168.255.1/30 interface=ether7

/routing igmp-proxy interface

add alternative-subnets=0.0.0.0/0 interface=ether7 upstream=yes

add interface=ether2

 

Здравствуйте!

А мне можете помочь? ВРоде делал по описаниям из интернета, но ТВ онлайн не кажет...

Настройки...

 

[admin@MikroTik] > /routing igmp-proxy export

# oct/16/2015 14:30:22 by RouterOS 6.32.2

# software id = H7BY-HJKZ

#

/routing igmp-proxy

set query-interval=1m5s query-response-interval=5s quick-leave=yes

/routing igmp-proxy interface

add alternative-subnets=0.0.0.0/0 interface=ether1-gateway upstream=yes

add interface=bridge-local

[admin@MikroTik] > /ip ad exp

# oct/16/2015 14:30:31 by RouterOS 6.32.2

# software id = H7BY-HJKZ

#

/ip address

add address=192.168.88.1/24 comment="default configuration" interface=wlan1 network=192.168.88.0

[admin@MikroTik] > /ip fi fi exp

# oct/16/2015 14:30:38 by RouterOS 6.32.2

# software id = H7BY-HJKZ

#

/ip firewall filter

add chain=input comment="IP TV" protocol=igmp

add chain=input comment="default configuration" protocol=icmp

add chain=input protocol=udp

Share this post


Link to post
Share on other sites

Показывайте /interface ethernet export, /interface bridge export и /ip address print

Share this post


Link to post
Share on other sites

Показывайте /interface ethernet export, /interface bridge export и /ip address print

 

[admin@MikroTik] > /interface ethernet export

# oct/16/2015 16:31:51 by RouterOS 6.32.2

# software id = H7BY-HJKZ

#

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether6 ] name=ether6-master-local

set [ find default-name=ether7 ] master-port=ether6-master-local name=\

ether7-slave-local

set [ find default-name=ether8 ] master-port=ether6-master-local name=\

ether8-slave-local

set [ find default-name=ether9 ] master-port=ether6-master-local name=\

ether9-slave-local

set [ find default-name=ether10 ] master-port=ether6-master-local name=\

ether10-slave-local

set [ find default-name=sfp1 ] name=sfp1-gateway

 

 

-----

/interface bridge

add admin-mac=D4:CA:6D:EE:0F:CC auto-mac=no mtu=1500 name=bridge-local

/interface bridge port

add bridge=bridge-local interface=ether2

add bridge=bridge-local interface=ether3

add bridge=bridge-local interface=ether4

add bridge=bridge-local interface=ether5

add bridge=bridge-local interface=ether6-master-local

add bridge=bridge-local interface=wlan1

 

 

-----

[admin@MikroTik] > /ip address print

Flags: X - disabled, I - invalid, D - dynamic

# ADDRESS NETWORK INTERFACE

0 ;;; default configuration

192.168.88.1/24 192.168.88.0 wlan1

1 D 188.32.6.154/22 188.32.4.0 ether1-gateway

 

Показывайте /interface ethernet export, /interface bridge export и /ip address print

 

[admin@MikroTik] > /interface ethernet export

# oct/16/2015 16:31:51 by RouterOS 6.32.2

# software id = H7BY-HJKZ

#

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether6 ] name=ether6-master-local

set [ find default-name=ether7 ] master-port=ether6-master-local name=\

ether7-slave-local

set [ find default-name=ether8 ] master-port=ether6-master-local name=\

ether8-slave-local

set [ find default-name=ether9 ] master-port=ether6-master-local name=\

ether9-slave-local

set [ find default-name=ether10 ] master-port=ether6-master-local name=\

ether10-slave-local

set [ find default-name=sfp1 ] name=sfp1-gateway

 

 

-----

/interface bridge

add admin-mac=D4:CA:6D:EE:0F:CC auto-mac=no mtu=1500 name=bridge-local

/interface bridge port

add bridge=bridge-local interface=ether2

add bridge=bridge-local interface=ether3

add bridge=bridge-local interface=ether4

add bridge=bridge-local interface=ether5

add bridge=bridge-local interface=ether6-master-local

add bridge=bridge-local interface=wlan1

 

 

-----

[admin@MikroTik] > /ip address print

Flags: X - disabled, I - invalid, D - dynamic

# ADDRESS NETWORK INTERFACE

0 ;;; default configuration

192.168.88.1/24 192.168.88.0 wlan1

1 D 188.32.6.154/22 188.32.4.0 ether1-gateway

 

-------

wlan1 - это вайфай, который я отключил, и не хочу его использовать с этого роутера

Share this post


Link to post
Share on other sites

На bridge-local какую-нибудь подсеть то повесьте, раз wifi не используете. Например:

/ip address add address=192.168.77.1/24 comment="bridge-local" interface=bridge-local network=192.168.77.0
/ip pool add name=default ranges=192.168.77.2-192.168.77.31
/ip dhcp-server add add-arp=yes address-pool=default disabled=no interface=bridge1 lease-time=1d name=default
/ip dhcp-server network add address=192.168.77.0/24 dns-server=192.168.77.1 gateway=192.168.77.1

Share this post


Link to post
Share on other sites

На bridge-local какую-нибудь подсеть то повесьте, раз wifi не используете. Например:

/ip address add address=192.168.77.1/24 comment="bridge-local" interface=bridge-local network=192.168.77.0
/ip pool add name=default ranges=192.168.77.2-192.168.77.31
/ip dhcp-server add add-arp=yes address-pool=default disabled=no interface=bridge1 lease-time=1d name=default
/ip dhcp-server network add address=192.168.77.0/24 dns-server=192.168.77.1 gateway=192.168.77.1

 

Сделано! К сож изменений нет...

Share this post


Link to post
Share on other sites

У вас РТ, он скорее всего IPTV подает через vlan, и для этого должен его включить на ваш порт доступа, в этом случае все действия без настройки со стороны прова бесполезны.

Share this post


Link to post
Share on other sites

У вас РТ, он скорее всего IPTV подает через vlan, и для этого должен его включить на ваш порт доступа, в этом случае все действия без настройки со стороны прова бесполезны.

 

Благодарю Вас! Вчера сделал как Вы писали и все заработало! Спасибо!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this