Jump to content
Калькуляторы

Вопрос по MikroTik проблемы с WiFi

Микротик: RB751G-2HdnD OS6.24

 

Есть подозрение, что МТ постоянно переключается между стандартами B/G/N, выражается это в следующем:

Включаю 2GHz-only-N, и замечательно смотрю ipTV через WiFi. Переключаю на 2GHz-B/G/N и все.. кинА нет вообще :( При этом при скачивании файла, через тот же диспетчер задач, наблюдаю пило-образную нагрузку, в то время как only-N дает ее просто идеально ровную.

Вы наверно скажите, ну и пользуйся only-N, но вопрос в том что все домашние телефоны (андроиды) не понимают его, а какой нынче телефон без Инета? :)

 

Вопрос: Как сделать так, чтобы всем было хорошо? И iptv работало и смартфоны подключались.

 

Странность: Выбираю 2GHz-B/G/N, далее Data Rates перевожу тумблер на configured и все.. опять телефоны не видят сеть. Я даже уже галочки во все поля проставил - но ситуация не изменилась.

 

PS. До этого у меня стоял Zyxel Keenetiс - все работало как часы пару лет, но понадобился мне 1Гбит порт и решил его променять на MT. Вот сейчас маюсь :(

Share this post


Link to post
Share on other sites

Имеется RB751U-2HnD с OS 6.24 в качестве домашнего роутера. iptv на нем не смотрю, а вот серфинг, торренты и скачивание файлов используется активно - проблем не замечено. Из устройств используются пару ноутов, пару андроид устройств, телек по кабелю. Но у 751 есть давно известная проблема работы в радио со штатным блоком питания на 12В. Замена на 18В или 24В проблему решала.

Edited by Saiko

Share this post


Link to post
Share on other sites

Т.е. проблема наблюдается именно при включении 2GHz-B/G/N? Хмм.. звучит как-то не убедительно! А есть ссылка на это дело, почитать более подробно, а то под рукой нет БП (такого напряжения) чтобы проверить.

 

Всегда думал, что МТ всеядный, а тут такое слышу.

Share this post


Link to post
Share on other sites

Просто не смотрите IPTV мультикастом по радио и не будет проблем. Так же не используйте устройства с кривыми драйверами, и проблемы вообще обойдут вас стороной.

 

Самое правильное решение это поставить 2 микротика. Первый настраиваете в режим N, и устанавливаете 1 канал, так как обычно клиентские устройства начинают сканировать сеть именно с 1 канала, если ловят несколько точек, то все нормальные устройства подключатся к первой точке. Вторую настраиваете в режим B/G, и снимаете галочки с B режимов, канал устанавливаете 12, к ней подключаться все устройства, которые не смогли подключиться к первой точке. Только и всего.

Share this post


Link to post
Share on other sites

Просто не смотрите IPTV мультикастом по радио и не будет проблем.

Логично, что если не пользоваться Wi-Fi, то и проблем не будет с ним. Это конечно вариант, но наверное не мой случай!

 

 

Так же не используйте устройства с кривыми драйверами, и проблемы вообще обойдут вас стороной.

Я бы поспорил на счет драйверов, драйвера во первых стоят самые последние, скаченные с оф. сайта Atheros. Во вторых я менял их, пробовал несколько. Проблемы однозначно с MT!

И ведь на Zyxel Keenetic все отлично, также как и на only-N! Поэтому не наблюдаю закономерности с драйверами.

 

 

Самое правильное решение это поставить 2 микротика.

Ага.. как в анекдоте получается: Сколько нужно MT, чтобы получить нормальную связь?

Т.е. Вы подтверждаете тот факт, что MT - г.. не способное предоставить даже нормальный WiFi?

 

PS. Всегда был лучшего мнения о MT... :(

Edited by Black Monk

Share this post


Link to post
Share on other sites

Ага.. как в анекдоте получается: Сколько нужно MT, чтобы получить нормальную связь?

Т.е. Вы подтверждаете тот факт, что MT - г.. не способное предоставить даже нормальный WiFi?

 

PS. Всегда был лучшего мнения о MT... :(

Вы задаете вопросы радиоприемнику, он только вещать умеет.

 

МТ и IPTV вещи не совместимые. Попытка решить проблему выливается в кучу граблей и костылей. Замените роутер на отличный от МТ и не парьтесь.

Share this post


Link to post
Share on other sites

SSD, iptv у меня прекрасно работает и дело совсем не в нем!

Я имел ввиду, что когда подключены отличные от N-стандарта устройства - все начинает лагать, а iptv вообще не идет, ну то есть идет, но как диафильм - слайдами.

Грешу на постоянное переключение MT между B/G/N.

И тем более, если Вы говорите правду, зачем MT вообще создали пакет multicast?

Share this post


Link to post
Share on other sites

Вообщим включил Only-G вроде все девайсы довольны, даже iptv идет, кроме HD-каналов.

 

Но вообще конечно интересно, раз такой расклад, зачем MT-цы делают мультирежимы, делали бы все ONLY и вопросов бы не было.

 

PS. Сейчас думаю зачем мне телевизор без HD-каналов, ТВ-ресивер-то у меня на WIFI, да и сам телевизор через wi-fi подключается (DNLA,internet,..). Прийдется наверно Zyxel Giga II брать :(

Хотя у меня DIR-300 где-то валялся, его наверно на G, а MT на N.

Edited by Black Monk

Share this post


Link to post
Share on other sites

И тем более, если Вы говорите правду, зачем MT вообще создали пакет multicast?

А кто сказал, что он предназначен для wifi? ;) Еще у МТ неизбывная засада с igmp snooping, то есть его просто нет, что добавляет проблем при нескольких получателях mcast, если wifi в L2 c LAN. Полного удовлетворения на МТ все равно не получите, можно потюнить настройки, убрать поддержку младших рейтов a/g, а поддержку b совсем (телефонов с ним у вас наверняка нет, а если есть то в инете им делать нечего), приоритет ht-ampdu на 4 выставить.

>interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode band=2ghz-b/g/n basic-rates-a/g=\
12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b="" bridge-mode=disabled channel-width=20/40mhz-ht-above disabled=\
no distance=indoors frequency=auto hw-protection-mode=rts-cts hw-retries=5 l2mtu=2290 mode=ap-bridge multicast-helper=full \
periodic-calibration=enabled periodic-calibration-interval=30 preamble-mode=long ssid=ANOTHER supported-rates-a/g=\
12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b="" tx-power=15 tx-power-mode=all-rates-fixed wmm-support=\
enabled

Для усредненного домашнего использования микротик не подходит, по крайней мере пока.

P.S>Cмешанные режимы и на Giga II такие же. И да, iptv через wifi, да еще и мультикастом - таки неправильно, но МТ иначе не умеет.

Edited by DRiVen

Share this post


Link to post
Share on other sites

SSD, iptv у меня прекрасно работает и дело совсем не в нем!

Я имел ввиду, что когда подключены отличные от N-стандарта устройства - все начинает лагать, а iptv вообще не идет, ну то есть идет, но как диафильм - слайдами.

Грешу на постоянное переключение MT между B/G/N.

И тем более, если Вы говорите правду, зачем MT вообще создали пакет multicast?

Наличие пакета мультикаст не означает корректную его работу. Чтобы избавится от постоянного переключения, зафиксируйте канальные скорости на микротике.

Share this post


Link to post
Share on other sites

DRiVen, можно поподробнее про "Cмешанные режимы и на Giga II такие же"?

У меня стоит обычный Keenetic у него с этим все хорошо, неужели во втором Гига все испортили?

Share this post


Link to post
Share on other sites

Ничего там не испортили, фраза "такие же режимы" означала, что образование смешанных режимов ровно такое же (B, B/G, B/G/N). Я убрал поддержку B руками в конфиге (compatibility GN), но не проверял, надо будет озадачиться. На wifi висят aura hd + TV sams + comp, но iptv в ауру идет через udpxy.

Share this post


Link to post
Share on other sites

PS. Сейчас думаю зачем мне телевизор без HD-каналов, ТВ-ресивер-то у меня на WIFI, да и сам телевизор через wi-fi подключается (DNLA,internet,..). Прийдется наверно Zyxel Giga II брать :(

 

Зачем телевизор подключать по вайфаю? Подключите кабелем. А по G HD каналы не идут, потому что данные на минимальной скорости передаются, установите галочки в Data Rates у 36M и не ниже, заработает сразу все нормально.

Share this post


Link to post
Share on other sites

2 дня моих эксперементов и вот вывод:

Забираю свои нехорошие слова о микротик назад, он не хуже и не лучше того же Zyxel.

 

Что выяснил:

Проблемой был - не стандарт N, а 40MHz. Отказался я от этих 40МHz, скорость подключения упала с 150Мбит до 65Мбит. Мощность понизил на всех скоростях до всего 9dBm.

Получил:

1. Нет жеских завалов до 200Кбайт, минимум падает до 1,5Мбайта/с.

2. Скорость ходит в пределах 3500-4700Кбайт/сек. Параметры: Only-N, 20/40MHz, PowerTX 25dBm - выдают туже скорость, только есть сильные завалы и не работают смартфоны.

 

Вообщим скорость хоть и не максимальная, но на все хватает.

 

Тему можно закрыть. Спасибо всем! :)

 

 

 

Saab95, при любом режиме, если переключаю галочку в Data Rates на Configure, хоть со всеми включенными скоростями, смартфоны теряют wifi.

Share this post


Link to post
Share on other sites

Saab95, при любом режиме, если переключаю галочку в Data Rates на Configure, хоть со всеми включенными скоростями, смартфоны теряют wifi.

 

Это как раз и говорит о том, что смартфоны глючные.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this