Jump to content
Калькуляторы

DHCP Relay SNR S2950-24G

Доброго времени суток. Не могу запустить dhcp relay на этом коммутаторе. Вернее вроде как запустил, но дхцп сервер видит remote-id (ip) вышестоящего свитча, а circuit-id (порт) - верный.

 

настройки следующие

101 - клиентский 10 - свитчной вланы

service dhcp
!
ip forward-protocol udp bootps
ip dhcp relay information option
ip dhcp relay information option subscriber-id format hex
!
ip dhcp snooping enable
ip dhcp snooping vlan 101
ip dhcp snooping binding enable
!
ip dhcp snooping information enable
ip dhcp snooping information option subscriber-id format hex
!
!
vlan 1;101;10
!
Interface Ethernet1/24
switchport access vlan 101
!
Interface Ethernet1/25
media-type copper
switchport mode trunk
switchport trunk allowed vlan 101;10
ip dhcp snooping trust
!
interface Vlan1
!
interface Vlan101
!
interface Vlan10
ip address 10.10.10.5 255.255.255.0
!
ip default-gateway 10.10.10.254
!
no login
!
end

 

Ставлю вместо SNR D-Link и всё работает нормально.

 

Как сделать нормальный релей с опцией 82????

Edited by ke1evra

Share this post


Link to post
Share on other sites

если на dhcp прилетает запрос с ip вышестоящего свича возможно вышестоящий свич подменяет опцию в запросе. Посмотрите настройки даун порта вышестоящего свича.

Edited by biox

Share this post


Link to post
Share on other sites

Доброго времени суток. Не могу запустить dhcp relay на этом коммутаторе. Вернее вроде как запустил, но дхцп сервер видит remote-id (ip) вышестоящего свитча, а circuit-id (порт) -

 

незнаком с коммутаторами SNR, но раз на них cisco like cli, то где

ip dhcp relay enable

ip dhcp relay server xx.xx.xx.xx?

 

dhcp relay тем и отличается, что пересылает запросы юникастом на определенный хост в mgmt vlan

Share this post


Link to post
Share on other sites

если на dhcp прилетает запрос с ip вышестоящего свича возможно вышестоящий свич подменяет опцию в запросе. Посмотрите настройки даун порта вышестоящего свича.

я ставил Dlink вместо SNR и всё нормально приходит.

 

 

 

ip dhcp relay enable

ip dhcp relay server xx.xx.xx.xx

к сожалению нет такой функции)))

есть только

SNR-S2950-24G(config)#sh ip dhcp relay information option
ip dhcp server relay information option(i.e. option 82) is disabled
ip dhcp relay information option(i.e. option 82) is enabled

Vlan101:
       ip dhcp relay information policy replace
       ip dhcp relay information option subscriber-id standard

Vlan10:
       ip dhcp relay information policy replace
       ip dhcp relay information option subscriber-id standard

но эти настройки никак не влияют на запросы, включен ли dhcp relay или выключен, порт начинает светиться только после включения ip dhcp information option, то есть не с помощью dhcp relay прилетает ip.

у меня уже мозг от этих коммутаторов поплавился...

Share this post


Link to post
Share on other sites

У меня так:

глобально

service dhcp

ip dhcp snooping enable

ip dhcp snooping binding enable

ip dhcp snooping information enable

ip dhcp snooping information option subscriber-id format hex


на клиентских интерфейсах

ip dhcp snooping binding user-control

на магистральном интерфейсе
ip dhcp snooping trust

Edited by FIGO

Share this post


Link to post
Share on other sites

чисто на снупинге? полагаю у вас одна подсеть сервера и клиентов, у меня же они разные и в разных вланах.

может я чего недопонимаю и дело совсем не в релее, объясню коротко - клиентский влан на подсеть 192.168 к примеру, а свитчи и дхцп сервер это другой влан с другой подсетью.

 

на длинках всё очень просто dhcp_relay add vlan 101 10.10.10.0, включил опцию 82 и снупингом рубай неверных, а тут так всё закручено.

 

Это ж оф. форум нага, где разработчики)))) хотелось бы услышать

Edited by ke1evra

Share this post


Link to post
Share on other sites

чисто на снупинге? полагаю у вас одна подсеть сервера и клиентов, у меня же они разные и в разных вланах.

может я чего недопонимаю и дело совсем не в релее, объясню коротко - клиентский влан на подсеть 192.168 к примеру, а свитчи и дхцп сервер это другой влан с другой подсетью.

 

на длинках всё очень просто dhcp_relay add vlan 101 10.10.10.0, включил опцию 82 и снупингом рубай неверных, а тут так всё закручено.

 

Это ж оф. форум нага, где разработчики)))) хотелось бы услышать

Наг, он такой наг.. support@nag.ru - вроде сюда писать

Share this post


Link to post
Share on other sites

А куда релеить-то? Судя по схеме: тут прозрачный L2 между сервером и клиентом, зачем релей?

 

Как уже указали выше, надо указывать ip сервера, куда юникастом релей шлет запросы.

 

Я бы убрал все настройки релея и подебажил dhcp snooping packet, скорее всего с коммутатора будет уходить верная опция 82, с нужным remote-id и circuit-id.

 

У нас QTech (тот же SNR), на доступе:

 

ip dhcp snooping enable
ip dhcp snooping vlan CVLANs
ip dhcp snooping binding enable
!         
ip dhcp snooping information enable
ip dhcp snooping information option subscriber-id format hex
!
Ethernet 1/1-24
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 1
!
Ethernet 1/25-28
ip dhcp snooping trust vlan CVLANs

 

Релей на похожем оборудовании настраивал так:

service dhcp
!         
ip forward-protocol udp bootps
ip dhcp server relay information enable
ip dhcp relay information option
!         
vlan 10
name Customers
supervlan
subvlan CVLANs
!
interface vlan 10
description Customers
ip address 10.10.0.1 255.255.255.0
ip address 10.10.1.1 255.255.255.0 secondary
  !forward protocol udp 67(active)!
ip helper-address 10.10.100.1
ip dhcp relay information policy keep
!

Edited by tehmeh

Share this post


Link to post
Share on other sites

ke1evra На самом деле вы настраиваете не релей а вставку в DHCP запрос дополнительной опции (82), а релей у вас выполняет устройство с адресом (из приведённого вами конфига)

10.10.10.254

 

вот на нём скорее всего и нужно поискать причину.

Edited by biox

Share this post


Link to post
Share on other sites

если между устройством 10.10.10.254 и целевым коммутатором есть ещё один коммутатор, возможно причина в его настройках.

Share this post


Link to post
Share on other sites

FIGO я по этим настройкам делаю, и получаю порт верный, а ip вышестоящего свитча. то есть на дхцп сервере вместо запроса 10.10.10.1->24 я вижу 10.10.10.3->24

если вместо SNR я ставлю DLink всё приходит как нужно, следовательно выплывает вопрос, может snr чего-то не добавляет? либо dhcp сервер неправильно обрабатывает запрос, но если вышестоящий dlink просто релеит с option_82 policy keep, то почему он всеравно видит ip dlink'а?

дебаг:

DHCPS PACKET: inserted an option 82(subscriber-id 00:06:08:E8:01:00:00:18 remote-id F8:F0:82:10:80:42) into this request packet(type:3), new packet length 327
%Jan 03 01:45:15 2006 DHCPS: rcv packet from client ba-5f-f3-78-3e-1b,
        interface Ethernet1/24(portID 0x1000018), length 373,
        type DHCPREQUEST, opcode BOOTREQUEST, stacking 0
%Jan 03 01:45:15 2006 DHCPS: flood dhcp pkt from Ethernet1/24 dst mac ff-ff-ff-ff-ff-ff
        to all up port except input port Ethernet1/24 in vlan 101
DHCPR PACKET:receive relay request packet,and enter function fnDhcpRelayRequest().
%Jan 03 01:45:15 2006 DHCPS: rcv packet to client ba-5f-f3-78-3e-1b,
        interface Ethernet1/25(portID 0x1000019), length 346,
        type DHCPACK, opcode BOOTREPLY, stacking 0
%Jan 03 01:45:15 2006 DHCPS: Get send port Ethernet1/24 for DHCP reply unicast packet
       for dhcp client ba-5f-f3-78-3e-1b in vlan 101
%Jan 03 01:45:15 2006 DHCPS: Send dhcp pkt from Ethernet1/25 dst mac ba-5f-f3-78-3e-1b
        to port Ethernet1/24 in vlan 101

 

и еще один вопрос, кто подскажет - что именно делает функция

ip dhcp broadcast suppress

, написано что отправляет юникастом дхцп пакеты.

включаю её и получаю бесконечную идентификацию. дебаг по кругу гоняет вот это:

DHCPS PACKET: inserted an option 82(subscriber-id 00:06:08:E8:01:00:00:18 remote-id F8:F0:82:10:80:42) into this request packet(type:3), new packet length 327
%Jan 03 02:04:00 2006 DHCPS: rcv packet from client ba-5f-f3-78-3e-1b,
        interface Ethernet1/24(portID 0x1000018), length 373,
        type DHCPREQUEST, opcode BOOTREQUEST, stacking 0
DHCPR PACKET:receive relay request packet,and enter function fnDhcpRelayRequest().

Edited by ke1evra

Share this post


Link to post
Share on other sites

У меня с SUpervlan вот такая вот проблема: дебаг на snr-s3750-24s

 

sw-s3750g-rad-1-7#DHCPR PACKET:receive relay request packet,and enter function fnDhcpRelayRequest().

%Jan 01 01:30:25 2006 DHCPR PACKET: rcvd BOOTPREQUEST from client 1 00-26-9e-10-4f-13 on interface Vlan100.

 

DHCPD: bind socket IP address error -98

%Jan 01 01:30:25 2006 DHCPR: can't register relay reply socket for vrf 0, error -98

DHCPR PACKET:receive relay request packet,and enter function fnDhcpRelayRequest().

%Jan 01 01:30:33 2006 DHCPR PACKET: rcvd BOOTPREQUEST from client 1 00-26-9e-10-4f-13 on interface Vlan100.

 

DHCPD: bind socket IP address error -98

%Jan 01 01:30:33 2006 DHCPR: can't register relay reply socket for vrf 0, error -98

 

 

Схема такова:

 

sw access(vl2002) - (vl2002)sw l3 (vl 300)- (vl300)se100

 

 

Настройки:

L3 sw

 

!

vlan 100

supervlan

subvlan 2002;2005-2006

!

!

interface Vlan100

ip local proxy-arp

ip address 10.10.0.1 255.255.255.0

!forward protocol udp 67(active)!

ip helper-address 10.199.199.2

!

interface Vlan300

description Int-for-L3

ip address 10.199.199.1 255.255.255.252

!

!

ip route 0.0.0.0/0 10.199.199.2

!

 

Если убрать vl100, навесить IP интерфейс на клиентский vlan 2002 с ip helper, то клиент авторизуется по opt82 (которая вставляется на sw access).

 

Но как тока 2002 я ввожу в супер влан. И на интерфейса супер влана назначаю ИП сети, то все. финиш...

 

 

Подскажите как побороть это ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this