Jump to content
Калькуляторы

ke1evra

Пользователи
  • Content Count

    27
  • Joined

  • Last visited

About ke1evra

  • Rank
    Абитуриент

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. вопрос тем, кто редиректит с ссылкой ?uri=... у вас в логах веб-сервера нет аномалий? непонятные редиректы, при чём не единично, а прям куча запросов одних и тех же, может вирус. вот такого вида ссылки в access_log nginx: GET /blocked?uri=http%3A%2F%2F%2Fncsi.txt GET /blocked?uri=http%3A%2F%2F%2Fmsi404%2F HTTP/1.1 и непонятно, почему три слэша %2F%2F%2F
  2. а в сторону PcapPlusPlus кто-то смотрел? Судя по их бенчмаркам, libpcap далеко впереди, но интересно было бы сравнить производительность конкретно в этой задаче
  3. нет, не ИП. так пример тут же гуляет в теме. единственное, я не понял, откуда юзеры взяли поля IPv4_subnet и IPv4 если в инструкции IpAddr. Я просто скачал пример с сайта ркн и дописал свои данные. В инструкции предельно ясно написано КАК заполнять, только вот местами не совсем понятно ЧТО.
  4. на той же странице где отправляется, блок "Ранее отправленные" или как-то так
  5. Отправил, пишет Результат success, присвоен рег. номер. Теперь вопрос - что дальше? Вообще непонятно, приказ обязывает написать кучу инфы по типу внутренних систем (dns, ntp, сигнализация), адресов, окпо, инн, паспортных данных, а в инструкции xml почти всё это можно пропустить. Кто-то подробности выяснял, насколько это серьезно? Или это важно только для крупных провайдеров, выходящих за пределы РФ.
  6. подскажите пожалуйста, а какие именно ошибки являются input errors? фильтр работает-работает, а потом на порту subscriber появляется Information Application - Port 0 input packets 491200231, input errors: 1, mbuf errors: 0, missed packets: 0 интернет работает без глюков, а вот трассировка ломается - один из хопов перестаёт отвечать: 1 <1 мс <1 мс <1 мс 192.168.0.1 2 10.10.10.1 сообщает: Заданная сеть недоступна. рестарт фильтра помогает, но эта одна ошибка периодически вылезает. почему-то всегда input errors: 1, т.е. они не растут и вылазит только на стороне subscriber
  7. докопался я до истины, пересобрал peafowl с флагом HTTP_PARSER_STRICT=0 роюсь в коде и просто в шоке, какую колоссальную работу вы сделали. спасибо =)
  8. у меня почему-то если в запросе есть кириллица, именно в строке запроса (кириллические домены блокирует на ура), то проходит мимо фильтра, я залогировал функцию on_header_complete_ext в worker.cpp: если я делаю curl -L http://ukranews.life/mixail-xachaturyan-dochernyaya-lyubov-i-ruben-tatulyan/ то она выполняется, d->host_r.buf = 'ukranews.life' и d->uri.buf = '/mixail-xachaturyan-dochernyaya-lyubov-i-ruben-tatulyan/' а если curl -L http://www.opamuzika.ru/mp3/Железный%20Порядок то on_header_complete_ext вообще не выполняется
  9. с флагом make_sp_chars = true ссылки появляются в нескольких вариантах: muzlishko.ru/mp3/%D0%9D%D0%BE%D1%87%D0%BD%D0%BE%D0%B9%20%D0%9F%D0%B0%D1%82%D1%80%D1%83%D0%BB%D1%8C muzlishko.ru/mp3/Ночной%20Патруль muzlishko.ru/mp3/������%20������� но всё равно не блокируется, если в урле кириллица. может проблема где-то в gcc или в системе? помогите советом пожалуйста :) отдебажить это нет возможности? посмотреть бы, в каком виде фильтр принимает url и кодирует ли он его дополнительно
  10. как бороться с миксом кириллицы и различными символами, есть какие-то дополнительные опции в extfilter.ini? не хочет блокировать, к примеру вот такие ссылки: www.muzlishko.ru/mp3/Коловрат++Радикальный+голос muzlishko.ru/mp3/Ночной%20Патруль allmir.in.ua/video/_osaSOafiRA/УНСОвці-і-quot-Рутенія-quot-Марш-УНСО.html если руками кодирую кириллицу, то вот так блокирует curl -L http://muzlishko.ru/mp3/%D0%9D%D0%BE%D1%87%D0%BD%D0%BE%D0%B9%20%D0%9F%D0%B0%D1%82%D1%80%D1%83%D0%BB%D1%8C в конфиге видел url_normalization, но он не работает и в скриптах нигде не фигурирует...
  11. я имею ввиду клиентские сети. чтоб к примеру 172.16.0.0/24 фильтровались, а 192.168.0.0/24 проходили мимо, как bypass чтоли
  12. а это нормально, что фильтр все используемые цпу в полку загоняет (даже без трафика), у всех так? я бы подумал, что неправильно система определяет загрузку, но температура проца без доп. охлаждения сразу ~80°C и ещё очень хотелось бы указать белый лист, чтоб исключить из проверки какую-нибудь src-net. я конечно понимаю, что это вряд ли в фильтре реализовано, но мало ли... заметки на будущее :)
  13. Да. проблема была в одном ядре =) на i7 полетело
  14. кто в режиме inline использует, отпишите в личку пожалуйста =\ по логам что-то бегает, но IP пакетов не видит, а если и видит, то всё равно ничего не работает Information Application - All worker threads seen packets: 7472, IP packets: 0 (IPv4 packets: 0, IPv6 packets: 0), seen bytes: 0, traffic throughtput: 18.41 pps из сетевой dpdk порт subscriber включен в mikrotik, который ругается на петлю interface,warning sfp-sfpplus1: bridge port received packet with own address as source address (d4:ca:2d:41:91:11), probably loop
  15. пытаюсь запустить на двухядерном процессоре для теста. карта Intel x520 линки 10G мигают, но при старте всё заканчивается вот так: [root@localhost ~]# /usr/local/bin/extFilter --config-file=/usr/local/src/extfilter/etc/extfilter.ini EAL: Detected 2 lcore(s) EAL: Probing VFIO support... EAL: PCI device 0000:01:00.0 on NUMA socket -1 EAL: probe driver: 8086:10fb net_ixgbe EAL: PCI device 0000:01:00.1 on NUMA socket -1 EAL: probe driver: 8086:10fb net_ixgbe acl context <extFilter-ipv4-acl0-0>@0x7f187f937f40 socket_id=0 alg=2 max_rules=1 rule_size=64 num_rules=1 num_categories=1 num_tries=1 PMD: ixgbe_dev_link_status_print(): Port 0: Link Down PMD: ixgbe_dev_link_status_print(): Port 1: Link Down по логам старт нормальный, ошибок нет 2020-02-03 07:44:18.084 [9822] Debug Application - Preparing thread 'WorkerThrd_0' 2020-02-03 07:44:18.084 [9822] Information WorkerThrd_0 - Output port for the worker 0 is 0 (tx_queue_id 1) n_tx_port 2 2020-02-03 07:44:18.085 [9822] Debug WorkerThrd_0 - Starting bridge working thread on core 1 2020-02-03 07:44:18.085 [9822] Information WorkerThrd_0 - -- lcoreid=1 portid=0 rxqueueid=0 2020-02-03 07:44:18.085 [9822] Information WorkerThrd_0 - -- lcoreid=1 portid=1 rxqueueid=0 2020-02-03 07:44:18.085 [9822] Debug Application - Starting statistic task... 2020-02-03 07:44:18.085 [9822] Debug ReloadTask - Starting reload task... в конфиге пробовал и зеркало и бридж, на данный момент вот эти опции правил, остальной конфиг дефолтный core_mask = 3 operation_mode = inline [port 0] queues = 0,1 type = subscriber mapto = 1 [port 1] queues = 0,1 type = network mapto = 0 на другой железке удалось запустить, но пишет вот так и бридж не работает: PMD: ixgbe_dev_link_status_print(): Port 0: Link Up - speed 0 Mbps - half-duplex PMD: ixgbe_dev_link_status_print(): Port 1: Link Up - speed 0 Mbps - half-duplex