Jump to content
Калькуляторы

Проблемы с OSPF Нужно завязать cisco и SE100

Всем доброго времени суток. Есть связка: к SE100 по ospf подключены две cisco по vlan. Проблема следующая: есть SE100 с конфигом

 

 

interface loopback2 loopback

ip address 172.16.5.11/32

 

interface to-core

ip address 10.10.12.2/24

 

router ospf 1

router-id 172.16.5.11

log-neighbor-up-down

area 0.0.0.1

interface loopback2

interface to-core

 

port ethernet 2/2

no shutdown

medium-type copper

encapsulation dot1q

dot1q pvc 998

bind interface to-core local

 

 

 

 

Есть cisco7104 с конфигом:

 

 

 

router ospf 1

router-id 172.16.5.6

log-adjacency-changes

redistribute connected subnets

network 10.10.12.0 0.0.0.255 area 1

 

interface GigabitEthernet0/3.998

description connectTOse

encapsulation dot1Q 998

ip address 10.10.12.1 255.255.255.0

 

ip route 0.0.0.0 0.0.0.0 10.10.12.2 200

 

 

 

И есть ещё cisco3845 с конфигом (приходит антегом конечно же влан):

 

 

 

interface GigabitEthernet0/1

ip address 10.10.12.5 255.255.255.0

 

router ospf 1

router-id 172.16.5.1

log-adjacency-changes

redistribute connected subnets

network 10.10.12.0 0.0.0.255 area 1

 

ip route 0.0.0.0 0.0.0.0 10.10.12.2

 

 

Периодически в логах каждой cisco появляется следующее:

*Oct 31 04:33:09: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.11 on GigabitEthernet0/1 from FULL to DOWN, Neighbor Down: Dead timer expired

*Oct 31 04:33:17: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.11 on GigabitEthernet0/1 from LOADING to FULL, Loading Done

 

у каждой cisco свои сообщения соответственно но текст один и тот же. НО!!! есть связь между SE100 и cisco7104 не прерывается при появлении этих сообщений, то связь между SE100 и cisco3845 рвется при появлении сообщений. В конфиге ничего необычного не нашел.Смущает что при одинаковом конфиге одна cisco работает а другая нет. Может какие то хитрости в настроке есть?! Помогите разобраться. Или носом ткните что не так прописано

Share this post


Link to post
Share on other sites

предлагаю для начала всем сделать арию 0

Share this post


Link to post
Share on other sites

mtu не трогали. не прописывали. как оно по дефолту есть так и оставили. В конфиге оно явно не прописано. Простите за незнание а что поменяет если сменить area на 0?!

Share this post


Link to post
Share on other sites

Простите за незнание а что поменяет если сменить area на 0?!

В вашем случае совершенно ничего. Это видать человек по незнанию ляпнул.

Share this post


Link to post
Share on other sites

Eagle18, проверьте mtu, чтобы везде все пролезало, попингуйте с df-bit'ом

Share this post


Link to post
Share on other sites

7204#ping 10.10.12.2 df-bit size 1000 repeat 1000

 

 

Type escape sequence to abort.

Sending 1000, 1000-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:

Packet sent with the DF bit set

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!

 

 

Собственно вот. Ничего не теряется. со второй cisco тоже ничего не теряется. MTU везде 1500 стоит на всех трех железках

Share this post


Link to post
Share on other sites

1500 попингуйте, понятно что он 1000 фрагментировать не будет :)

Share this post


Link to post
Share on other sites

Вот собственно результат. Один только потерялся

 

 

7204#ping 10.10.12.2 df-bit size 1500 repeat 1000

 

Type escape sequence to abort.

Sending 1000, 1500-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:

Packet sent with the DF bit set

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!

 

 

Share this post


Link to post
Share on other sites

покажите

 

7204#sh int g0/1 mtu

и на se100

sh ip int в нужном контексте

 

между ними что-нибудь есть? коммутатор например

Share this post


Link to post
Share on other sites

 

 

7204#sh int gi0/3.998 | i MTU

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

 

Core_3845#sh int g0/1 | i MTU

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

 

[local]PPPoE#sh ip interface to-core

 

Intf name: to-core

Intf state: Up MTU: 1500

 

 

На названия интерфейса не обращайте внимания, осталось со старой схемы

Share this post


Link to post
Share on other sites

между маршрутизаторами есть коммутаторы какие-нибудь? может мультикаст где не проходит?

таймеры ospf нигде не подкручены?

Share this post


Link to post
Share on other sites

таймеры ospf нигде не подкручены?

Про таймеры OSPF оно бы в логах сразу написало.

Share this post


Link to post
Share on other sites

ну между ними есть коммутер но там в одном влан бегает он на три порта настроен и все. никаких ограничений нет на портах. таймеры также в ручную не крутили-все по дефолту

Share this post


Link to post
Share on other sites

ещё из того что проверить - на физическом порту SE100 какое mtu настроено? там же dot1q, сделайте 9198 для верности

 

Eagle18, коммутатор не экстрим случаем? :)

Share this post


Link to post
Share on other sites

 

 

[local]PPPoE#sh port 2/2 detail

ethernet 2/2 state is Up

Description :

Line state : Up

Admin state : Up

Link Dampening : disabled

Undampened line state : Up

Dampening Count : 0

Encapsulation : dot1q

MTU size : 1500 Bytes

 

 

комутер у нас dlink dgs-3120-24TC. 9198 MTU сделать на порту или на виртуальном интерфейсе!?

Share this post


Link to post
Share on other sites

Линковые ospf адреса в сабскрайберов не попадают?

Share this post


Link to post
Share on other sites

Линковые ospf адреса в сабскрайберов не попадают?

нет не попадают.

Share this post


Link to post
Share on other sites

на физическом порту

port eth 2/2

с утреца попробую сделать. сейчас уже убегать надо. Все таки думаешь что проблема в MTU. И на 7104 сообщения о крахе ospf появляются ну несколько раз в день а на 3845 практически каждые минут 15-20

 

Eagle18, а между цысками оспф не падает?

ну судя по логах падает ospf только с SE100. Про падение ospf между цисками записей нет

Share this post


Link to post
Share on other sites

Сегодня ночью поигhался с MTU.На SE100 выставил 9198. на cisco3845 1500. После поднятия ospf между ними - связь появилась. пинги ходили. но ни один клиент не смог выйти в инет. хотя cisco и SE100 видели друг друга. При этом в логах cisco было следующее:

 

 

%OSPF-5-ADJCHG: Process 1, Nbr 172.16.5.11 on GigabitEthernet0/1 from EXSTART to DOWN, Neighbor Down: Too many retransmissions

 

 

Это ошибка как я успел прочитать была из-за разных MTU. Прописал на порту MTU руками 1500 и на cisco и на SE100. Все поднялось и заработало. Просидел в офисе час прождал. И всем известная фраза: "Не было ни единого разрыва"...Я обрадовался и поехал домой наконец то спать. Но только приехал домой лег и приходит смс что все упало. Залез в телефон смотрю а все работает уже. В логах Cisco3845 было пресловутое сообщение что ospf разорвалось по Dead timer. И вот это было последний раз.уже 6,5 часов нет разрывов ospf. Пока наблюдаю и жду. Может и правда дело было в MTU, только его нужно было руками указать. Может фиксики там все доделали за меня, а может и мистика. В общем жду. Всем спасибо за советы.

Share this post


Link to post
Share on other sites

Eagle18, всё-таки нужно было MTU на интерфейсах всех руками прописать. Мало ли, завтра запустите MPLS и везде придётся переколбашивать MTU на физических портах + руками проставлять на всех интерфейсах.

Share this post


Link to post
Share on other sites

а вот и не помогло. вышли на работу и за три часа работы уже два раза ospf рвалось по dead timer((((

Share this post


Link to post
Share on other sites

На Dlink нет никаких настроек касаемо multicast ? igmp_snooping, filtered_unregistered_group ?

Можно ещё покрутить dead timer и отключить проверку mtu на интерфейсах маршрутизаторов.

Edited by uk2558

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this